Jump to content
roozbeh

spvDuke3d [v0.4c]...with Sound/Music now!

Recommended Posts

Well that figures, I checked everywhere (Even did a forum/google search) except the first post. I expected someone else to post the patch after the initial first post. Thanks, music seems to work fine now, except it's taking forever just to load the first level now, so I might have to turn it off (Update: seems to load fine now) :D

So now that's been taken care of, I don't suppose there's a way to enable cheats, is there? I could beat this game on “Damn I’m Good” on the PC, but playing with cell phone controls is pretty tough. Even just the level warp code would be petty nice (dnscotty XX). Is there anyway I can bind codes to single buttons in the .cfg file or something? Thanks :(

i havnt tried actually..cant u just simply enter in the cheat if you have a qwerty keyboard? ill try next time i get a chance

Share this post


Link to post
Share on other sites
mikeeey did you try the cheat thing? does it work?

yes i just tried it, all cheats worked. edited controls didnt seem to effect it, it worked fine.

Share this post


Link to post
Share on other sites

duke3d full version grp file doenst work on smt 5600

shareware version works great. everytime i start

the game after getting to the menu it crashes

but if shareware version works could it be grp file is

too large or some mod with the cfg file

any help would be great

thanks

Share this post


Link to post
Share on other sites
duke3d full version grp file doenst work on smt 5600

shareware version works great. everytime i start

the game after getting to the menu it crashes

but if shareware version works could it be grp file is

too large or some mod with the cfg file

any help would be great

thanks

let me guess..the atomic edition? delete all your saves and try again, for the atomic edition you need to reconfig some stuff a little different sometimes..

or, just use the full version that isnt the atomic edition.

Share this post


Link to post
Share on other sites

When I turn on music (yes, the timidity directory is correct) it's incredibly distorted, even with high values. Why is this?

Share this post


Link to post
Share on other sites
When I turn on music (yes, the timidity directory is correct) it's incredibly distorted, even with high values. Why is this?

are you using the latest version of spvDuke3D? (the latest version is not 0.4c, it's 0.4g).

Share this post


Link to post
Share on other sites
yes i just tried it, all cheats worked. edited controls didnt seem to effect it, it worked fine.

Heh, it's been a while since I've been here. I kind of gave up on this since I can't get by the first few levels.

So the cheats worked for you? That's odd, do you have a Dash too? If not, what phone are you using? Did you have to use the Multikey or something? I do have edited controls, but you said that's not a problem... hmmm.... so why isn't it working for me? And YES, I am typing them in correctly; I can asure you that.

Share this post


Link to post
Share on other sites
Heh, it's been a while since I've been here. I kind of gave up on this since I can't get by the first few levels.

So the cheats worked for you? That's odd, do you have a Dash too? If not, what phone are you using? Did you have to use the Multikey or something? I do have edited controls, but you said that's not a problem... hmmm.... so why isn't it working for me? And YES, I am typing them in correctly; I can asure you that.

im using the tilt (kaiser or TyTN II), and i just simply type the cheat in gameplay. are you using the full version? is it the atomic edition or normal edition? im just using the normal version. the first cheat i typed in was dncash, and i held down the spacebar button and duke was throwing cash everywhere lol.

Share this post


Link to post
Share on other sites

Hello there,

It's my first post on this forum, I would like to congratulate roozbeh for his work, porting such a game like D3D on smartphones is just GREAT !

It works perfectly on my HTC S710, I was really impressed by the frame rate and general speed of game, AWESOME ! But I had to download version 0.4f at http://www.spv3d.com as 0.4c version on the first page of this topic doesn't work. Then I used Caraboy's (see previous page of this topic) config file for landscape mode, I'm not completely satisfied by his key mappings for my personnal use but that's not so hard to edit. (thanks caraboy for your contribution)

Edited by fansq

Share this post


Link to post
Share on other sites
Hello there,

It's my first post on this forum, I would like to congratulate roozbeh for his work, porting such a game like D3D on smartphones is just GREAT !

It works perfectly on my HTC S710, I was really impressed by the frame rate and general speed of game, AWESOME ! But I had to download version 0.4f at http://www.spv3d.com as 0.4c version on the first page of this topic doesn't work. Then I used Caraboy's (see previous page of this topic) config file for landscape mode, I'm not completely satisfied by his key mappings for my personnal use but that's not so hard to edit. (thanks caraboy for your contribution)

have you tried my key mappings? or is your device not a landscape right device?

Share this post


Link to post
Share on other sites

Thanks very much mikeeey - it worked. Too bad there isn't some kind of configuration tool for the keys. Ah well. I also noticed that the problem I explained in this thread is still there: http://www.modaco.com/content/Other/264244...ypad-Sticking-/

So I must determine it's a hardware problem. I have no idea why the keys 'stick' like that. It's really annoying and kills the fun with pretty much any emulator or port. :)

Edited by ShaunC193

Share this post


Link to post
Share on other sites

I've just installed the application on my smartphone (Q9h). I placed it in "Storage Card/Duke3D" and coppied all the files required for the game. I also placed the music files in thier directory on the Storage Card.

When I run spvDuke3D.exe, it never loads the game, but gives me an error instead. There is a lot of information in the error, so I will copy some of it here:

Technical Information

Process: spvDuke3d.exe

Module: coredll.dll

Data Abort: Thread=8a75d640

Proc=863e2ca0 'spvDuke3d.exe'

There's more after that, but some how I am guessing the exact details do not matter. I have tried it with UsingGapi set to 1 and 0. I have Landscape set to 1, since it is a landscape device. I have the music and sound set to 13, so I do not have to worry about them slowing down the game.

Does anyone have any ideas what the problem might be.

Thanks

Share this post


Link to post
Share on other sites
I've just installed the application on my smartphone (Q9h). I placed it in "Storage Card/Duke3D" and coppied all the files required for the game. I also placed the music files in thier directory on the Storage Card.

When I run spvDuke3D.exe, it never loads the game, but gives me an error instead. There is a lot of information in the error, so I will copy some of it here:

Technical Information

Process: spvDuke3d.exe

Module: coredll.dll

Data Abort: Thread=8a75d640

Proc=863e2ca0 'spvDuke3d.exe'

There's more after that, but some how I am guessing the exact details do not matter. I have tried it with UsingGapi set to 1 and 0. I have Landscape set to 1, since it is a landscape device. I have the music and sound set to 13, so I do not have to worry about them slowing down the game.

Does anyone have any ideas what the problem might be.

Thanks

idk if this has anything to do with it but try renaming your folder to spvDuke3d. make sure you have all the nessecery files too.

Share this post


Link to post
Share on other sites
idk if this has anything to do with it but try renaming your folder to spvDuke3d. make sure you have all the nessecery files too.

Thanks for the suggestion Mikeeey. I changed the folder name on my storage card and still no luck. I double checked that I have all the files. I am using the shareware version of Duke for the Duke3D.grp, but that should not make a difference.

I've run Doom on here before and was dying to play Duke. It's really annoying that I can't get this to work when other owners of the phone seem to have little or no problem.

Anyone else with an idea?

Thanks

Share this post


Link to post
Share on other sites

Hi, I'm new!!

I've got a problem, little problem, i hope.

I've got a I-Mate K-JAM....

I've try some times to play with this game with the left landscape, now i've do it but there is a problem...:

only ONE, only ONE, thing didn't work......the "X" button on the bottom right of the screen, if i tap on it nothing appened, well maybe there's another way, set the "menu" button on the keyboard of my K-JAM but......in the *.cfg there isn't any "menu".......what i must to do?

Share this post


Link to post
Share on other sites
I've just installed the application on my smartphone (Q9h). I placed it in "Storage Card/Duke3D" and coppied all the files required for the game. I also placed the music files in thier directory on the Storage Card.

When I run spvDuke3D.exe, it never loads the game, but gives me an error instead. There is a lot of information in the error, so I will copy some of it here:

Technical Information

Process: spvDuke3d.exe

Module: coredll.dll

Data Abort: Thread=8a75d640

Proc=863e2ca0 'spvDuke3d.exe'

There's more after that, but some how I am guessing the exact details do not matter. I have tried it with UsingGapi set to 1 and 0. I have Landscape set to 1, since it is a landscape device. I have the music and sound set to 13, so I do not have to worry about them slowing down the game.

Does anyone have any ideas what the problem might be.

Thanks

I had a similar problem on my motoQ and I moved all of the files directly to the storage card directory "Storage Card/" not in their own folder then I set Gapi to 0 then it ran great. oh wait... I also had set landscape to 1 since it is a landscape device BUT I had to set it back to 0 b4 it would work correctly, dunno why but it worked.

:D Let me know if it works for ya.

While I am at it I want to give a great big Thank you to roozbeh for getting this on my phone. Duke was my first 3D shooter, and on a pc that barely ran it with a 640x480 resolution. That game was chugging along at maybe 15fps but I loved it.

Now I can play it on my phone at 30fps or better, looks great, and can go with me anywhere. woohoo!!!

BTW don't be alarmed if you get an "I hate you" note from my wife. She doesn't seem to appreciate your work as much as I do. <_<

:) :D

Share this post


Link to post
Share on other sites

For those who cant get cheats to work...I have somewhat of a solution. if you open user.con inside textedit, you can change the value of your health and armor. You can change it so you can start with 999 health and 999 armor. Pretty much God Mode in a sense.

Edited by 1000101

Share this post


Link to post
Share on other sites

Hi, i've searched this forum and google for a result, but nothing...

Is there any way to use the "special keys" in a magician (qtek s100/110) for this game?

The Scan Code Mapping always returns a zero in all my keys...

I have:

Camera

record

calendar

contacts

scroll up/down

and none of these keys are accepted...

:D

Edited by twolf

Share this post


Link to post
Share on other sites
Hi, i've searched this forum and google for a result, but nothing...

Is there any way to use the "special keys" in a magician (qtek s100/110) for this game?

The Scan Code Mapping always returns a zero in all my keys...

I have:

Camera

record

calendar

contacts

scroll up/down

and none of these keys are accepted...

:D

im not sure if this will help but try using this to find your button's code

keycode.exe

Share this post


Link to post
Share on other sites

Can't get this to work at all on the E650. Tried the latest version, which doesn't seem to do anything and version 0.4c which brings up the grey loading screen and then cuts out after a "very low memory" message. I've tried running it after switching the machine on and off so there's nothing running in the background, alas I've had no luck. Any ideas?

Share this post


Link to post
Share on other sites
im not sure if this will help but try using this to find your button's code

Thanks for the help, but im not sure what to do with it...

It gives me, for example, the code 0xC3 (195) for my camera button.

But in the config there are a lot of places to put it...

sc_0 = "PPCKey1"

sc_0 = "195"

sc_0 = "0xC3"

Fire = "sc_0"

Fire = "sc_195"

Fire = "195"

Fire = "0xC3"

:S its confusing...

Share this post


Link to post
Share on other sites
Thanks for the help, but im not sure what to do with it...

It gives me, for example, the code 0xC3 (195) for my camera button.

But in the config there are a lot of places to put it...

sc_0 = "PPCKey1"

sc_0 = "195"

sc_0 = "0xC3"

Fire = "sc_0"

Fire = "sc_195"

Fire = "195"

Fire = "0xC3"

:S its confusing...

for my fire config it just looks like:

there are lots of places to put it because there are 3 different configurations in this file, portrait, landscape left, and landscape right. use whatever works for your device. the confuration wasnt that hard for me tho. when i had my sda fire was:

Fire = "Star" ""

and now with my kaiser it's:

Fire = "." ""

Share this post


Link to post
Share on other sites
Can't get this to work at all on the E650. Tried the latest version, which doesn't seem to do anything and version 0.4c which brings up the grey loading screen and then cuts out after a "very low memory" message. I've tried running it after switching the machine on and off so there's nothing running in the background, alas I've had no luck. Any ideas?

have you tried turning gapi on and off? and are you using a working version of duke nuke? have you tried the full version or demo?

Share this post


Link to post
Share on other sites
for my fire config it just looks like:

there are lots of places to put it because there are 3 different configurations in this file, portrait, landscape left, and landscape right. use whatever works for your device. the confuration wasnt that hard for me tho. when i had my sda fire was:

Fire = "Star" ""

and now with my kaiser it's:

Fire = "." ""

I appreciate your help, but there must really be some special key config for my Qtek S110...

These work fine:

Move_Forward = "Left" ""

Move_Backward = "Right" ""

Turn_Left = "Down" ""

Turn_Right = "Up" ""

These...well, just dont work at all:

Fire = "Record" "195"

Open = "Contact" "196"

Next_Weapon = "Enter" ""

Jump = "VolumeUp" ""

Crouch = "VolumeDown" ""

Alt_EscapeKey = "call" "endcall"

Edited by twolf

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×