bitbank

Sega GG + Nintendo GameBoy emulator for SP beta test

1583 posts in this topic

I've debated the 2-minute limit versus an end-date for limiting the beta, but in the past, pirates have taken advantage of any opening, so I must keep things locked down for now. It's been really hard lately to find time for SmartGear, but I'm still trying to fix/add each week as much as I can. Here's the latest news:

1) Added "rewind" feature. Can be invoked from a key/button or menu item when paused. Rewinds the current game 4-6 seconds in case you make some "fatal" error in a game and want to replay it. It does this by saving the current game state every 4 seconds into a memory buffer.

2) Added the "C" button to touchscreen controls for Genesis and fixed the clipping issue.

3) Working on Genesis performance. Lately I've made some infrastructure changes to the Genesis code which made is more accurate, but slower. Now I'm going to dive in and speed it up again.

4) The Desktop PC version is slowly catching up. I think I'll make the UI identical to the mobile version now.

5) I've begun rewriting the Yamaha FM sound emulation for better performance. This will take a long time, but at least I started :).

6) Still looking into supporting Morphmodules so that you can play GBA and SNES in SmartGear.

7) I started adding 6-button support to Genesis, but got sidetracked. I'll get back on that as well.

L.B.

Will the rewind be only able to bounce back one of these auto-saves, or will multiple presses make it bounce mack more than one?

0

Share this post


Link to post
Share on other sites

most pirates actually are NOT classifed as true pirates being they do it as a try before you buy thing. Meaning most software is limited in what it can do for trial versions or in this case very very short time to actually try it out. If they like it, they buy it. If not they delete it. I am perfectly fine with these type of pirates. Now for True Pirates that just want things for free and/or sell it for a profit I very much disagree.

Ok L.B. i ran into some more bugs and these are more major then the keyboard config. on NES the save/load feature is really messed up also ingame saves will it will not save at all. On SMS/GG it works fine until reboot or turn off the phone. when i open smartgear back up it shows the save but will not open it.

For the NES I was playing Zelda 1 and on GameGear i was play Defenders of Oasis. Both games work perfectly on 1.x when i was on my sch-i600. So not sure if its the dash or windows mobile 6.5.5 std

Also as far as the slow down on sega games goes that everyone has been talking about. It does not do this on the dash. it runs exactly the same as the 1.x and the phone is only overclocked from 200mhz to 210mhz. i have also tried it on defualt clock with same results.

If its the version of windows its no biggy i can always downgrade. Also was wondering if there is way you can intergrate a feature for benchmarking. Meaning you can select which systems and video/sound settings for each system. I think this will help many users select the most suited settings for their device as well as give everyone else an idea which device holds up the best with smartgear. Also i think it would be very useful for you if you add a diag report that users can either save as a file and send to you or send via phone using data plan/wifi when we experience problems.

0

Share this post


Link to post
Share on other sites

Hi bitbank,

when i play zelda (GBC) sometimes it freezing when the game change from one screen to another. is this bug related to smartgear or maybe from the game itself....??????

i use 2.0.15

and still i cannot load my saved games from 2.0.15 to 2.0.17. Any suggestion????

and i hope you will fix the mapping keys setting on your next SG version.

0

Share this post


Link to post
Share on other sites

I've spent today fiddling about with the CobaltController to let two people play at once (such as Golden Axe). However it meant reallocating all the keys - is there a separate file to store the keys in and if so where is it? I wouldn't mind having a few configurations saved as a .txt or similar file I could load up depending on how I'm configuring my Touch Pro 2. Thanks.

0

Share this post


Link to post
Share on other sites
Hi bitbank,

when i play zelda (GBC) sometimes it freezing when the game change from one screen to another. is this bug related to smartgear or maybe from the game itself....??????

i use 2.0.15

and still i cannot load my saved games from 2.0.15 to 2.0.17. Any suggestion????

and i hope you will fix the mapping keys setting on your next SG version.

actually it did the same for me using 2.0.15 it was a bug in that version. it fixed in .17

as for the mapping keys. i found a work around for the freeze up after you set a key. press the end phone key. the key that looks like a red phone. then press the back key. it should look like an arrow key pointing to the left.

0

Share this post


Link to post
Share on other sites
actually it did the same for me using 2.0.15 it was a bug in that version. it fixed in .17

as for the mapping keys. i found a work around for the freeze up after you set a key. press the end phone key. the key that looks like a red phone. then press the back key. it should look like an arrow key pointing to the left.

thanks for reply.....

thanks god it had already fixed. but still i cannot load my saved games to 17. that why i'm still playing 15.

about mapping, i have done it too (my previous post). just like you'd said. but it still bugging me. i hope it will fix for next release.

0

Share this post


Link to post
Share on other sites
thanks for reply.....

thanks god it had already fixed. but still i cannot load my saved games to 17. that why i'm still playing 15.

about mapping, i have done it too (my previous post). just like you'd said. but it still bugging me. i hope it will fix for next release.

ya its kinda annoying to me as well but no where near as much as the save/load bug.

0

Share this post


Link to post
Share on other sites

New beta available (2.0.18). Many fixes including the load/save bug.

get the code here: www.bitbanksoftware.com/sg.zip

See the changes here: www.bitbanksoftware.com/SG_Beta.html

L.B.

0

Share this post


Link to post
Share on other sites
New beta available (2.0.18). Many fixes including the load/save bug.

get the code here: www.bitbanksoftware.com/sg.zip

See the changes here: www.bitbanksoftware.com/SG_Beta.html

L.B.

Hi Larry,

I'm still experiencing the same choppy/slow audio with Genesis ROM Might and Magic 2 as before, even with quality bumped down to 11Khz and BestPerformance selected...

0

Share this post


Link to post
Share on other sites
Hi Larry,

I'm still experiencing the same choppy/slow audio with Genesis ROM Might and Magic 2 as before, even with quality bumped down to 11Khz and BestPerformance selected...

The way that SmartGear works, the audio sample rate won't affect choppiness. As the system runs out of spare CPU cycles, frames will be dropped; the audio takes priority. It must not be an issue with the settings. I'll take a look tonight.

L.B.

0

Share this post


Link to post
Share on other sites
The way that SmartGear works, the audio sample rate won't affect choppiness. As the system runs out of spare CPU cycles, frames will be dropped; the audio takes priority. It must not be an issue with the settings. I'll take a look tonight.

L.B.

Thanks! I do know that when you first fixed the sound bug with Genesis back in January or February of this year, the game ran absolutely fine. No slowdown or audio choppiness whatsover. I was quite happy! ;) Unfortunately, as the betas progressed and the Genesis audio emulation portion was rewritten, the audio got progressively choppy again. Hopefully, you can speed up the audio just as you had earlier this year. I look forward to testing the next version.

0

Share this post


Link to post
Share on other sites

Great job! I've changed my phone for an HTC Touch Pro, emulation speed isn't perfect but a little better than the previous version (Genesis game). Sounds are better too. There is always some issues on Flashback... Some sounds seems to miss... It 's difficult to explain for a french guy!

0

Share this post


Link to post
Share on other sites

wow.... it's finally release!!!!!!!

can't wait to try it....

i hope i can write my review soon....

thanks.... many thanks......

;) :( :) :D ;)

Edited by dablo
0

Share this post


Link to post
Share on other sites

When i check the machine ID, it is different with 2017. maybe that is the reason why 2018 ask me the register key....

2017 ==> machine ID : 2a7e3464

2018 ==> machine ID : 44e1d6ef

it is only me or another user also has this problem too...??????

0

Share this post


Link to post
Share on other sites
When i check the machine ID, it is different with 2017. maybe that is the reason why 2018 ask me the register key....

2017 ==> machine ID : 2a7e3464

2018 ==> machine ID : 44e1d6ef

it is only me or another user also has this problem too...??????

yup i got a different machine ID as well: 19bd2688

Also L.B. lots of games now work for gens including the lost vikings. Still need to know where i should start putting games that are compatible with 2.x and rev. already beat a few nes games and gbc games without any problems. let me know

Edited by TripFX
0

Share this post


Link to post
Share on other sites
yup i got a different machine ID as well: 19bd2688

Also L.B. lots of games now work for gens including the lost vikings. Still need to know where i should start putting games that are compatible with 2.x and rev. already beat a few nes games and gbc games without any problems. let me know

The different machine IDs is troublesome. I need to double check that on all of my devices. If the numbers change each time I rebuild, then I have to abandon the current system and start over.

L.B.

0

Share this post


Link to post
Share on other sites

2018 works great.....

i can load my saved games only from 2017. none of 2015.

some genesis games are slow to play. such as tintin (very slow), monopoly (menu) but when i play the game, it's work fine.

mario land v.1 (gbc) won't play at all.

i agree that we have to list all games that are work or not. so bitbank can focus to solve the problem.....

my device samsung c6625

0

Share this post


Link to post
Share on other sites

I'm currently working on a professional looking games capability and bugs list/ fixes in 3 formats PDF, DOC, & whatever web format L.B. wants to put on the website. If anyone wants to contribute to the list, email or PM me. It must contain the following in perferable but not required order:

Tester: (Nick Name or Real Name) "Credits to"

Game Sytem:

Game:

Capability: (Fully Works, Works with bugs/glitches, or Doesn't Work) "anseres only"

Bugs/Glitches: "Please describe what works and/or doesn't work"

Settings Used: "Display Settings and Sound Settings only"

Fixes: "If you know find a fix for it please say how or NA"

SmartGear Version: x.x.xx

Device:

OS: "including version"

Overclocked: ( Speed in mhz) or NA "for anseres only"

Verified By User: "put your name here instead if it has already been submitted by another tester"

**CONTACT INFO**

My Email: [email protected]

Please put "SmartGear Game" in the subject so it gets sent to the proper folder in my email

Also I will accept it in any Adobe Reader, Notepad, Word. Open Office, MS Office file format for anyone keeping their own list on the computer.

0

Share this post


Link to post
Share on other sites
I'm currently working on a professional looking games capability and bugs list/ fixes in 3 formats PDF, DOC, & whatever web format L.B. wants to put on the website. If anyone wants to contribute to the list, email or PM me. It must contain the following in perferable but not required order:

Tester: (Nick Name or Real Name) "Credits to"

Game Sytem:

Game:

Capability: (Fully Works, Works with bugs/glitches, or Doesn't Work) "anseres only"

Bugs/Glitches: "Please describe what works and/or doesn't work"

Settings Used: "Display Settings and Sound Settings only"

Fixes: "If you know find a fix for it please say how or NA"

SmartGear Version: x.x.xx

Device:

OS: "including version"

Overclocked: ( Speed in mhz) or NA "for anseres only"

Verified By User: "put your name here instead if it has already been submitted by another tester"

**CONTACT INFO**

My Email: [email protected]

Please put "SmartGear Game" in the subject so it gets sent to the proper folder in my email

Also I will accept it in any Adobe Reader, Notepad, Word. Open Office, MS Office file format for anyone keeping their own list on the computer.

wow, lets get to work..........

0

Share this post


Link to post
Share on other sites

Any word yet on how to fix it or anything L.B.?

0

Share this post


Link to post
Share on other sites
6) Still looking into supporting Morphmodules so that you can play GBA and SNES in SmartGear.

Hey L.B.,

SNES and GBA support would be SOOOO great :D! But do we have to pay extra for these integrations? If not I would purchase it immediately when it's out!! SNES is great! I have a Genesis device here, too, but SNES is even more awesome :).

Edited by SomeWhat
0

Share this post


Link to post
Share on other sites

BitBank,

I know that this was already said in this topic, but you could integrate a GameShark/GameGenie code insert option in the next releases?

Thanks a lot.

0

Share this post


Link to post
Share on other sites
BitBank,

I know that this was already said in this topic, but you could integrate a GameShark/GameGenie code insert option in the next releases?

Thanks a lot.

Several people have asked for this, so I will revisit this issue.

Sorry I've been quiet lately. Lots going on and haven't have much time to work on SmartGear. This weekend I should get some time and put together a new release.

L.B.

0

Share this post


Link to post
Share on other sites

Hi Larry,

Sounds good. Hopefully, you can tackle the issue of the Genesis ROM slowdown, especially when playing the Might and Magic 2 ROM. Looking forward to beta-testing! :)

0

Share this post


Link to post
Share on other sites

Yo LB,

Just FYI: I've updated my Very Old 1.0.4 version to the newest one. I'm sure that I've did everything right but the "About" dialog is saying that I'm on the 1.0.4 Version yet... I've tried everything: update the version, uninstall and re-install the new version and nothing changes... (jus about: I've lost a very very far pokémon crystal save game in the process - by my fault, I know. Backups are there to avoid these cases, but...). Is there anything that I need to change in order to make the system show the new version or was the dialog box tha doesn't have been changed?

One more thing: Anything about GBA emulation?

Sorry about this annoying text... and sorry about the crappy english... I'm trying to don't use translators. :angry:

Thanks a lot again!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.