• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Needing serious help with 8390

8 posts in this topic

Posted · Report post

I'm in Dallas Texas and I have a Mitac 8390. I'm not able to get my phone to come on. The battery went dead and I fully recharged it until the green light came on. but now the phone won't turn on. The face clock looks to be working, but it displays the same time all the time. Is there any service centers or tech help I can get in the US.

Rpiceman

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm in Dallas Texas and I have a Mitac 8390.  I'm not able to get my phone to come on.  The battery went dead and I fully recharged it until the green light came on.  but now the phone won't turn on.  The face clock looks to be working, but it displays the same time all the time.  Is there any service centers or tech help I can get in the US.

Rpiceman

<{POST_SNAPBACK}>

when u turned on the phone the front display is working? if yes i have the same problem... :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

when u turned on the phone the front display is working? if yes i have the same problem... :D

<{POST_SNAPBACK}>

Damn, it's just happened to me today. I'm wondering if Mitac set a time bomb on these phones. Any help would be appreciated!!!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Damn, it's just happened to me today. I'm wondering if Mitac set a time bomb on these phones. Any help would be appreciated!!!

<{POST_SNAPBACK}>

Sorry to hear about this but mitac isn't competent enough to have done it on purpose. All I can tell you is to leave it in the charger for a few hours and then try to start it up into the boot menu. Hold down the asterisk and both softkeys when you turn on the phone. If that works, simply go to option 5 to reboot the phone and you'll be set. If that doesn't work, try a hard reset. Hold in the volume button (press in the center of the button, not up or down exclusively) while turning on the phone. It should vibrate when it comes on. If that works, great, but it will wipe out anything you have saved on the phone. If neither of those work, I don't really know what to tell you.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm in Dallas Texas and I have a Mitac 8390.  I'm not able to get my phone to come on.  The battery went dead and I fully recharged it until the green light came on.  but now the phone won't turn on.  The face clock looks to be working, but it displays the same time all the time.  Is there any service centers or tech help I can get in the US.

Rpiceman

<{POST_SNAPBACK}>

Oh...the only way you could have gotten it serviced would be to send it to China, have it repaired and sent back, all at your expense. And it is VERY expensive to do that, like on the order of at least a couple hundred dollars, if I recall correctly. I know of one 8390 owner who did that but that was a long time ago and mitac doesn't appear to support this phone at all any more. If it's at all possible, sell it and get something else. I recent bought an E200 in great shape off ebay for $187 which included shipping from the UK and now I'm trying to determine if I want to sell my 8390 or smash it with a hammer.

Sorry to be the messenger but that's the way it is with this bullsh*t company and it's bullsh*t products.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Oh...the only way you could have gotten it serviced would be to send it to China, have it repaired and sent back, all at your expense. And it is VERY expensive to do that, like on the order of at least a couple hundred dollars, if I recall correctly. I know of one 8390 owner who did that but that was a long time ago and mitac doesn't appear to support this phone at all any more. If it's at all possible, sell it and get something else. I recent bought an E200 in great shape off ebay for $187 which included shipping from the UK and now I'm trying to determine if I want to sell my 8390 or smash it with a hammer.

Sorry to be the messenger but that's the way it is with this bullsh*t company and it's bullsh*t  products.

<{POST_SNAPBACK}>

Yeah, I saw your comment about 8390 being suck on the thread and I'm secondly motioning it. I'll try to do all those thing you've said. My phone looks fairly new and tried to keep in best shape. It's just bad that the phone put me down. Best of luck to me........ Thanks......

0

Share this post


Link to post
Share on other sites

Posted · Report post

I had to send the 8390 back to china. It was $75.00 shipping to china. I got it back and so far it works great. I didnt have to pay for the repair or for the shipping back becuase they told me that it was still under warranty. This is my first smartphone and I'm not sure how to do all the fancy things with it. It does look like they loaded the latest software versions. I have yet to find any thing that is in chinese. All menus are in english. I was told that the problem i think was that they had to fully replace an RF board. I downloaded the service pack 1, but only on my PC. I dont think i'm going to install seeing that i'm not have a problem yet. Any cool ideas to do on the phone would be apprecaited. Short of hitting it with a hammer.... haha

0

Share this post


Link to post
Share on other sites

Posted · Report post

cool ive never had a problem with my 8390 yet like these guys. anyways can you go into settings then to about and tell me what you see

Mine is -------------------------------

Version 4.20.0 (build 13291)

Radio Version R4.0.4 MBE4303601 P2

Operator: 4.20.13291.0

Manufacturer: 42.0.0.0

Microsoft: 4.20.13291.0

Language:4.20.13291.0

File System 4.20.13291.0

when did you get your phone back? install a game and see if you need the GAPI signing fix

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.