• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Solution to adding t9 languages to SPV C500

72 posts in this topic

Posted (edited)

Hello. Can anyone help with this?

Good morning!

Help!!! I have tried to get Spanish to work on my Cingular 2125 (WM5) for weeks to no avail. I don't even get the option to change languages (is there a trick?).

Here is what I have done:

Extracted the Spanish dll from the language pack posted on this thread. Created a directory in my storage card (Storage Card\t9\) and moved the dll to the folder directly from my PC using ActiveSync.

Changed my registry values:

In the HKEY_LOCAL_MACHINE\MUI\Available I added the value 040a And called

the Value Data: "Spanish"

Then in HKEY_LOCAL_MACHINE\T9 Input Method\LDBs I added the value 040a

and called the value data: "\Storage Card\t9\T9SpanishLdb.dll"

And finally in the HKEY_LOCAL_MACHINE\T9 Input method\MUI\Languages I edited the value: "Available"

from "0409" to "0409,040a"

Am I missing anything? Need any other files or tweaks?

Thanks in advance!

Edited by mancha
0

Share this post


Link to post
Share on other sites

Posted

Thanx guys ! Works great !

Smart Explorer won't work for copying the DLL, but the built in

Windows Explorer does !

<{POST_SNAPBACK}>

Hello there.

sorry to bother u but I just bought the C550 and I'm trying to install the czech ddl without any success.

Changing "values" "directories" and all these different words confused me a lot. I'm not that crap with mobile devices but difinitely not an expert.

I know time is limited these days for everyone but IF you manage to get some free time can u please explain to me step by step the istallation?

Thanks in advance.

Kiri

0

Share this post


Link to post
Share on other sites

Posted

Where is spanish?

<{POST_SNAPBACK}>

can anyone tell from where to download T9Urdu Dll file...

0

Share this post


Link to post
Share on other sites

Posted

I don't have a fooking storage card, what do I do here?

I have a Qtek 8010 running WM5 btw.

0

Share this post


Link to post
Share on other sites

Posted

Same problem here, I have a mpx200 upgraded to wm2005 and now my Storage card is seen as part of the rom, so, no storage card, what can we do.

0

Share this post


Link to post
Share on other sites

Posted

We are not in the same boat exactly. I actually don’t have a storage card. I haven’t yet found a need for it until now that is.

0

Share this post


Link to post
Share on other sites

Posted

Cingular 2125:

I've strugled with this for a couple of days but now found a very simple sollution. I live in the USA, I'm Dutch so I needed the dutch T9 stuff.

Turns out the Dutch DLL is already in there together with English, German, French and Italian, the only thing I did was to download this handy editor which allows you to edit the mobile registry from your pc:

http://www.breaksoft.com/Blog/Utilities/20...try_Editor.aspx

Then I only added 0413 (dutch) to HKEY_LOCAL_MACHINE\T9 Input Method\MUI\Languages\Available

Now T9 Dutch is available...

Have fun!

Wim

0

Share this post


Link to post
Share on other sites

Posted

Well, finally was able to load a spanish .dll file onto my mpx200 running wm5, did the registry edits, now, I choose spanish on the T9 menu, but, can't write anything, I just get beeps instead. anyone has a solution?

0

Share this post


Link to post
Share on other sites

Posted

Well, finally was able to load a spanish .dll file onto my mpx200 running wm5, did the registry edits, now, I choose spanish on the T9 menu, but, can't write anything, I just get beeps instead. anyone has a solution?

Hi, according to another website I saw we need a MUI file for each language as well. f.x. T9ImeRes.Dll.0413.mui which recides in the windows directory. Without the MUI it will just beep.

So I want to start by asking for the danish MUI file or does anyone know how to make your own language file and MUI ?

For more languages I have included a file I found on the internet.

t9languages.zip

0

Share this post


Link to post
Share on other sites

Posted

Thanks it work fine!!

Regards

0

Share this post


Link to post
Share on other sites

Posted

Hi,

I am new here and have already a question :

on my QTEK 9100 with WM5 English I want to install a Dutch T9.

Downloaded an registry editor and the t9languages.zip.

But... my registray HKLM\T9 Input Method\etc does not exist.

And I do not have a T9 selection menu.

Am I missing something ?

Thanks, Bram

0

Share this post


Link to post
Share on other sites

Posted

Hello i have the same problem as FJatle, its configured fine, but when i write it makes a sound and does anything...

any solution?

0

Share this post


Link to post
Share on other sites

Posted

Anyone succeeded with WM6 OS phone? I tried it with Czech and Norwegian with my HP IPAQ 514 and had no luck. 

The verison of the dll files found here seem to be the same as the built-in English dll, I managed to be able to choose the new languages, n

vertheless i only heard beeping when trying to type.

Moreover, sometimes I was not able to type properly with English T9 (inability to enter space or letters being pressed twice randomly) and sometimes even with classic method (space did not work). Everythin

 turned fine again when i reverted the registry changes.

Some hints in case somebody wants to continue from where I finished:

 - Copy the files directly to Windows directory (Go to Menu -> Options and uncheck Hide hidden files to see hidden and system file

)

 - Set Read-only, Hidden and System attribs to new DDLs (see what other DLLs have). If this is not set, some applications won't start (messaging) and T9 About page will display confirmation that you want to run insecure file.

 - There is a file T9ImeRes.Dll.0409.mui - I tried to play with it for a while (e.g. copy it with new language ID) and this seems to have no effect. I looked inside and it seems to be some HP specific file according to the messages.

 - I could not find any other useful registry keys (when searched for "T9" and "0409")

 - T9Ime.dll seems to have no impact, as it is assigned to probably all languages in registry.

 - Always restart the phone when changing the registry, the changes seem to be visible (e.g. language is offered), but strange things happen

 - By setting the correct attributes, I managed the new DLLs to be offered in T9 About DLL listing. Unfor

unately this did not help, but it is probably a good success indicat

r (Settings 9-9-1-3 to check)

I tried also "T9 Config Utility 1.0", which does not seem to work either.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Anyone succeeded with WM6 OS phone? I tried it with Czech and Norwegian with my HP IPAQ 514 and had no luck.

Hi there!

I'm trying the same thing for my 514 too. With italian language file. I didn't even get as far as having the .dll being loaded (only german, english, french appear in the about). I'm starting to belive that the T9 software has some kind of security measure to make it impossible to load "unofficial" T9 language files. Rather by checking if a DLL comes from the ROM or if it has the right certificate.

However, seeing that you were able to make the app load the dll lets me reconsider. I think, I'll keep trying, although I'm running out of ideas.

Cheers!

PS: Yes, I've set the .dll and the .mui attributes to +s +h +r -a, just like the other files are.

PPS: Did anyone succeede in copying existing t9xxx.dll-files from a WM6 device (preferably smartphone)? I'd really like to compare it to the files that float around the net.

BTW: Some poor guy had the idea to ask HP for help on that:

http://forums1.itrc.hp.com/service/forums/...hreadId=1150643

Edited by Anonymaus
0

Share this post


Link to post
Share on other sites

Posted

Share this post


Link to post
Share on other sites

Posted (edited)

Hello

I'm french

Could you put in a image of the registre HLM for the T9 language.

Anything language

I 'm sure , i'm a "nut" ;)

Thanck you :wub:

Edited by grisly
0

Share this post


Link to post
Share on other sites

Posted

Hi to all forum members. I recently got a smartphone, wich doesn't have croatian T9 input. Colud you post that language here, please. If anyone colud find it?

0

Share this post


Link to post
Share on other sites

Posted

Just in case anyone is reading here regarding Windows Mobile 5

I managed to get Spanish t9 working on the C600 using the C500 spanish t9 file as posted above and the following entries:

HKLM\MUI\Available (Added string 040a with value "Spanish")

HKLM\T9 Input Method\MUI\Languages (Added ",040a" to end of value data list)

HKLM\T9 Input Method\LDBs (Added string 040a with value "\Storage Card\t9\T9SpanishLdb.dll)

I made the folder "t9" on my storage card and put the spanish t9 file there, as you can see the language code for that spanish is 040a (traditional sort)

hope this helps anyone looking

I'm not sure if anyone will be reading this as it's been a long time since it was posted - but this worked perfectly after a few frustrating mistakes of forgetting ".dll" etc.

I'm now a fully integrated Spaniard with a UK SPV C600,

Thank you!

0

Share this post


Link to post
Share on other sites

Posted

Good to hear you got it working :)

0

Share this post


Link to post
Share on other sites

Posted

...

BTW: Some poor guy had the idea to ask HP for help on that:

http://forums1.itrc.hp.com/service/forums/...hreadId=1150643

Hello. I am the poor guy that asked HP for help :D

does anybody know here how to install additional T9 languages on my IPAQ 514? I am still interested in getting an answer as all I got at the other forum did not work :)

thanks!

0

Share this post


Link to post
Share on other sites

Posted

i´m having trouble to install T9 Portuguese in smt5600(c500) with windows mobile 6.1

the name appear, but when I choose, I only beep error

0

Share this post


Link to post
Share on other sites

Posted

I used a cab file to instal t9 (dutch) for my Imate SPL wm6.1

Way easier! I also couldn't find HKLM\T9 Input Method\ like the other dutch guy mentioned. link for cab files:

http://melgurth.ovh.org/index.php?page=downloads

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.