onuo

C500 stuck on Profile - Known Fault?

5 posts in this topic

Hey,

First post and im very stressed! - Having spent three weeks looking at the C500 and a Sendo X I decided to get a C500 sim-free from my local orange store and since have had woes since day one...

I have waited for 2 weeks to have the phone unlocked for abroad use (or maybe T-Mobile :D ) by Orange which you are legally allowed to ask for.

After many phone calls and many lies 'we'll have it by tomorrow" and being told by several members of their customer service (including a supervisor) and by many assistants in the shop to just go to a local independent phone shop (i.e. bloke with a computer and data cable) and have them unlock it - "cause its quicker than us". I finally took the plunge and got it unlocked in 5 MINUTES !!! using Florin's imei-check website - thanks Florin, surprisingly enough it does work and its not a scam!

Also went in to the shop to buy the roll out keyboard after being told it would work when i bought the phone only for them to open the box to find it works only with E200 and then being told "why do you want it anyway you would only look like a dick!!" by the assistant.

Anyway after that i thought all my troubles were over then i decided to use the headset all seemed well until it came apparent that i could not put the phone into silent or normal mode. Jumped onto the internet and i found this...

http://www.coolsmartphone.com/stuck-in-headset.htm

So it seems that i have bought one dog of a phone, i have tryed all methods of fixing the problem and i cannot get it too work, If i take the phone back and shout alot no doubt i will get a refund but i will have lost out on my £20 to Florins excellent site (which in all matters of things was the only thing that did what it said!!!! )

I like the phone but now im feeling i wished i payed the extra for the sendo x as i have already came from a symbian nokia with no trouble in the year of owning it and the sendo is no more than a jumped up nokia S60.

The other thing with this is that this could be well a health and safety issue! If the phone is stuck on headset mode then the ringer is always set to low so as not to blow your ear drums ! Once stuck the only way to hear if the phone is ringing is to set the phone to an increased volume when headset is removed however if for example i am listening to music with headset in and the phone rings surely this could make me deaf or cause impairment.

As this does not seem to be an isolated case i feel that i have and others have paid for something of shoddy workmanship and could have easily bought a cheap sagem and a palm for the cost of this phone !

Has anyone else had this fault or have a soloution or advice !

Would be most welcome of any....

onuo

0

Share this post


Link to post
Share on other sites

I had this happen with my C500 once. Found the solution was to plug in the headset and remove it, over and over again. There must have been some sort of switch or something inside which had gotten stuck. It eventually became un-stuck and works brilliantly from then on. If it doesnt work with your C500's headset, try something else with a 2.5mm jack on it. It worked first time for me with a motorola handsfree kit.

0

Share this post


Link to post
Share on other sites

mine gets stuck in headset mode at least once a week!! pain in th A*** also locks up about once a week needing the battery pulling out to fix it!!

Great phone.. big faults!!

I have sprayed PC cleaner in the jack socket and it seems to have stopped the headset fault, if it happens again its going back..

G

0

Share this post


Link to post
Share on other sites

HA-HA !

It's fixed, found many others complaining of the same thing on the site, then i found one entry saying to try two things...

1. Go through each of the profiles and revert to default, reboot and retry.

or

2. Hard reset.

The latter worked a treat and i can pull the plug in and out with no problems making me think it's not a harware fault but a software glitch, I have tryed to find a link to that page but have lost it, can anyone find it? - it had more details of the above, for others in the same position.

Anyway hard reset worked for me why not try it, the way to do this can be found on this site in many places...

Hopefuly things are looking up! :D

onuo

0

Share this post


Link to post
Share on other sites
also locks up about once a week needing the battery pulling out to fix it!!

This is probably due to some applicatin you have installed on the phone.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.