Sign in to follow this  
Followers 0
starsoft

SPV E200 Water Damage

2 posts in this topic

Everything works on the phone apart from the acutal phone itself no signal on ariel can anyone help many thanks

Happy 2006 ;)

0

Share this post


Link to post
Share on other sites
Everything works on the phone apart from the acutal phone itself no signal on ariel can anyone help many thanks

Happy 2006  ;)

Best thing would be to open it to check for any corrosion and if found remove with a fibreglass pencil or clean in a waterbath.

Was the unit ok until the water damage? More common to get power circuit shorts than loose signal. Corrosion around the actual aeriel wouldn't block the signal unless for some reason the aeriel antennae has become detached / disconnected from the board?

There are some fusable resistors around the car kit aeriel connection. From repairing a Tanager board, if these short you're still ok, it if the circuit breaks you get no signal. (It wasn't corrosion with this problem, someone had tried to force a tanager into a canary wired car kit and sheared the connector off breaking the circuit.)

EDIT - just occured that without the stopper in place this is the perfect entry point for moisture into the phone - might be the aera to check closely on the board.

If all else fails and you've got a good screen, keypad and casing I have some mainboards knocking about.

Richard

Edited by fluffcat1
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.