• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

WiFi SDIO on MDA Compact II (charmer)

71 posts in this topic

Posted (edited) · Report post

Hello,

Can anyone who has used wifi with the MDA Compact II tell me what card and drivers they are using. I have been through several cards now and none of them work on my device. The Spectec has come closest (almost recognises it!) and they are developing a bugfix for the WM5 drivers.

I need a WiFi SDIO for the Compact II do you have one that works?

fUNKUS

Ps: cards that work on the Compact will not nessisarily run on the Compact II due to different Operating System, processor ect. The MDA Compact II is also known as a HTC Charmer but i not on sale under any other name so if you dont own one of these.....you need not apply hehe

Edited by fUNKUS
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hello,

Can anyone who has used wifi with the MDA Compact II tell me what card and drivers they are using. I have been through several cards now and none of them work on my device. The Spectec has come closest (almost recognises it!) and they are developing a bugfix for the WM5 drivers.

I need a WiFi SDIO for the Compact II do you have one that works?

fUNKUS

Ps: cards that work on the Compact will not nessisarily run on the Compact II due to different Operating System, processor ect. The MDA Compact II is also known as a HTC Charmer but i not on sale under any other name so if you dont own one of these.....you need not apply hehe

<{POST_SNAPBACK}>

See http://www.modaco.com/charmer_with_moto_ht820-t236732.html

Sounds like you had a more positive response from Spectec than I did - though I do think if T-Mobile add a hsdcard.dll support the spectec is probably the best candidate for actually working

Edited by kaf
0

Share this post


Link to post
Share on other sites

Posted · Report post

I presume that adding the hsdcard.dll file and correct regestry settings wouldn't hake a difference because if it might then i'll try the drivers with these additions.

1. I need a link to the file (hsdcard.dll ) or just a Cut and paste of it contents if possible.

2. Also i need all the the registry settings in [HKEY_LOCAL_MACHINE\ Drivers\SDCARD\HostController\xxx\xxx (all details from SDCARD would be best)

Let me know and ill try it, i thnik all i need to do is add the pnp codes for the card/ device which im sure can find. Im not positive on this but if you can give me any details ill try this.

Thankyou in advance,

fUNKUS

0

Share this post


Link to post
Share on other sites

Posted · Report post

I presume that adding the hsdcard.dll file and correct regestry settings wouldn't hake a difference because if it might then i'll try the drivers with these additions.

1. I need a link to the file (hsdcard.dll ) or just a Cut and paste of it contents if possible.

2. Also i need all the the registry settings in [HKEY_LOCAL_MACHINE\ Drivers\SDCARD\HostController\xxx\xxx (all details from SDCARD would be best)

Let me know and ill try it, i thnik all i need to do is add the pnp codes for the card/ device which im sure can find. Im not positive on this but if you can give me any details ill try this.

Thankyou in advance,

fUNKUS

<{POST_SNAPBACK}>

I've tried all that - doesn't work - think HSDCard.dll is pocket PC device specific and whereas you could possibly use one off and XDA2 with a QTek 2020 I don't think there is any close model comparison with an MDAc2

0

Share this post


Link to post
Share on other sites

Posted · Report post

I've tried all that - doesn't work - think HSDCard.dll is pocket PC device specific and whereas you could possibly use one off and XDA2 with a QTek 2020 I don't think there is any close model comparison with an MDAc2

<{POST_SNAPBACK}>

The prophet is likely to be a better match, same OS, same CPU and a SDIO card slot.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Utterly gutted. :)

Trying to get some help on xda-developers see here for results:

http://forum.xda-developers.com/viewtopic....p=235076#235076

Hopfully someone will take pity on us.

fUNKUS

PS: I've only just changed to T-Mobile from Orange and this is secret wifi disable says alot to me about how they do business. Maybe ill change back.

Either way im headed into a store tomorrow to kick up a fuss about it, i might even demand an upgrade to the Vario, but to be honest i dont want one, they are fat and ugly, thats why i chose this!

Edited by fUNKUS
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

If anyone has a HTC Prophet please contect me with the above registry settings, i can easily explain how to find them.

Thanks in advance

fUNKUS

POST EDITED PER FORUM RULES

Edited by Pondrew
0

Share this post


Link to post
Share on other sites

Posted · Report post

T-Mobile said they would fix it in the next update didnt they? well since theyve have said the Vario ROM with AKU2 would now be as late as June, would they bother with a mdac2 update now without AKU2 and then again in a few months with AKU2?!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Well i dont know mate, where did you hear they were going to fix it? Id love to have that confimed, then i can stop trying to build wifi into this thing from the ground up.

I dont care how they fix it, if they would speak to Microsoft and get permission then they could just email out the missing files and an automatic .reg update. That would do for now, it would take 1 techie from T-Mobile less than a day to get these things together and put them up as a download on the support site.......but will they do it?......i doubt it.....it wont make them money

I imagine that if T-Mobile are planning on fixing it they would have emailed me back. But ill try sending the email to the wifi hotspot dept of support:

T-Mobile wifi support

Try emailing them yourself if youre trying to get this working, maybe they value customer support? I know orange didn't, thats why i changed.

I'd love to have AKU2, but to be honest this is my only problem with the device, its great apart from that. Also worth remembering that that the usual 'service packs' from microsoft do more damage than good, remember sp2 for xp? that was brutal!

fUNKUS

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

read that someone was also trying to get a sdio card to work on the charmer on xda have a look here http://forum.xda-developers.com/viewtopic....&highlight=sdio

Looking through the wizard rom, it doesnt contain those registry keys or the dll file so it is device specfic rather than WM5. so best bet really is getting hold of a prophet or waiting for t-mobile. hopefully there arent as bad as orange when it comes to rom updates. (ie, c500 with wmp10!!)

Edited by dave106
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

OK so i found:

HSDCard.dll

SDBusDriver.dll

SDMemory.dll

and these reg settings: From here:Reg Settings

[HKEY_LOCAL_MACHINE\Drivers\SDCARD]

[HKEY_LOCAL_MACHINE\Drivers\SDCARD\ClientDrivers]

[HKEY_LOCAL_MACHINE\Drivers\SDCARD\ClientDrivers\Class]

[HKEY_LOCAL_MACHINE\Drivers\SDCARD\ClientDrivers\Class\MMC_Class]

"Dll"="SDMemory.dll"

"Prefix"="DSK"

"FSD"="FATFS.DLL"

"IOCTL"=dword:00000004

"BlockTransferSize"=dword:00000040

"Profile"="MMC"

"IClass"=hex(7):\

7b,41,34,45,37,45,44,44,41,2d,45,35,37,35,2d,34,32,35,32,2d,39,44,36,42,2d,\

34,31,39,35,44,34,38,42,42,38,36,35,7d,00,7b,41,33,32,39,34,32,42,37,2d,39,\

32,30,43,2d,34,38,36,62,2d,42,30,45,36,2d,39,32,41,37,30,32,41,39,39,42,33,\

35,7d,00,00,00,00,00,00

[HKEY_LOCAL_MACHINE\Drivers\SDCARD\ClientDrivers\Class\SDMemory_Class]

"Dll"="SDMemory.dll"

"Prefix"="DSK"

"FSD"="FATFS.DLL"

"IOCTL"=dword:00000004

"BlockTransferSize"=dword:00000040

"Profile"="SDMemory"

"IClass"=hex(7):\

7b,41,34,45,37,45,44,44,41,2d,45,35,37,35,2d,34,32,35,32,2d,39,44,36,42,2d,\

34,31,39,35,44,34,38,42,42,38,36,35,7d,00,7b,41,33,32,39,34,32,42,37,2d,39,\

32,30,43,2d,34,38,36,62,2d,42,30,45,36,2d,39,32,41,37,30,32,41,39,39,42,33,\

35,7d,00,00,00,00,00,00

[HKEY_LOCAL_MACHINE\Drivers\SDCARD\HostControllers]

[HKEY_LOCAL_MACHINE\Drivers\SDCARD\HostControllers\XSDSC]

"Dll"="HSDCard.dll"

"Prefix"="HSD"

[HKEY_LOCAL_MACHINE\Drivers\SDCARD\SDBusDriver]

"BusDriverHandle"=dword:002f7f50

"Order"=dword:00000020

"Dll"="SDBusDriver.dll"

"Prefix"="SDC"

"ThreadPriority"=dword:00000064

"RequestListDepth"=dword:00000030

As fas as i can see im not sure if SdMemory.dll is neccisary. So i copied HSDCard.dll and SDBusdriver.dll to the windows directory and made the corresponding regestry entries (those in bold font)

What happened after a reset and inserting SDIO WiFi card:

1. The little blue light suddenly turned on (for the fist time), but it doesn't seem to turn off!

2. The small white wifi icon appeared.

Basically it didn't work though, it still seems to crash when i load WiFiFOFum, but when i load hitchhiker it does behave differently, where it used to say 'no wifi detected' it now attempts to connect to the card but unfortuantely it does then crash/hang untill i remove the card.

If anyone notices anything wrong witht these files or reg keys (suck as a device specific code) please tell me and ill try this again:

Anyone else want to try this out, as i dont even know if im doing it right, and it would be a pity if a small error in the reg's i input hid the solution!

let me know

fUNKUS

POST EDITED PER FORUM RULES

Edited by Pondrew
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I found this inside the Wizards Registry

[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\SDHC]

"BaseClockFrequency"=dword:01312d00

"CDPriority"=dword:00000065

"CardDetectSysIntr"=dword:0000001d

"SDIOPriority"=dword:00000064

"ControllerIRQ"=dword:0000001c

"Prefix"="SHC"

"Dll"="OMAP850_SDHC.dll"

"Order"=dword:00000021

HC for host controller maybe?

and this one

[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\SDBusDriver]

"IClass"=multi_sz:"{20FA98A8-B298-4b32-8D72-C716AEE2FA84}=%b","{6F40791D-300E-44E4-BC38-E0E63CA8375C}=%b","",""

"Flags"=dword:00010000

"RequestListDepth"=dword:00000030

"ThreadPriority"=dword:00000064

"Prefix"="SDC"

"Dll"="SDBus.dll"

"Order"=dword:00000015

and these!

[HKEY_LOCAL_MACHINE\Drivers\SDCARD]

[HKEY_LOCAL_MACHINE\Drivers\SDCARD\ClientDrivers]

[HKEY_LOCAL_MACHINE\Drivers\SDCARD\ClientDrivers\Custom]

[HKEY_LOCAL_MACHINE\Drivers\SDCARD\ClientDrivers\Custom\MANF-0001-CARDID-0000-FUNC-1]

"Prefix"="SIO"

"Dll"="TNETWLN.dll"

"Instance0"="TNETWLN:TNETWLN1"

[HKEY_LOCAL_MACHINE\Drivers\SDCARD\ClientDrivers\Class]

[HKEY_LOCAL_MACHINE\Drivers\SDCARD\ClientDrivers\Class\MMC_Class]

"IClass"=multi_sz:"{A4E7EDDA-E575-4252-9D6B-4195D48BB865}","{A32942B7-920C-486b-B0E6-92A702A99B35}","",""

"IOCTL"=dword:00000004

"FSD"="FATFS.DLL"

"Profile"="MMC"

"BlockTransferSize"=dword:00000040

"Prefix"="DSK"

"Dll"="SDMemory.dll"

[HKEY_LOCAL_MACHINE\Drivers\SDCARD\ClientDrivers\Class\SDMemory_Class]

"IClass"=multi_sz:"{A4E7EDDA-E575-4252-9D6B-4195D48BB865}","{A32942B7-920C-486b-B0E6-92A702A99B35}","",""

"IOCTL"=dword:00000004

"FSD"="FATFS.DLL"

"Profile"="SDMemory"

"BlockTransferSize"=dword:00000040

"Prefix"="DSK"

"Dll"="SDMemory.dll"

Edited by dave106
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

[HKEY_LOCAL_MACHINE\Comm\TNETWLN1]

"ImagePath"="tnetwln.dll"

"Group"="NDIS"

"DisplayName"="SDIO WLAN Wireless Adapter"

[HKEY_LOCAL_MACHINE\Comm\TNETWLN1\Parms]

"PrivacyMode"=dword:00000002

"RateFallBackThreshold"=dword:00000080

"HTCPowerSaveTimeout"=dword:0000003c

"HTCPowerSaveRxDataThreshold"=dword:00000002

"HTCPowerSaveTxDataThreshold"=dword:00000001

"HTCPowerMode"=dword:00000000

"dot11ShortPreambleInvoked"=dword:00000001

"dot11DesiredTxRate"=dword:00000000

"dot11SupportedRateMask"=dword:00000001

"ResetOnResume"=dword:00000001

"Testmode"=dword:00000000

"PAType"=dword:00000001

"Sysintr"=dword:00000023

"BusType"=dword:00000000

"BusNumber"=dword:00000000

[HKEY_LOCAL_MACHINE\Comm\TNETWLN1\Parms\Tcpip]

"DhcpRetryDialogue"=dword:00000008

"DhcpMaxRetry"=dword:00000015

[HKEY_LOCAL_MACHINE\Comm\TNETWLN]

"ImagePath"="tnetwln.dll"

"Group"="NDIS"

"DisplayName"="SDIO WLAN Wireless Adapter"

[HKEY_LOCAL_MACHINE\Comm\TNETWLN\Linkage]

"Route"="TNETWLN1"

These all seem like they are related.

Edited by dave106
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

:oops: actually, looking through the mdac2, it already has most of those. my device is missing HKEY_LOCAL_MACHINE\Comm\TNETWLN1 and subs keys as well as HKEY_LOCAL_MACHINE\Drivers\SDCARD\ClientDrivers\Custom and subs keys though.

After added all those bits i'm missing. SDIO Wireless Adapter appears in the Network Cards control panel, options availible are assigning IP address to it, setting up DNS/WINS or auto assigning by DHCP

Edited by dave106
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Please dont post any copyrighted files here, i have already had one thread locked for this reason and if this one is locked i will definetly not be able to sort this problem, all i want is advice, thankyou. fUNKUS

PS: Sorry admin i didn't mean to breach copyright laws!!!

PPS: Go to next page for a respone by T-Mobile :)

Edited by fUNKUS
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Ok, ive looked at those regedits and dll's but unfotunately my mate has identified these as the drivers:

TNETWLN1 and its .dll are for the built in wifi that comes on the magician so im certain that they will be specific to the built in wifi chip. Think thats a dead end.

SDCARD\ClientDrivers\ anything in 'clientdrivers' is corresponding to specific drivers from 3rd party hardware (ie a wifi card you install or similar preinstalled chips) So its not relevant.

Basically im not sure these files will help.

HOWEVER

I have finally recieved a response from T-Mobile:

Hello Christopher

Thank you for your email about out MDA Compact 2. I'm sorry to hear you have been having problems.

I have spoken to the product manager for the MDA Compact 2 and he does not believe we have intentionally disabled SDIO capability on the device. However as you mentioned there does seem to be a perception on the web that we have.

What I have done is passed the details onto our MDA specialist team in T-Mobile Germany to test the SDIO capabilities of the device. It could take a few weeks for them to respond to me but at least when they do I will have a definitive answer for you.

Also there will be a ROM updated available for the MDA at some point in the second quarter this year. The exact content of the update has not been finalised yet as it is still in testing at the

I hope this is satisfactory for yourself. In the meantime if you have any other queries please don't hesitate to contact me again.

Kind regards

Ross

Escalation Desk

Technical Data & Multimedia Support (TDMS)

YES!!! well they say that they are going to test its 'SDIO' capabilities in Germany and let me know, that probably means they're gping to say 'no youre right it doesnt work' in two weeks time but maybe they will put out a fix for it, or just include the fix in the update. Then i dont have to risk my warranty on a different rom :)

Heres hoping

fUNKUS

Edited by fUNKUS
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

T-Mobile seem to have released an update for the MDA Compact II but i dont think they have fixed it, ive tried the update and theres no apparent change in wifi capabilities, my sdio's still dont work and actually cause any client to hang unless i eject them.

In fact im pretty sure that the files available are identical to those already on my system.

Its called:RUU_Charmer_1120223_11202110_11220_T-MobileUK_Ship.exe

And my old rom was 1.12.223

I dont know if they have changed anthing but if they did i cant see it ;)

Not sure how patient i can be, my GPRS bill is already massive because of how i use my device. Being billed per mb is only good if you dont use it that much. :?:

Edited by fUNKUS
0

Share this post


Link to post
Share on other sites

Posted · Report post

Where is the rom available from Funkus? There was the original shipped rom available on the T-Mobile download manager for a time but it was since taken down...

Also, out of curiousity, what's the extended rom version number? The reason I ask is as my extended rom version number doesn't seem to match what the majority here have despite it being a standard unit bought directly from T-Mobile over the web.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

T-Mobile Download Manager:

T-Mobile link

Since changing the rom is 'illegal' or whatever it seems strange that they put up a rom 'restoring' program. Maybe this is a subtle hint of some kind?

Here are my details afer updating using the above file:

ROM:1.12.2.23 WWE

ROM date: 11/14/05

Radio Version; 01.12.20

Protocol Version: 4.0.13.23

Ext rom : 1.12.02.110

Let me know if you think they have changes anything but it looks like they call it the 'production rom' so i think its just the same.

I spent ages doing this udate thinking they had fixed the wifi issue ;) no such luck.

Ps:oh and its got the wrong photo on it so dont let it confuse you, lol

Edited by fUNKUS
0

Share this post


Link to post
Share on other sites

Posted · Report post

Its the same ROM they had before. i tried it out then because the date was different to my shipped one but its just an error on the site.

0

Share this post


Link to post
Share on other sites

Posted · Report post

ugh, well never mind it was wishful thinking.

Im in a bit of a conumdrum now, i need advice on the Compact II and stopping t-mobile mods from disabling wifi but i cant do that here, everyone at MoDaCo has been really helpful but im not allowed to discuss these 'rom' subjects here, which is fair enough.

I tried to get help on XDA developers forum, where these discussions are allowed but noone has relplied to the thread there. Dead thread....;)

So im kinda stuck, i think i might know a solution, but i cant discuss it with anyone to check.

Any ideas?

[i am aware that discussing illegal rom's here is frowned upon here so please be careful what you say , dont post any links to rom files ect]

0

Share this post


Link to post
Share on other sites

Posted · Report post

How very annoying that we are not allowed to discuss something that in many people's eyes should have been included in the model in the first place.

The network provider concerned is obviously consciously trying to block use of WiFi as they do not wish the (rather good) web tariff to be undermined by WiFi technology.

It's this kind of thing that encourages people to switch network provider ... and having taken out a T-Mob contract very recently, I have to say I am seriously wondering if I should take advantage of the Distance Selling Act!

Not impressed!

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

How very annoying that we are not allowed to discuss something that in many people's eyes should have been included in the model in the first place.

Its not that it should have been included, its a standard feature that shouldnt have been disabled, its not a special feature, its what a wm5 ppc with a fully enabled SDIO does. Thats what infuriates me so much! It worked before t-mobile got their grubby mits on it.

Heres a 'real world' example:

I went to the shop and bought a horse, when i got it home i realized it was missing its legs! I went to the farm i was born on and they assured me that all their horses have legs. So i went to the market and dicovered many other dissatisfied customers. It turns out that the horse shop had accidentally chopped all the horses legs off!

A few weeks letter i received a letter from the horse shop telling me that they are investigating the reason as to why my horse has no legs and that they will 'give me a difinite answer in a few weeks'.............

I have emailed them twice asking them if they are going to even attempt to fix it and they have replied both times with 'there will be an update, but we cant say whats in it' so as time fast runs out for me to change to a device with built in wifi, so does my patience.

Furious exausted ranting aside....i agree...sort it out t-mobile.....wifi isnt everywhere and with the short range wifi provides, we'll still use gprs most of the time. But i actually use my device constantly in a 'work network' capacity and therefore being charged per megabyte to communticate with our own servers externally through the internet sucks.....in fact its rediculous!

My horse is kinda useless...

Edited by fUNKUS
0

Share this post


Link to post
Share on other sites

Posted · Report post

Guys, have you queried with the member who started this thread here?

From what he says his MDA Compact II reacted to his entering a wifi sdio card by not only showing the wifi icon but even showed available networks...

...only problem he had was being unable to get the device to actually connect.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Er i started the thread, and i've never seen any available networks when trying to get it to work...just the icon.

Did you read that somewhere else? Im very interested!

fUNKUS

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.