• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

WM5torage

1019 posts in this topic

Posted (edited)

Sorry, I dont know how to fix leaked firmwares.

Make OS direct (sector IOCTL) disk access fully work - and it will work, that all I know.

If it detects the device but cant actually properly read/write data - that means the problems most likely with actual per-sector flash access. Wheither it down do no proper dismount, or simply lack of proper direct disk access in leaked builds - no idea.

It also can be due to the bugs in the usb function (hardware) driver in these builds - they hardly have big quality as they is.

Edited by Ingvarr
0

Share this post


Link to post
Share on other sites

Posted

I already wrote why support for Typhoon/feeler is problematic.

Like with MPX200, for them part of OS is stored on storage card. To make usb disk access properly work, storage card must be made unaccessible to smartphone (dismounted), but no way do it properly when part of OS is on it.

Thats why driver is "activated" and device is "detected", but no actual proper disk access is done later.

Make dismount work, and it will work. But I think you'll need to fix this "unofficial firmware" for that.

<{POST_SNAPBACK}>

That is completely wrong, no part of WM5 for Typhoon stored on storage card. Probably dismount works a bit differrent, could you give us more diagnostics when it's trying to dismount Storage Card.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Sorry, I dont know how to fix leaked firmwares.

Make OS direct (sector IOCTL) disk access fully work - and it will work, that all I know.

<{POST_SNAPBACK}>

How I understand itsutl`s are using IOCTL to access directly to card.They are working with this "unofficial firmware", so could be something else.

Edited by rrunner
0

Share this post


Link to post
Share on other sites

Posted (edited)

Could be. Most likely its USB Function MDD or controller then.

Edited by Ingvarr
0

Share this post


Link to post
Share on other sites

Posted

Still getting problems with "Cant Switch to Mass Storage USB driver, error 1f".

If you are connected with ActiveSync and then activate WM5torage it works fine.

If you then deactivate WM5torage and exit ActiveSync will restart. Next pull the USB cable from the device disconnecting ActiveSync and try to activate WM5torage you get the error.

I have stopped all programs from running but error still persists also from this point onwards ActiveSync refuses to connect. The only way to rectify both problems is to soft reset.

0

Share this post


Link to post
Share on other sites

Posted

;) hello ever body, I'm french!

I have an eten m600 with WM5 and Windows xp pro couldn't install correctly the driver (that is what he is telling to me)!

I didn't install the software on m mmc card but on the memory of my m600!

If you could explain me why windows doesn't want to recognize the m600 as a USB key thank you! ;)

0

Share this post


Link to post
Share on other sites

Posted

Under OS X (10.4.5) it shows up as :

Windows Mobile Device:

  Version: 0.00

  Bus Power (mA): 500

  Speed: Up to 12 Mb/sec

  Manufacturer: Microsoft

  Product ID: 0xffff

  Vendor ID: 0x045e

Apple: Introduction to Mass Storage Device Driver Programming Guide

Anyone in for developing a OS X MSD driver that support WM5Storage?

<{POST_SNAPBACK}>

I would also like to see this work under Mac OS X. However, I think that would be pretty bad if we had to install a driver to get it to work. I think this program needs to implement the USB mass storage device like other USB drives. I've never seen a normal USB drive that would only work on Windows.

0

Share this post


Link to post
Share on other sites

Posted

I would also like to see this work under Mac OS X.  However, I think that would be pretty bad if we had to install a driver to get it to work.  I think this program needs to implement the USB mass storage device like other USB drives.  I've never seen a normal USB drive that would only work on Windows.

<{POST_SNAPBACK}>

True, MSD always works for me under OS X. (Exept for WM5torage)

What I would realy like is support for iSync and WM5 on the Mac.

Nobody seems to be able to do the trick (yet).

http://www.markspace.com/wm5.html

http://www.pocketmac.net/products/pmpro3/index.html

Damn, they even fixed Windows on a Intel Mac faster ;)

0

Share this post


Link to post
Share on other sites

Posted

Any chance of a ppc version?

<{POST_SNAPBACK}>

This works fine on my XV6700, the only problem is where it puts the short cut. Any chance the installer can be modified to identify if it is on a PPC and put the shortcut into the programs group....

Geoff

0

Share this post


Link to post
Share on other sites

Posted

I always wondered why MS never had this built in, been waiting years for this app. since I got my first PPC with an SD slot. Installed on a Cingular 8125 and can switch between Active Sync and the phone running in USB drive mode with no problems. Thanks!

0

Share this post


Link to post
Share on other sites

Posted

I would also like to see this work under Mac OS X.  However, I think that would be pretty bad if we had to install a driver to get it to work.  I think this program needs to implement the USB mass storage device like other USB drives.  I've never seen a normal USB drive that would only work on Windows.

<{POST_SNAPBACK}>

Well it works perfectly under Linux, so it seems Max OSX has the problem?

0

Share this post


Link to post
Share on other sites

Posted

Version 1.3

  - added prompt to soft-restart the device after installation

  - when storage is attached to USB host, mobile device USB controller and flash disk are ordered to be kept in "Power On" state

  - added switch to choose between "Removable" and usual ("Hard Disk") device classes. Will affect how the host OS treats the device - for instance, it will not create System Restore and Recycle Bin if class is Removable.

Updated Wed, Mar 29 2006 1:02 pm

View File

<{POST_SNAPBACK}>

ARGH i tought it will be a simple removable flash disk, the thing installed me a new cdrom and even ask me to reboot windows !!!!!!!!! I think this is totally useless. Damn, i want it on macos9

0

Share this post


Link to post
Share on other sites

Posted

This looks promising ! Nice one

0

Share this post


Link to post
Share on other sites

Posted

I'm having some issues with this. I get the following error:

alert

Cant switch to Mass Storage USB drive, error 57

0

Share this post


Link to post
Share on other sites

Posted

People who getting error 57 most likely havent fully unlocked their smartphones. I know that some unlock "recipies" around dont unlock all APIs, so some software will work, some (more deep system-level) wouldn't. Try this one

to HKLM\Security\Policies\Policies

add new value "0000101b": dword = 1

That would set security model to "one-tier" - unsigned applications/components will still ask for confirmation, but after you confirm, they will launch in full-trust access mode, like on WM5 PocketPCs.

I was getting the error 57 on my sp5m. Try what is suggested above, i did it and it now works fine.

Great bit of software by the way!!

cheers

0

Share this post


Link to post
Share on other sites

Posted

the excellent tool is getting even better! thank you a lot Ingvarr. wm5torage is maped to mine wizard's leftsoftkey from first version:)

0

Share this post


Link to post
Share on other sites

Posted

Works great on my MDA Vario

just needs USB2 now ;)

Thanks for a great app

Dahquim

0

Share this post


Link to post
Share on other sites

Posted

For all of you guys who have problems with application unlocking your phone (or who get this error 57) - here's a nice tutorial that will show you how you can unlock your phone in three easy steps: HOWTO Application Unlock your Windows Mobile Smartphone

0

Share this post


Link to post
Share on other sites

Posted

Spasibo Victor!Works well on Motorola MPX200 with WM5 inside. 8)

0

Share this post


Link to post
Share on other sites

Posted

Is there a fix for error 1f? How do I use this exactly? So I've installed it to \Storage did the recommended soft reset. Turn the app on and I get the error 1f prompt. After that the device will not sync with Activesync until a soft reset. Should I be connecting it to USB 1st before activating it?

My device:

Dopod 838 WM5 PocketPC

ROM: Qtek Test ROM 2.8.7.1 WWE

0

Share this post


Link to post
Share on other sites

Posted

Seems I was missing:

HKEY_LOCAL_MACHINE \Security\Policies\Policies

-> Add new value "0000101b": Dword = 1

Alls good now.

0

Share this post


Link to post
Share on other sites

Posted

I haven't seen "error 1f" since I installed v1.3 as removable class. Am I the only one?

0

Share this post


Link to post
Share on other sites

Posted

http://www.modaco.com/index.php?showtopic=...79entry708679

I've tried what's in that thread for unlocking. I still get error:

"Cant switch to Mass Storage USB drive, error57"

Any suggestions?

<{POST_SNAPBACK}>

thanks for the link changed the reg keys on my wizard and now the app works ;) I just wish it did not install automatically to the Accessories folder but I guess this is to make it easier for SP users... ;)
0

Share this post


Link to post
Share on other sites

Posted

thanx for the masterpiece ;)

some suggestions to next version:

- statusbar icon when enabled

- automatic disable after disconnection

0

Share this post


Link to post
Share on other sites

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.