• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Activesync 4 and firewalls (sygate).

24 posts in this topic

Posted · Report post

Hi,

I was having many many many problems getting activesync 4.x to sync my SPV M600 phone while my sygate firewall was enabled (to the point of driving me mad !). I trawled through all the solutions and found this, which worked perfectly. Hope it helps others !! :

cheerio

Matt

The following registry change on the M600 resolves the compatibilkity issue of AciveSync 4.1 and Sygate Security Agent.

Registry Sub Key: [HKEY_LOCAL_MACHINEDriversUSBFunctionDriversRNDIS]

Name of the Value to add: MTU

Type : DWORD

Data: 1514 (Value is Decimal)

Registry Sub Key: [HKEY_LOCAL_MACHINEDriversUSBFunctionDriversRNDIS]

Name of Value to add: MaxOutTransfer

Type: DWORD

Data: 1642 (Value is Decimal)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hi Matt,

Thanks for the tip. I have been having problems with AS the whole time I've had my JAMin. The firewall I use is an old version of Tiny Personal Firewall (2.0.15 I think), which I keep on using because I prefer the interface to anything else I've tried. Anyway, Activesync 4.1 is the first thing ever to break it.

My findings with your patch is as follows:

Before, I was experiencing problems with the AS dialogue, where there would be a small box saying something like "Transferring Settings", and it would just never go away. I could however still access the mobile device folder, and install apps, so I could live with it. Also, the firewall would very frequently generate error messages, but didn't actaully cause anything to fail.

After the patch, AS seemed to complete successfully for the first time. It now says "Connected" and sync's like it should do. There is still one small gremlin, and that is when I connect the JAMin (via USB as always), I hear the bong-bing sound, that means something is plugged in, but AS doesn't do anything. When I temporarily disable the firewall, the Password dialogue appears (where I type in the devices password number). I can then switch the firewall back on again and everything works fine from then on. I can live with this though.

Thanks again.

Toonie.

Edited by Toonie
0

Share this post


Link to post
Share on other sites

Posted · Report post

Dopod 818pro has came out a patch for solving this problem. Once this program is installed, you can select between USB or serial mode. This serial mode will bypass the firewall problem.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Dopod 818pro has came out a patch for solving this problem. Once this program is installed, you can select between USB or serial mode. This serial mode will bypass the firewall problem.

And here it is for those who don't have it:-

Install and pick Serial from the chosen menu within the USB app in programs

USBSwitch_PPC.CAB

Edited by wardy
0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks! I'll have a look at that when i get the chance.

Regards,

Toonie.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Dopod 818pro has came out a patch for solving this problem. Once this program is installed, you can select between USB or serial mode. This serial mode will bypass the firewall problem.

Hi, just out of interest, would this allow it to work with ActiveSync 3.8 ?

Regards,

Toonie.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hmm ... anyone managed to sort this for activesync 4.1, M600 & zonelabs free firewall??

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hmm ... anyone managed to sort this for activesync 4.1, M600 & zonelabs free firewall??

Works ok on my Jammin with AS 4.1 and Check point intergrity flex. Very similar to ZoneLabs

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hmm ... anyone managed to sort this for activesync 4.1, M600 & zonelabs free firewall??

I don't have a solution but my activsnyc does not work with the Zonelabs firewall. If I disable it, it works and syncronises.

Not ideal as I have to disconnet the internet first as the firewall is off.

Would be grateful if anyone has any ways round this.

Thanks

Chiz

0

Share this post


Link to post
Share on other sites

Posted · Report post

I haven't tried this but Activesync 4 creates a new network connection (shows as Local Area Connection 2 in Network Connections for me, you'll see it pop up in the taskbar when you connect the device before Activesync actually detects it) - you could try trusting all traffic through this connection in ZoneAlarm / other firewall?

I don't use anything other than Windows firewall on my machine as my hardware stuff stops anything malicious so I'm just guessing ;)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

I was having many many many problems getting activesync 4.x to sync my SPV M600 phone while my sygate firewall was enabled (to the point of driving me mad !). I trawled through all the solutions and found this, which worked perfectly. Hope it helps others !! :

cheerio

Matt

The following registry change on the M600 resolves the compatibilkity issue of AciveSync 4.1 and Sygate Security Agent.

Registry Sub Key: [HKEY_LOCAL_MACHINEDriversUSBFunctionDriversRNDIS]

Name of the Value to add: MTU

Type : DWORD

Data: 1514 (Value is Decimal)

Registry Sub Key: [HKEY_LOCAL_MACHINEDriversUSBFunctionDriversRNDIS]

Name of Value to add: MaxOutTransfer

Type: DWORD

Data: 1642 (Value is Decimal)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Genius - the serial patch seems to have worked with my m600 and corporate sygate.

thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

See if the ActiveSync 4.2 beta fixes this too! ;)

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

See if the ActiveSync 4.2 beta fixes this too! ;)

P

it's taken 6 months for my company to get get 4.1 released and they've now admitted that they only tested it with 2003 devices despite the request being so that 2005 devices could be synched!

0

Share this post


Link to post
Share on other sites

Posted · Report post

See if the ActiveSync 4.2 beta fixes this too! :P

P

Sorry to report that it doesn't work for me. I can connect & explore the device, but sync just keeps on spinning. ;)

0

Share this post


Link to post
Share on other sites

Posted · Report post

;) Well, I have managed to get my M600 to sync without switching off my zonealarm firewall!!

For any zonealarm users ... click the firewall tab on the left, and click the 'zones' tab within that. Then set your windows mobile device to the trusetd zone, rather than the internet. Hey presto!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Funny.... i downloaded the USB Switch program and installed it, only to realise that I think i had that program there before - it came with my phone ! (iMate SP5)

Switched to Serial and works... sweet!

0

Share this post


Link to post
Share on other sites

Posted · Report post

The USB Switch program worked like a charm!

Thanks alot, have been waiting for a solution to my Active Sync problems ever since I bought my Prophet..

0

Share this post


Link to post
Share on other sites

Posted · Report post

:) Well, I have managed to get my M600 to sync without switching off my zonealarm firewall!!

For any zonealarm users ... click the firewall tab on the left, and click the 'zones' tab within that. Then set your windows mobile device to the trusetd zone, rather than the internet. Hey presto!

cheers

works like a dream

ash .

0

Share this post


Link to post
Share on other sites

Posted · Report post

And here it is for those who don't have it:-

Install and pick Serial from the chosen menu within the USB app in programs

OK, for the thickos among ud - that's me, by the way, lol - if it's using the USB cable, then how can switching to serial help? all I have to connect my phone is a USB cable!

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

OK, for the thickos among ud - that's me, by the way, lol - if it's using the USB cable, then how can switching to serial help? all I have to connect my phone is a USB cable!

Today I got my htc-wizzard, and was annoyed because syncing didn't work..

I solved the exploring bit of activesync by:

Connect the phone.

Kill WCESMgr.exe and wcescomm.exe in the taskmanager (PC).

restart wcescomm.exe.

Go to active sync and start exploring your phone :)

syncing doesn't work, but exploring and putting the cab's on the phone does work ;)

Now testing if switching to serial mode does the trick for me :D

>> UPDATE :( :P

Syncing is not a problem any more :D

Edited by equinoxe
0

Share this post


Link to post
Share on other sites

Posted · Report post

That usb switch app is amazing. I've been messing around for the last few days as my active sync stopped working over usb (fine over bt). It used to work fine but suddenly stopped and removing firewall didn't fix.

usb switch has fixed it.

Thankyou very much indeed. Saved me a hard reset.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Dopod 818pro has came out a patch for solving this problem. Once this program is installed, you can select between USB or serial mode. This serial mode will bypass the firewall problem.

Brilliant. Worked like a charm. Had problems with corporate firewall and HTC Wizard and this little app made it all good. Thanks a lot.

0

Share this post


Link to post
Share on other sites

Posted · Report post

And here it is for those who don't have it:-

Install and pick Serial from the chosen menu within the USB app in programs

ty so much for posting this little app

solved a problem with my iPaq hx2190 and ZoneAlarm Internet Security, oddly by choosing RNDIS which allowed me to add the devices address to my safe zone

Thank you again

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.