• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Can WM5 connect to Internet via USB ActiveSync?

16 posts in this topic

Posted

When I connect my Wizard or Prophet via USB ActiveSync I can't access the internet. GPRS and WiFi stop working. I am sure my Blue Angel running WM 2003 is able to access the internet via USB ActiveSync.

Have things changes in WM5 or am I missing a setting on the PPC (or PC)?

I have tried a search but only found Syncing via WiFi rather than passthrough internet over USB.

Is there a guide or thread to setting up passthrough internet on a WM5 PPC?

It is really frustrating keep connecting and disconnecting the USB to Sync and then to surf.

Can anyone help?

0

Share this post


Link to post
Share on other sites

Posted

Yes, WM5 does use your computer's internet connection when it is synced via USB :)

0

Share this post


Link to post
Share on other sites

Posted

You should be able to browse via activesync, but you need to make sure that you have this selected on your PC in the active sync settings. Right click the activesync icon in the taskbar, and in connection settings set the computer to connect to the internet, that way it should be able to hand out DNS settings to your phone. If it doesn't work make sure that any firewalls you have installed aren't causing problems.

0

Share this post


Link to post
Share on other sites

Posted

You should be able to browse via activesync, but you need to make sure that you have this selected on your PC in the active sync settings. Right click the activesync icon in the taskbar, and in connection settings set the computer to connect to the internet, that way it should be able to hand out DNS settings to your phone. If it doesn't work make sure that any firewalls you have installed aren't causing problems.

I have tried setting 'internet' in activesync, no joy.

I do have firewall settings on laptop, desktop and router. I will do some tests with all the firewalls turned off.

What ports would I need to configure in the firewall to allow the PPC to use pass through?

0

Share this post


Link to post
Share on other sites

Posted

Why would you want to browse the internet while connected via USB? USB would mean your within a couple of meters from your PC so why not just browse on it? :)

Anyway in older activesyncs you had to check a box for pass through connection but in 4.2 it just seems to work.

0

Share this post


Link to post
Share on other sites

Posted

Why would you want to browse the internet while connected via USB? USB would mean your within a couple of meters from your PC so why not just browse on it? :)

Anyway in older activesyncs you had to check a box for pass through connection but in 4.2 it just seems to work.

I want to check how Orb (Satellite TV streaming) will work on my PPC when I go down the pub, so the easiest is via pass through.

I am using AS 4.2 beta.

Decided to recheck if Blue Angel does work before changing the firewall settings. Works fine on desktop and laptop.

Tried Prophet and that now connects to the desktop ok. It seems to have a prolem with the laptop, indicates the USB port is malfunctioning. I'll reboot laptop and try again.

0

Share this post


Link to post
Share on other sites

Posted

Provided you have "this computer connects to" set to either automatic or the internet it should work.

I assume that your PC is connected to the internet OK?

If it doesn't connet then it is almost certainly your firewall if the ActiveSync connection is made.

If you are using a router you shouldn't be using a firewall on your computer and laptop as well (provided it's a decent hardware firewall) - I leave my router to worry about the firewall side of things and diable all other firewalls and it works fine.

0

Share this post


Link to post
Share on other sites

Posted

Provided you have "this computer connects to" set to either automatic or the internet it should work.

I assume that your PC is connected to the internet OK?

If it doesn't connet then it is almost certainly your firewall if the ActiveSync connection is made.

If you are using a router you shouldn't be using a firewall on your computer and laptop as well (provided it's a decent hardware firewall) - I leave my router to worry about the firewall side of things and diable all other firewalls and it works fine.

AS 4.2 set to Internet and PC's connect to internet ok. As per my earlier post all PPC's are fine now execept when connected to the laptop (laptop is connected to internet via WiFi). Blue Angel can access internet via laptop.

The Prophet comes up with an IE error of 'page cannot be found due to an unknown error 0x80072f78' when trying to surf via pass through on the laptop. Any ideas?

0

Share this post


Link to post
Share on other sites

Posted

AS 4.2 set to Internet and PC's connect to internet ok. As per my earlier post all PPC's are fine now execept when connected to the laptop (laptop is connected to internet via WiFi). Blue Angel can access internet via laptop.

The Prophet comes up with an IE error of 'page cannot be found due to an unknown error 0x80072f78' when trying to surf via pass through on the laptop. Any ideas?

Its most likely something to do with the laptops network settings. When a WM5 device connects, it does so over RNDIS and the laptop acts effectively as a DHCP server for the network between the laptop and the device - giving itself an IP address of 169.254.2.1 and the WM5 device an IP address of 169.254.2.2

Have a look next time you connect your device and you should see a new network connection start up (mine is Net Connection 6) - make sure you have TCPIP etc enabled on that connection.

0

Share this post


Link to post
Share on other sites

Posted

Its most likely something to do with the laptops network settings. When a WM5 device connects, it does so over RNDIS and the laptop acts effectively as a DHCP server for the network between the laptop and the device - giving itself an IP address of 169.254.2.1 and the WM5 device an IP address of 169.254.2.2

Have a look next time you connect your device and you should see a new network connection start up (mine is Net Connection 6) - make sure you have TCPIP etc enabled on that connection.

I'm up to connection #12, is there some way of removing # 1 to 11?. TCP/IP is already enabled. As you say the IP of the PPC is set to 169.254.2.2.

I notice when the Blue Angel (WM2003) connects it doesn't show a network connection but it works fine.

Only difference I know between desktop & laptop is laptop uses a (works) domain. Does the PPC need to log onto the domain somehow?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Go into the network settings - Start, Settings, Connections (tab), Connections, Advanced (tab), Select Networks and select "My Work Network" from both of the pull down lists. Then tap the Edit... button under either list. Under the Proxy Settings (tab), the top box (This network connects to the Internet) should be checked but leave everything else on this page blank. After tapping OK, make sure both dropdown lists are still set to My Work Network and OK your way back to the Today page and then soft reset.

Edited by Charlie Hower
0

Share this post


Link to post
Share on other sites

Posted

Its most likely something to do with the laptops network settings. When a WM5 device connects, it does so over RNDIS and the laptop acts effectively as a DHCP server for the network between the laptop and the device - giving itself an IP address of 169.254.2.1 and the WM5 device an IP address of 169.254.2.2

Have a look next time you connect your device and you should see a new network connection start up (mine is Net Connection 6) - make sure you have TCPIP etc enabled on that connection.

I select RNDIS(from WM6 ActiveSync advanced, the IP excatly like 169.254.2.x) but can't connect thru internet via my GPRS/EDGE.

It only work able to access internet via GPRS/EDGE when select USB Serial (from WM6 ActiveSync advanced), the IP is 192.168.0.x)

If you notice the different, RNDIS won't put in the default gateway while USB Serial yes. Oh yah, even I manually add in the gateway inside Windows XP's network from RNDIS connection, it failed to access internet too..

FYI, my laptop no internet access, only via iPAQ 512 WM6's EDGE connection.

By the guide, RNDIS said "Enable internet capability, select RNDIS. Disable internet capability, select USB Serial". :wub:

I was thinking the RNDIS designed should be for ActiveSync + Internet Access via the Telco GPRS/EDGE/3G...but..it isn't work. ;)

0

Share this post


Link to post
Share on other sites

Posted

Hi all, I have the cingular 8525 pocket PC and i am trying to get connected to internet through AS. I have tried everything but still I can connect to AS and I can synchronize files but when I try to access internet from my Pocket PC when it is connected to my desktop it just dont happen. I read your article and it I am just curious how could you network Pocket PC to WinXp desktop ? I do not see any new connection on my desktop network places when it is connected to my pocket PC. Any help would be appreciated.

0

Share this post


Link to post
Share on other sites

Posted

Hi all, I have the cingular 8525 pocket PC and i am trying to get connected to internet through AS. I have tried everything but still I can connect to AS and I can synchronize files but when I try to access internet from my Pocket PC when it is connected to my desktop it just dont happen. I read your article and it I am just curious how could you network Pocket PC to WinXp desktop ? I do not see any new connection on my desktop network places when it is connected to my pocket PC. Any help would be appreciated.

Have you tried:

http://www.htcwiki.com/page/Desktop+passthrough?t=anon

0

Share this post


Link to post
Share on other sites

Posted

Open Registry Editor on your desktop (Start/Run and type "regedit") and locate the key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows CE Services. Right-click on the value list and choose New/DWORD value. Type the name "AllowLSP" and leave the value zero.

Disconnect and connect your device and Pocket Internet Explorer (and all other applications) will start working.

Or write this to file and set extension to ".reg"

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows CE Services]

"AllowLSP"=dword:00000000

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.