• Announcements

    • PaulOBrien

      Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance) CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission) ROMs must give full credit to the original author ISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • PaulOBrien

      Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Pagemakers

MToeR & SP5 Compared

45 posts in this topic

You can but another user pm'd me to say he'd tried that and lost 50% of battery in ONE hour!

Now THAT is weird!

0

Share this post


Link to post
Share on other sites

Sorry. My mistake :) This is what he said:

"I thought battery life was comparable to the SP5, except when there was no 3G signal (I had the phone set to 3G instead of auto band). If it was searching for a network, the battery would go down to 50% within a hour"

0

Share this post


Link to post
Share on other sites

Internet Explorer seems very slow. Not in the downloading of the webpage but in the actual "thinking time" before it does anything.

You click on a link and it seems to say "locating" then "opening" for up to 30 seconds. The SP5 does this process almost instantly. Almost make the 3G speeds a bit pointless.

Closing and re-opening the data connection seems to cure things for 10 minutes or so.

0

Share this post


Link to post
Share on other sites

Hi there!

Could you please check the version numbers on your devices, cause i have upped my battery time on my new HTC MTeoR in contrast to my old Qtek 8310 (SP5).

Could it be something different with different networks, i live in Bergen, Norway in the outskirt of a UMTS area and my phone switches all the time.

Im running on my second day now without trouble, and there is still 34% left.........

Or was i just EXTREMELY lucky with this version, also when using as a modem over 3G with bluetooth it doesnt get very hot?!?!?!

Do you got the ROMver 1.13.251.2 ?

Or maybe the trick is to set the language to norwegian?????? lol

Somebody has to get an appunlock soon....please......

Brynis

0

Share this post


Link to post
Share on other sites

When I was in the USA last week with no 3G network the battery lasted for days. Now I am back home in the UK and just on the fringes of a 3G network my battery lasts 1 day max.

0

Share this post


Link to post
Share on other sites

Sorry, I've lived with this heap of junk for a couple of weeks now and I'm sorry to say I'm back with my SP5.

In my opinion the HUGE failing of this phone are:

1) Battery life is CRAP

2) Rom is buggy. Settings get dropped, phone locks up etc

3) IE is SLOOOOOW. It sits on connecting/opening for ages.

All in all, a total disappointment from start to finish.

Now, where's expansys's return policy.....

0

Share this post


Link to post
Share on other sites
3) IE is SLOOOOOW. It sits on connecting/opening for ages.

All in all, a total disappointment from start to finish.

Now, where's expansys's return policy.....

Pagemakers, can I ask which network you're on? Reason I ask is that on 3G voda, my IE is dead quick, connects practically instantly and I get good D/L speeds. But when I switch to my t-mobile W&W sim, the connection is just as you say- it says "locating" and "opening" for ages, and often times out. I've scoured the web for settings etc and think I have them right, so I'm stumped. Fortunately the t-mobile SIM is on PAYG, so I'm not bleeding money on a contract which I can't use.

I agree though, this phone is not great- was released too early IMO. Still, I'm keeping mine over my SP5 as it just about does what I need it to, and I prefer the look and feel.

Edited by Thetechnogeek
0

Share this post


Link to post
Share on other sites

Hmm, interesting. I'm on T-mobile and the internet performance is awful. That said, I have the same sim back in my SP5 and there are no issues at all. Click on a page and it opens in GPRS speeds. On the MTeoR, clicking on the same page it it would say...

locating.................................................................

opening................................................................ x 1000

Then it would finally open the pitiful webpage.

Maybe the imate ROM is better?

Also i forgot to mention, the MTeoR has a great habit of ringing once or twice and then dropping the call to answer machine when I pick up. Or ringing then the ring volume stutters in and out of silence.

Basically, I wanted to love this phone. It does everything I need. I'd be hard pressed to give it 5 out of 10.

Edited by Pagemakers
0

Share this post


Link to post
Share on other sites

Thanks Pagemakers for an interesting and honest review of the MTeoR. I have had a SP5 for a year now on Orange with no problems. Have used the Wi- Fi in free hotspots here and in Europe with fast connectivity. I like the USB and mini jack connections too. It seems to me the SP5 veers to a PPC where as the MTeoR goes towards a conventional mobile phone. I must confess the MTeoR looks good but I think the SP5 does too so I will stay where I am as I cannot see anything at the moment that can beat the Tornado. Many thanks again for your work. :D

0

Share this post


Link to post
Share on other sites
Do you got the ROMver 1.13.251.2 ?

Brynis

Mine is ROM version 1.13.251.2 like your, and like you I'm getting good battery life when on the edge of a 3G network.

Agree with Pagemakers though re the dropping calls after a couple of rings- mine does this quite a lot.

0

Share this post


Link to post
Share on other sites

Interesting - I'm on T-Mobile with the W&W package and find that web pages load quite quickly on my MTeoR. For example the BBC PDA website opens in 6 seconds and that's certainly quicker than on my previous SP5! However, I've setup my phone with alternative DNS servers rather than the automatically assigned T-Mobile ones, so that might make a difference.

I agree that the battery life using 3G data isn't great, but it's not proving to be an issue for me as it's mainly used for push email and web browsing to the odd page during the day. I also use the phone as an MP3 player for an hour on the way to work and make numerous calls / send text messages during the day. When I get home in the evening I typically have at least 30% battery life left.

I've not yet experienced any lock-ups or crashes, but have had one instance of the phone losing the username and password of my data connection - although that was a couple of weeks ago now and hasn't happened since.

Overall I like the phone, a LOT - the form factor is perfect for me, the processor is quick and that makes the phone nice and snappy to use which is much better than the SP5. It's a shame that they've removed the 2.5mm headphone jack, but last night I butchered the supplied headset and made my own headphone adaptor cable so that I can use my Sony in-ear headphones. :D

I'm definitely keeping this phone and the MDA Vario II (TyTN) that I got when I signed up to T-Mobile is going on eBay in the next few days!

Simon.

0

Share this post


Link to post
Share on other sites

TDK - W&W Pro or just regular W&W?

I'm on Pro and I think that's where the problem somehow is.

0

Share this post


Link to post
Share on other sites
Interesting - I'm on T-Mobile with the W&W package and find that web pages load quite quickly on my MTeoR. For example the BBC PDA website opens in 6 seconds and that's certainly quicker than on my previous SP5! However, I've setup my phone with alternative DNS servers rather than the automatically assigned T-Mobile ones, so that might make a difference.

............I butchered the supplied headset and made my own headphone adaptor cable so that I can use my Sony in-ear headphones. :D

Simon.

Simon,

Would you be able to supply us with your alternative DNS settings? I assume you're in the UK?

Headphones- I've done exactly the same! :D

0

Share this post


Link to post
Share on other sites

I'm on regular W&W and get 1.2Mbit/sec here in central London with HSDPA. :D

Primary DNS: 194.164.6.112 (UK)

Secondary DNS: 83.217.93.246 (Belgium)

Simon.

0

Share this post


Link to post
Share on other sites

I've tried the couple as supplied by Paul and they appear to make no difference.

0

Share this post


Link to post
Share on other sites
I'm on regular W&W and get 1.2Mbit/sec here in central London with HSDPA. :D

Primary DNS: 194.164.6.112 (UK)

Secondary DNS: 83.217.93.246 (Belgium)

Simon.

I'll give these ones a go and see if it makes any difference for me. Maybe we all need to compare settings :D

Thanks very much!

0

Share this post


Link to post
Share on other sites

My battery life on my Mteor is pathetic. I recently bought a Samsung I320 and sent that back for the same reason. I have had loads of HTC phones and am deeply dissapointed about this one. I have got my old SP5 out of my cupboard but I need to send that back for a sticky joytick so now I am back to an SP3i with a cracked screen. Cheers for that HTC!

Seriously I love windows phones but I doubt Nokia or Ericsson would make phones that are quite so unreliable. I wont be changing to those brands but I hope the windows manufacturers start making more robust and reliable phones soon.

0

Share this post


Link to post
Share on other sites

Hi, I have had a SP5 for the last year..it's good. Although the MTeoR looks nice I have decided not to bother with it as I see it as a retrograde step. As regards the joystick this is a strange one. I have found that if you keep the phone free from clutter and activesync regularly it functions perfectly. I think it is a software issue and the device likes a clean path. I don't think it is a mechanical problem. Give your SP5 a freshen-up. Cheers..Looby.

0

Share this post


Link to post
Share on other sites

sticky joystick:

is that sp5 or sp5m you were reffering to?

I-Mate sp5m ROM is known to have this sticky joystick issue. if so, your device needs ROM update rather then repair.

0

Share this post


Link to post
Share on other sites

I usually replace my HTC based phone every year. And as I am looking at what's available today or in the near future none of the current or upcoming HTC smartphones are as good as SP5m. This is sad... or may be SP5 was ahead of its time.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.