Sign in to follow this  
Followers 0
dave55

C550 not charging, no switch on

6 posts in this topic

Hi

I seem to have a dead C550. Left it chargin on a usb quite happy. Next day dead phone, no charge light wont switch on. Tried friends battery still no joy...Please help is it the bin for it ?

Dave

0

Share this post


Link to post
Share on other sites

Just to make sure, the battery was also from a C550? Have you tried leaving it sitting on the AC charger? Letting it sit on USB is normally no good as there isnt enough voltage going through it.

0

Share this post


Link to post
Share on other sites
Just to make sure, the battery was also from a C550? Have you tried leaving it sitting on the AC charger? Letting it sit on USB is normally no good as there isnt enough voltage going through it.

Hi

The friends battery was from a c600 fully charged, still would not switch on.. Its now on the ac charger but no lights nothing, looks like a dead one

Dave

0

Share this post


Link to post
Share on other sites
Hi

The friends battery was from a c600 fully charged, still would not switch on.. Its now on the ac charger but no lights nothing, looks like a dead one

Dave

Just an update.. The phone started to boot the orange start up screen days later after being left the turn itself off and then nothing for at least 20 mins, then the same, orange start up screen then nothing, kept trying to to a hard reset but could never get it to activate. Left a few days with battery out then tried a hard reset . This time it caught the press zero to continue screen which i did it then went blank and stayed like that for a few minutes doing nothing like a normal reboot..

Finally it said no sim press to continue which i did and it just hung on no sim screen. Getting desperate i did it again with a sim in from a hard reset. This time i got past the valid sim screen and it then said Cold reboot phone restarting which it did.. ( heart Pumping madly) and wahoo :rolleyes: :( :) its back to normal..

What happened, corrupt firmware ? who know's. Just one thing when i take battery out it loses date and time is this normal or has the onboard battery died. Don't seem to remember it doing this.

Dave

0

Share this post


Link to post
Share on other sites
Just one thing when i take battery out it loses date and time is this normal or has the onboard battery died. Don't seem to remember it doing this.

Dave

The backup battery is either flat or faulty. Give it a good few hours charge after the main battery shows full then try it.

Check your warranty at http://service.htceurope.com/ if it is faulty.

Richard

0

Share this post


Link to post
Share on other sites
The backup battery is either flat or faulty. Give it a good few hours charge after the main battery shows full then try it.

Check your warranty at http://service.htceurope.com/ if it is faulty.

Richard

Damm :rolleyes: :( :) Its crashed again won't switch on again, the odd flash on the red LED then tries to start, Is the backup battery causing this problem ?. Can it be replaced ? Going to have to catch it again and try to get it to reboot.. It appears to charge the battery even though its got no led's showing

Dave

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.