• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Updated Vista / WMDC / CF 3.0 compatible CABviaActiveSync now available

59 posts in this topic

Posted

cabviaactivesync.jpg
I'm pleased to a minor update to CABviaActiveSync - which is FREE since version 1.4, previously only available to MoDaCo Plus members. (hence the topic bump)

The application has been updated to version 1.5, which adds support for .net Framework 3.0 (which broke v1.4) and of course includes the previously added full Vista WMDC support (as well as XP ActiveSync support of course), including running smoothly with UAC enabled.

From my original posting:

How can a small application change your mobile life? Here's how :P

Last week, nedge2k and I were lamenting how much of a nuisance it was to install CABs on the phone. Sure, it's not complex, but there are a bunch of applications out there to try and choose from that do it (one by myself from a long time ago included!), once you've installed a CAB you need to keep a copy of it for future installs, it doesn't integrate with ActiveSync and - well - in general, it's a bit painful.

With this in mind, I mentioned to nedge2k that writing an application to integrate CABs with the ActiveSync installer wouldn't theoretically be very hard. This morning, I actually got the inspiration to do something about it... so it's my pleasure to introduce CABviaActiveSync 1.3. :)

So how does it work?

- CvAS installs on your desktop PC, and adds a right-click context menu for CAB files
- When you click the menu, the CAB is automatically parsed, copied to your ActiveSync directory, and a regular ActiveSync install is initiated
- When the install is complete, the CAB file stays in the ActiveSync directory, meaning you can un/reinstall in future, without having to archive the CAB away somewhere.

For me, it's a serious time saver.

The application can be downloaded HERE.

Enjoy, and feedback is appreciated! :D

P
0

Share this post


Link to post
Share on other sites

Posted

Superb stuff Paul. The effort's appreciated you can be sure... :)

0

Share this post


Link to post
Share on other sites

Posted

I'll put this thru it's paces after I pick-up my next phone tomorrow! :)

0

Share this post


Link to post
Share on other sites

Posted

Let us know what the i607 is like Encece :)

0

Share this post


Link to post
Share on other sites

Posted

Awesome work Paul!!!! A great utility for my qtek!!

0

Share this post


Link to post
Share on other sites

Posted

Thanks a lot!! I love this little app and I'm glad I can keep using it after a Vista upgrade in time.

0

Share this post


Link to post
Share on other sites

Posted (edited)

I'm getting an error while trying to install the cab file.

My error is:

The application has encountered an error: 0x0, with following description:


The operation completed successfully.


Additional information:


Unable to load the main module C:\Program Files\CABviaActiveSync\%APPNAME%.EXE or one of its dependencies.


Please contact the publisher of this application for more information.

I'm using ActiveSync 4.2 - the danish version.

EDIT! Sorry, i installet the DotNetFX and now it works.

Thanks for this app.

Edited by cork
0

Share this post


Link to post
Share on other sites

Posted

That is one quality bit of kit!

So simple, yet saves so much time ;)

Top marks sir!

0

Share this post


Link to post
Share on other sites

Posted

I've been getting this error on Vista when I try to use it: "Application Manager cannot install this application on your mobile device due to an invalid setup file. Reinstall and try again." This happens no matter which .cab I attempt to execute it on. And yes, I'm an administrator on the machine. ;) Any ideas?

0

Share this post


Link to post
Share on other sites

Posted

Mine worked a few times then i got this issue as well just last night!

0

Share this post


Link to post
Share on other sites

Posted

I'll check it out guys.

/me digs out source code...

P

0

Share this post


Link to post
Share on other sites

Posted

Any luck on this fantastic program? Been wanting to install some CABs to my storage card on Vista, but I keep getting the same error: Application Manager cannot install this application, etc etc. I'm running Vista Ultimate and I have a XDA IIi, if you need and bugspotting or testing, feel free to let me know.

0

Share this post


Link to post
Share on other sites

Posted

A friend is getting this error when runnig the program:

exception of type 'system.exception' was thrown

Any ideas?

0

Share this post


Link to post
Share on other sites

Posted

I've been getting this error on Vista when I try to use it: "Application Manager cannot install this application on your mobile device due to an invalid setup file. Reinstall and try again." This happens no matter which .cab I attempt to execute it on. And yes, I'm an administrator on the machine. :) Any ideas?

Me too. I used this application a lot on XP and just recently upgraded to Vista. Any news on this? The titlebar of the popup window is "Invalid Windows CE Setup Files" if that helps (although I guess the message text made that obvious!)

0

Share this post


Link to post
Share on other sites

Posted

A friend is getting this error when runnig the program:

exception of type 'system.exception' was thrown

Any ideas?

Sadly, I get this too, which is a shame as this looks like it would be a great app!

C

0

Share this post


Link to post
Share on other sites

Posted

I'm getting the same error as post #7 on my nice new shiny S710.

I've tried installing CF.Net, but it says I'v got a later version on there - I'm guessing it's included with WM6.

Cheers,

GB

0

Share this post


Link to post
Share on other sites

Posted

Any chance to have it working on Vista?

;)

0

Share this post


Link to post
Share on other sites

Posted (edited)

I installed this on XP service pack 2, and when i right-click on a cab file and select it i get this error message:

"This application has encountered an error: 0x0, with following description:

Task completed

Additional information:

Unable to load the main module: D:\Programs\CABviaActivesync\%APPNAME%.EXE or one of itsdependencies"

PLEASE HELP! I cannot install cab files on my PPC which is a QTEK 9000, and i need to be able to! So i really need this program! THANK YOU ;)

EDIT: Oh just saw some dude had the same problem as me... I'll do what he did... Hope it works

EDIT: DAMN IT! It still won't work....

Edited by resistor
0

Share this post


Link to post
Share on other sites

Posted

I installed this on XP service pack 2, and when i right-click on a cab file and select it i get this error message:

"This application has encountered an error: 0x0, with following description:

Task completed

Additional information:

Unable to load the main module: D:\Programs\CABviaActivesync\%APPNAME%.EXE or one of itsdependencies"

PLEASE HELP! I cannot install cab files on my PPC which is a QTEK 9000, and i need to be able to! So i really need this program! THANK YOU :(

EDIT: Oh just saw some dude had the same problem as me... I'll do what he did... Hope it works

EDIT: DAMN IT! It still won't work....

Paul, any chance of a fix for this? Its been a while now.

0

Share this post


Link to post
Share on other sites

Posted

Absolutly Amazing Paul. Keep up the good work. I have been having some amazing experience on these forums since I joined them last week :(

0

Share this post


Link to post
Share on other sites

Posted

Paul, you should rename it to:

CAB2Mobile

CABtoWM or something.. because CABviaActivesync is misleading, considering it also works with Windows Device Center

:(

0

Share this post


Link to post
Share on other sites

Posted (edited)

I'm getting an error while trying to install the cab file.

My error is:

The application has encountered an error: 0x0, with following description:


 The operation completed successfully.


 Additional information:


 Unable to load the main module C:\Programmi\CABviaActiveSync\%APPNAME%.EXE or one of its dependencies.


 Please contact the publisher of this application for more information.

I have the same problem of cork

I'm using ActiveSync 4.5 - the italian version.

no problem using the 1.3 version

please help me, thx in advance

Edited by arty.net
0

Share this post


Link to post
Share on other sites

Posted

Ah OK, that error message gives me a clue. Let me look into it.

P

0

Share this post


Link to post
Share on other sites

Posted

Hello i have exactly the same problem, about 2 weeks later.

"This application has encountered an error: 0x0, with following description:

Task completed

Additional information:

Unable to load the main module: D:\Programs\CABviaActivesync\%APPNAME%.EXE or one of itsdependencies"

Is it a problem with .net ?????

0

Share this post


Link to post
Share on other sites

Posted

I just updated to .net 3.5 and i am now getting this error message hope this helps.

Is it a problem with .net ?????
0

Share this post


Link to post
Share on other sites

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.