• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Samsung SGH-i600 -Firmware Updates here!!!

581 posts in this topic

Posted (edited)

I've download a new update rom for my Samsung SGH-i600, but, there is a problem: how can i activate device's reflashing mode???

New update rom is a file.exe that explain this message:

1. Connect your device to PC using the cable.

2. turn on the device with reflashing mode.

3. please click start button if device found.

I try to search instruction over internet, but i find nothing!!!

Can someone help me, please???

Many regards

HumaX

Edited by humaxnet
0

Share this post


Link to post
Share on other sites

Posted

Where'd you get the ROM image from?

I've attached a Zipped copy of the manual, but on a quick glance I didn't see anything useful in it

SGH_i600_EU_UG_Eng_Rev.1.0_070226.zip

0

Share this post


Link to post
Share on other sites

Posted (edited)

This work on i600. Please don't try it on different device than i600 !! It will not work on i607

@humaxnet:

To enter flash mode / boot mode in i600 you must firt tunr off device,

Then press three keys "power" + "right soft key" + "camera key / back key"

Shown on the picture:

resetda2.jpg

New software

Tip:

To format device: turn off, press "up key" + "power"

@chucky.egg

New rom image for i600 i found on xda forum (tested and work fine) can be download from:

Please don't post links to ROMs hosted on rapidshare

Edited by The Doctor
Removed link to ROM hosted on rapidshare
0

Share this post


Link to post
Share on other sites

Posted

can you tell us more about this update? any changelogs

0

Share this post


Link to post
Share on other sites

Posted

+ more stable system

+ faster switch for diffrent application

+ aplications, camera, foto work faster

+ conenction manager (wifi) run faster

+ chance startup/shutdown animation to samsung funclub (remove operator animation)

+ more free memory 4MB

- remove mms,internet settings (need to set again)

0

Share this post


Link to post
Share on other sites

Posted

Does this version also have dutch language? And what is the windows ver if you look under info in settings?

thank you verry much for your effort.

+ more stable system

+ faster switch for diffrent application

+ aplications, camera, foto work faster

+ conenction manager (wifi) run faster

+ chance startup/shutdown animation to samsung funclub (remove operator animation)

+ more free memory 4MB

- remove mms,internet settings (need to set again)

0

Share this post


Link to post
Share on other sites

Posted

"Does this version also have dutch language? "

In menu settings >regional settings > language , there is: Duch, Svenska,Norsk,Nederlands,Dansk,Espanol,US English,Russky,Suomi,Francais,Portugal,UK English,Italiano,Greece(?)

Good news - after chose Nederlands and reset i600, the language is change also.

"And what is the windows ver if you look under info in settings?"

PDA version: i600XXGC6

Phone version: i600PMGC5

Eboot version: i600XXGC6

OS 5.1.525 (buil 15363.3.4.3)

Radio Version i600PMGC5

RIL Version 2.002

0

Share this post


Link to post
Share on other sites

Posted (edited)

"And what is the windows ver if you look under info in settings?"

PDA version: i600XXGC6

Phone version: i600PMGC5

Eboot version: i600XXGC6

OS 5.1.525 (buil 15363.3.4.3)

Radio Version i600PMGC5

RIL Version 2.002

Didn't you have any problems flashing the Phone version?? I manage to flash eboot and PDA, but phone remains the old version...

Could you also check the complete version info from the *#1546792*# menu? Is there an official release info available? I'm also curious if this is actually the latest version. Thanks!

Edited by Mizzle
0

Share this post


Link to post
Share on other sites

Posted

I check detailed info about version by running \Windows\AdminSettings.exe (or *#1546792*#)

PDA: i600XXGC6

Phone: i600PMGC5

H/W: MP 1.502

Bluetooth

S/W: i60x.002

H/W: Rev 2.0

Wlan

S/W: 1.0.5.0

H/W: 1.0.0

(Eboot version: i600XXGC6)

OS 5.1.525 (buil 15363.3.4.3)

Radio Version i600PMGC5

RIL Version 2.002

There was no problem with flash. If You try to flash, remember to disable activesync usb connection.

After flash with new rom i load another patch/fix and then load SDA_unlock

For now there is no official info about rom for i600, only i607 had official relase from samsung.

I think that more free ram, and more stable system is worth to make this update.

0

Share this post


Link to post
Share on other sites

Posted

There was no problem with flash. If You try to flash, remember to disable activesync usb connection.

Hmm.. after various efforts, the update procedure gets stuck at the part where flashing the Phone part of the ROM. PDA and Eboot finish properly, but when flashing the Phone-part it hang displaying in the phonesceerd time with 3 digits endlessly counting... Then I take out the battery after a while cause it doesn't repond to anything.

So, after flashing the results are:

PDA: i600XXGC6

Phone: i600XXGC2 (didn't change after flash???)

Eboot: i600XXGC6

I flashed using "I600XXGC6_fix_phone_flashing_problem", which should be the next version. I'll try with the previous version and see what happens....

0

Share this post


Link to post
Share on other sites

Posted

Mizzle: at the end of flash, there will be counting 3 digits - it's ok.

Remove usb cable, and then remove battery, insert battery again and power on phone.

I don't know what is "I600XXGC6_fix_phone_flashing_problem". At monday i will post link to new version fix

0

Share this post


Link to post
Share on other sites

Posted

Remove usb cable, and then remove battery, insert battery again and power on phone.

I don't know what is "I600XXGC6_fix_phone_flashing_problem". At monday i will post link to new version fix

That's exacly what I did, but the Phone part stays CG2, instead of CG5 like yours. Strange huh?

The "I600XXGC6_fix_phone_flashing_problem" is a new file from winVista, I guess you heard of him :rolleyes: .

Anyway, I'll wait what you'll post Monday then. Thanks.

0

Share this post


Link to post
Share on other sites

Posted

That's exacly what I did, but the Phone part stays CG2, instead of CG5 like yours. Strange huh?

The "I600XXGC6_fix_phone_flashing_problem" is a new file from winVista, I guess you heard of him :rolleyes: .

Anyway, I'll wait what you'll post Monday then. Thanks.

I have just flashed from an Australian operator download v1.3 on my SGH-i601 to a USA operator download v1.2 (SGH-i607) and then finally to an Open download v1.1 (SGH-i600), I600XXGC6.

Why you may ask... I want to enable the WiFi, which has been blocked on the Australia and USA downloads.

I got the WiFi, but I had the same problems as defined above by Mizzle, and now I have no USB or Bluetooth connectivity.

During the flash process, the downloader seemed to get stuck on testing of Port 8. It failed and then the 3 digit counter kept running for about 30mins, before i turned off the handset and removed the battery.

Can someone please help me!

0

Share this post


Link to post
Share on other sites

Posted

@humaxnet:

To enter flash mode / boot mode in i600 you must firt tunr off device,

Then press three keys "power" + "right soft key" + "camera key / back key"

Shown on the picture:

resetda2.jpg

New software

Tip:

To format device: turn off, press "up key" + "power"

@chucky.egg

New rom image for i600 i found on xda forum (tested and work fine) can be download from:

Rom i600 Rev15_XXGA2

Would you be so kind of linking also the relative discussion on the xda forum? or where the file have been posted?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Mizzle:

After load rom "Rom i600 Rev15_XXGA2" to my i600, i make patch with this files:

BLACKJACK3_OPEN_XXGC6_phone.bin

ONENAND.bin

Pocket_merge.nb0

Patch enable to use Picsel Viewer as registered

First need to run: I600_WCEDownloader_v1.1_Single.exe, then chose eboot, phone, pda.

After this succes patch, there will be at end 3 digit counter. It's ok. To make reset remove / insert battery.

Edit: Please don't link to ROMs hosted on rapidshare

The only problem i had it was caused by Windows Vista with no device found.

"[startDownload => 0] StartDownload !!

[PDA] Connect and Power-on the Device.

[PDA]Device Not Found.

"

I made patch/patch/unlock in Windows XP with Activesynch with usb option disable, and all went good.

"[PDA-0]Driver Opened.

[PDA]Read Wait. = [0]

[PDA]Read Done. = [0]

[PDA]Device Found. = [0]

[PDA]Eboot data length = <1100KB>

[PDA]EBoot data download ready."

Stepir:

The thread from xda forum is here:

http://forum.xda-developers.com/showthread...841&page=11

The second patch is described also in: pdafrance

First info about new rom/patch I found on polish board i600:

http://www.nadchodzi4.info/viewtopic.php?t=422

issaralife:

Sad to hear that. Rom for i607 are different that for i600...

What can i help.. try to format phone, and then run in boot mode and load "Rom i600 Rev15_XXGA2". Please write if it help.

I got wm6 modifed, but i won't try to instal it on my i600 unless there will be official info about correct version :rolleyes:

Edited by The Doctor
Removed link to ROM hosted on rapidshare
0

Share this post


Link to post
Share on other sites

Posted (edited)

@Mizzle:

Next patch are 3 files from Edit: Please don't link to ROMs hosted on rapidshare

for phone, boot and pda

I got patch from pdafrance

After this i unlock registry

@issaralife:

It's sad to hear that. Rom from i607 don't work on i600.

Try to perform a format on i600 and then load Rev15_XXGA2

First I'd load rom Rev15_XXGA2, after end there was 3 digits counting. Removing/insert battery for reset.

It should be ok.

@Stepir:

On xda forum there is discussion about Card Wheel Plug-In and also about rom.

First time that i had read about new rom was from this polish forum about i600 test

Please feel free to ask, i will try to help.

btw. i had problemw with flashing in Windows Vista (device was not found) so i flash under Windows XP (with disable usb connection in activesync)

Edited by The Doctor
Removed rapidshare link
0

Share this post


Link to post
Share on other sites

Posted

@Mizzle:

Next patch are 3 files from I600XXGC6

for phone, boot and pda

I got patch from pdafrance

After this i unlock registry

Thanks, I fixed it! All I needed was a proper modem driver for the i600, that I got from winVista. Now everything is version CG6 (Phone, PDA and Eboot). I noticed that the filesizes you posted are different, what version are you on with these files above? Just curious and thanks for your help!

0

Share this post


Link to post
Share on other sites

Posted

After flash my i600 with this ROM, my "Picsel Viewer" was expired. When open my Excel files, it displayed "Your license to use Picsel Viewer has expired. Picsel viewer will now close".

Is it normal? Anybody got the same problem?

Thanks, I fixed it! All I needed was a proper modem driver for the i600, that I got from winVista. Now everything is version CG6 (Phone, PDA and Eboot). I noticed that the filesizes you posted are different, what version are you on with these files above? Just curious and thanks for your help!
0

Share this post


Link to post
Share on other sites

Posted

After flash my i600 with this ROM, my "Picsel Viewer" was expired. When open my Excel files, it displayed "Your license to use Picsel Viewer has expired. Picsel viewer will now close".

Is it normal? Anybody got the same problem?

I checked but mine is still working ok.

0

Share this post


Link to post
Share on other sites

Posted

@ issaralife: please use this driver to solve the connectivity problem. It worked for me! First time flashing resulted in the port-problem, but trying again worked, it chose a different port.

0

Share this post


Link to post
Share on other sites

Posted

Mizzle:

"I noticed that the filesizes you posted are different, what version are you on with these files above? Just curious and thanks for your help!"

I got rom from xda and pdafrance, maby the compression of file are different, but rom works fine. I'm glad that everything is ok.

Like I mentioned before, my current version are:

"PDA: i600XXGC6

Phone: i600PMGC5

H/W: MP 1.502

Bluetooth

S/W: i60x.002

H/W: Rev 2.0

Wlan

S/W: 1.0.5.0

H/W: 1.0.0

(Eboot version: i600XXGC6)

OS 5.1.525 (buil 15363.3.4.3)

Radio Version i600PMGC5

RIL Version 2.002"

Samuel Chan:

"After flash my i600 with this ROM, my "Picsel Viewer" was expired. When open my Excel files, it displayed "Your license to use Picsel Viewer has expired. Picsel viewer will now close"."

Try to load patch I600XXGC6 that I posted, it will bring back Picsel Viewer.

0

Share this post


Link to post
Share on other sites

Posted (edited)

I got rom from xda and pdafrance, maby the compression of file are different, but rom works fine. I'm glad that everything is ok.

Like I mentioned before, my current version are:

PDA: i600XXGC6

Phone: i600PMGC5

H/W: MP 1.502

Bluetooth

S/W: i60x.002

H/W: Rev 2.0

Wlan

S/W: 1.0.5.0

H/W: 1.0.0

(Eboot version: i600XXGC6)

OS 5.1.525 (buil 15363.3.4.3)

Radio Version i600PMGC5

RIL Version 2.002"

After flashing, almost everything is the same for me, except for the Phone and radio version: these are also running version i600XXGC6. Isn't that strange? Let me know if you want to try that one too...

Edited by Mizzle
0

Share this post


Link to post
Share on other sites

Posted (edited)

Edited by jafangie
0

Share this post


Link to post
Share on other sites

Posted (edited)

Hello everybody,

I have exactly the same problem.

I have just flashed from a French version (I600GCXX4) on my SGH-i600 to a USA operator download v1.2 (SGH-i607) for Xcingular Blackjack.

Why you may ask... I just wanted to see the I 607 version 's differences before to flash with the I600GCXX6.

During the flash process, everything was OK. The 3 digit counter kept running, before i removed the battery.

Now, I lost the wifi, all the sound, the bluetooth etc....

Also, I can not connect at all, no Activesync, no explorer.... Nothing.

When I try the Bootloader mode, I have only :

*USB Downloader-Xcingular V1.2

[Phone] Active OFF

I have tried to download the modem driver and lot of things but I can do nothing. The phone is not detected by my computer on USB. :rolleyes:

I think that I have to replace the boot loader! Perhaps with the MicroSD.... :P

Can someone please help me!

In advance thanks a lot

Jafangie

Edited by jafangie
0

Share this post


Link to post
Share on other sites

Posted

Hello everybody,

I have exactly the same problem.

I have just flashed from a French version (I600GCXX4) on my SGH-i600 to a USA operator download v1.2 (SGH-i607) for Xcingular Blackjack.

Why you may ask... I just wanted to see the I 607 version 's differences before to flash with the I600GCXX6.

During the flash process, everything was OK. The 3 digit counter kept running, before i removed the battery.

Now, I lost the wifi, all the sound, the bluetooth etc....

Also, I can not connect at all, no Activesync, no explorer.... Nothing.

I have tried to download the modem driver and lot of things but I can do nothing. The phone is not detected by my computer on USB. :rolleyes:

I think that I have to replace the boot loader! Perhaps with the MicroSD.... :P

Can someone please help me!

In advance thanks a lot

Jafangie

Hi,i have same problem,

yesterday i flash my i600 to cingular rom.

Now my i600 normal boot,but promptly stretch out.

when i try boot mode,i have too Xcingular 1.2 and this is all.Phone not connected to PC .

Sorry for my bad englisch

heeeelp me please and thanks

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.