Reado

WM5 Upgrade has SCREWED my hx4700 !!!

6 posts in this topic

I just bought an hx4700 from eBay along with the WM5 upgrade for it. Followed the instructions carefully and attempted the upgrade. The software said I needed the latest ROM (2.0), which is tried installing. The iPAQ booted into the HP Invent v1.01 screen and now just sits there no matter what I do!

It doesn't work anymore. When I ran the software, it froze on 0.1%, then crashed with a "Comms Error"!

What am I meant to do now? Can anyone help?

0

Share this post


Link to post
Share on other sites
I just bought an hx4700 from eBay along with the WM5 upgrade for it. Followed the instructions carefully and attempted the upgrade. The software said I needed the latest ROM (2.0), which is tried installing. The iPAQ booted into the HP Invent v1.01 screen and now just sits there no matter what I do!

It doesn't work anymore. When I ran the software, it froze on 0.1%, then crashed with a "Comms Error"!

What am I meant to do now? Can anyone help?

Sorry to say it (as i had the same pda untill a crash on the m4 'took care of it') but it sounds like its deaded. You might try getting in touch with HP. If you acctually speak to a service guy, they are pretty helpful.

0

Share this post


Link to post
Share on other sites

Hi

i had a similar thing on my svp c500 when unlocking it(it wouldnt boot up), and i was advised to disable all Anti-virus and Firewall software and run it again

did that it worked

it may would work for you, make sure the battery is charged and disable any Anti-virus and Firewall you have running and try it again, you maybe lucky and it finish the update

Regards

0

Share this post


Link to post
Share on other sites
I just bought an hx4700 from eBay along with the WM5 upgrade for it. Followed the instructions carefully and attempted the upgrade. The software said I needed the latest ROM (2.0), which is tried installing. The iPAQ booted into the HP Invent v1.01 screen and now just sits there no matter what I do!

It doesn't work anymore. When I ran the software, it froze on 0.1%, then crashed with a "Comms Error"!

What am I meant to do now? Can anyone help?

If it worked before you began the upgrade than it's probably not dead. It's a fairly common problem... but there's not too many articles that deal with how to fix it. I had a similar problem with my hx4700 and had to piece together my own solution. Here it is.

The first step is to get a copy of the rom image onto an SD card. Download the latest ROM update from HP and start the installation (it will fail but what needs to be done will be done) Using a hex editor (I recommend the Cygnus Free Hex Editor) you need to delete the first 2600 bytes of NBF that is included with the update. The file should be located in a folder with the same name as the update EXE in C:\iPAQ\. Then use the trial version of All Image (Link) to write the rom image to an sd card. The card should be 256MB or larger.

The next thing you need to do is to upload the rom image to the pda. Remove the battery from the pda and put the SD card into the slot. Put the battery back on and connect it to power but not USB. On the pda hold the power button, contacts button, and iTask button and shortly tap the reset button. It may or may not say "Press power to flash". A progress bar should appear and the percentage should slowly increase. When it's done it should say the checksum was ok or it was a failure. It doesn't matter which comes up it just means it's done. Then perform a hard reset and you're device should be ready to go!

Hope that helps!

Edited by Matt Graham
0

Share this post


Link to post
Share on other sites

Reado, this is a situation that many have encountered. There are a number of threads on Brighthand and Mobilitysite that you can read. However, I would recommend you look at http://forum.brighthand.com/showthread.php?t=243731 for Chrismrulz's Bootloader tool. With this you will be able to recover your 4700 from any failed ROM flash. Works great. In fact I use it now for flashing my 4700 with the kozhura ROMS (would also highly recommend these to you over the HP version. I can almost guarantee you will not like the HP ROMs.

Regards.

0

Share this post


Link to post
Share on other sites
Reado, this is a situation that many have encountered. There are a number of threads on Brighthand and Mobilitysite that you can read. However, I would recommend you look at http://forum.brighthand.com/showthread.php?t=243731 for Chrismrulz's Bootloader tool. With this you will be able to recover your 4700 from any failed ROM flash. Works great. In fact I use it now for flashing my 4700 with the kozhura ROMS (would also highly recommend these to you over the HP version. I can almost guarantee you will not like the HP ROMs.

Regards.

So you gave up on the Viet - ROM's ? :D

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.