• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Help with SPV M600 WiFi

4 posts in this topic

Posted (edited)

Dear All,

I like to think of myself as reasonably good with the latest technology, and if i do have a problem a quick search on t'internet usually manifests the solution.

However, this time i am well and trully puzzled.

I have recently purchased an SPV M600, and have since unlocked it to work on my Virgin Mobile simcard. When i first received it, i did a hard reset, as it was previously owned.

But i am having constant problems connecting to wifi. In my own home network, i finally managed a connection after reading about a setting on the Belkin Pre-N router called QofS that has to be unabled. Which worked. But only if i entered my IP config manually.

If i try and connect to any network, either unprotected or not, even if i have the security code, i cannot get a connection unless i manually enter the IP address and other entries.

Whenever i look at the network cards and look at the SDIO wifi adapter. If the automatic IP address button is checked, then the server assigned IP address is always FE280:: etc which is the hexidecimal IP address? I can never allow the unit to automatically detect and connect to a network?? Sometimes i think this is due to the networks router, but even if the unit is not in any range of any network, the SDIO adapter always give the IP address as the hexidecimal entry.

Also if i enter the details manually i can't always get an internet connection, even if i have a network connection?

If anyone knows of a registry setting, tweak software or simple explanation please help me!!!!!!!!!!!!!!!!

Many thanks.

Edited by Danny Slay
0

Share this post


Link to post
Share on other sites

Posted

I assume other devices are connecting to your router and getting an IP OK?

P

(Moved to the HTC Prophet area)

0

Share this post


Link to post
Share on other sites

Posted

Paul,

Yes, i connected with my previous Dell Axim X50, and currently with my Home PC, MiniMac and Sony PSP. But the M600 will not??

But as i said, it won't even let me onto my friends unsecure network with auto IP assignment. Just get the hex-IP

0

Share this post


Link to post
Share on other sites

Posted

Paul and everyone else:

I have still been having problems with the connection. But alas i have found a solution on another board. I felt that it would be beneficial to post the description here to help others. It seems that the Network Adapters need to be set for connecting to 'work' at the beginning, but when the connection is found then set to internet!!

Anyway here is the post, so i hope it helps someone at least.

Initial configuration

With WiFi Off, open the Wireless Manager and tap Settings/WiFi Settings. You may be taken to the Wireless LAN screen, which will have all fields blank as WiFi is off, or you may be taken straight to the Network Adapters screen.

If not on the Network Adapters screen, tap Menu/Network Cards, then tap the Network Adapters tab.

Make sure "My Network Connects to" is set to "Work". Nb: It is vital that this particular setting is set to "Work" not "The Internet". One of the later settings specifies the Internet connection.

Tap the "SDIO Wireless Adapter" (or the relevant Wireless adapter, depending on device model), and select "Use Server Assigned IP Address". Make sure all entries in "Name Servers" are blank.

Keep tapping OK back to the main Wireless Screen.

Device Connection

Now turn on WiFi. What happens from here depends on which type of Encryption your router is using (you are using encryption I hope!)

The process for WPA encrypted Routers should be simple from here; WEP is more complex.

Whichever you use, you should get a "Bubble" with Radio Buttons asking which WiFi network to connect to. Select your Router and tap "Connect". If there are no other routers in range, you may not get this bubble; You will then get a bubble asking about the type of connection (The Internet or Work): Select "The Internet" then tap "Connect".

You should then get a request for the encryption Key. For WPA encrypted systems, type in your key (remember it's case sensitive), and tap "Connect"

At this point, your WiFi should connect, but it can take a few minutes.

For WEP encrypted sytems, even entering the full 26 character key at this point is unlikely to work (WM5 seems to expect all connections to be WPA).

If it doesn't connect, go into the WiFI Settings again- see if your Router is showing in the Connection and signal strength fields.

Tap the Power Mode tab, and put the power up to "Best Performance". Make sure all the fields in Enroll are blank.

Tap Menu/Network Cards. Make sure the "Networks to Access" box is set to All Available.

If your Routers SSID is listed, tap its entry (if not, tap "New Connection" and manually enter your SSID in the top field).

Ensure the "Connects To" box is set to "The Internet", then tap the Network Key tab.

To set up WEP Connections: Set Authentication to "Open" and Data Encryption the "WEP".

Uncheck "The Key is Automatically provided" and enter the exact 26 character Hex string into the Network Key box, and Key Index to 1 (for 128bit this should be the only Key Index available).

I'm not sure of the settings in the 802.1x tab for WEP, but I'd advise accepting the defaults.

OK out of these screens and wait with crossed fingers!

To manually set WPA Connections: Set Authentication to "WPA-PSK" and Data Encryption to "TKIP".

The setting for "The Key is Automatically Provided" should be greyed out; if not, make sure it is unselected. Now type the WPA Passphrase in the Network Key field.

You don't need to change anything in the 802.1x tab, so tap "OK" back to the Today screen, and hopefully the connection will establish.

I must stress that these are settings which worked for me, and there is no guarantee that they will work in all situations.

Good luck!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.