vagelis

Video Driver Performance issues

5 posts in this topic

Greetings; I've posted this in Expansys forum as well; I believe it's an important issue that deserves Maximum exposure for an appropriate and expedient resolution.

When I tested the UBiQUiO in rotated 'portrait' mode to run my legacy PocketPC applications, I noticed an extreme slowdown of its' graphics abilities, a problem identified better with this benchmark posted in pocketnow.com's review:

img2D.jpg

Very Anemic for a 520 MHz device, wouldn't you say?

It appears that there is an issue with the video subsystem; UBiQUiO's video driver appears to be doing something wrong; any applications using graphics such as games or even the standard Office MS apps redraw very slowly. You can notice this if an alert window was drawn before the device automatically powered off. When you power it up again, the alert's outline is drawn for a few seconds.

I believe that this needs to be looked at; it would be crucial for the device's long term success with power users and the casual gamer.

Martha has responded that that is the first time she heard of the issue, and that she will report that to the engineers for a future fix, *after* connectivity and keyboard issues are addressed.

Further testing indicates that indeed there is something at fault with the way the video buffer is handled. Legacy games from Microsoft's entertainment pack Cubicle Chaos, Fire Drill and PacMan that have been runiing with no issues on all other WM6 Pro devices like P4330 and T-Mo Wing are crawling and unusuable in the 503g. The same thing happens with pdamill's snails.

I have had problems using Slingplayer on it as well.

I believe that this 'issue' doesn't help with the keyboard lag either; if the graphics subsystem is not optimized, it would certainly exert a toll on other systems as well. Please note that the other systems benchmarked are all using 200MHz OMAP CPU's and perform better by a factor of 30.

Please understand that as much as I really appreciate the device, such a disparity indicates that there is much more power possible to be harnessed from a more mature ROM build.

0

Share this post


Link to post
Share on other sites

I don't know...

I had to sit on a train yesterday so I uploaded 2 movies on my SD card. I had no issues with playback in full screen mode.

0

Share this post


Link to post
Share on other sites
I don't know...

I had to sit on a train yesterday so I uploaded 2 movies on my SD card. I had no issues with playback in full screen mode.

it is not the video playback that has issues; it is the sprite/graphics library that is not optimized

You can download spb benchmark for free from here

Spb benchmark

and test it against your Touch; the results will surprise you since you can see what happens when the test is running.

0

Share this post


Link to post
Share on other sites

Same thing with the 501, no direct draw and slow GAPI

If we're in luck, it could be an driver issue or not... hardware limitation?

0

Share this post


Link to post
Share on other sites
I don't know...

I had to sit on a train yesterday so I uploaded 2 movies on my SD card. I had no issues with playback in full screen mode.

HI, I´m having the same problem playing WMV, AVI and MPGs.

can you tell me how did you uploaded the movies? wich format, how did you convert them?

thanks

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.