• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Chainpus BGP100 Bluetooth GamePad

52 posts in this topic

Posted

it works for me on the Motorola Q9h WM6 with the latest drivers. Chainpus' page seems unavailable by now so I uploaded the drivers here.

I've downloaded those drivers for the game pad (Originaly I had v 1.20).

I have Asus p535 with WM 6.1.

I'm installing WinCE_Widcomm - English (in the "WinCE_Widcomm" there are folders "CN" and "TW" - what are they?)

Plus, I have a problem. Gamepad program easily finds my device. configures it and works for one time. Ather some time it closes by itself and blocks all keys on pda and the gamepad. After soft reset the program finds the device, but doesn't respond on the pressed keys. Only reinstal helps to solve this but only for one time.

Can you help me?

Where can I download 1.502 or later vershion of the drivers?

I'm not able to open the official site of the Chainpus. Are they alive? Have they moved?

0

Share this post


Link to post
Share on other sites

Posted (edited)

I've downloaded those drivers for the game pad (Originaly I had v 1.20).

I have Asus p535 with WM 6.1.

I'm installing WinCE_Widcomm - English (in the "WinCE_Widcomm" there are folders "CN" and "TW" - what are they?)

Plus, I have a problem. Gamepad program easily finds my device. configures it and works for one time. Ather some time it closes by itself and blocks all keys on pda and the gamepad. After soft reset the program finds the device, but doesn't respond on the pressed keys. Only reinstal helps to solve this but only for one time.

Can you help me?

Where can I download 1.502 or later vershion of the drivers?

I'm not able to open the official site of the Chainpus. Are they alive? Have they moved?

well, I just uploaded the 1.50 drivers, thats all I got.

Just in case, to show it works:

Edited by yves
0

Share this post


Link to post
Share on other sites

Posted

well, I just uploaded the 1.50 drivers, thats all I got.

Just in case, to show it works:

What about my other questions?

0

Share this post


Link to post
Share on other sites

Posted

What about my other questions?

TW is taiwanese, CN is chinese.

I can not find chainpus' official site anymore. I think they are gone.

0

Share this post


Link to post
Share on other sites

Posted

TW is taiwanese, CN is chinese.

I can not find chainpus' official site anymore. I think they are gone.

Hell ( I wonder what to do next....

0

Share this post


Link to post
Share on other sites

Posted

Hell ( I wonder what to do next....

did you try driver 1.5?

0

Share this post


Link to post
Share on other sites

Posted

did you try driver 1.5?

Yep) I wrote about it:

Gamepad program easily finds my device. configures it and works for one time. Ather some time it closes by itself and blocks all keys on pda and the gamepad. After soft reset the program finds the device, but doesn't respond on the pressed keys. Only reinstal helps to solve this but only for one time.
0

Share this post


Link to post
Share on other sites

Posted

Hi !

I bought the same gamepad from PEARL (Germany) and have the exact same problem as the thread starter. I've got a Yakumo DeltaX 5BT with WinMobile 5.0 and the driver either won't start at all or states "Connection Error ! Sorry ! This gamepad is not supported by this driver". I've tried almost every driver for every hardware supplied with the installation CD (it seems to me, there are only 2 versions at all). None would work. It's driver revision 1.5 from 2004. I've already contacted the manufacturer of these gamepads (http://www.enrtech.com/) but they state, that the original company that build these gamepads had gone bankrupt and they don't support this gamepad anymore.

Can anybody help me get this thing working ?

I've got a standart WinMobile 5.0 device after all....so it should work...right ?

thx in advance

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi !

I bought the same gamepad from PEARL (Germany) and have the exact same problem as the thread starter. I've got a Yakumo DeltaX 5BT with WinMobile 5.0 and the driver either won't start at all or states "Connection Error ! Sorry ! This gamepad is not supported by this driver". I've tried almost every driver for every hardware supplied with the installation CD (it seems to me, there are only 2 versions at all). None would work. It's driver revision 1.5 from 2004. I've already contacted the manufacturer of these gamepads (http://www.enrtech.com/) but they state, that the original company that build these gamepads had gone bankrupt and they don't support this gamepad anymore.

Can anybody help me get this thing working ?

I've got a standart WinMobile 5.0 device after all....so it should work...right ?

thx in advance

It should work perfectly with WM 5.0 (I've used it with HTC P3300)

The problem may be in the type of the bluetooth of your device. from 1.5 try both variants: WinCE_MS or WinCE_Widcomm

Edited by DarkPaLadin
0

Share this post


Link to post
Share on other sites

Posted

It should work perfectly with WM 5.0 (I've used it with HTC P3300)

The problem may be in the type of the bluetooth of your device. from 1.5 try both variants: WinCE_MS or WinCE_Widcomm

Thanks for the quick answer, but I don't get what you're suggesting.

I'm new to these problems. What am I supposed to do here ?

Change the bluetooth driver in my device ?

How would I do that ? Where can I find it ?

I can't find anything under "system" or "bluetooth properties".

Thx for helping.

0

Share this post


Link to post
Share on other sites

Posted

Thanks for the quick answer, but I don't get what you're suggesting.

I'm new to these problems. What am I supposed to do here ?

Change the bluetooth driver in my device ?

How would I do that ? Where can I find it ?

I can't find anything under "system" or "bluetooth properties".

Thx for helping.

usually, it's a hard thing to change bluetooth stacks, sometimes you need to change the ROM. have a look at xda-devs maybe they have a thread for your device.

0

Share this post


Link to post
Share on other sites

Posted

usually, it's a hard thing to change bluetooth stacks, sometimes you need to change the ROM. have a look at xda-devs maybe they have a thread for your device.

Hi again !

Now I got what he meant by "try both drivers".

He meant the drivers on the cd. I tried both.

Only the MS version would start up...but with the same result: "we don't support this gamepad"

The widcomm driver won't start at all.

So.....anybody suggestions what to do ?

Where is the fault here ?

thx

0

Share this post


Link to post
Share on other sites

Posted

Hi again !

Now I got what he meant by "try both drivers".

He meant the drivers on the cd. I tried both.

Only the MS version would start up...but with the same result: "we don't support this gamepad"

The widcomm driver won't start at all.

So.....anybody suggestions what to do ?

Where is the fault here ?

thx

what version are they?

0

Share this post


Link to post
Share on other sites

Posted

what version are they?

I've tried 1.5 and 1.502 which I got from the Internet.

Didn't make any difference.

I read some threads, where they discussed changing the bluetooth stack on WM5 Axim devices.

Is this possible with Yakumo DeltaX 5BT, too ?

0

Share this post


Link to post
Share on other sites

Posted

I've tried 1.5 and 1.502 which I got from the Internet.

Didn't make any difference.

I read some threads, where they discussed changing the bluetooth stack on WM5 Axim devices.

Is this possible with Yakumo DeltaX 5BT, too ?

by theory, yes.

0

Share this post


Link to post
Share on other sites

Posted

I've tried 1.5 and 1.502 which I got from the Internet.

Didn't make any difference.

I read some threads, where they discussed changing the bluetooth stack on WM5 Axim devices.

Is this possible with Yakumo DeltaX 5BT, too ?

can you upload 1.502 drivers here or to any free storage in thr Internet (iFolder or Sendspace for example)? or give a link to it?

0

Share this post


Link to post
Share on other sites

Posted

Finally had a little success on this today, but not on the Kaiser! Recently put a new ROM on my old Wizard and thought I'd give the pad another go. Same old message as usual but noticed that on XDA that there was a Widcomm stack for the Hermes that also worked with the Wizard. I installed the cab and after changing the port in the registry I was able to contect to the pad using the gamepad program and redefined the buttons! Haven't actually tried a game as I have nothing on the device at the mo.

So I tried the same cab file on the Kaiser (a couple of people mentioned it may work), alas no matter what settings I try it will not detect any bluetooth device including the pad. If anyone wants to try this is the thread on XDA.

0

Share this post


Link to post
Share on other sites

Posted

Hello,please help me, i use the bluetooth gamepad BGP100 on my HTC Diamond,but it does not work.whith driver need you?

ok, as I have made the youtube video, you all know it works. I extracted the required files from the CAB as the CAB is not necessary. Now just download the RAR (for the Diamond and most devices, it is Install_MS.rar)

make a new folder on your Diamond, extract all content of the RAR archive into it and run gamepad.exe. If you get an error telling oyu no BT devie found, you picked the wrong version. try the other one. That's it.

0

Share this post


Link to post
Share on other sites

Posted

Hi,

I've a MSI BGP 100 gamepad, but I've some trouble with it and my HTC Diamond 2.

The connection works fine, and the directional buttons too but the A B C D and R buttons works like if it was only 1 button. ( sorry for my english ^^ )

On the button mapping tool, when I Push button A for exemple, the code is 0xe5 and when I push button B, the code is 0xe5 too...

Can somebody help me ?

Thanks !

0

Share this post


Link to post
Share on other sites

Posted

Does anyone know if the pad works with a Touch Pro 2?

0

Share this post


Link to post
Share on other sites

Posted

As far as i can tell no, the bgp 100 does not i have been trying to get it to work for a long time.

0

Share this post


Link to post
Share on other sites

Posted

As far as i can tell no, the bgp 100 does not i have been trying to get it to work for a long time.

Good news! I just got a TP2 and found my old BGP100 sitting in a drawer. It took about 10 minutes to get code working, but I've written a utility which can talk to the BGP100. I will clean it up and publish it shortly.

Larry B.

0

Share this post


Link to post
Share on other sites

Posted

good news indeed :)

0

Share this post


Link to post
Share on other sites

Posted

hello,

after some experiment I successfully connected a SNES-gamepad to FPSECE using some home-cooked code for a microchip pic, a RS232 bluetooth module and Bitbank driver 8-)

here is the picture of the try :

.IMGP1271_m.jpg

it works really fine, for now I have to replace all the wires by a custom pcb and the pic (18f2450) by a low voltage one (18Lf2450) so that I'll need only 2 AA battery (maybe 2 AAA) (the gamepad seems to handle the 2.8v very well).

I'll try to contact seeedstudio in order to have them making the pcb. :)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.