• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

guide to play Duke Nukem 3D on your Kaiser (with keyboard)!

34 posts in this topic

Posted (edited)

hey, i can play duke nukem on my TyTn II, however only the 1st level (L.A meltdown) works fine

when i start a new game on the 3 other levels, it crash and thats what i get:

- when i load "lunar apocalypse" it says: Map E2L1.map not found!

- when i load "shrapnel city" it says: Map E3L1.map not found!

- when i load "birth" it says: Map E4L1.map not found!

where can i find those maps?

ive read somewhere how to fix the time delay but i cant find it anymore.

the problem i have is that when i shot, i get the shooting sound like 1 second after.

also when i play on landscape mode, a small picture of the keyboard is displayed in the middle of the bottom of the screen.

how can i get rid of it?

thanks

Edited by maxXxim
0

Share this post


Link to post
Share on other sites

Posted

hey, i can play duke nukem on my TyTn II, however only the 1st level (L.A meltdown) works fine

when i start a new game on the 3 other levels, it crash and thats what i get:

- when i load "lunar apocalypse" it says: Map E2L1.map not found!

- when i load "shrapnel city" it says: Map E3L1.map not found!

- when i load "birth" it says: Map E4L1.map not found!

where can i find those maps?

ive read somewhere how to fix the time delay but i cant find it anymore.

the problem i have is that when i shot, i get the shooting sound like 1 second after.

also when i play on landscape mode, a small picture of the keyboard is displayed in the middle of the bottom of the screen.

how can i get rid of it?

thanks

your first problem.. it sounds to me like you are using the shareware version. (shareware means only the first episode) You need the full version to play the rest.

actually i never took any time to try to fix the sound issue, as it didnt seem so bad for me, but ill look into it.

well i did notice that when you enabled Gapi the little keyboard thing did appear, but when gapi was disabled it wouldnt appear (or maybe it was the other way around?). Anyway, try enabling gapi and disabling it and your outcome of all the other settings will be different. I the cfg i have included it should be fine, just remember to run duke in portrait and when the splash screen comes up you then slide out your keyboard.

0

Share this post


Link to post
Share on other sites

Posted

@mikeeey

Did you get the game to run on the latest 6.1 ROMs on XDA without crashing?

Changing GAPI messes up the landscape mode and is unplayable as well

I'll keep checking this thread till something comes up

0

Share this post


Link to post
Share on other sites

Posted

@mikeeey

Did you get the game to run on the latest 6.1 ROMs on XDA without crashing?

Changing GAPI messes up the landscape mode and is unplayable as well

I'll keep checking this thread till something comes up

nope, and on xda and here on modaco you will here me repeat over and over how these new wm6.1 roms dont support quake, quake 2, or duke nukem, something they are missing, but no one knows what.

So im using dutty's 4/29 rom and it works fine, unfortunately I cant install the drivers with this rom.

You are right, changing GAPI does make it run, but makes it crash and unplayable.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Wheeeeeee,

I got this working on my WM 6.1 TyTnII by editing the DUKE3D.cfg like this

[setup]

SetupVersion = "1.3D"

spvDuke3DVersion = "0.4f"

spvDuke3DPortAuthor = "Roozbeh GHolizadeh"

spvDuke3DPortHome = "www.spv3d.com"

[Engine Setup]

UsingGapi = 0

ShowSIPButton = 1

Platform_Timer_HZ = 100

LandscapeMode = 0

CacheMemory = "-2400"

ShowFPS = 1

ShowKeyCodes = 0

TickRate = 135

TicksPerFrame = 26

ScanCodeMapping = 0

Alt_EscapeKey = "BakSpc"

Timidity_Dir = "\Storage Card\timidity"

[scan Code Mapping]

[screen Setup]

ScreenMode = 1

ScreenWidth = 320

ScreenHeight = 240

Shadows = 1

Password = ""

Detail = 1

Tilt = 1

Messages = 1

Out = 0

ScreenSize = 8

ScreenGamma = 16

Make the changes in bold above. When you start the game be in portrait mode, as soon as the grey loading screen comes up you can open the keyboard.

If you want to stop the keyboard icon showing up over the top of the game, dont run it from explorer. create a shortcut in the start menu. if you are in a program that makes the keyboard icon showup on the tastbar when you load the game then it will not be removed from the screen. If you are at the today screen and run the game from the menu the keyboard icon will not be displayed.

One problem I have is I cant work out how to rempap the keys as it loses all the mappings in the config when I have made these changes.

 

Edited by funem
0

Share this post


Link to post
Share on other sites

Posted

Wheeeeeee,

I got this working on my WM 6.1 TyTnII by editing the DUKE3D.cfg like this

[setup]

SetupVersion = "1.3D"

spvDuke3DVersion = "0.4f"

spvDuke3DPortAuthor = "Roozbeh GHolizadeh"

spvDuke3DPortHome = "www.spv3d.com"

[Engine Setup]

UsingGapi = 0

ShowSIPButton = 1

Platform_Timer_HZ = 100

LandscapeMode = 0

CacheMemory = "-2400"

ShowFPS = 1

ShowKeyCodes = 0

TickRate = 135

TicksPerFrame = 26

ScanCodeMapping = 0

Alt_EscapeKey = "BakSpc"

Timidity_Dir = "\Storage Card\timidity"

[scan Code Mapping]

[screen Setup]

ScreenMode = 1

ScreenWidth = 320

ScreenHeight = 240

Shadows = 1

Password = ""

Detail = 1

Tilt = 1

Messages = 1

Out = 0

ScreenSize = 8

ScreenGamma = 16

Make the changes in bold above. When you start the game be in portrait mode, as soon as the grey loading screen comes up you can open the keyboard.

If you want to stop the keyboard icon showing up over the top of the game, dont run it from explorer. create a shortcut in the start menu. if you are in a program that makes the keyboard icon showup on the tastbar when you load the game then it will not be removed from the screen. If you are at the today screen and run the game from the menu the keyboard icon will not be displayed.

One problem I have is I cant work out how to rempap the keys as it loses all the mappings in the config when I have made these changes.

Edit:- Fixed it. Just copy the key settings from KeyDefinitions_Landscape1 to KeyDefinitions_Landscape0 and KeyDefinitions_Landscape2 and you get a fully working copy of Duke Nukem 3D on a WM6.1 TyTn II running in landscape :D

/

0

Share this post


Link to post
Share on other sites

Posted

Wheeeeeee,

I got this working on my WM 6.1 TyTnII by editing the DUKE3D.cfg like this

[setup]

SetupVersion = "1.3D"

spvDuke3DVersion = "0.4f"

spvDuke3DPortAuthor = "Roozbeh GHolizadeh"

spvDuke3DPortHome = "www.spv3d.com"

[Engine Setup]

UsingGapi = 0

ShowSIPButton = 1

Platform_Timer_HZ = 100

LandscapeMode = 0

CacheMemory = "-2400"

ShowFPS = 1

ShowKeyCodes = 0

TickRate = 135

TicksPerFrame = 26

ScanCodeMapping = 0

Alt_EscapeKey = "BakSpc"

Timidity_Dir = "\Storage Card\timidity"

[scan Code Mapping]

[screen Setup]

ScreenMode = 1

ScreenWidth = 320

ScreenHeight = 240

Shadows = 1

Password = ""

Detail = 1

Tilt = 1

Messages = 1

Out = 0

ScreenSize = 8

ScreenGamma = 16

Make the changes in bold above. When you start the game be in portrait mode, as soon as the grey loading screen comes up you can open the keyboard.

If you want to stop the keyboard icon showing up over the top of the game, dont run it from explorer. create a shortcut in the start menu. if you are in a program that makes the keyboard icon showup on the tastbar when you load the game then it will not be removed from the screen. If you are at the today screen and run the game from the menu the keyboard icon will not be displayed.

One problem I have is I cant work out how to rempap the keys as it loses all the mappings in the config when I have made these changes.

 

This works for me, im running Hyperdragon III rom and got duke2d working...

thank, now im working on quake2 to run on my tytn2, need some help though

0

Share this post


Link to post
Share on other sites

Posted

This works for me, im running Hyperdragon III rom and got duke2d working...

thank, now im working on quake2 to run on my tytn2, need some help though

I got the newest hyper dragon III rom as well. unfortunatly when it isn't using gapi the framerate is lower (about 25fps instead of 45fps) and you can see the distortion in the frames as they switch (not too noticable tho).

I havn't even tried quake and quake 2 yet, I'm focused on other things, such as DoomGLES, now that proper drivers are working!

0

Share this post


Link to post
Share on other sites

Posted

Hello i run duke nukem ..but my pda say ..the mising files duke3d.grp ... why?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.