• Announcements

    • PaulOBrien

      Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance) CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission) ROMs must give full credit to the original author ISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • PaulOBrien

      Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
PaulOBrien

How to install and USE .net Compact Framework 3.5 WITHOUT upgrading your ROM.

148 posts in this topic

I followed the directions for installation to the "T"!! It will not install version 3.5

I am using a US Cellular HTC Touch Pro 2

Any suggestions? I get as far as the part where you RUN .net configuration. When I go to "Device Policy" tab, it only comes up with the older 2.? version. The installation of NETCFv35.wm.armv4i.cab FAILS EVERY time...

I went to the Microsoft Download page and like you said it is embedded, so the application for version 3.5 does not want to execute from the Program Files page on my Phone.

Help would be nice....

Also was wondering why US Cellular HTC Pro 2 is not listed for being supported for Windows Mobile 6.5???

0

Share this post


Link to post
Share on other sites
I followed the directions for installation to the "T"!! It will not install version 3.5

I am using a US Cellular HTC Touch Pro 2

Any suggestions? I get as far as the part where you RUN .net configuration. When I go to "Device Policy" tab, it only comes up with the older 2.? version. The installation of NETCFv35.wm.armv4i.cab FAILS EVERY time...

I went to the Microsoft Download page and like you said it is embedded, so the application for version 3.5 does not want to execute from the Program Files page on my Phone.

Help would be nice....

Also was wondering why US Cellular HTC Pro 2 is not listed for being supported for Windows Mobile 6.5???

Figured it out. Had to download a "safeMode" app and run my HTC Touch Pro 2 in safe mode and then install the NETCFv35.wm.armv4i.cab application, then do a soft restart. Works great Paul. Maybe this is just a Touch Pro 2 Glitch?? Still wondering about Windows Mobile 6.5 and if it can b e downloaded for the HTC Touch Pro 2 (US Cellular usedr). Cant Find it as being applicable for my cell provider>>>>????

0

Share this post


Link to post
Share on other sites
Figured it out. Had to download a "safeMode" app and run my HTC Touch Pro 2 in safe mode and then install the NETCFv35.wm.armv4i.cab application, then do a soft restart. Works great Paul. Maybe this is just a Touch Pro 2 Glitch?? Still wondering about Windows Mobile 6.5 and if it can b e downloaded for the HTC Touch Pro 2 (US Cellular usedr). Cant Find it as being applicable for my cell provider>>>>????

Downloaded both cabs...works great on my Samsung I8000 too. Thks guys. U have done great where Microsoft has disappoint all. ;) ;) ;)

0

Share this post


Link to post
Share on other sites

Thaaaanks, I was looking for this explanation and these files. Works just fine on my HTC HD2.

0

Share this post


Link to post
Share on other sites

I have a wee 'AppsToDate' link in my Start menu which has appeared after installing both these apps...any ideas how to remove it? It doesn't appear in the 'remove apps' menu on my O2 HTC HD"...many thanks :)

0

Share this post


Link to post
Share on other sites

Perfect, all installed and running on my HD2. Thanks for both cabs.

0

Share this post


Link to post
Share on other sites

Appreciate your effort. The instructions and the software worked perfectly :-) Now those apps that werent working due to old .net software finally work. :)

0

Share this post


Link to post
Share on other sites

Thanks for these Paul your a legend worked fine on my omnia although i had to restart the phone to get it recognised but thats no biggie :).

0

Share this post


Link to post
Share on other sites
If you're a developer or have knowledge of .net Compact Framework, you'll be aware that version 3.5 has shipped. You'll be aware that it offers a number of enhancements in features, stability and performance, and you'll likely also know that it provides full backwards compatability with previous versions of the Compact Framework. What you may NOT know is that when CF 3.5 is installed on a device, applications that target previous versions of the Compact Framework will continue to run against the old versions, and 3.5 and previous versions will live side by side on the device. Only when new devices come along will we see ONLY 3.5 on a device.

This presents a number of problems, namely

  • Users who deploy CF 3.5 to their device but use applications targeting older versions will not benefit from the 3.5 performance improvements
  • Developers who develop apps for pre CF 3.5 frameworks cannot easily test their applications ready for when 3.5 only devices come along

Thankfully, help is at hand in the form of a little known Compact Framework 3.5 powertoy named '.Net Configuration'. The application, which is available in this download at Microsoft, provides the user with full granularity of control over the .net CF on their device. You can see installed versions, change the used CF version for a particular application or change the used CF version for all applications run on your device! Perfect!

Sadly in Microsoft's infinite wisdom the application in question is tucked away in simple EXE inside the 6.2MB download and somewhat hard to find, so i've taken the liberty of packaging it up into a CAB here that installs it with it's own Start Menu shortcut. I've also included the .net CF 3.5 CAB below, so you can get your device updated quickly and easily by...

- Downloading and installing both CABs below (to internal memory!)

- Running '.Net Configuration' from your Start Menu

- Navigating to the 'Device Policy' tab and selecting version 3.5

- Selecting 'Apply' then 'OK'

That's it, you're done! You can even check it's working by installing my CamerAware Beta and hitting 'About', after which you should see the screen below.

Enjoy, and hope this is useful :)

P

PS If you ARE a developer, there's other goodies in that Powertoys package that are well worth a look too!

netcfcfg.cab

NETCFv35.wm.armv4i.cab

cf351.jpgcf352.jpg

0

Share this post


Link to post
Share on other sites

thanks paul, just what i need it, great help, it's being a pain on............. with the default configuration, thanks one more time......

0

Share this post


Link to post
Share on other sites

Wonderful stuff...thank you

Navigating at Microsoft is a nightmare

0

Share this post


Link to post
Share on other sites

Let me add my voice to the chorus of thanks for doing this.

Still a bit staggered that my 4 month old HTC HD2 shipped with version 2 in the first place.

Finally, I can get Arkswitch to work

0

Share this post


Link to post
Share on other sites

i fought the cf 3.5 upgrade for a week. modoco would not let me download until i was a member. so drop all searching and downlad quest now. go register at the front page. return to article and follow the directions to a flawless upgrade to 3.5. on an htc tilt 2, anyways. i tried all other ways, doing this was the most efficent.

0

Share this post


Link to post
Share on other sites

Thanks for the great work! It works after a soft reset of Samsung SGH-i780 (Windows Mobile 6).

I'm so glad that I can use the application BusGuide2 now.

Cheers! B)

0

Share this post


Link to post
Share on other sites
hey. thanks for the post.

really help.

it works in my HTC Touch PRO2

thanks Paul.

I Love Indonesia.

0

Share this post


Link to post
Share on other sites

Hey guys mine says Please uninstall older version of .net compact framework. I did but it doesnt work. HELP!

0

Share this post


Link to post
Share on other sites

PAul ur genius ....thank u tooooooooooooooooomuch

:D

this is fabulous site

u helped me ,i was upset from 15 days and i finaly got this site as a form of god to me ...

Cheers

Thanku So much

REagrds

shankey (india)

Telephone SPAM 9569388891

Edited by shankey
0

Share this post


Link to post
Share on other sites

hi

i have a pocket pc with os: wince 5.0 and processor type: ARM .

it have .net2. but i have to install .net3.5 into this pocket pc.

i download "NETCFv35.wm.armv4i.cab" and "Microsoft .NET CF 3.5.CAB" too and "NETCFSetupv35.msi" too and any file but dont install any file on the pocket pc.

that show me:

"The file"NETCFv35.wm.armv4i.cab" is not a valid Windows CE setup file".

how can i install .net3.5 on this pocket pc????

plz help me.

0

Share this post


Link to post
Share on other sites

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.