MoDaCo is undergoing planned maintenance. Site functionality may be reduced - follow @modaco or @paulobrien on Twitter for updates.

  • Announcements

    • Reminder - MoDaCo position on illegal content

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software
      Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)


      CUSTOM ROMS

      You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not be hosted directly in topic via the MoDaCo attachment system
      ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)
      ROMs must give full credit to the original author
      This decision has been taken in light of the huge amount of interest in this area of device customisation within the community, and member feedback! Please note that custom ROM discussion should be kept in specific device sub-areas, (e.g. Kaiser.MoDaCo.com for Kaiser based devices). ISSUES If you have any issues with this policy, please contact me directly via PM. P
    • Support MoDaCo by signing up to a MoDaCo Silver or Gold membership

      To sign up to an annual MoDaCo Silver subscription which will eliminate all ads from the site (as well as giving you access to the MoDaCo Online Kitchens for Android) for only £9.99 using PayPal, Credit or Debit Card, ensure you are logged in to the site, and then click the link below, which will take you directly to the subscription store! You can also sign up to an annual MoDaCo Gold subscription for £29.99, which adds the benefits listed below! PURCHASE A MODACO SUBSCRIPTION - FREE Titanium Backup Mobile for Android worth $5.99! - FREE 1 year PrivateInternetAccess.com worth $39.95! - FREE 1 year LastPass Premium worth $12! - FREE CalcConvert for Pocket PC from Binaryfish worth $17.95! - FREE Calendar Bar for Pocket PC from OmegaOne worth $9.99! - FREE CamerAware for Pocket PC and Smartphone from MoDaCo worth £19.99 / $30! - FREE Chronos for Pocket PC from ActiveKitten worth $14.95! - FREE CodeWallet Pro for Smartphone and Pocket PC from DeveloperOne worth up to $24.95! - FREE Concentrix for Pocket PC from eSoft Interactive worth $9.95! - FREE FlexMail for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE FTouchSL for Pocket PC from Vekoff s.r.o. worth 10 euro / $12.50! - FREE Jewel Challenge for Pocket PC from eSoft Interactive worth $9.95! - FREE John Cody's Alerts Pro for Smartphone from Omnisoft worth $14.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Dutch for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> French for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> German for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Italian for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Spanish for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Dutch for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> French for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> German for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Russian for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Turkish for Smartphone from Lingvosoft worth $49.95! - FREE Note2Self for Pocket PC and Smartphone from WebIS worth up to $19.90! - FREE Opera 8.60 for Pocket PC and Smartphone from Opera Software worth up to $48! - FREE Pocket Informant for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE Pocket Launcher for Pocket PC and Smartphone from Conduits worth $9.95! - FREE PTab for Pocket PC and Smartphone from z4soft worth up to $60! - FREE Resco Explorer for Pocket PC and Smartphone from Resco worth up to $49.90! - FREE Safemode for Pocket PC from monocube worth $12.95 - FREE SplashPhoto for Pocket PC and Smartphone from SplashData worth up to $59.90! - FREE Sprite Backup for Pocket PC and Smartphone from Sprite Software worth $29.95! - FREE Teksoft Glyphs UI for Pocket PC and Smartphone from Teksoft €9.95! - FREE Teksoft HeadsetRemote for Pocket PC and Smartphone from Teksoft €4.95! - FREE Traffic Jam for Pocket PC from eSoft Interactive worth $9.95! - FREE unlock (1 per year) from imei-check.co.uk - DISCOUNT of 10% at MoDaCo FairDeal - DISCOUNT of 10% at Semsons.com - FORUM - AD FREE SITE - FORUM - custom rank / title - FORUM - double competition entries - FORUM - double post attachment space - FORUM - no search flood control - FORUM - priority event registration - FORUM - triple PM space
    • Reminder: Selling items on the forum directly is not allowed

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspensions / ban.

HTC Shift - VPN Connection Issues.

17 posts in this topic

Posted · Report post

Hello All,

I wonder is any of you guys could help me, I have contacted HTC first line, second line, third line Support and no one seems to have an answer.

My connection never drops out on SnapVue, at present it is showing H four bars, if I switch to Windows Vista the connection is up and running, internet browsing is fine etc. If I connect to my VPN it keeps dropping the connection within Windows Vista, it seems to last for 1-2 minutes before dropping out, while the connection is out if I switch to SnapVue I have full signal and can sychronise email etc. Switch back to Vista the connection is still out, then suddenly appears again. It will not drop again if not connecting to a VPN, but if you do connect the same thing happens, I thought it maybe an issuse with the VPN tunnel so I removed the SIM card closed all connections, inserted the SIM into a Vodafone datacard, connect to VPN and everything works fine and the VPN running for 7 hours to test not one drop out......

I am at the pull your hair out stage, all HTC support say is reset to factory settings as the drivers for the network card have not installed correctly, but I do not feel this is right, can any one help me??

They don't seem to know what they are doing, I know it is a new product but, HTC support :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

Maybe try to MSCONFIG all start up applications.. see if it is something software orientated casuing the issue? Then a hard reset may be justified..

0

Share this post


Link to post
Share on other sites

Posted · Report post

hi there,

i had the same problem.

try as follows:

vpn-connection->properties->network

now you see the ipv4 and the ipv6. i did the changes to both entries.

so: ipv4->settings->advanced

here you can see a checkbox. there's written something like

'use local gateway for remote'.

uncheck this box in ipv4 and ipv6 and maybe it will work.

first i got just local connection but then i tried to connect to inet and it worked fine.

sorry about my bad englisch, i'm swiss.

have a nice day

nullpunkt

0

Share this post


Link to post
Share on other sites

Posted · Report post

If I connect to my VPN it keeps dropping the connection within Windows Vista, it seems to last for 1-2 minutes before dropping out, while the connection is out if I switch to SnapVue I have full signal and can sychronise email etc. Switch back to Vista the connection is still out, then suddenly appears again.

This maynot be related - I get my Shift tomorrow, so will be able to tell you for sure - but I had problems connecting to my VPN with Vista from a laptop over 3G and saw exactly the same kind of drop outs.

It turns out that O2 where using a private IP address range that was the same as our local LAN. The default subnet mask they used was far too large and caused the PC to get "mixed up" when routing traffic between the VPN and the internet (non-VPN).

The fix was to get O2 to give me an APN for 3G that gave public IP addresses.

If this happens on my Shift, which I think it will, I will be a little annoyed, but will post here and let you know!

PDAMerlin

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi PDAMerlin,

I think this is the answer my internal network is 192.168.0.x & my Vodafone SIM is showing an IP address of 192.168.160.1, any ideas how I can get Vodafone to change this???

This maynot be related - I get my Shift tomorrow, so will be able to tell you for sure - but I had problems connecting to my VPN with Vista from a laptop over 3G and saw exactly the same kind of drop outs.

It turns out that O2 where using a private IP address range that was the same as our local LAN. The default subnet mask they used was far too large and caused the PC to get "mixed up" when routing traffic between the VPN and the internet (non-VPN).

The fix was to get O2 to give me an APN for 3G that gave public IP addresses.

If this happens on my Shift, which I think it will, I will be a little annoyed, but will post here and let you know!

PDAMerlin

0

Share this post


Link to post
Share on other sites

Posted · Report post

I think this is the answer my internal network is 192.168.0.x & my Vodafone SIM is showing an IP address of 192.168.160.1, any ideas how I can get Vodafone to change this???

Hi.

Sorry, no idea. To confirm, if you run open a command prompt when conencted and type

ROUTE PRINT

then post the output here (or PM) I will have a look and see if it looks like the same problem i had with O2.

Merlin

0

Share this post


Link to post
Share on other sites

Posted · Report post

Evening all.

I am now getting exactly the same issue using O2. WM side works fine, Vista side works fine until I connect a pptp vpn. It stays up for a few seconds then the network connection drops (and also the network card disappears in Manage Network connections).

disconnect the VPN, wait 10 seconds and 3G comes back up and browsing works!

It's a bug somewhere...HELP!!

PDAMerlin

0

Share this post


Link to post
Share on other sites

Posted · Report post

Dear All,

I have just been told by my reseller, the HTC Shift cannot handle VPN traffic using the internal network card, I don't know how true this is, but if it is HTC will be getting it back!!!!!

I will update you...

Evening all.

I am now getting exactly the same issue using O2. WM side works fine, Vista side works fine until I connect a pptp vpn. It stays up for a few seconds then the network connection drops (and also the network card disappears in Manage Network connections).

disconnect the VPN, wait 10 seconds and 3G comes back up and browsing works!

It's a bug somewhere...HELP!!

PDAMerlin

0

Share this post


Link to post
Share on other sites

Posted · Report post

Does anyone have a resolution, this is driving me mad :D

Dear All,

I have just been told by my reseller, the HTC Shift cannot handle VPN traffic using the internal network card, I don't know how true this is, but if it is HTC will be getting it back!!!!!

I will update you...

0

Share this post


Link to post
Share on other sites

Posted · Report post

I don't suppose there are any updates to this? Just noticed today I can't even put a VPN up over WiFI. The only way it works is if I plug in the USB hub and use a cable!

Merlin

0

Share this post


Link to post
Share on other sites

Posted · Report post

Dear All,

I have the resolution to this issue, I am just testing but seems to work fine, I will update once I have run some more tests.

With kind regards,

Ross.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Dear All,

I have the resolution to this issue, I am just testing but seems to work fine, I will update once I have run some more tests.

With kind regards,

Ross.

hello,

"nice" to hear that there are people with the same problem.

extremeneo, if you have the solution, please put it online because i'd like to setup this device properly for my boss and this is the only possible solution i can think of...

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

hello,

"nice" to hear that there are people with the same problem.

extremeneo, if you have the solution, please put it online because i'd like to setup this device properly for my boss and this is the only possible solution i can think of...

Hey All,

I am also atm on the way to go crasy... 2days I tryed to find out what the Connection problem in combination 3G+MS PPTP+128bitenc is about or how to fix it...

Like some of u guys told, that everything is working fine for them, others have the same Prob like I.

Prob in detail: Internet via 3g works after WM6 is setuped some min l8ter Vista got the NDIS eth. and I can surf the web.

But when I start the VPN (PPTP) connection there are 2 ways:

Without any changes in the VPN IP4 -> VPN connects, all fine, i can ping the server in the VPN Network and i would be very happy if the Connection would stay alive, but after some seconds ~10 -max 25 sec. the ping is gone, on the windows side I see that NDIS is gone and the VPN con. is still up and timeouts some moments l8ter... again some min l8ter the NDIS is back again and i am online... if I connect the VPN again, the same starte again like discriped above....

The other way, if I remove the mark in the IP4 extende options VPN Con -> Network -> IP4 -> extendent ->'use default gateway on remote network' 

both keeps alive, and internet is working fine, but i got no ping and communication through the vpn...

I need a solution, or the HTC is useless for us tbh...

Thx for some help at this point already!

greetz

profi aka seb

Edited by pr0fi
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I got the shift and have exactly the same issues as you guys. This is the response I got back from HTC:

"Can you please telephone us in regard to your Shift VPN problems? This issue is far to complicated to troubleshoot using email.

We are getting very, very few reports about VPN failure on the Shift, and we really like to speak to customers who are facing this issue so we can investigate further."

I guess we all better start calling them as it seems not a lot of htc shift users are having problems...

Edited by wills
0

Share this post


Link to post
Share on other sites

Posted · Report post

Dear All,

This is the only resolution at present I am aware of, please note this solution is for Vodafone UK only, You can get the HTC Shift device to work perfectly using a VPN connection but you do lose some functionality.

All you need to do is create a new connection within SnapVue.

These are the steps to follow:

From SnapVue (non liberated)

Select "Settings"

Select "Connections"

Select "Manage Existing Connections"

You should have a connection named "Contract Internet" number "internet" DO NOT DELETE THIS.

Select New.

Enter a name for the connection, I entered my name as VPN.

Select a Modem "Cellular Line (GPRS,3G)"

Access Point Name "mylan"

User Name "mylan"

Password "mylan"

Domain "Leave Blank"

You don't need to add Advanced settings.

Click "Finish"

Once new connection is setup, click on connection and hold, then select connect. Then start up the Windows Vista operating system, then wait for the system to complete start up, and ensure connection using the SnapVue network sharing is connected, connect to your VPN, and all will work fine. I have had a VPN connected for 6 days using this method previously it would last no longer than 3 minutes.

The only issue with this is that SnapVue will lose all internet connectivity, as this connection is for VPN traffic only Vodafone will not allow internet connectivity through this type of connection, I am working on a resolve, and will update you all.

The main issue I think is the way SnapVue issues the IP addresses to the Internet Sharing for Vista.

For anyone who would like to help me resolve this issue all help would greatly received........

0

Share this post


Link to post
Share on other sites

Posted · Report post

Dear All,

This is the only resolution at present I am aware of, please note this solution is for Vodafone UK only, You can get the HTC Shift device to work perfectly using a VPN connection but you do lose some functionality.

All you need to do is create a new connection within SnapVue.

These are the steps to follow:

From SnapVue (non liberated)

Select "Settings"

Select "Connections"

Select "Manage Existing Connections"

You should have a connection named "Contract Internet" number "internet" DO NOT DELETE THIS.

Select New.

Enter a name for the connection, I entered my name as VPN.

Select a Modem "Cellular Line (GPRS,3G)"

Access Point Name "mylan"

User Name "mylan"

Password "mylan"

Domain "Leave Blank"

You don't need to add Advanced settings.

Click "Finish"

Once new connection is setup, click on connection and hold, then select connect. Then start up the Windows Vista operating system, then wait for the system to complete start up, and ensure connection using the SnapVue network sharing is connected, connect to your VPN, and all will work fine. I have had a VPN connected for 6 days using this method previously it would last no longer than 3 minutes.

The only issue with this is that SnapVue will lose all internet connectivity, as this connection is for VPN traffic only Vodafone will not allow internet connectivity through this type of connection, I am working on a resolve, and will update you all.

The main issue I think is the way SnapVue issues the IP addresses to the Internet Sharing for Vista.

For anyone who would like to help me resolve this issue all help would greatly received........

Hi,

i have the same problem, only with KPN, Netherlands.

I have tried this solution, but whitout result...

does anybody have another solution?

thanx.

greets.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Dear All,

I think I have a working solution. (at least it works for me on the vodafone proximus network in Belgium)

In Vista go to Network and sharing center,

Tap on "manage network connections"

Now rightclick on your 3G connection and choose "properties"

Be sure to check only the Qos packet scheduler and the TCP/IPv4

Leave the rest unchecked! and click "OK"

Now rightclick on your VPN connection and choose "properties"

select the TAB "Networking"

uncheck the TCP/IPv6 and leave the rest checked

Tap on TCP/IPv4 and click the "properties" button

Click "advanced" button

Uncheck the "Use default gateway on a remote network"

click "OK" x3

Now connect to your VPN

Happy surfing :lol:

greetz

Stefan

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.