• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

HELP. mpx220 not turning on

6 posts in this topic

Posted (edited) · Report post

Here's the thing, a few months ago i started having a hard time charging my mpx220, long story short, the problem was that the pins from the charging center were not well soldered to the main plate (or whatever it's called u get me, right?). I took my cell to a technician to fix the problem and he did, thing is i can't get my phone to turn on, i charged the battery to 100% with a universal charger and tried to turn it on, nothing happened. When i plug the charger screens don't turn on. I tried to do a master reset and nothing happened either. Since my computer can detect it (without the battery and SIM card) now that the pin problem is fixed, i did a ROM upgrade. It was correctly done but when i put the battery on (after inserting the SIM card) both screens turn on, and the internal one says "Master reset !" on the top and "Formating ..." on the bottom for about 4 seconds and then it turns off again and nothing will make it start.

The technician told me the flex wire is intact and all the conections are well made. So i guess it should be a software issue but, how can i solve this?

Please guys help me, i don't wanna give up on this awesome phone. Thanks

Edited by Mac8
0

Share this post


Link to post
Share on other sites

Posted · Report post

Welcome to the site :D

Either the battery is faulty or there is something shorting out in the phone.

If it was a short of some sort the battery would be getting hot due to the sudden discharge.

I would get the battery checked or buy a cheap replacement to test.

Did you do a ROM upgrade without the battery in the phone? if you did this could be your problem as the battery HAS to be in the phone and preferably at 100% charge before and flashing is done. It would be unlikely that the flash process was completed despite what the pc may report.

This leaves three possible problems with your phone,

1, The guy that repaired your phone has introduced a fault. This would be the first thing on my list as you appear to say that the phone was working before the fault was repaired the only problem you had was that you had to use an external battery charger.

2, The battery is faulty and needs to be replaced (possibly caused by either age, a faulty charger unit or a questionable repair)

3, The flashing process was not completed correctly you say them battery was not in the phone when you did the ROM upgrade. I would place the battery or preferably a replacement in the phone and reflash the device.

Personally No1 is the prime suspect for me and as I side note I would have never attempted to flash a device that had a fault without rectifying the fault first. The phone not being able to turn on after an attempted repair can only really point to a bodged repair.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Either the battery is faulty or there is something shorting out in the phone.

If it was a short of some sort the battery would be getting hot due to the sudden discharge.

I would get the battery checked or buy a cheap replacement to test.

Now that u mention it, when i got the phone from the technician guy and tried to charge it, the battery was getting hot. Do u think there might be a short in the phone? If there was, how can i know for sure or test it?

0

Share this post


Link to post
Share on other sites

Posted · Report post

If the battery suddenly got hot is means it has either shorted out due to a bodged repair or it means that the charge in the battery was so low it was heating up as it was charging.

The only way to test it would be to try the battery in another device and see if it works ok or to try a new battery in you phone.

I'm edging my bets on a faulty repair that has caused a short. As I have mentioned previously, if it was working before the repair and now it does not since the repair then it does point to the a faulty repair that may have damaged or killed your phone.

0

Share this post


Link to post
Share on other sites

Posted · Report post

well, i could finally get a new battery, i charged it and everything but i got the same result when doing the rom upgrade. I guess that means bad news, huh?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Unfortunately so.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.