• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Wifi connection whilst connected to ActiveSync

5 posts in this topic

Posted

I connect my Kaiser to my work PC to sync my meetings so I don't forget where I'm supposed to be. However, my work LAN is locked down so I can't sync my device email across the LAN.

I'd like to have it so that my device will connect to the 'net over GPRS whilst it's connected, so it still gets email updates every 30 minutes while connected. But it doesn't work - it gives a connection failure and only downloads email if I specifically disconnect from the USB cable and then hit send/receive.

I have the "Allow wireless connection on the device when connected to the desktop" option checked in Activesync, but it appears to make no difference.

It's really annoying to have to periodically disconnect my device to see if I have any email.

Any ideas?

0

Share this post


Link to post
Share on other sites

Posted

What do you have for "This computer is connected to:" ?

Also turn off "Allow USB Connection"

Do that first before you dock the phone.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Also turn off "Allow USB Connection"

I thought you'd hit the nail on the head there. But no. Doing that actually completely disables the USB connection altogether, so I don't have any ActiveSync connection at all.....

I have "This computer is connected to..." set to "Work Network".

Edited by Webreaper
0

Share this post


Link to post
Share on other sites

Posted

I thought you'd hit the nail on the head there. But no. Doing that actually completely disables the USB connection altogether, so I don't have any ActiveSync connection at all.....

I have "This computer is connected to..." set to "Work Network".

THIS REFERANCE ARTICAL MY BE OF INTREST http://www.informit.com/guides/content.asp...&seqNum=326

0

Share this post


Link to post
Share on other sites

Posted

I connect my Kaiser to my work PC to sync my meetings so I don't forget where I'm supposed to be. However, my work LAN is locked down so I can't sync my device email across the LAN.

I'd like to have it so that my device will connect to the 'net over GPRS whilst it's connected, so it still gets email updates every 30 minutes while connected. But it doesn't work - it gives a connection failure and only downloads email if I specifically disconnect from the USB cable and then hit send/receive.

I have the "Allow wireless connection on the device when connected to the desktop" option checked in Activesync, but it appears to make no difference.

It's really annoying to have to periodically disconnect my device to see if I have any email.

Any ideas?

This is a security feature to avoid the possibility of introducing back doors into corporate networks. When connected via USB, all other network interfaces are disabled. For example, without this, had your IT department allowed your device to get full LAN access via ActiveSync, then you could also have WiFi running, providing an unsecured access point straight into your corporate network. Similar for GPRS.

This causes a real problem with debugging Windows Mobile applications which make use of WiFi or GPRS - connecting via USB to enable debugging disables the very interfaces you want to debug! There are ways around it for debugging (eg. not doing USB but doing it over WiFi - but that's another story: http://blogs.msdn.com/windowsmobile/archiv...22/420884.aspx).

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.