Junoman

►► Permanent GPS fix for Samsung i900 & i8000 Omnia ◄◄

Recommended Posts

Latest up dates; - NB: Please back up your original registry settings before try this

A. settings for i900 omnia

1. Make sure Omnia's External GPS settings as on defaults;

- GPS program port = COM3

- GPS Hardware port = COM9 and Bud rate = 4800

- Manage GPS Automatically

2. Extra data injection through Enhanced GPS

3. Here are registry editings (works fine with TomTom)

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\InputBufferSize: set from 4096 to 512

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\OutputBufferSize: set from 4096 to 512

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\SleepOnNoData: set from 100 to 0

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\CurrentLogFile: set from CurrentLogFile to Blank (set string value to blank)

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\OldLogFile: set from OldLogFile to Blank (set string value to blank)

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer\MaxBufferSize: set from 16384 to 1024

4. Switch off and on or soft reset.

5. Check and make sure above registry settings done properly, unless complete them proceed further!

6. Now you can check GPS reception; type in *#1472365# go into menu\views\ and click on "satellites info". Then go back into menu and click "get position". You will get a page with number of sats and the signal strength from each.

You should get GPS fixed within 2-3 minutes, even after soft re-set if you have a good GPS reception!

B. settings for i8000 omnia (thanks to jh787)

Please refer to post 95 here for relevat instructions!

Thanks should goes to all original innovators. Once again it is reminded you to back up your original registry settings before try this. Finally DO NOT forget to post your feed back please as we need to improve it further!!

Enjoy!

J.

(last edited on 10 April 2010)

================================================================================

It has innovated the registry tweaks to fix the Ever lated Poor GPS reception of i900 Omnia at Last! I just thought to share this info with our Modaco folks.

1. Make sure Omnia's External GPS settings as on defaults;

- GPS program port = COM3

- GPS Hardware port = COM9 and Bud rate = 4800

- Manage GPS Automatically

2. Here are the settings and please change these settings in the registry on your omnia: (you may need registry editing software like total commander for this)

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\InputBufferSize: set from 4096 to 512

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\OutputBufferSize: set from 4096 to 512

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\SleepOnNoData: set from 100 to 0 (for TomTom) or 5 (for Garmin)

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer\MaxBufferSize: set from 16384 to 1024

3. Soft reset.

4. Open your navigation software and assign necessary GPS settings to it first. So you should get GPS fixed within quick 10 -30 seconds.

NB: I can confrim most importantly GPS flow is continuous and no battery drain.

Thanks should goes to original innovater.

Please DO NOT forget to post your feed back!! B)

Enjoy!! B)

J.

(last edited on 10 February 2010)

================================================================================

NAVIGATOR 7 for Windows

  • ERA MDA Vario IV
  • HTC P3470
  • HTC Touch Cruise
  • HTC Touch Cruise II
  • HTC Touch Diamond 2
  • HTC Touch HD
  • HTC Touch Pro
  • HTC Touch Pro 2
  • HTC TyTN II
  • O2 XDA Diamond Pro
  • O2 XDA Guide
  • O2 XDA Orbit 2
  • Orange HTC Touch Pro
  • Orange P4550
  • Samsung i900 Omnia
  • SFR HTC Touch HD
  • SFR HTC Touch Pro
  • Sony Ericsson XPERIA X1
  • Swisscom HTC Touch Pro
  • Swisscom HTC Touch Pro 2
  • Swisscom XPA1615
  • T-Mobile MDA Vario III
  • T-Mobile MDA Vario IV
  • Vodafone HTC Touch Pro
  • Vodafone XPA1615

At last they have come with solution to our poor i900 omnia!!!

(last edited on 17 November 2009)

================================================================================

I/we have tried the following Tom Tom versions with our i900 Omnia.

Tom Tom - version 7.450

Tom Tom - version 7.451

Tom Tom - version 7.910

we have experienced following out comes.

a. Poor GPS reception most of times and waiting for a valid GPS signal for ages

b. Sometimes it indicates number satalites (in the show GPS status), but never fix/connect with them

c. After a restart or reset it pick-ups GPS signals in few seconds/minutes

d. Having tried the registry tweak (setting value to null/zero to Current log and Old log file in the registry), but did not see any apprarent success

e. It works fine with GPS supportive third party softwares like gpsproxy, gpsgate

f. We noticed (further different topic of this forum) there is no major GPS reception issue like this with other navigation softwares like Garmin, IGO8 etc. with i900. Therefore should be bug in the Tom Tom itself

Most of our i900 commnunity prefer to use Tom Tom, therefore need your support and feed back on expert guys advise. Please share your experienced too (We respect and do not suggest to use a differnt navigation software rather Tom Tom please)

1. Is there any patch avaialble to fix this issue?

2. Can any or you guys give any advise to fix this issue please?

3. What I would expect is can somebody consider this issue when cooking a new rom by intragrating GPS supportive patch/software to Tom Tom specially.

Cheers'

J

PS. Mind the poor language

Edited by Junoman

Share this post


Link to post
Share on other sites

I wish TomTom could be fixed! Personally I point the finger of blame at TomTom *sort of*. Ultimately TomTom 7 is diamond only, I just hope they decide to make it publically available. Hmph

Share this post


Link to post
Share on other sites
I/we have tried the following Tom Tom versions with our i900 Omnia.

Tom Tom - version 7.450

Tom Tom - version 7.451

Tom Tom - version 7.910

we have experienced following out comes.

a. Poor GPS reception most of times and waiting for a valid GPS signal for ages

b. Sometimes it indicates number satalites (in the show GPS status), but never fix/connect with them

c. After a restart or reset it pick-ups GPS signals in few seconds/minutes

d. Having tried the registry tweak (setting value to null/zero to Current log and Old log file in the registry), but did not see any apprarent success

e. It works fine with GPS supportive third party softwares like gpsproxy, gpsgate

f. We noticed (further different topic of this forum) there is no major GPS reception issue like this with other navigation softwares like Garmin, IGO8 etc. with i900. Therefore should be bug in the Tom Tom itself

Most of our i900 commnunity prefer to use Tom Tom, therefore need your support and feed back on expert guys advise. Please share your experienced too (We respect and do not suggest to use a differnt navigation software rather Tom Tom please)

1. Is there any patch avaialble to fix this issue?

2. Can any or you guys give any advise to fix this issue please?

3. What I would expect is can somebody consider this issue when cooking a new rom by intragrating GPS supportive patch/software to Tom Tom specially.

Cheers'

J

PS. Mind the poor language

Have a look at http://www.modaco.com/content/i900-omnia-h...t-xtra-enabled/

My seems to be working like a treat now.

have a try. Been looking for ages and found that on another site.

Thanks

Share this post


Link to post
Share on other sites
Have a look at http://www.modaco.com/content/i900-omnia-h...t-xtra-enabled/

My seems to be working like a treat now.

have a try. Been looking for ages and found that on another site.

Thanks

Having tried that option (refer note d) already, never help me!!!! It seems; TT6/7 softwares itself needs some improvement from the origin rather.

Further notes as are follows to my experience (TT7);

1. i900-Ominia stuggle to get the initial GPS reception at all times. once it gets connected, there wont be any worries. Flow is good

2. There is a relation get the initial GPS reception with phone's battery power. If the battery power inidicate full, it tends to get GPS reception quickly in most occations. B)

3. TT7 mainly designed for HTC not for other PDA/PNA rather...!! B) Shame really

Some Solutions/sugesstion to my experience;

4. When you need to use TT after coming out from a premises; just press the phone wake up botton and wait for 1-2 minutes before starting TT. It will help you to get quick GPS reception

5. Re-start also does the job!!

Share your experience.

Cheers'

J.

PS-Please don't mind my language skills

Share this post


Link to post
Share on other sites
Having tried that option (refer note d) already, never help me!!!! It seems; TT6/7 softwares itself needs some improvement from the origin rather.

Further notes as are follows to my experience (TT7);

1. i900-Ominia stuggle to get the initial GPS reception at all times. once it gets connected, there wont be any worries. Flow is good

2. There is a relation get the initial GPS reception with phone's battery power. If the battery power inidicate full, it tends to get GPS reception quickly in most occations. B)

3. TT7 mainly designed for HTC not for other PDA/PNA rather...!! B) Shame really

Some Solutions/sugesstion to my experience;

4. When you need to use TT after coming out from a premises; just press the phone wake up botton and wait for 1-2 minutes before starting TT. It will help you to get quick GPS reception

5. Re-start also does the job!!

Share your experience.

Cheers'

J.

PS-Please don't mind my language skills

Hi sorry got all excited yesterday as I thopught it had been cracked buit its starting misbehaving again this morning.

Regards

Vik

Share this post


Link to post
Share on other sites
I/we have tried the following Tom Tom versions with our i900 Omnia.

Tom Tom - version 7.450

Tom Tom - version 7.451

Tom Tom - version 7.910

we have experienced following out comes.

a. Poor GPS reception most of times and waiting for a valid GPS signal for ages

b. Sometimes it indicates number satalites (in the show GPS status), but never fix/connect with them

c. After a restart or reset it pick-ups GPS signals in few seconds/minutes

d. Having tried the registry tweak (setting value to null/zero to Current log and Old log file in the registry), but did not see any apprarent success

e. It works fine with GPS supportive third party softwares like gpsproxy, gpsgate

f. We noticed (further different topic of this forum) there is no major GPS reception issue like this with other navigation softwares like Garmin, IGO8 etc. with i900. Therefore should be bug in the Tom Tom itself

Most of our i900 commnunity prefer to use Tom Tom, therefore need your support and feed back on expert guys advise. Please share your experienced too (We respect and do not suggest to use a differnt navigation software rather Tom Tom please)

1. Is there any patch avaialble to fix this issue?

2. Can any or you guys give any advise to fix this issue please?

3. What I would expect is can somebody consider this issue when cooking a new rom by intragrating GPS supportive patch/software to Tom Tom specially.

Cheers'

J

PS. Mind the poor language

Junoman I quote your troubles; I've got i780 a month ago I'had got the same issues and I'm still waiting for a fix. If someone find out some tips pls post

Share this post


Link to post
Share on other sites

Hi there,

I had exactly this problem on my HTC Diamond for a while until I played around with the GPS settings inside TomTom.

Here's what I did. Hope it is of some use to you, or anyone else finding this problem:

1. Start TomTom, go to 'Change Preferences'

2. Navigate to "Show GPS status"

3. Go to 'Configure'

4. Select 'Other NMEA GPS receiver'

5. Set baud rate to 4800

6. Select 'COM4:"

That cured it for me. My GPS device is on COM4 on the HTC diamond - the Omnia might be different. To check it out:

1. Go to Start -> Settings

2. Click 'System' tab

3. Click 'External GPS'

4. Observe com port listed under 'GPS program port:"

After changing it, it works perfectly for me. Hope you have some luck!

Share this post


Link to post
Share on other sites
Hi there,

I had exactly this problem on my HTC Diamond for a while until I played around with the GPS settings inside TomTom.

Here's what I did. Hope it is of some use to you, or anyone else finding this problem:

1. Start TomTom, go to 'Change Preferences'

2. Navigate to "Show GPS status"

3. Go to 'Configure'

4. Select 'Other NMEA GPS receiver'

5. Set baud rate to 4800

6. Select 'COM4:"

That cured it for me. My GPS device is on COM4 on the HTC diamond - the Omnia might be different. To check it out:

1. Go to Start -> Settings

2. Click 'System' tab

3. Click 'External GPS'

4. Observe com port listed under 'GPS program port:"

After changing it, it works perfectly for me. Hope you have some luck!

Hi Guys,

TomTom supportive rom has beeen released at last here and thanks to s_wind!

There are some bug in the rom but works fine for me. This is a good news and hoping that much improved rom may come out very soon soon. B)

Original source: http://www.modaco.com/content/i900-omnia-r...t-and-fast-gps/.

Flash the rom with your own risk.

J.

Share this post


Link to post
Share on other sites

Tested the new room (full one).

Yes the GPS fix is much faster but with TT the situation is the same: you still need GPSGate or similar since the protocol is still incompatible.. B)

Share this post


Link to post
Share on other sites
Tested the new room (full one).

Yes the GPS fix is much faster but with TT the situation is the same: you still need GPSGate or similar since the protocol is still incompatible.. B)

What Rom are you talking about? Is it the HK1 or HK2?

thanks

vik

Share this post


Link to post
Share on other sites

can you post the registry settings off the gps with your rom

maybee we can see what has changed to cause the quick fix

Tested the new room (full one).

Yes the GPS fix is much faster but with TT the situation is the same: you still need GPSGate or similar since the protocol is still incompatible.. B)

Share this post


Link to post
Share on other sites
Tested the new room (full one).

Yes the GPS fix is much faster but with TT the situation is the same: you still need GPSGate or similar since the protocol is still incompatible.. B)

Hi Dude,

It should not be!! I flashed the following rom and works perfect with TT, but there are some bug in that rom (some ringing tons not working, Menu icon in the Samsung Today 1 not functioning). Overall it's quite a good rom at the moment.

Phone: DXHK2/PVR04

PDA: DXHK2

Change your TT settings as follows, which considered to be default;

- Select 'Other NMEA GPS receiver

- Set baud rate to 4800

- Select COM3

J.

Share this post


Link to post
Share on other sites
can you post the registry settings off the gps with your rom

maybee we can see what has changed to cause the quick fix

Samsung Omnia works with Tomtom Navigation Software and here is the fixing tips to enhance the satellite signal reception problem;

1st - Settings:

I use in external GPS settings - program port "COM7" and hardware port "COM9" at 4800. (note: Make sure your TomTom configure also follows COM7 port!)

2nd - Reboot

Then I shut off the device completely (complete off), and reboot. Once I reboot.

3Rd - Delete the 'GPSID_log' files

I go to File Explorer --> My Device and I delete the TWO 'GPSID_log' fileS.

[note: the reboot step is absolutely necessary, because if you don't reboot, then it won't allow you to delete one of the 'GPSID_log' file!!!]

4th - Start TomTom OUTSIDE (under the clear sky) and within 20 - 30 secs the program catches the satellites (they show up on the configure screen). But not only that - after 1-2 minutes the software actually CONNECTS to the satellites (the satellites turn BLUE) and in the front screen it says - no route planned! Note: You Must Wait Until The Front Screen Says "No Rote Planned" and the map is in color (opposed to black and white) before you start setting your destination, otherwise it will keep on hanging and just showing you the satellites in grey without ever turning into blue.

J.

Share this post


Link to post
Share on other sites
It should not be!! I flashed the following rom and works perfect with TT, but there are some bug in that rom (some ringing tons not working, Menu icon in the Samsung Today 1 not functioning). Overall it's quite a good rom at the moment.

Phone: DXHK2/PVR04

PDA: DXHK2

I don't like that rom. Too many bugs...

but the full DXHK2 I used should be the same in respect of GPS improvements

- Select 'Other NMEA GPS receiver

- Set baud rate to 4800

- Select COM3

I do use these ones.

But even with the new room I can't see any improvement in TT ability to recognise the signal (without using a virtual port). Stil too unreliable and cumbersone to use it in this way...

IMHO the only practical solution is still to use TT + GPSGate and a mortscript to open and close both at the same time.

Share this post


Link to post
Share on other sites

I do use these ones.

But even with the new room I can't see any improvement in TT ability to recognise the signal (without using a virtual port). Stil too unreliable and cumbersone to use it in this way...

IMHO the only practical solution is still to use TT + GPSGate and a mortscript to open and close both at the same time.

Share this post


Link to post
Share on other sites

I run TomTom 6 on the i910 I got yesterday. I added an external com port (6) and it worked perfectly fine after. The only hangup I have right now is its telling me that there are no selectable voices for use. Prolly something stupid I did that I need to fix somewhere.

Share this post


Link to post
Share on other sites

i used to have tomtom 7 on my omnia, my experience with tomtom is not so good for it takes time to get a gps fix/lock satellite. I changed to igo8, which has a better map image and better navigation feature, it locks in few seconds under a clear sky. It is really far compared to tomtom 7 on my personal opinion. later I will post here a link where I found it. Im busy right now and Im gonna look at the link first, tomorrow probably I'll post it here, it is worth saving time really if you use nav n go igo8 instead. cheers! :-)

Share this post


Link to post
Share on other sites

i did the registry hack(remove gpsid_log etc etc)

when you do this and reboot you will notice that reception is very bad and you do not see any sattelits in gpsproxy, gpsgate.

i just used it a couple of days in my car and it turns out it really works

i get a fix in seconds every day without a gps on and without a current xtra file

it seems that this gps needs clear sky and movement.

eg when i put it in my car and enable gps i see nothing

the minute i start driving all sattelites show up at oneces

it looks like it is waiting for movement to show the satellites.

so

without registry hack

slow fix but sattelites show up when stationary

with registry hack

very fast fix, sattelites only show up after movement in your car.

maybee this is a power saving thing(eg when stationary it shuts of)

registry hack is explained here

http://www.modaco.com/content/i900-omnia-h...t-xtra-enabled/

Agps is off

these are the settings i am using in the registry

Under: HKLM\SYSTEM\CurrentControlSet\GPS Intermediate Driver\

- Drivers\Samsung GPS Hardware\PollInterval -> 500 (default is 1000)

- Drivers\Samsung GPS Hardware\InputBufferSize -> 512 (default is 4096)

- Drivers\Samsung GPS Hardware\OutputBufferSize -> 512 (default is 4096)

- Drivers\Samsung GPS Hardware\RetryWaitonerror-> 10000 (default is 10000)

- Drivers\Samsung GPS HardwareSleepOnNoData -> 100 (default is 1000)

- Multiplexer\MaxBufferSize -> 8192 (by default not present, you have to create it or standard 16384)

Edited by gravityz

Share this post


Link to post
Share on other sites
i used to have tomtom 7 on my omnia, my experience with tomtom is not so good for it takes time to get a gps fix/lock satellite. I changed to igo8, which has a better map image and better navigation feature, it locks in few seconds under a clear sky. It is really far compared to tomtom 7 on my personal opinion. later I will post here a link where I found it. Im busy right now and Im gonna look at the link first, tomorrow probably I'll post it here, it is worth saving time really if you use nav n go igo8 instead. cheers! :-)

Map is exactly the same since it's produced by TeleAtlas. Actually the latest 815.20XX available for TT are newer then the latest 2008.07 available for iGo

Indeed iGo works perfectly with the internal GPS (as Garmin XT) because they have uptodate GPS drivers that TT is missing.

But again until TT officially support other PPC then HTC D, we may not see anything from TT (and Samsung either..)

Share this post


Link to post
Share on other sites

today i noticed something strange.

after doing the registry hack the receiving of satellites is very fast.

today i walked outside and did some tests

GPSproxy and tomtom, very fast show up of satellites and fix

googlemaps bo fix at al and 0 satellites.

i enabled Agps and downloaded the XTRA file.

after that googlemaps was really fast, tomtom stayed the same.

it looks like google maps need the XTRA file while tomtom does not.

eg

software who has direct communication to the intermediate driver(googlemaps) benefit from the XTRA file)

software who communicates to a commport do not benefit from the XTRA file

Map is exactly the same since it's produced by TeleAtlas. Actually the latest 815.20XX available for TT are newer then the latest 2008.07 available for iGo

Indeed iGo works perfectly with the internal GPS (as Garmin XT) because they have uptodate GPS drivers that TT is missing.

But again until TT officially support other PPC then HTC D, we may not see anything from TT (and Samsung either..)

Share this post


Link to post
Share on other sites

Having used DXHK2/PVR04 & DXHK3/PVR07 roms. I got an good impression about both of these roms and they show apparent improvement with TomTom. It catches GPS signal within 1-2 minutes of most time.

But I do not know about DXHK2 & DXHK3 full versions posted by secany. Please share your experience

J.

Share this post


Link to post
Share on other sites

Hi,

i also tried tomtom 7 on omnia with the registry change and deleting the two files. it did start to get gps fix in a minute or two.

But the same problem as mentioned in post 1. sometimes it works repeatedly but sometimes it wont.

u need to turn of and on the phone before it works. there is something bothering it. has someone been able to figure out ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.