somedude

[FIXED 12-5-08!!]Tethering on the I910 Verizon Omnia?

396 posts in this topic

First time poster here, but I've used the forum to acquire a TON of information for my phone, including the tethering and wifi programs discussed in this current thread. I've used both programs successfully over the past 6 months, but it seems that I have come across a problem just recently: My computer no longer recognizes the interent signal from my phone.

The error message I get when I try and "repair" the connection is this: "Windows could not finish repairing the problem because the following action cannot be completed: Renewing your IP address."

Now, I'm quite ignorant when it comes to anything computers, and will admit that I have to be "spoon fed" when it comes to stuff like this, but I'd appreciate any words of advice on how I can get this program up and running again. I've tried soft and hard resets, as well as re-installing the programs and my computer still won't recognize either signal (wifi or dial-up), so I'm sunk. I do work for a 500 company, so it could be a block that my IT department has set up, but I have not yet asked them for assistance as I don't like to use them very often for personal problems.

Again, I appreciate any consideration in to helping me on this matter. Thanks.

0

Share this post


Link to post
Share on other sites

I tether the connection to my PC< then use the connection for my Xbox 360....

Just use method above, and Bridge connections with your ethernet connection and assign an IP ON the XBOX....

0

Share this post


Link to post
Share on other sites

How to: Get Wifi Tethering working on the Verizon Omnia I910

**** If you have installed any other ICS files before you will need to do a hard reset. ****

Use the files I have attached.

  1. Download/Install the attached "ICSInstall.CAB" file.
    (You may not need to do 2 - 6 but this is how I got it to work.)
  2. Restart your phone.
  3. Test the install by Connecting the USB cable to your computer.
  4. Then run "IntShrUI" from the Programs Menu and select "Connect".
  5. If done correctly the program should display "Connected".
  6. Now select "Disconnect" and disconnect the USB cable.
  7. Download/Install the attached "WMWifiRouter91.CAB" file.
  8. Restart your phone.
  9. Turn on Wifi.
  10. Run WMWifiRouter from the Programs Menu.
  11. Select "Connect"
  12. If done correctly the program should display "Connected to WMWifiRouter Ready".
  13. From your computer search for the "WMWifiRouter" wireless connection.
  14. Now have fun surfing the web from anywhere.
*You may need to restart your phone and repeat steps 10 - 14 a few times to get it to work.

Almost 2 years old and this fix worked. You sir are a the mf'n man! I have been searching for all kinds of things that would work on my omnia, but failed every single time. Getting ready for a long road trip and needed to tether into my laptop and now I can tether and go wifirouter. Can't thank you enough.

0

Share this post


Link to post
Share on other sites

anyone else use this for xbox? it kicks me off every now and then....

0

Share this post


Link to post
Share on other sites

I got this working with wifi (really cool btw), but it would not work with just USB and ICS. The pc saw my omnia and tried to install drivers. What drivers would I need? I have a netbook so the omnia CD wouldn't work (and I don't have it available anyway).

0

Share this post


Link to post
Share on other sites
I got this working with wifi (really cool btw), but it would not work with just USB and ICS. The pc saw my omnia and tried to install drivers. What drivers would I need? I have a netbook so the omnia CD wouldn't work (and I don't have it available anyway).

Make sure ics is installed on device. put device to usb mass storage mode. And connect to computer and yes it will need a couple of usb drivers. On my win7 acer netbook it found drivers through wifi and went fine. Once you can browse device from computer turn off wifi on netbook and run ics on device. settings should be "pc connection : usb" "network connection : broadband access" should be flawless from there. And I don't even have device center or active sync on this machine.

good day.

0

Share this post


Link to post
Share on other sites

See I've used this netbook to connect to the phone for months. It connects fine to browse storage, but when I run ICS it tries to install driver on the netbook and ICS on the phone says check USB connection.

I'll try later when I get home and have real internet, maybe it will find the drivers it needs.

Edit: installed active sync, then I was getting ready to install vzaccess but it worked. Uninstalled activesync and it still works. Must have been a necessary driver in the activesync package somewhere. Dont know dont care!

Edited by clange50
0

Share this post


Link to post
Share on other sites

I was trying the steps above, and unfortunately i only got to step one before i started having problems. I downloaded the first file, saved it in a folder, and as soon as I tried installing it, an error mesage came up, stating

""There is no application associated with"[file name]." Run the application first, then open this file from within the application.""

This error message has come up with a number of other things in the past, however, I really want this to work and so I am trying to find a solution to the problem. Do I have the application in question, or do i have to download it? If I have to, can someone post a link to where I need to download it from?

Also, since the omnia is a smartphone and you basically have to pay for the internet in it, do you have to pay extra for the internet you tether, or is it free? I am going to try to use this tether thingy for Xbox LIVE (which uses quite a bit of data) and i dont want to have a heart attack from sticker-shock when my bill comes in the next month.

thanks!

Edit: P.S.: by "trying the steps above" i mean the steps on post one, just to avoid any confusion.

Thanks again!

Edited by snappyT3
0

Share this post


Link to post
Share on other sites
Make sure ics is installed on device. put device to usb mass storage mode. And connect to computer and yes it will need a couple of usb drivers. On my win7 acer netbook it found drivers through wifi and went fine. Once you can browse device from computer turn off wifi on netbook and run ics on device. settings should be "pc connection : usb" "network connection : broadband access" should be flawless from there. And I don't even have device center or active sync on this machine.

good day.

I can get this to work but only for a short time. It will drop the internet connection, said the server, thus Verizon, has disconnected.

0

Share this post


Link to post
Share on other sites

The link is dead and I can't find this version of WM Wifirouter anywhere else. Can someone upload another link for it. Thanks.

0

Share this post


Link to post
Share on other sites

Can anyone who has the ICS cab and free WMWifiRouter cabs please post them? I would greatly appreciate it. Thanks.

0

Share this post


Link to post
Share on other sites
Here ya go... :huh:

Thanks I appreciate it. But everytime I try to connect now it says "cannot connect for unknown reason.." It occurs right when ICS starts up. I have tried just connecting ICS by itself thru USB and same error. I used to use ICS and WifiRouter all the time no problem, now can't connect.

I think its something with my Verizon connection settings, but it dials 777 and seems fine, any suggestions? Thanks.

0

Share this post


Link to post
Share on other sites
Thanks I appreciate it. But everytime I try to connect now it says "cannot connect for unknown reason.." It occurs right when ICS starts up. I have tried just connecting ICS by itself thru USB and same error. I used to use ICS and WifiRouter all the time no problem, now can't connect.

I think its something with my Verizon connection settings, but it dials 777 and seems fine, any suggestions? Thanks.

Uninstalled a few programs. Reinstalled these 2 files. Works now. Thank you!

0

Share this post


Link to post
Share on other sites

Hi,

I'm using Windows 7 32bit.

I got it tethering on Windows XP (Thats how I am online right now :huh:)

But when using Windows 7 and the drivers Windows Update gives me I press connect on the phone and it'll connect then all of a sudden disconnect.

Anybody have any experience with this issue? I've tried running in all compatibility modes and admin mode and still no luck.

Thank you

0

Share this post


Link to post
Share on other sites

So yeah. Omnia II tethering is just strange for me.

I've installed the two files above in post 387, and followed the instructions. I'm able to connect just fine to a Win7 64-bit and Vista 64-bit via Wifi. It connects fairly quickly with decent speed.

I'm unable to get either to fully connect via USB through ICS. It connects just fine, but will not resolve to the internet to allow browsing. It even asks me what type of network, Home, Office, Public it is, but just gives me that little red X right before Internet. Any ideas?

WIFI will not work while plugged in usb so I'm draining the battery like crazy. I suppose I could wall charge while I wifi, but then the access is totallyu unsecured. I cant find anywhere to enable WEP.

I haven't tried BT yet, but I dont have BT on either of these machines.

EDIT: Did a hard reset and set everything up again (didn't have a good backup available)

Making incremental backups as I go.

I was successful with the USB tethering. Next I'll try adding Wifi and seeing if it breaks the USB. Hopefully.

Edited by Rippleeffect
0

Share this post


Link to post
Share on other sites
Uninstalled a few programs. Reinstalled these 2 files. Works now. Thank you!

I had the same problem with the loss of connection...Do you remember what programs you uninstalled? The only programs I have in my add/remove program list are: Google Search; Opera Software Opera Mobile 10; and OZ Communications Inc. Mobile Email (Verizon's Mobile Email program).

Thanks for any tips!

0

Share this post


Link to post
Share on other sites

Thank's a lot. Works great!!! But what about the security? Does anyone knows how to configure it?

0

Share this post


Link to post
Share on other sites

Hello all,

Just wanted to chime in my experience with the procedure here so far. I just needed a USB tethering option so I only installed the ICS cab file listed in this thread. So far it has worked pretty well. The only issue I have really encountered is that the connection can be sporadic at times. I'll have yet to test it in a full-bar coverage area, so that may be the issue.

What happens is the connection will connect but then drop after a min or two, sometimes after a few seconds. So either it's a signal issue or some sort of other issue. I have gotten the "remote party has ended the connection" error once or twice, but I have gotten that error even when just using the phone normally (built-in opera browser) so I'm not too worried about that.

One thing to note is that as soon as the connect drops and ICS says to hit connect again... the phone is automatically recognized with an autoplay prompt (browse files/play videos/view pictures/etc). I set the phone up as a mass storage device, perhaps i'll set it back to active sync.

Anyways, thank-you all for this cool work-around. It has definitely helped me. Hope everyone can find a happy medium of performance vs stability. Good luck and thanks again OP and contributing users.

-WiFi_Sailor

Edit: I'm using a samsung i910 with the "after lawsuit verizon" gps enabled rom.

Edited by WiFi_Sailor
0

Share this post


Link to post
Share on other sites

How to: Get Wifi Tethering working on the Verizon Omnia I910

**** If you have installed any other ICS files before you will need to do a hard reset. ****

Use the files I have attached.

  1. Download/Install the attached "ICSInstall.CAB" file.
    (You may not need to do 2 - 6 but this is how I got it to work.)
  2. Restart your phone.
  3. Test the install by Connecting the USB cable to your computer.
  4. Then run "IntShrUI" from the Programs Menu and select "Connect".
  5. If done correctly the program should display "Connected".
  6. Now select "Disconnect" and disconnect the USB cable.
  7. Download/Install the attached "WMWifiRouter91.CAB" file.
  8. Restart your phone.
  9. Turn on Wifi.
  10. Run WMWifiRouter from the Programs Menu.
  11. Select "Connect"
  12. If done correctly the program should display "Connected to WMWifiRouter Ready".
  13. From your computer search for the "WMWifiRouter" wireless connection.
  14. Now have fun surfing the web from anywhere.
*You may need to restart your phone and repeat steps 10 - 14 a few times to get it to work.

This also works like a charm for People on the Sasktel ( Bell ) network in Canada, great stuff thank you very much! =D

We don't even have the option of paying for the Internet Sharing service so this is just awesome!

0

Share this post


Link to post
Share on other sites

Thanks for the post. I followed the simple instructions and got my Omnia I910 providing Internet to my Motorola Xoom and my Dell Inspiron E1505. It works with WiFi and Bluetooth. I've tested it from as far as 75 feet away and was able to stream YouTube videos. Thanks!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.