• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[FIXED 12-5-08!!]Tethering on the I910 Verizon Omnia?

396 posts in this topic

Posted · Report post

How to: Get Wifi Tethering working on the Verizon Omnia I910

Use the files I have attached.

  1. Download/Install the attached "ICSInstall.CAB" file.
    (You may not need to do 2 - 6 but this is how I got it to work.)
  2. Restart your phone.
  3. Test the install by Connecting the USB cable to your computer.
  4. Then run "IntShrUI" from the Programs Menu and select "Connect".
  5. If done correctly the program should display "Connected".
  6. Now select "Disconnect" and disconnect the USB cable.
  7. Download/Install the attached "WMWifiRouter91.CAB" file.
  8. Restart your phone.
  9. Turn on Wifi.
  10. Run WMWifiRouter from the Programs Menu.
  11. Select "Connect"
  12. If done correctly the program should display "Connected to WMWifiRouter Ready".
  13. From your computer search for the "WMWifiRouter" wireless connection.
  14. Now have fun surfing the web from anywhere.
*You may need to restart your phone and repeat steps 10 - 14 a few times to get it to work.

That worked perfectly. How the heck did you find the right ICS file to use. I've used several from XDA and couldn't get either one of them to work.

0

Share this post


Link to post
Share on other sites

Posted · Report post

That worked perfectly. How the heck did you find the right ICS file to use. I've used several from XDA and couldn't get either one of them to work.

Hey is this Dikiem from HowardForums?

I got it from a friend that got ICS working on his Touch Pro over at PPCGeeks.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Nice work OctaneMS, glad to see this working. I typed my previous message from my i910. I was using the ICS cab file previously posted with the newest version of WMWiFiRouter, so I'm unsure of weather it was the ICS file, or maybe the security settings of the WMWiFi. I believe after looking farther into it, it was the cab file itself as I could never get it to actually display "connected", would only create a network of PCs but not connected to the data cellular connection. We certainly appreciate your contribution, as many people will benefit from it! Thanks!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Tried this on my Samsung i910 and while it appeared to connect to my Vista laptop, I couldn't get an internet connection. I quit the router program, turned off wifi and did a soft reset on my Omnia, but now my 'turn on wifi' button does not work. Any idea why this would happen and how do I fix it?

0

Share this post


Link to post
Share on other sites

Posted · Report post

So how do i turn the wi-fi off once i run WMWifi? Its draining my battery!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Tried this on my Samsung i910 and while it appeared to connect to my Vista laptop, I couldn't get an internet connection. I quit the router program, turned off wifi and did a soft reset on my Omnia, but now my 'turn on wifi' button does not work. Any idea why this would happen and how do I fix it?

If you have tried other versions of ICS you many have caused a problem. You will need to do a hard reset and start all over. Be prepared to lose all your settings and installs. Only use the files I list above.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have followed the above directions and downloaded the 2 files. tried hooking up tp laptop with usb cable sharing was fine. when i run wmwifirouter it starts ok, but stops at screen says connected wlan is on! waiting for ics. any help would be appreciated. thanks, pajer

0

Share this post


Link to post
Share on other sites

Posted · Report post

I was able to successfully download and install the ics program but my i910 won't allow me to install the wmwifirouter program. has anyone else gotten this error while trying to install to the device?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I was able to successfully download and install the ics program but my i910 won't allow me to install the wmwifirouter program. has anyone else gotten this error while trying to install to the device?

I have no problem isntalling it. Only to uninstall it, it won't let me. So I can't reinstall it without hardreset : (

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have followed the above directions and downloaded the 2 files. tried hooking up tp laptop with usb cable sharing was fine. when i run wmwifirouter it starts ok, but stops at screen says connected wlan is on! waiting for ics. any help would be appreciated. thanks, pajer

Sounds like you have problem with the ICS install. Try a hard reset and install again.

0

Share this post


Link to post
Share on other sites

Posted · Report post

So how do i turn the wi-fi off once i run WMWifi? Its draining my battery!

---------------------

Everything worked great for me, thanks for your help!!!

Somedude, there are a few different ways to turn off Wifi, if you are using the Samsung widget, on the today screen there is a Wireless Manager widget, pull that to the main screen and there is a very easy to use on off button for wifi, bluetooth and the phone.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

---------------------

Everything worked great for me, thanks for your help!!!

Somedude, there are a few different ways to turn off Wifi, if you are using the Samsung widget, on the today screen there is a Wireless Manager widget, pull that to the main screen and there is a very easy to use on off button for wifi, bluetooth and the phone.

Ive tried that, but when i drag the widget out and click on "Wi-fi On" nothing happens and wifi stays on.

Edited by somedude
0

Share this post


Link to post
Share on other sites

Posted · Report post

I am tethered on my laptop from my i910 omnia thanks guys for this great tool!!!! freeee wifi tethering!!!!

0

Share this post


Link to post
Share on other sites

Posted · Report post

This worked great. One thing though...

Since WIFI sucks battery life like crazy, how do I get it to work with USB cable still connected to it, but still use the exact same functionality (dont want to use through USB, but to use USB to charge phone)?

0

Share this post


Link to post
Share on other sites

Posted · Report post

This worked great. One thing though...

Since WIFI sucks battery life like crazy, how do I get it to work with USB cable still connected to it, but still use the exact same functionality (dont want to use through USB, but to use USB to charge phone)?

Nevermind, got it to work.

By the way the later version of WMWIFI does a lot of neat things! Including stronger security!!!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Ive tried that, but when i drag the widget out and click on "Wi-fi On" nothing happens and wifi stays on.

If you go to settings and then power and enable power saving on the wifi, then you can turn it off

0

Share this post


Link to post
Share on other sites

Posted · Report post

I was wondering if anyone found the answer to this. I get this "wlan is on waiting for ics" on my omnia and in my laptop i get connected with little or no connectivity. I don't know what I did wrong, I followed the instructions and downloaded the same files on the post before.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I use June Fabrics PDA net. It's only $30 and works on any WinMo phone, plus I can tether over bluetooth as well as cabled, make /receive phone calls while it is tethered and it auto-connects when I wire my phone. Its a pretty cool product for the price. Anyway, just thought I'd add my 2 cents.

Blake

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I have been using this tethering fix for a couple days now. Everything has been working great. I did a soft reset this evening and when the phone came back on, Wifi is not able to be enabled. When i opened up the Wireless Manager, Wifi isn't even listed.

The tethering still works through the USB cable. Nothing else has been changed with the phone since i did the install. Has anyone else had this problem?

Update: after soft resetting like 9 times, Wifi came back...

Edited by bwonish
0

Share this post


Link to post
Share on other sites

Posted · Report post

Many thanks for the info!

I tried it last nite and it worked like a charm!

Does anyone know if you get a more reliable/faster speeds when connected by cable?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

so i was all excited about seeing that tethering was working for everyone and ready to install it. Got ICS working fine. was able to connect and share internet via USB. great!, then i had to greedy and try to install wmwifirouter. everytime i try to install i get "Jorri Jongma WMWifiRouter cannot be installed" tried installing in device and tried installing in /my storage. tried a few soft resets. any ideas? thanks

UPDATE: Able to connect and tether via bluetooth using ics. so not really need for the wifi (still haven't got wmwifirouter installed), unless using with wifi connection is faster than the bluetooth. i just wanted to make sure i could connect with or with the usb connection.

Edited by Omnia_Chief
0

Share this post


Link to post
Share on other sites

Posted · Report post

so i was all excited about seeing that tethering was working for everyone and ready to install it. Got ICS working fine. was able to connect and share internet via USB. great!, then i had to greedy and try to install wmwifirouter. everytime i try to install i get "Jorri Jongma WMWifiRouter cannot be installed" tried installing in device and tried installing in /my storage. tried a few soft resets. any ideas? thanks

UPDATE: Able to connect and tether via bluetooth using ics. so not really need for the wifi (still haven't got wmwifirouter installed), unless using with wifi connection is faster than the bluetooth. i just wanted to make sure i could connect with or with the usb connection.

I get exactly the same error. Since I received the phone from Verizon, I've installed nothing on it except a registry editor (PHM) and ICS. BTW, ICS works beautifully over USB, thanks so much! Would love to get the WiFi working tho

0

Share this post


Link to post
Share on other sites

Posted · Report post

I get exactly the same error. Since I received the phone from Verizon, I've installed nothing on it except a registry editor (PHM) and ICS. BTW, ICS works beautifully over USB, thanks so much! Would love to get the WiFi working tho

just FYI, isc will also work over bluetooth if you want a wireless connection.

0

Share this post


Link to post
Share on other sites

Posted · Report post

so does this process just use data? so my email and web payment would cover unlimited use of tethering? im on verizon using an i910, thanks in advance.

0

Share this post


Link to post
Share on other sites

Posted · Report post

so does this process just use data? so my email and web payment would cover unlimited use of tethering? im on verizon using an i910, thanks in advance.

if you have an unlimited data plan, then yes it would cover this. just don't tell Big Red that you are tethering.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.