Site Notice - We are currently investigating an issue with missing download links. Apologies for any inconvenience caused. PaulOBrien

  • Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

sms incoming msg timestamp is wrong

15 posts in this topic

Posted · Report post

i got an issue with my wm6.1 (htc rom) htc tytn ii (aka kaiser, aka kais100, aka att tilt, aka i'm sure its got more codenames by now.. sigh lol) anywho,

the problem is that incoming sms text messages have a timestamp from 4 hours ago

i have tried hard reset, configuring the regional/timezone settings, and have installed the microsoft dst timezone patch. also there was a settings regarding the registry i read on the xda forums which was supposed to make it ignore network provider timezone for the phone (i forget the reg key, xda forums is not loading for me now...)

on htc's web site there is a new rom update for the att tilt. its still wm6.1 but probably with some bug fixes, drivers, patches, etc. not sure if it will work on my htc kaiser.... if it does it will also delete some built-in apps which the att rom doesnt have but the htc does include...

i called htc support and was quickly told it was a network issue. i'm using rogers wireless in canada on the gsm network. i called them and they said they wont support it since its an htc branded unlocked gsm pda. so now i'll be calling htc back again to argue the point with them.

i'm waiting for my old sony ericson to charge so i can switch the sim then test sms msg on it. i would assume it will work. i've gone through 4 unlocked gsm phones with rogers and only until the htc kaiser did i have an issue with sms timestamp. so i think it isn't a network issue. cus apparently rogers wont do s*** about it cus its unlocked non-rogers brand.

sry if i sound angry lol. but any help would be appreciated. i hate talkin to tech support. they do nothing most of the time but come up with excuse for not helping lol

any suggestions? :-)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Have you checked the person sending you the SMS has the time set correctly on their handset?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Have you checked the person sending you the SMS has the time set correctly on their handset?

i havent checked but i would assume that they do have correct times on their own phones. plus this issue happens with anyone sending me a text msg. i tried also sending txt msg to myself via windows live messenger, same issue. i dont think the problem has to do with other devices. cus for example if i got a text msg from china (i'm in canada), the txt msg would (should) show a recieved time in my local timezone. not from china lol. at least thats my understanding of the issue.

my guess... its a registry problem somewhere.... for wm, everything is a registry problem!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Heh, usually yes. It is strange that it's affecting all messages but I seem to remember hearing the same thing HTC are saying, that it's a network issue. In fact, I thought sms timestamps were set by the receiving SMSC? A quick test here would seem to imply that.

Not saying it isn't necessarily a handset problem though :rolleyes:

0

Share this post


Link to post
Share on other sites

Posted · Report post

Heh, usually yes. It is strange that it's affecting all messages but I seem to remember hearing the same thing HTC are saying, that it's a network issue. In fact, I thought sms timestamps were set by the receiving SMSC? A quick test here would seem to imply that.

Not saying it isn't necessarily a handset problem though :rolleyes:

hmm i dont know. i really dont. but i'm reading up on it - http://www.developershome.com/sms/sms_tutorial.asp?page=smsc

i wish i had another phone right now just to test. but if memory serves me right, sms timestamps were working fine on a 7290 blackberry and a nokia i had a few months ago. same number, same sim. but i guess a few months ago doesnt mean now...

rogers wireless tech said he could "reset" my wireless account. dont know what that means.... but it didnt work

0

Share this post


Link to post
Share on other sites

Posted · Report post

found the fix on the xda forums.

FIX: You need to add this to the registry: Go to HKEY_LOCAL_MACHINE\SOFTWARE\OEM\PhoneSetting\

Add a dword key "TrustTimeZoneField" and give it a dword value of 0

http://forum.xda-developers.com/showthread.php?t=374956

funny, their forum was down a min ago. then it came back up, i searched it, found that, tried the reg tweak, tested and it worked. now their forum is down again for me... shame. i hope their servers r ok after today

from my reading on that post it seems the issue is in regards to the rogers network giving out the wrong timezone settings, and the wm devices just accepting it without checking. god i hate rogers. also hate microsoft. but i love my tytn ii....... hate my tytn ii..... no no love my tytn ii.... sigh i cant decide....

0

Share this post


Link to post
Share on other sites

Posted · Report post

Heh, so a combination of both network and WinMo issues! Glad you got it sorted :rolleyes:

0

Share this post


Link to post
Share on other sites

Posted · Report post

Heh, so a combination of both network and WinMo issues! Glad you got it sorted :rolleyes:

That registry fix did not work for me on my EPiX on the Rogers network

I did not have the OEM key or the phonesetting key so I added them, then TrustTime DWORD, rebooted and still off by 5 hours.....did I miss something or am I doing it worng?

thanks

J

0

Share this post


Link to post
Share on other sites

Posted · Report post

No one has any ideas?

Not even the usual smart a$$ "your a noob?"

Its really annoying me, such a small thing as a time stamp but damn annyoing!!!

0

Share this post


Link to post
Share on other sites

Posted · Report post

thanks so much!!! I have a touch pro 2 bought unlocked and was starting to loose hope. It worked perfectly! :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

found the fix on the xda forums.

FIX: You need to add this to the registry: Go to HKEY_LOCAL_MACHINE\SOFTWARE\OEM\PhoneSetting\

Add a dword key "TrustTimeZoneField" and give it a dword value of 0

http://forum.xda-developers.com/showthread.php?t=374956

funny, their forum was down a min ago. then it came back up, i searched it, found that, tried the reg tweak, tested and it worked. now their forum is down again for me... shame. i hope their servers r ok after today

from my reading on that post it seems the issue is in regards to the rogers network giving out the wrong timezone settings, and the wm devices just accepting it without checking. god i hate rogers. also hate microsoft. but i love my tytn ii....... hate my tytn ii..... no no love my tytn ii.... sigh i cant decide....

Anyone got this fix to work on Samsung Omnia device???

those registry folders (OEM\PhoneSetting) dont seem to exist on my phone.

Cab file registred those values, but with no successful result.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Anyone got this fix to work on Samsung Omnia device???

those registry folders (OEM\PhoneSetting) dont seem to exist on my phone.

Cab file registred those values, but with no successful result.

Hi, I have the same issue - Omnia II device. Can't find the registry folders OEM\PhoneSettings

Appreciate any help to resolve this timestamp issue please..

Thanks!

Btw, am with Petro Canada Mobility which I believe belongs to Rogers too.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi, I have the same issue - Omnia II device. Can't find the registry folders OEM\PhoneSettings

Appreciate any help to resolve this timestamp issue please..

Thanks!

Btw, am with Petro Canada Mobility which I believe belongs to Rogers too.

I am with Fido Canada, having Omnia 2, same problem here

0

Share this post


Link to post
Share on other sites

Posted · Report post

I am with Fido Canada, having Omnia 2, same problem here

Same thing here, rogers canada + omnia 2. Haven't been able to find a fix that actually works.

0

Share this post


Link to post
Share on other sites

Posted · Report post

hmm i dont know. i really dont. but i'm reading up on it - http://www.developershome.com/sms/sms_tutorial.asp?page=smsc

i wish i had another phone right now just to test. but if memory serves me right, sms timestamps were working fine on a 7290 blackberry and a nokia i had a few months ago. same number, same sim. but i guess a few months ago doesnt mean now...

rogers wireless tech said he could "reset" my wireless account. dont know what that means.... but it didnt work

Thanks for sharing the link!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.