• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Fixing bluetooth audio routing for i900

317 posts in this topic

Posted

finelly its work !!!

i have installed the shank's room, and it didnt work

but my rom was dx5, so i decide to reinstall iliads rom on it,

i was afraid, because earlier i tried it, and it f.k my i900

but all thing gone great

i installed voice command, connet the bluetooth set, and says "what time is it" in french, and i hear "il est 01:15" in the bluetooth set

whaou, one month later i did it,

so thank you iliad, and other supporter how help me in my story.

now ill enjoy it before trying something else.

0

Share this post


Link to post
Share on other sites

Posted

I'm still waiting for your fix the waken up bug.

I tried other ROMs but, I prefer yours.

Somehow my HS (SE HBH-IV840) works best with your ROM.

Thanks

0

Share this post


Link to post
Share on other sites

Posted

using Omnia TouchFlo2D build 21193 (22 March 2009) and no wake up bug & works like it should... to all concerned you have made my i900 the way i required with the BT working as it should ... thanks to you B) ... shame Samsung for leaving us i900 users out in the cold :(

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi All, can anyone please redirect me to a final rom link, from where I can download the all working version for BT headset problem. It would be great if someone can send me step by step procedure for flashing this particular rom. I will flashing rom for the first time.

One more question, will I be able to listen to radio wirelessly using BT stereo headset with this rom?

Waiting for your responses.

Can you guys help me out for installing this custom rom.

Edited by milind yande
0

Share this post


Link to post
Share on other sites

Posted

Has anyone actually got Voice dial to activate when I press the button on my bluetooth device? I using Shoakka's 15M with BT ROM

I have installed Jetaware and Cyberon VD. But it still needs me to initiate the Cyberon VD from my device. When I click the bluetooth button, it still just opens my phone dialer.

Is it that the entire thread is dedicated to MS Voice commander?

Regards

0

Share this post


Link to post
Share on other sites

Posted

Has anyone actually got Voice dial to activate when I press the button on my bluetooth device? I using Shoakka's 15M with BT ROM

I have installed Jetaware and Cyberon VD. But it still needs me to initiate the Cyberon VD from my device. When I click the bluetooth button, it still just opens my phone dialer.

Is it that the entire thread is dedicated to MS Voice commander?

Regards

Work good. Cyberon VD + Motorola H505 headset what I have. By the Jetware Advanced options must be the Voice dialing enabled, all another disabled. For the first pressing do nothing, but the second press it came VC, and hear on the headset a ping. Sory for my bad indian english.

0

Share this post


Link to post
Share on other sites

Posted

Please provide an installable cab file for this fix for users. Thank you!

0

Share this post


Link to post
Share on other sites

Posted

Please provide an installable cab file for this fix for users. Thank you!

Unfortunately the BT fixes can only be cooked in as it involves replacing drivers etc which are in use...

0

Share this post


Link to post
Share on other sites

Posted

Unfortunately the BT fixes can only be cooked in as it involves replacing drivers etc which are in use...

So, you arent developers?

0

Share this post


Link to post
Share on other sites

Posted (edited)

so, Taril, you not funny bro...if you can only ask these type of silly pointless questions in others threads, then please dont bother. Shall i do it to you??

We are clearly not developers, We are people who make stuff happen and try to better ourselves.

You must be a developer? Or you wouldnt post remarks like this.

Maybe if you are a developer, you could help us and other here instead of posting stuff like this. I seen you do it a few times. I was gonna PM u bout it bro, but i cant remove your post and neither can you.

Please show some respect to what people do here (or try to do). You obviously think better of yourself than us, or you wouldnt even post such remarks.

Not happy bro!

In addition, as you probably already know..a cab cannot be made for this as we change files that dont fully exist in the finished product. Which you know, so please dont try to make others look stupid by asking them to do something that you already know cannot be done.

Edited by shokka9
0

Share this post


Link to post
Share on other sites

Posted

so, Taril, you not funny bro...if you can only ask these type of silly pointless questions in others threads, then please dont bother. Shall i do it to you??

We are clearly not developers, We are people who make stuff happen and try to better ourselves.

You must be a developer? Or you wouldnt post remarks like this.

Maybe if you are a developer, you could help us and other here instead of posting stuff like this. I seen you do it a few times. I was gonna PM u bout it bro, but i cant remove your post and neither can you.

Please show some respect to what people do here (or try to do). You obviously think better of yourself than us, or you wouldnt even post such remarks.

Not happy bro!

Oh. Am sorry for pissed you up.

0

Share this post


Link to post
Share on other sites

Posted

Hi All, can anyone please redirect me to a final rom link, from where I can download the all working version for BT headset problem. It would be great if someone can send me step by step procedure for flashing this particular rom. I will flashing rom for the first time.

One more question, will I be able to listen to radio wirelessly using BT stereo headset with this rom?

Waiting for your responses.

Can you guys help me out for installing this custom rom.

0

Share this post


Link to post
Share on other sites

Posted

i have 2 ROMs with the BT fix...look for my SHK15bM (in my kitchen - see signature)

Also SHK15bL - LITE rom found in the my LITE ROM thread here.

Look in the ROM Discussion page, both on the first page too!

0

Share this post


Link to post
Share on other sites

Posted

Just wanted to let know that i *somehow* managed to get it "working" without a reflash.

1) Renamed the dlls (e.g. add "k" in front of name so "touch.dll" becomes "ktouch.dll" and so on)

1) Signed the dlls with a privileged certifacte

2) imported the certificate

3) copy the dlls to \windows

4) Modified the reg in HKLM\Drivers\Builtin to point to the new dlls

5) Modified the reg in HKLM\HARDWARE\Touch to point to the new ktouch.dll

6) Imported the rgu as reg file

7) did a soft-reset

The drivers did load an even the touchscreen was usable (you can check which drivers were loaded with e.g. FDJ TaskManager (tag devices))

So it seems to work.

I think you did the following 2 things wrong when trying to replace the files

1) they were not signed

2) you can't replace the existing drivers because they are in the ROM but you can of course copy additional drivers to \windows B)

I currently have no time to do further testing (business trip) but if anyone wants to test it, i attached the following 2 files:

1) _gps-signtool-xdadev.zip => from XDA Devs. Just copy the dlls in the sign dir, rename them and use "sign.bat <dllname>" IMPORTANT: You should open a command line and navigate to the sign dir and then execute sign.bat. Otherwise it won't work

2) Trusted_Cert.cab => The trusted certificate. Just copy over to Omnia and install

IMPORTANT: Before trying this install MyMobiler. So in case the new touch.dll can't be loaded correctly and the screen isn't responding just connect via ActiveSync and revert the reg key via MyMobiler which works :( - so no hard-reset necessary

Happy testing.

PLEASE DON'T COMPLAIN IF YOU BRICKED YOUR PHONE WITH THAT. IT'S JUST AN IDEA. I ACCEPT NO RESPONSIBILITY IN ANY FORM.

TRY IT AT YOUR OWN RISK!!!

_gps_signtool_xdadev.zip

Trusted_Cert.cab

0

Share this post


Link to post
Share on other sites

Posted

Excellent findings gemx.

Will test as soon as possible.

And... if all goes well, taril's dream of an installable cab may not be far off. Ouch!

Just wanted to let know that i *somehow* managed to get it "working" without a reflash.

1) Renamed the dlls (e.g. add "k" in front of name so "touch.dll" becomes "ktouch.dll" and so on)

1) Signed the dlls with a privileged certifacte

2) imported the certificate

3) copy the dlls to \windows

4) Modified the reg in HKLM\Drivers\Builtin to point to the new dlls

5) Modified the reg in HKLM\HARDWARE\Touch to point to the new ktouch.dll

6) Imported the rgu as reg file

7) did a soft-reset

The drivers did load an even the touchscreen was usable (you can check which drivers were loaded with e.g. FDJ TaskManager (tag devices))

So it seems to work.

I think you did the following 2 things wrong when trying to replace the files

1) they were not signed

2) you can't replace the existing drivers because they are in the ROM but you can of course copy additional drivers to \windows B)

I currently have no time to do further testing (business trip) but if anyone wants to test it, i attached the following 2 files:

1) _gps-signtool-xdadev.zip => from XDA Devs. Just copy the dlls in the sign dir, rename them and use "sign.bat <dllname>" IMPORTANT: You should open a command line and navigate to the sign dir and then execute sign.bat. Otherwise it won't work

2) Trusted_Cert.cab => The trusted certificate. Just copy over to Omnia and install

IMPORTANT: Before trying this install MyMobiler. So in case the new touch.dll can't be loaded correctly and the screen isn't responding just connect via ActiveSync and revert the reg key via MyMobiler which works :( - so no hard-reset necessary

Happy testing.

PLEASE DON'T COMPLAIN IF YOU BRICKED YOUR PHONE WITH THAT. IT'S JUST AN IDEA. I ACCEPT NO RESPONSIBILITY IN ANY FORM.

TRY IT AT YOUR OWN RISK!!!

0

Share this post


Link to post
Share on other sites

Posted

Just wanted to let know that i *somehow* managed to get it "working" without a reflash.

1) Renamed the dlls (e.g. add "k" in front of name so "touch.dll" becomes "ktouch.dll" and so on)

1) Signed the dlls with a privileged certifacte

2) imported the certificate

3) copy the dlls to \windows

4) Modified the reg in HKLM\Drivers\Builtin to point to the new dlls

5) Modified the reg in HKLM\HARDWARE\Touch to point to the new ktouch.dll

6) Imported the rgu as reg file

7) did a soft-reset

The drivers did load an even the touchscreen was usable (you can check which drivers were loaded with e.g. FDJ TaskManager (tag devices))

So it seems to work.

I think you did the following 2 things wrong when trying to replace the files

1) they were not signed

2) you can't replace the existing drivers because they are in the ROM but you can of course copy additional drivers to \windows B)

I currently have no time to do further testing (business trip) but if anyone wants to test it, i attached the following 2 files:

1) _gps-signtool-xdadev.zip => from XDA Devs. Just copy the dlls in the sign dir, rename them and use "sign.bat <dllname>" IMPORTANT: You should open a command line and navigate to the sign dir and then execute sign.bat. Otherwise it won't work

2) Trusted_Cert.cab => The trusted certificate. Just copy over to Omnia and install

IMPORTANT: Before trying this install MyMobiler. So in case the new touch.dll can't be loaded correctly and the screen isn't responding just connect via ActiveSync and revert the reg key via MyMobiler which works :( - so no hard-reset necessary

Happy testing.

PLEASE DON'T COMPLAIN IF YOU BRICKED YOUR PHONE WITH THAT. IT'S JUST AN IDEA. I ACCEPT NO RESPONSIBILITY IN ANY FORM.

TRY IT AT YOUR OWN RISK!!!

Didn´t work for me in a IA5 rom. The touch panel and sound didn`t work. I can revert without problem with mymobiler. I did all the steps with the dll of the first page of the thread, any idea?

Thanks

0

Share this post


Link to post
Share on other sites

Posted

Sorry I didn't post for so long.. Been busy :(

Just wanted to let know that i *somehow* managed to get it "working" without a reflash.

...

gemx - that's great !

I was actually thinking this might work, but didn't get to it..

It'll make my attempts of patching the audio driver dll much easier.

I'll try to find the time this week to make a cab out of this. That is, unless someone beats me to it B)

0

Share this post


Link to post
Share on other sites

Posted

Hi am new to the i900 and use to using a treo 750 with MVC running smoothly. I am not experienced enough to do all of the things I am reading about, just confuses me to even think about it but I really need the bluetooth capabilities for the phone. I downloaded the cab files for Cyberon Voice and Jetware but here comes the stupid question. Since they are cab files how do I load them into the phone? After they are unzipped I am unsure where to put them. Sorry for the stupid questions but would love to try and see if this works for me. Any help would be appreciated. I have just been searching the internet for solutions to the bluetooth problem and found this forum.

0

Share this post


Link to post
Share on other sites

Posted

Sorry I didn't post for so long.. Been busy :(

gemx - that's great !

I was actually thinking this might work, but didn't get to it..

It'll make my attempts of patching the audio driver dll much easier.

I'll try to find the time this week to make a cab out of this. That is, unless someone beats me to it B)

Thanks for your ongoing efforts on fixing the Bluetooth problem. This issue of voice command is my only real issue with my Omnia and I don't really want to flash the rom to fix this if there is a possibility of an installable CAB which could get that functionality operating correctly.

0

Share this post


Link to post
Share on other sites

Posted (edited)

post to delete

Edited by swatop
0

Share this post


Link to post
Share on other sites

Posted

Found a solution

Would you please be so kind to enlighten us then? B)

0

Share this post


Link to post
Share on other sites

Posted (edited)

Sorry , i made an error while posting, i had a problem during the cooking of my rom with the Stevenh's wake up fix, but i finaly found the solution to my problem. sorry again.

But now i realy need your help. I'm using a french rom i900_French_XHHH4.exe

I added the wakeup fix, but when i tried to flash my omnia with the new rom i cooked, the flashing process stops at 3% when it tries to do something with the eboot (downlading or writing, I don't remember).

Could you please tell me if there's a compatibility problem between the wake up fix and this rom.

Thanks in advance and sorry again for my wrong post. :excl: :excl: :excl: :excl:

Edited by swatop
0

Share this post


Link to post
Share on other sites

Posted

I am new here. I have a Scala Rider headset, which has a mono bluetooth connection. With the Omnia phone it works good, but not for the navigation instructions. I have asked Samsung, but they are not yet solving this problem (Dutch helpdesk will ask the product manager). My Rom for PDA is:i900XKHJ3/XKHJ3 for Phone: i900XXHI4. What rom update must I use or should I wait until another solution is available? The last time I did a rom-update using the Samasung method, I briked my phone and had to send it to the service shop.

0

Share this post


Link to post
Share on other sites

Posted

liads, some news on the cab to make all the change simultaneously? ther's a way to fix the bt problem without hardreset?

thanks

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.