• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

How to mount a new Touch panel on OMNIA

787 posts in this topic

Posted · Report post

Munie90... I got some bad news for you.. Just did the research since I also bought one of those.. If you are in Jamaica, you have an I900L and not an I900 or I908. The touch screen is too short for our case... About 1 mm too short.

I bought the housing and screen.. Anybody want a screen and white housing to buy?? or SWAP for an I900L touch screen?

Im dont live in Jamaica i live in st lucia and ordered my omnia i900. Its says omnia i900 not omnia i900L. do you live in jamaica? I want ur screen it should work on mine so...whats the vybe???

0

Share this post


Link to post
Share on other sites

Posted · Report post

I mounted new touchscreen panel and complete housing,everything works great,TS is awesome,but my signal sucks,especially when i hold it with my hand,like the iphone problem...so...ANYBODy have some ideas???

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I mounted new touchscreen panel and complete housing,everything works great,TS is awesome,but my signal sucks,especially when i hold it with my hand,like the iphone problem...so...ANYBODy have some ideas???

the new housing you bought doesn't come with the antenas (gold antenas) to connect to the motherboard... you need to remove them from the original housing and put them into the new housing

Edited by monteiro-ribas
0

Share this post


Link to post
Share on other sites

Posted · Report post

Well, after 2 months it's still the same - much better :)

I don't think so

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi everyone! :)

I need some help with my old touch screen!

someone can give me the link to buy the new touch screen more sensitive? 've found several on ebay, but don´t know what to buy.

(sorry for my bad english)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Just finished installing mine,

I had these instructions: http://www38.zippyshare.com/d/34579888os/1...10/34579888.doc

(From an earlier post, sry cannot remember who)

Which is this as a Doc: http://www.formymobile.co.uk/omniadisassembly.php

You do not need to remove the Camera or the optical sensor, that said it's a good time to clean out all the dust in EVERY Nook & Cranny

I end up putting the optical sensor back on and using to line everything up like this guy dose:

<< Putting it back together

Also the hinge for the contact pad/Tape from the Touch pad, flip it back before you try and put it in other wise you'll find it impossible.

On taking it out I had not noticed it was a hinge as I had just pulled the tape out.

On first boot the screen was back lit but not pic. The Plug & socket style connecter was not connected fully, as it was clicked in but not flat the IC Board.

unplugged, replunged and it went flat

All good, & I'm very happy to have my mob back as I had lost most of the touch in the top havle of the screen.

enjoy

Edited by Axe_2_Gr1nd
0

Share this post


Link to post
Share on other sites

Posted · Report post

Just finished installing mine,

I had these instructions: http://www38.zippyshare.com/d/34579888os/1...10/34579888.doc

(From an earlier post, sry cannot remember who)

Which is this as a Doc: http://www.formymobile.co.uk/omniadisassembly.php

You do not need to remove the Camera or the optical sensor, that said it's a good time to clean out all the dust in EVERY Nook & Cranny

I end up putting the optical sensor back on and using to line everything up like this guy dose:

<< Putting it back together

Also the hinge for the contact pad/Tape from the Touch pad, flip it back before you try and put it in other wise you'll find it impossible.

On taking it out I had not noticed it was a hinge as I had just pulled the tape out.

On first boot the screen was back lit but not pic. The Plug & socket style connecter was not connected fully, as it was clicked in but not flat the IC Board.

unplugged, replunged and it went flat

All good, & I'm very happy to have my mob back as I had lost most of the touch in the top havle of the screen.

enjoy

Looks like I followed a very similar path to Axe_2_Gr1nd, using the same documents but a different youtube video for reference. I decided not to take anything out that didn't have to be touched, so I left the sticker, camera and keyboard/optical sensor well alone. It takes some effort to unstick the old digitizer, but having the new one to hand so you can see how thick it is gives conficence to know exactly where to insert the tool you are using to pry the old one off. I invested a couple of quid in a set of tools from ebay which included two triangular plastic things for separating the case and prying off the digitizer which made the job much easier.

Thanks to all who have posted on this thread. It has definitely rescued my omnia from early retirement. The more I read about Windows Phone 7 the longer I think I will end up keeping the omnia.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Just changed my digitizer for my Omnia, whent fast and easy just followed the tutorials. Now it works really nice no more need for fingernails. Huge difference..

Edited by PJ_Omnia
0

Share this post


Link to post
Share on other sites

Posted · Report post

Yeah I just replaced my digitizer as well. No more dead spots and lag. For some reason this digitizer makes it lag a lot less and the sensitivity and accuracy is ridiculous. I definitely recommend for everyone.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Can anyone tell me how to fix my omnia I900. Got a new screen and digitizer. Phone turns on and after playing with it I got the screen to turn on but then when it goes to sleep the screen remains dark even though the phone is on. How can I get the backlight to turn back on? Not sure how I did it the first time but it was a combo of buttons and the back light turned on. Any ideas. Thanks

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Does anyone know to connect the black FPCB connector?

I just disassembled and reassembled everything, and the only thing I can't get connected is the black FPCB connector(black connector that leads to the top part of the phone, just above the MicroSD slot).

When I try to hold the connector in its place and try to power on the phone, it doesn't do anything. However, when I plug it into the wall charger, it shows me the charging logo on the display.

Could anyone help me with this?

Thanks

Edit: I just managed to power on the phone by holding that connector down while pressing the power button, so atleast my phone still works.

The connector still doesn't snap onto the motherboard, which is really frustrating. I'm sure I was really careful when removing it.

Edited by kekelol0r
0

Share this post


Link to post
Share on other sites

Posted · Report post

Are there any providers for Romania ?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.