Site Notice - We are currently investigating an issue with missing download links. Apologies for any inconvenience caused. PaulOBrien

  • Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

OmniaTMC Beta 2 (and unofficial Beta 3)

470 posts in this topic

Posted (edited) · Report post

Hi!!

After some months from project start, here it is the first public beta release of my TMC kit for i900.

You'll find a CAB file and a PDF document enclosed. Please read the document before installing the kit beacuse there are some steps to be performed before installing the package.

Actually it was tested with iGo only (both 8.0 and 8.3 versions) and I hope to hear some reports from you!

If someone wants to include this kit into its custom rom, I can give standalone exe, dlls and registry specs.

BETA 2 INSTALLATION ISSUES SINCE JAN 2010: the MS SDK certificates used to sign the AdvFMRadio driver expired on december 2009 and therefore BETA 2 isn't installable anymore. The Beta 3 is ready to test, but I don't own the i900 anymore so ... a public unofficial realease (0.9.5.1) is available to anyone willing to test it. Look at page 23 for details.

BETA 2 RELEASED: as usual, if you have a previous version, uninstall it (read the readme file to find how) before installing the new one.

TO EVERYBODY EXPERIENCING GPS/TMC CRASH AFTER FIRST iGO SESSION:

the problem is not related with iGO 8.3.2.64873 (it shows also with later builds) and the solution is to check SYS.txt file.

You have to add/check spell of:

Source="virtlserial"

in [gps] section. Some users have virtserial (missing L). the effect is that iGO (in some way) closes/poweroff/crashes Microsoft GPS mixer leaving it in that state. On the second iGO session TMCSerial is unable to open GPS ports and reports its failure to iGO. Result: iGO shows unavailable TMC (correct behaviour).

Beside OmniaTMC

I started to work with flywhc from xda-developes to supprt his very promising project. The final objective is to have a common and cross platform (HTC and Omnia at the moment, but open for growth) FM/RDS/TMC stack. This would greatly improve the quality and availability of the software (FM radio releted of course) we are going to see.

Take a look at his thread

My personal thanks to the donors:

wkmmx500 (€ 20) ... hey you are in pole postion :excl:

DAlma (€ 10) ... thank you, an extra motivation for Beta 3 :excl:

flywhc (€ 10) ... let's see how to make OmniaTMC become OmniTMC!!!!

amazone (€ 5) ... the first non Omnia donor

To anybody who wants to support OmniaTMC, just click on the image btn_donate_SM.gif

(please also add you nickname to the donation so I can add you on the above list!!!)

OmniaTMC_0_9_4_1.zip

Edited by BeamRider
0

Share this post


Link to post
Share on other sites

Posted · Report post

What is OmniaTMC?

0

Share this post


Link to post
Share on other sites

Posted · Report post

What is OmniaTMC?

http://en.wikipedia.org/wiki/Traffic_Message_Channel

This is a project that's been rumbling on a while to get TMC data from the Omnia's radio chip. A very interesting project too and I am keen to test the fruits of that research. Great work!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Woo hoo! Thanks Beamrider! Going to try it now!!

TMC = Traffic Message Channel. Allows IGO to use the FM receiver to receive TMC broadcasts and therefore traffic situations on your phone.

0

Share this post


Link to post
Share on other sites

Posted · Report post

this is a great application. thank you very much for your effort!

0

Share this post


Link to post
Share on other sites

Posted · Report post

After install and first launch I have no OmniaTMC AdmFMRadio v0.9 interface at log window.. I tried some combination of port and after soft reset I got only "OpemnDevice: FAILURE, Error: The specified network resource of device...."

Installed into memory with non-original ROM...

0

Share this post


Link to post
Share on other sites

Posted · Report post

Anyone know where I can get the developer certs (certs.cab) on the net? been Googling for about 15 mins now with no joy :excl:

thanks!

0

Share this post


Link to post
Share on other sites

Posted · Report post

will this ever worok for the i910?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

After install and first launch I have no OmniaTMC AdmFMRadio v0.9 interface at log window.. I tried some combination of port and after soft reset I got only "OpemnDevice: FAILURE, Error: The specified network resource of device...."

Installed into memory with non-original ROM...

That message comes out when AdvFMRadio is not starting up. Possible causes are:

  • SDK Certs is not installed
  • File AdvFMRadio.dll missing from \Windows
  • Check that "\HKLM\Drivers\Builtin\FMRadio\DLL" registy key is FMRadio.dll (old driver) or AdvFMRadio.dll (new one)

Which ROM are you using? On which firmware is based upon? Was the FM radio working before?

will this ever worok for the i910?

I was discussing that with some i910 users, the FM radio driver of i910 is pretty the same of i900 one and there are good chanches that this will work as is. If someone wants to try, I strongly suggest to backup the device first. If the phone boots after AdvFMDriver activation (and I bet it will), there's 90% probability of everything working fine.

Anyone know where I can get the developer certs (certs.cab) on the net? been Googling for about 15 mins now with no joy :excl:

Use this:

http://rapidshare.com/files/223562328/SDKCerts.cab.html

Edited by BeamRider
0

Share this post


Link to post
Share on other sites

Posted · Report post

Many thanks. Off to the car now to get my headphones so I can have a go!

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

IGO:

IGO keeps saying: "No TMC Hardware found", doesn't matter if I select the port/baudrate or put it to AUTO (I've got Igo v8.3.2.64873, so which protocol/port/baudrate should I use in IGO cz the autodetect doesn't pickup anything.

OmniaTMC:

The program seems to tune to channel 91300 and see I the long list flashing by,

it's using TMC port 4 and GPS port 3 (enabled is RADIO AF RDS)

Protocol = off (greyed out).

Edited by jeffrey2000
0

Share this post


Link to post
Share on other sites

Posted · Report post

IGO:

IGO keeps saying: "No TMC Hardware found", doesn't matter if I select the port/baudrate or put it to AUTO (I've got Igo v8.3.2.64873, so which protocol/port/baudrate should I use in IGO cz the autodetect doesn't pickup anything.

Same on my i910. I can get the app to show the signal, but iGO won't autodetect (crashes) and if I put in the port number manually, still won't show the info.

0

Share this post


Link to post
Share on other sites

Posted · Report post

can it hurts my device? is it dangerous? possible to uninstall? :excl:

0

Share this post


Link to post
Share on other sites

Posted · Report post

IGO:

IGO keeps saying: "No TMC Hardware found", does'nt matter if I select the port/baudrate or put it to AUTO (I've got Igo v8.3.2.64873, so which protocol/port/baudrate should I use in IGO cz the autodetect doesn't pickup anything.

OmniTMC:

The program seems to tune to channel 91300 and see I the long list flashing by,

it's using TMC port 4 and GPS port 3 (enabled is RADIO AF RDS)

Protocol = off (greyed out).

Sorry mate, this happened once to a friend of mine but I wasn't able to reproduce it on my device (my fault to haven't incuded into known bugs) :excl:

To fix this just manually set this segistry key:

"HKLM\Devices\BuiltIn\OmniaTMC\TMCProtocol" to 3

then decativate and reactivate TMCSerial using the tool.

The protocol box should read Royaltek also when greyed out.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I am very excited to see the progress and thanks the developer for this good job.

By the way everything works fine but 'Protocol' stay greyed and 'OFF' and this is probably why IGO do not see any TMC Material.

Any clue how to get 'Royaltek' 's protocol ?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

It seems to be reading data now. What protocol do I set in iGo 8?

EDIT: Never mind, answered above

Edited by 3shirts
0

Share this post


Link to post
Share on other sites

Posted · Report post

can it hurts my device? is it dangerous? possible to uninstall? :excl:

I usually suggest to backup the mobile just because you are installing a low level driver that means if something goes wron (but should go very wrong) you have to perform an hard reset.

This was appening to me (and me only) in a very early driver development stage when I was reverse engineering the original driver. Since the first alpha release to testers, nobody reported any device lock.

During usage the driver doesn't perform any risky operation so, no it won't hurt your device but to your (and my) safety, just make a backup of the device before installing the cab.

In the pdf you'll find the uninstall procedure.

0

Share this post


Link to post
Share on other sites

Posted · Report post

iGo 8 TMC setup is

Royaltek

COM4 (if you used 4 as TMC port)

auto speed (or whatever you like ... the speed doesn't matter)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Sorry mate, this happened once to a friend of mine but I wasn't able to reproduce it on my device (my fault to haven't incuded into known bugs) :excl:

To fix this just manually set this segistry key:

"HKLM\Devices\BuiltIn\OmniaTMC\TMCProtocol" to 3

then decativate and reactivate TMCSerial using the tool.

The protocol box should read Royaltek also when greyed out.

I did this (you made a typo btw, it is Drivers not Devices) but then when I tried to restart TMCSerial it said "GPS ports does not exist"

EDIT: Soft reset resolved it and bingo bango iGo now sees it! Great work with this

Edited by 3shirts
0

Share this post


Link to post
Share on other sites

Posted · Report post

I did this (you made a typo btw, it is Drivers not Devices) but then when I tried to restart TMCSerial it said "GPS ports does not exist"

EDIT: Soft reset resolved it

Yep ... I'm a little bit in a hurry :excl:

Anyway I wrote this workaround on the main topic, it is just happening to a lot of people and I'm starting to understand where the problem is.

0

Share this post


Link to post
Share on other sites

Posted · Report post

It works for me too .... IGO do see the TMC now.

For now i di not get any RDS/TMC message but everything seems to be operational.

Thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

It works for me too .... IGO do see the TMC now.

For now i di not get any RDS/TMC message but everything seems to be operational.

Thanks

Very happy to hear that ... hope you'll find some TMC feed soon

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yeah it all seems to work now I just can't get a signal. I understand Classic FM is the only UK station that TMC is broadcast over and I can't pick that up at work so I'll try in the way home.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I too had to edit the reg to get it working but now it looks like its playing nicely. TMC Setup seems to receive some data at 87.5 Mhz (in the UK) but when I start Igo it can pick up any TMC data. Perhaps I need to try again this evening when on the move and in better signal areas.

Just a few points:

When TMC Setup is running, I can't get to my today screen. It will fill the entire screen unless I launch another app.

Do I have to keep TMC Setup running to use Igo, or can I click "ok" and close it?

Otherwise, my thanks again to you and all the testers that helped put this together - if it saves me from one, just one traffic jam, I shall sing your praises!

0

Share this post


Link to post
Share on other sites

Posted · Report post

I did this (you made a typo btw, it is Drivers not Devices) but then when I tried to restart TMCSerial it said "GPS ports does not exist"

EDIT: Soft reset resolved it and bingo bango iGo now sees it! Great work with this

Yep ... I'm a little bit in a hurry :excl:

Anyway I wrote this workaround on the main topic, it is just happening to a lot of people and I'm starting to understand where the problem is.

Yup got the Protocol: Royaltek now (greyed out) on TMC Port 4 and GPS 3, first got same error and softresetted and accepted the change afterwards but Igo is still not picking up the signal even if I put it manually there. It keeps saying "No TMC hardware not Found".

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.