• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

How to Flash your i900 Omnia phone

288 posts in this topic

Posted

HOW-TO FLASH I900 OMNIA TUTORIAL

=====

First of all for the newbies i would recommend to play a bit with the phone before upgrading. Get to know how your phone and current ROM works.

Please be patient and read again if you don't understand anything. Make sure that you know what you are doing.

I TAKE NO RESPONSIBILITY IF U DAMAGE YOUR DEVICE!

GOOD LUCK!

Important :

Those who then want to make you sure for the safest way of changing the ROM in OMNIA i900 should follow closely (in case) the following steps.

Make sure you:

  • Turned off any Firewall you have on the PC.
  • Not running the update in Safe Mode.
  • Not to perform any other work on your PC.
  • Make sure the phone is fully charged (important)
  • Do not update from a PC where you have limited rights. Eg. Internet Cafe, Work etc.
  • Prefer Laptop as if you have electricity dropped you will have some extra battery and wont harm your phone.
  • Use only one USB port for you Omnia update, the best one it works for you. Do not try multiple.
    1. Make the Install Microsoft ActiveSync 4.5 (once)
    2. Make Install the Samsung Modem Driver XP (once)
    3. Reboot the PC.
    4. After the first 2 steps try to disconnect your Omnia from USB and connect it back on. Repeat it 1-2 times so the PC can recognize the phone.
      Leave the phone connected for about 10-15 minutes. If it disconnects by itself most probably you have to repeat the procedure from 1st step.
      It is advised to reboot your PC also.
    5. Make sure that have backup all your important stuff (contacts, pictures etc).
    6. Switch OFF the phone by holding the Power button for ~5 seconds.
    7. Run the updater. (Works the same way for Original or Cooked ROMs)
    8. Switch ON the phone again by holding the Power button.
    9. Press START and happy flashing. Do not move your phone or the USB wire as it might fail during flashing.
    10. Wait until the updater shows JOB DONE! DO NOT DISCONNECT BEFORE.
    11. Disconnect your phone.
    12. Leave the phone to reboot 2 times, calibrate screen and finish the start-up procedure.
    13. Enjoy the new firmware.
    =====================================================================

    Steps used for updating under VMWare for Windows Vista (32bit & 64bit) / Windows 7 (32bit & 64bit).

    The tutorial is taken from my friend shokka9. Thank you baw$

    If you don't know what VMware is, take a look at http://en.wikipedia.org/wiki/VMware for more information.

    Things you'll need on Vista:

    • VMware Workstation (latest will work)
    • Microsoft Windows XP CD or .ISO image and the serial key
    • 2gb of free disk space
      • Use the ones that mentioned for Windows XP.
      • Make sure you turn off the USB on the Windows Mobile Device Center.

        • Mobile Settings -> Connection Settings -> Untick "Allow USB Connections".
        • After flashing tick it back.

        Let's start:

        [*]First install VMware's Workstation. You can get a trial version at http://www.vmware.com/

        [*]If you have an .ISO image of your Windows XP CD on your hard disk like I do, you won't need the CD, otherwise you'll need it. If you don't have the image, put the CD into your CD/DVD-ROM.

        [*]Run the workstation.

        [*]Go to FILE -> NEW -> VIRTUAL MACHINE and choose TYPICAL. On the next tab select the source from where you want to install a virtual Windows XP operating system (CD or image).

        [*]On the next tab, press next. When the dialog appears, choose YES.

        [*]Now enter a name for your virtual XP machine and choose a location where you want to save the machine - it's good to have at least 2gb of free space!

        [*]On the nex tab, I've chosen 2.5gb. I think that's enough, if you wish only to flash your ROM. You can choose to install the machine to a single file or splitted. I've chosen single.

        [*]On the next tab, click Customize Hardware button and select "USB Controller". Make sure High-Speed USB 2.0 and Auto connect USB devices are checked. Press OK, then press FINISH.

        [*]Maybe you'll get a warning from VMware but don't bother, just skip it.

        [*]The Windows installation process should follow. The installation took on my PC for about 25min.

        [*]When the setup has finished, you can normally run and use Windows XP via WMware.

        [*]Update your XP machine via Windows Update, reboot and start flashing.

        Flashing:

    [*]Make the Install Microsoft ActiveSync 4.5 (once)

    [*]Make Install the Samsung Modem Driver XP (once)

    [*]Reboot the PC.

    [*]After the first 2 steps try to disconnect your Omnia from USB and connect it back on. Repeat it 1-2 times so the PC can recognize the phone.

    Leave the phone connected for about 10-15 minutes. If it disconnects by itself most probably you have to repeat the procedure from 1st step.

    It is advised to reboot your PC also.

    [*]Make sure that have backup all your important stuff (contacts, pictures etc).

    [*]Switch OFF the phone by holding the Power button for ~5 seconds.

    [*]Run the updater. (Works the same way for Original or Cooked ROMs)

    [*]Switch ON the phone again by holding the Power button.

    [*]Press START and happy flashing. Do not move your phone or the USB wire as it might fail during flashing.

    [*]Wait until the updater shows JOB DONE! DO NOT DISCONNECT BEFORE.

    [*]Disconnect your phone.

    [*]Leave the phone to reboot 2 times, calibrate screen and finish the start-up procedure.

    [*]Enjoy the new firmware.

0

Share this post


Link to post
Share on other sites

Posted

Thank you, sector.

Thats brilliant.

0

Share this post


Link to post
Share on other sites

Posted

Great detail, very useful !!

Thanks!! <_<

0

Share this post


Link to post
Share on other sites

Posted

When you are updating on Vista using virtual machine make sure you turn off the USB on the vista sync centre.

Double click Vista sync centre (if you don't have it download it).

Double click on the windows based mobile device.

Highlight mobile device setting with your mouse and click on connection settings.

Untick Allow USB connections.

Update using virtual machine as above when finished turn back on the allow USB connections in sync centre.

If you don't do the above XP Sp3 in VM mode will not recognise your phone.

0

Share this post


Link to post
Share on other sites

Posted

When you are updating on Vista using virtual machine make sure you turn off the USB on the vista sync centre.

Double click Vista sync centre (if you don't have it download it).

Double click on the windows based mobile device.

Highlight mobile device setting with your mouse and click on connection settings.

Untick Allow USB connections.

Update using virtual machine as above when finished turn back on the allow USB connections in sync centre.

If you don't do the above XP Sp3 in VM mode will not recognise your phone.

Works without doing it but it is safest. I will add it also on tutorial.

0

Share this post


Link to post
Share on other sites

Posted

Hi, Sorry to clog up your thread as a newbie wanting help, but I flashed my omnia earlier today, using HJ2 from the samsung website. It all appeared to work fine, it said it had completed successfully. I booted up the omnia and everything appeared to work - except that in "wireless manager" the phone is set to off and I can't turn it on. Also, google maps cant find the internal GPS.

Any suggestions - cause I'm ready to cry that I bricked phone. Thanks.

0

Share this post


Link to post
Share on other sites

Posted

good work bro.....

i knew you being a mod here would make things better as a whole....

Keep it up baw$$!

0

Share this post


Link to post
Share on other sites

Posted

got a question

i just flash my mobile

and lost the configuration for data transfer (internet, mms, etc)

now, i tried to restore some files from an old backup i've got

i did manage to get the configuration back, but also got some config back from other apps that are not in the phone right now so it's all messed up

my question is, is there a file where i can find that config without messing up the whole phone?

i know there should be, but there are lots of files that i can't open to 'see' inside

thx

0

Share this post


Link to post
Share on other sites

Posted

Nice, it`ll be usefull for a lot of people <_<

0

Share this post


Link to post
Share on other sites

Posted

Hi, Sorry to clog up your thread as a newbie wanting help, but I flashed my omnia earlier today, using HJ2 from the samsung website. It all appeared to work fine, it said it had completed successfully. I booted up the omnia and everything appeared to work - except that in "wireless manager" the phone is set to off and I can't turn it on. Also, google maps cant find the internal GPS.

Any suggestions - cause I'm ready to cry that I bricked phone. Thanks.

First don't stress. It's all good. You did not brick your phone. When you brick a phone it is usefully only as a brick, hence the name.

Try to do a couple hard resets. Read sector's post in the main OMNIA thread. Then check and see if its not working. Sometime you need to clear out old files by doing a couple of them.

If it is still not working reflash your phone... If you want an official ROM read the 'incorrect software" thread by paul just above this one and reflash.

Remember if all else fails you can take it to a service center. I had to do that when I bricked mine (IT JUST SAT THERE I TRIED TO POKE IT AND TALK NICE TO IT AND IT JUST SAT THERE...... DON'T WORRY IT'S JUST SLEEPING IT WILL WAKE UP LATER SHE'S JUST SLEEPING ) :) B) <_<

0

Share this post


Link to post
Share on other sites

Posted

hey guys

im trying to install the new rom and im not noob i know what im doing but when i sync. than i start up the i900_M2D04_PaS08.exe and than my sync close and than i restart my phone and the updater says this:

timeout--

No PDA Device Found ... close device

timeout--

No PDA Device Found ... close device

timeout--

No PDA Device Found ... close device

timeout--

No PDA Device Found ... close device

timeout--

No PDA Device Found ... close device

PDA Device not found.

i searched minimal for 6 hours and found alot of other errors but not this one so can somebody please help me?

0

Share this post


Link to post
Share on other sites

Posted

hey guys

im trying to install the new rom and im not noob i know what im doing but when i sync. than i start up the i900_M2D04_PaS08.exe and than my sync close and than i restart my phone and the updater says this:

timeout--

No PDA Device Found ... close device

timeout--

No PDA Device Found ... close device

timeout--

No PDA Device Found ... close device

timeout--

No PDA Device Found ... close device

timeout--

No PDA Device Found ... close device

PDA Device not found.

i searched minimal for 6 hours and found alot of other errors but not this one so can somebody please help me?

Hello Guys,

I am getting the same error message, anything i am doing wrong.

Thanks

0

Share this post


Link to post
Share on other sites

Posted

Hello Guys,

I am getting the same error message, anything i am doing wrong.

Thanks

well

there's no answer to this

the phone restarts before the vmmachine recognizes the usb connected phone

maybe you should try to shutdown the phone instead of restarting

i was so sick of this problem that i got a new hdd and installed xp on it !!

0

Share this post


Link to post
Share on other sites

Posted

Hey guys... I'm having a very frustrating problem with VMWare. This is that no mattter what, it won't detect the phone when I connect it.

I have disabled Mobile Centre in Vista, I have active sync 4.5 and installed the modem drivers but whenever I plug my phone it, it just makes the "vista usb noise" and XP won't detect it, not even if I try to force a connection from ActiveSync...

I've tryied different versions of VMWare and different windows versions and NOTHING. I have run out of ideas and was wondering whether any of you have come accross this problem before and know of any possible solutions?

Thank you very much in advance!

0

Share this post


Link to post
Share on other sites

Posted

please i flashed with the latest sector rom and i have a problem , the phone is always asking for aligning screen HELP please

0

Share this post


Link to post
Share on other sites

Posted

Thanks alot... i was able to flash my omnia without encountering a problem for the first time... thanks man! i now have wm6.5 :D

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi I want to try a deifferent firmware, but I have already bricked 3 omnias before and been luck to exchange them

I have followed all steps and my 4th used omnia is a tmobile uk branded but already has mshj1 on it which would sugest its already been flashed.

Can someone give me a difinitive answer will it work

( I also point out that im not new to flashing had many winmo phones and flashed like crazy, just have probs with omnia)

p.s im using a freshly formatted XP install and if its any use my last 3 omnias were voda uk branded

I TOOK THE PLUNGE................................FINGER HOVERING ABOVE START............................................IT WORKED I CANT BELIVE IT :D

Edited by mac_d4di
0

Share this post


Link to post
Share on other sites

Posted

Just recently have Flashed my Omnia i900 and was able to document a few highlights for your perusal guys...

post-542164-1245071882_thumb.jpg

post-542164-1245071893_thumb.jpg

post-542164-1245071910_thumb.jpg

post-542164-1245071924_thumb.jpg

post-542164-1245071937_thumb.jpg

post-542164-1245071949_thumb.jpg

post-542164-1245071966_thumb.jpg

post-542164-1245072001_thumb.jpg

post-542164-1245072016_thumb.jpg

post-542164-1245072031_thumb.jpg

post-542164-1245072056_thumb.jpg

post-542164-1245072066_thumb.jpg

0

Share this post


Link to post
Share on other sites

Posted

I'm in the process of upgrading my i900 now with the DXID1_21815 ROM of 6.5

It's been sitting on 11% (Downloading image) with my i900 on the boot screen for the last 20 minutes.

How long is the process supposed to take?

Thanks.

0

Share this post


Link to post
Share on other sites

Posted

Hello to all ok i read all about before i do any update, mod to the rom, heam i read for Vista because this f*ç%*%*ç%g OS is installed and i don't have any CD for XP i have HP machines here and thex don't give any CD for XP or Vista so.... if i read all correctly i can't upgrade my phoneon this f*ç%*ç%g vista right? i want to be sure before i do and i'm really newbie with ISO and especially the dowloaded ones... i don't trust them thanks for reply :D it's a really good site

0

Share this post


Link to post
Share on other sites

Posted

Thanks a lot for the guidelines mate....

0

Share this post


Link to post
Share on other sites

Posted (edited)

Thanks for the post. I followed all the instructions, updating to BOHH5 (t-mobile, since my SIM is t-mobile). It all seems to have updated ok but I'm now getting a "Network Lock" message and it's not connecting to a network. Previously the phone was unlocked so I'm assuming it's now locked to t-mobile; however, given that my SIM is t-mobile, why isn't it connecting to the network? Any tips on how to either unlock it again, or at least get it to connect to t-mobile? Thanks.(Version now is i900XXHH7/BOHH5)

Edited by ericbaber
0

Share this post


Link to post
Share on other sites

Posted

  1. Make Install the Samsung Modem Driver XP (once)

any better links to download this because RapidShare is giving me a lot of problems.

0

Share this post


Link to post
Share on other sites

Posted

google it.

It is posted in my 'How to use a Custom ROM' thread at samsung-omnia.com

It is everywhere bro :D

Laters

0

Share this post


Link to post
Share on other sites

Posted (edited)

awesome guide :D

Edited by XtremeMaC
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.