• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

How to Flash your i900 Omnia phone

288 posts in this topic

Posted

Hey, thanks for the original post.

I tried steff195's latest "Normal" software and it looks and feels great.

I have one issue/problem, maybe "modem" related: On the new ROM I can't connect to the internet through my phone service provider (Orange, GPRS in the UK). I can connect to the internet fine through wifi, but not through just the phone itself. Because I can't get to gprs, it means I can't send or receive picture messages either. I'm trying to sort out my settings but struggling to find the right info. Any help please?

Is it anything to do with the steps in the original post?

1. I have Active Sync 4.5 (although don't ever use it)

2. I downloaded the Samsung Modem Driver XP .zip, extracted and installed on my computer. What does this step do?

Thanks...

0

Share this post


Link to post
Share on other sites

Posted

Run the updater.

where to find the updater?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Is there a need for the custom cooked roms to be compatible with my omnia's version before flashing them on my omnia?

I have a Version of

PDA:DXIA5/DXIA5

PHONE: DXIA2

If i would use grandprix, do i need to flash a custom rom that is from a DXIA5 rom only?

Edited by crazy beautiful
0

Share this post


Link to post
Share on other sites

Posted

I'm having trouble.. trying to update in XP

downloaded the file ock_Eclipse_23118_TouchInput_Edition

I run the application and pres the START button as that is how simple it seems to be. I get to the point: Step 1. Eboot image Downloading

Downloading EBOOT...

i have gotten to 100% but nothing after. any clues as to what I'm doing wrong?

0

Share this post


Link to post
Share on other sites

Posted

Hi friend´s

i have a I900 and i have flashed lot´s of times but this weak i try flash the rom in friend and when the phone restarted the first time never loaded again. how can this be possibel? The rom i try flashing was

PDhee_i900Omnia_WM653_23136.5.3.9_WM7Style_Beta1
that is working very well in my i900 .

The Phone doesn´t load modem so i can try to flashe again is there another way to load the ROM

Thank´s friend´s

Re

0

Share this post


Link to post
Share on other sites

Posted

Hy, guys ! I have a Samsung Omnia, from Germany, the main ROM language was German and I couldn't understand a thing. So first I've flashed the phone, with an early version of Samsung Omnia ROM and that would be DXHJ1, in order to flash the phone with the latest version of ROM, DXID1. After the phone was flashed with DXHJ1 everything was just fine, the menu switched in English and finally I could understand my Omnia. :)

But when I tried to flash the DXID1 version, the program for flashing get stuck here:

PDA Device Found!

-------------------------------------------------------------------------------------

PDA Device ready to download!

Please Press Start Button if You want to download image now...

-------------------------------------------------------------------------------------

PDA 1 starts downloading...

Don't plug it out until the label becomes blue!!!

-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------

Step 1. Eboot image Downloading

Downloading EBOOT...

I even tried to flash DXHL3 and DXIA5 from here and I get the same problem. I tried on my laptop, on my PC, on two different Windows XP versions, SP2 and SP3, changed the USB Ports for flashing, I also used GrandPrix for the i900DXHL3_DZHL5 version and nothing happened.

Can you help me to flash the latest version ? Thanks !

0

Share this post


Link to post
Share on other sites

Posted

hello i have a samsung omnia i900 version:

PDA: i900JXHJ2/JXHJ2

Phone: i900NSPR0

if you wound which is the version of ROM that can walk with my phone? plz :)

0

Share this post


Link to post
Share on other sites

Posted

i tried to flash via wn7 with granprix.. now my phone is dead.. any help will be appreciated..

0

Share this post


Link to post
Share on other sites

Posted

hi everytime I try to flash a rom (not official) the exe hang and close ( i can recover the phone using WinControl and official updater) anyone knows why I cannot flash??

0

Share this post


Link to post
Share on other sites

Posted

i`m looking for clean and good screen senstivity rom ..

i bought it with some Custom rom named Sector in the begining :) PDA: i900DXID1/DXID1 ; PHONE: i900DXID1

any suggestions

thanks ..

0

Share this post


Link to post
Share on other sites

Posted

Hi i followed the instructions to the letter.

1.turned off phone by holding button for 5 secs

2.start updater

3.turn on phone!

but phone wouldnt turn on i pressed the soft reset button and got the omnia logo and updater discovered the phone. i then pressed start and got this

PDA Device Found!

-------------------------------------------------------------------------------------

PDA Device ready to download!

Please Press Start Button if You want to download image now...

-------------------------------------------------------------------------------------

PDA 1 starts downloading...

Don't plug it out until the label becomes blue!!!

-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------

Step 1. Eboot image Downloading

Downloading EBOOT...

EBOOT image downloaded.

PDA Reboot to download Eboot twice!!!

but it has now hanged! any ideas? seems like i know have a brick for a phone!

suggestions for sorting would be appreciated

0

Share this post


Link to post
Share on other sites

Posted

Hi Guys,

I hope anyone can help me. I am not new when it comes to windows mobile phones. I am a member of xda-dev for a long time and I've been using HTC phones for a long time now. But this is the first time I am using a samsung one. I am currently flashing my i900-16gb, did all the steps provided in the first post. And I just want to try this ROM first "28244 Normal by steff195". Successfully doe with flashing. Restarted the phone but it is stock on the samsun Omnia black screen...what's going on?

0

Share this post


Link to post
Share on other sites

Posted

hi, this is my first flashing and I have a problem..

I'm stuck between step 8 and 9... That is, the updater doesn't recognize the phone.. It just says Waiting for device and I can't hit start... everything worked fine up to this step.. activesync recognized and synchronized a couple of times, turned off, on etc.. and then this..

I have windows 7 x64 and virtual PC with XP mode installed, so i thought I'd follow the steps under Windows XP..

I have to click USB - attach device every time I turn phone on or plug USB in.. Is this causing trouble?

0

Share this post


Link to post
Share on other sites

Posted

Any advice or .exe that will do all the steps for flashing i900 in windows 7 ??

or i'll take any link that can explain flashing rom in windows 7 easy?

0

Share this post


Link to post
Share on other sites

Posted

Hi Guys,

I hope anyone can help me. I am not new when it comes to windows mobile phones. I am a member of xda-dev for a long time and I've been using HTC phones for a long time now. But this is the first time I am using a samsung one. I am currently flashing my i900-16gb, did all the steps provided in the first post. And I just want to try this ROM first "28244 Normal by steff195". Successfully doe with flashing. Restarted the phone but it is stock on the samsun Omnia black screen...what's going on?

Hi guys,

I was able to upgrade my omnia but using another tool. I have been using my phone for a couple of days. Then something happen. I tried to flash it again with a different ROm but during the flashing process I accidentally shutdown may laptop, and now even my phone was fully charge. it wont even turn on. Hope someone can help me...

0

Share this post


Link to post
Share on other sites

Posted

Hello,

First off I want to say hello! Second, I am a complete n00b to all this, so I apologize if I am posting in the wrong section.

I was reading this post for beginners and got to step 7 "Run the updater. (Works the same way for Original or Cooked ROMs)" What is the updater? Where do i get it? Have I missed something?

I ran the version checker on my Omnia I900 and it says PDA:i900DXHJ1

Phone: I900DXHJ1

I bought this phone new from newegg a couple years ago and I am not even sure if it can be flashed. Its an unlocked version 16gb Omnia. I would appreciate all the help I can get.

Thank you!

0

Share this post


Link to post
Share on other sites

Posted

Hello everyone,

I am receiving an error message,

i open the application, turned off the device, then i turn on the device and receive this message:

timmed out

timmed out

timmed out

timmed out

PDA device not found

can someone help me???

0

Share this post


Link to post
Share on other sites

Posted

Thanks for this post! I was looking for this and I got it here.

0

Share this post


Link to post
Share on other sites

Posted

Try using vmWare; a little guide that i threw on the net a very long time ago, click my link below!!

http://www.samsung-omnia.org/shokka9s-kitc...e-using-vmware/

hı ..

sorry for my bad english and writing in the wrong place because ı coldnt find right place

ı hve big problem with my omnia i900 .problem started this way ,first ı installed few apps after and after .apps that ı installed lastly are here ,apptodate.cab, CHT_v2.0.0_LanguagePack.PublicBeta_R0.cab, Co0kie.HomeTab_v2.0.0.cab, RemoteDesktopMobile.CAB, and after i instaled FTouchSL_2.10.cab, it said me to do softreset and i did it and it never work again .ı press power button to start ,power button gets red and comes this " samsung omnia "and then this "starting windows" and it waits a bit and th screen gets black blank and nothing ,never respond ,nonbuttons works till ı remove the battery ,ı did that way again and again but nothing changed .may be hardreset can be solution but firstly ı have to get my contacts ,is there any way to get the contacts in that stuation

second question ,is it possible to rescue to recover to get only the contacts by using some apps like recovery my files etc after hardreset ,

please help me :mellow:

0

Share this post


Link to post
Share on other sites

Posted

Can Anyone tell me what to do next please. I have omnia i900: PDA -i900DXHH1/DXHH1 and phone - i900XXHG5 and is running WM6.1 pro. I want to upgrade to WM6.5. I have done everything that could have been directed on this forum all to no avail.

First, I installed samsung modem for vista and thenWMDC. I downloaded ROMs: i900DXIDI and it didnot work. I downloaded DXIA5, it did not work. I followed all the procedure highlighted for vista, yet it did not work.

Now the problem is that USDL GrandPrix after loading the various part cannot see the phone. I restart the phone, the same thing. When you put off the phone to restart, it will sense that the phoneis not available and reports same. When the phone is on, WMDC confirms same, the process (upgrading) does not run. Im so sick of this. Any thing undone?

I will appreciate your prompt reply

0

Share this post


Link to post
Share on other sites

Posted

are koe indian h yaha par madad karne ko kya ye gsm set bhi upadate kar dega agar ha to kaise cdma modem bata raha h

0

Share this post


Link to post
Share on other sites

Posted

are koe indian h yaha par madad karne ko kya ye gsm set bhi upadate kar dega agar ha to kaise cdma modem bata raha h

where should i keep new rome file .7z so updater can easly red it because my updater can not read the rome file .7z form my desktop please reaply urgently

0

Share this post


Link to post
Share on other sites

Posted

Hi,everyone...I'm new here and I need some help.I bought an Omnia from an sh store.I decided to change OS because it was in german and I wanted in english.When it was in german it appears me the logo of T-MOBILE and appears me like SGH-I900...now, logo is from SAMSUNG .After the instalation of wm 6.1,in english,it appears me like SGH-I908.I tried to connect to internet with an Orange SIM but didnt work.Below battery there is a label which is written : the model SGH-I900.If I put *#1234# code it appears me:"PDA:i908ZHHH2 & PHONE :i908ZHHH2".I have read on forums how to install an wm 6.5 and I started instalation of wm 6.5 .I have Microsoft ActiveSync ver 4.5...I installed Samsung CDMA Modem 4.1.34,restart,deactivate firewall and the antivirus,again restart and than I started instalation...I clicked on Start and i was waiting the green loading bar...I tried for 10 times,I think...I changed the usb port...I don't know anymore what to do...I have win XP sp 2 on my pc.Any advice is good...Thank you very much.

0

Share this post


Link to post
Share on other sites

Posted

Hi,everyone...I'm new here and I need some help.I bought an Omnia from an sh store.I decided to change OS because it was in german and I wanted in english.When it was in german it appears me the logo of T-MOBILE and appears me like SGH-I900...now, logo is from SAMSUNG .After the instalation of wm 6.1,in english,it appears me like SGH-I908.I tried to connect to internet with an Orange SIM but didnt work.Below battery there is a label which is written : the model SGH-I900.If I put *#1234# code it appears me:"PDA:i908ZHHH2 & PHONE :i908ZHHH2".I have read on forums how to install an wm 6.5 and I started instalation of wm 6.5 .I have Microsoft ActiveSync ver 4.5...I installed Samsung CDMA Modem 4.1.34,restart,deactivate firewall and the antivirus,again restart and than I started instalation...I clicked on Start and i was waiting the green loading bar...I tried for 10 times,I think...I changed the usb port...I don't know anymore what to do...I have win XP sp 2 on my pc.Any advice is good...Thank you very much.

No1 to help me ?

0

Share this post


Link to post
Share on other sites

Posted

If i get the russian android on my omnia, all i have to do to get winmo back is to flash it with a winmo ROM?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.