• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

How to Flash your i900 Omnia phone

288 posts in this topic

Posted

All I get out of the phone now is -

- Power button turns on the phone but will not turn the phone off and does not light up when connected to pc however it will charge off mains supply adapter with a big charging icon in the middle of the screen.

- phone does not progress past this screen

- reset can only be done by poking the reset button and turning off is only with battery removal

- after reset and turn on (after removing battery) vista detects device but then 10 seconds later removes it showing device properties below initially it states the device is connected beofre reporting this device status.

samsung1.jpg

- therefore I cannot reflash as none of the flash tools can see the phone.

Any other way out of this?

Did you try Xp using the .exe installer??

Normally it will pick the phone up in the first 3-8 sec..

0

Share this post


Link to post
Share on other sites

Posted

if you'd just follow the steps correctly there wouldn't be any problems, you've probably just bricked your phone or something :)

0

Share this post


Link to post
Share on other sites

Posted

Thanks!! :) ;) ;)

0

Share this post


Link to post
Share on other sites

Posted

Hi all,

I just flashed my phone with Khunanchai's latest ROM and the phone is off and wont turn on.. I have done resets and flashed again.... While flashing once the bootloader said "SWITCHING FROM USB TO PHONE" then "PONE NOT FOUND" ERROR. Whats the problem? Now i have wm6.5 running but cannot activate the phone!!

0

Share this post


Link to post
Share on other sites

Posted

wow thank you what a smooth upgrade!

a tip for people - remember to switch your firewall OFF cause i was racking my brains over why the upgrader wasn't detecting my phone

thanks again! :D

0

Share this post


Link to post
Share on other sites

Posted

can someone point me to a rom 6.5WM for the omnia but with the looks and option of the original samsung 6.1WM? i know i saw it somewhere but i can't seem to find it anymore :D

thanx

0

Share this post


Link to post
Share on other sites

Posted

Hi noob question does flashing your omnia cause all the programs, music, images, etc to be deleted? Should I back them up before going ahead with my flashing?

0

Share this post


Link to post
Share on other sites

Posted

Hi Im New here for Windows mobile fon...im from malaysia.

after flash my OMNIA i900 to M2D (http://rapidshare.com/files/161757072/i900_M2D03fix1_PaS08.rar) ,

i found my original OMNIA function was gone. can i flash it back to my original ROM (stock ROM)

FYI ,

PDA : i900DTHJ9

PHONE : i900DXID1

please help me...thanks inadvice god bless u all...

0

Share this post


Link to post
Share on other sites

Posted

hi guys

i hope anybody helps

my omnia is JPIA3/JVHK2 running Windows Mobile 6.1

i hope some one tell me how to Run WM6.5 on new Rom ...,, i mean how can i know if there is a new rom availbe

i heard there is IA5 but does it run for middle east users ? hope some1 help me here am so confused

i hope to run wm6.5 but still be able to write and read in arabic

waiting from anyone rolleyes.gif

0

Share this post


Link to post
Share on other sites

Posted

hi guys

i hope anybody helps

my omnia is JPIA3/JVHK2 running Windows Mobile 6.1

i hope some one tell me how to Run WM6.5 on new Rom ...,, i mean how can i know if there is a new rom availbe

i heard there is IA5 but does it run for middle east users ? hope some1 help me here am so confused

i hope to run wm6.5 but still be able to write and read in arabic

waiting from anyone rolleyes.gif

Install the ROM without any phone part, as JVHK2 phone part you have will force any other PDA ROM to recognize your regional settings, Language, ..Etc don't even have to install any Arabization application., have fun I've tested & works.

0

Share this post


Link to post
Share on other sites

Posted

Install the ROM without any phone part, as JVHK2 phone part you have will force any other PDA ROM to recognize your regional settings, Language, ..Etc don't even have to install any Arabization application., have fun I've tested & works.

OOOh atlast some one replied thx morad so much am new with omnia and hope to upgrade to winmo6.5 as it is much finger friendly :D)))

i'll give it a try to a cooked rom rabena yostor :angry:)))

0

Share this post


Link to post
Share on other sites

Posted

Hi Sector.

I'm a newbbie in flashing Roms, and I need to know if is there a way to get the original ROM of my Omnia? I'm not sure if I'm being very clear, but what I want is to have an .exe file, like the cooked ROM, for restore purposes later.

Another question. My Omnia, from a brazilian company (VIVO) has VIHI3 version. Is there any problem to flashing it? The ROM I choosed was the 23041 one.

Thanks in advance for your time, and I'm sorry about my poor english.

AlexGV99 at gmail

0

Share this post


Link to post
Share on other sites

Posted

Hello to all ok i read all about before i do any update, mod to the rom, heam i read for Vista because this f*ç%*%*ç%g OS is installed and i don't have any CD for XP i have HP machines here and thex don't give any CD for XP or Vista so.... if i read all correctly i can't upgrade my phoneon this f*ç%*ç%g vista right? i want to be sure before i do and i'm really newbie with ISO and especially the dowloaded ones... i don't trust them thanks for reply :) it's a really good site

Yesterday I was able to flash my Omnia i900 with WinMo 6.5 running Windows 7 and Windows XP VM :) ;

Wasn't hard at all.

Thanks Sector, great job!

:)

0

Share this post


Link to post
Share on other sites

Posted (edited)

Edited by hoof-hearted
0

Share this post


Link to post
Share on other sites

Posted

I am also trying to flash my omnia and it's not really working:

PDA Device Found!

-------------------------------------------------------------------------------------

PDA Device ready to download! 

Please Press Start Button if You want to download image now...

-------------------------------------------------------------------------------------

PDA 1 starts downloading...

Don't plug it out until the label becomes blue!!!

-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------

Step 1. Eboot image Downloading

Downloading EBOOT...

and it remains at 0%

whats wrong there?

Hi, thanks to all the posters on this forum for some great advice and tips. I am having the same problem as above - I followed the instructions exactly and have even tried on another computer with the same result. Are there any specific settings you need to do to the phone first? Any help would be much appreciated.

0

Share this post


Link to post
Share on other sites

Posted

I installed vmware workstation and everything worked great, but when I installed I didnt made any shortcuts or folder in the start menu...So now I don't know how to run vmware again, and there is no .exe file to run the program in the folder where I installed it.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Nvm everything working fine now =)

Edited by Downloaderz
0

Share this post


Link to post
Share on other sites

Posted (edited)

-wrong topic- have moved it to the correct one.

Edited by Crazy Dutch
0

Share this post


Link to post
Share on other sites

Posted

I am reading and trying for weeks now. I read almost every topic and every forum about upgrading my ROM (Brandend Vodafone) from my Omnia i900(v).

It is already discussed that the code to get ride of the incorrect software version is not working. I did managed to get to the preconfiguration but I could not choose for Singapore (I think the countries named in the list are just the Vodafone networks in these countries). I thought I choose for New Sealand and it looked promising but after some hard resets etc etc I still couldn't go further with the updater.

I tried to install the Samsung modem and it told me the installation was succesfull but Nothing happens when I connect my Omnia (reset or not..I even tried Hard reset). I can't see a screen from the modem and in my Desktop PC (configuration) I can't see a modem or something linked to the Samsung Modem. I am using Windows XP and not Vista with the VMware.

Yes I shut down all the firewalls and I tried to shut down the virus program.

This is my Omnia:

PDA version: i900XKHG5/ARHG5

Phone version: i900BUHG5

Nothing on it anymore after a couple of hard resets..

Tried the hex editor also..

Thanks already.

i am also experiencing the same problem....i even went as far as reinstall windows xp on my PC, but then it still doesn't work...can someone help ?

0

Share this post


Link to post
Share on other sites

Posted

would this work on a vodafone branded i900?

0

Share this post


Link to post
Share on other sites

Posted

would this work on a vodafone branded i900?

I don't see why not. You should just follow the steps listed in this topic, and be fine all the way thru!.

I achieved a ROM update today on windows 7 ultimate x64 running vmware: xp prof. x86.

Tho I don't have vodafone, I don't see any reason why it shouldn't work.

0

Share this post


Link to post
Share on other sites

Posted

Man, this guide is absolutely AWESOME.

I flashed my Omnia with WM6.5 23047 by Sector from another thread. Really smooth. After doing it a couple times, taking all precautions it's even easier than I thought.

Fair warning though: sometimes it might be hard to input your internet connection settings back. For example, for my carrier (Vivo-BR), I needed to configure connections *and* GPRS authentication (something they don't tell you in over-the-phone support).

0

Share this post


Link to post
Share on other sites

Posted

Hi...i have big problem when trying to upgrade my firmware with official one (i900DZIA5_updater_vista). During downloading mode(2nd file downloading) suddendly failed. I'm trying to restart and turn on my phone but stuck in the 'samsung omnia' logo only. Trying to flash back but still stuck in downloading mode. Any solutions guys? :)

0

Share this post


Link to post
Share on other sites

Posted

'sector' date='May 17 2009, 07:09' post='1013233']

HOW-TO FLASH I900 OMNIA TUTORIAL

=====

First of all for the newbies i would recommend to play a bit with the phone before upgrading. Get to know how your phone and current ROM works.

Please be patient and read again if you don't understand anything. Make sure that you know what you are doing.

I TAKE NO RESPONSIBILITY IF U DAMAGE YOUR DEVICE!

GOOD LUCK!

Important :

Those who then want to make you sure for the safest way of changing the ROM in OMNIA i900 should follow closely (in case) the following steps.

Make sure you:

  • Turned off any Firewall you have on the PC.
  • Not running the update in Safe Mode.
  • Not to perform any other work on your PC.
  • Make sure the phone is fully charged (important)
  • Do not update from a PC where you have limited rights. Eg. Internet Cafe, Work etc.
  • Prefer Laptop as if you have electricity dropped you will have some extra battery and wont harm your phone.
  • Use only one USB port for you Omnia update, the best one it works for you. Do not try multiple.

Steps used for updating under Windows XP (32 bit).

[*]Make the Install Microsoft ActiveSync 4.5 (once)

[*]Make Install the Samsung Modem Driver XP (once)

[*]Reboot the PC.

[*]After the first 2 steps try to disconnect your Omnia from USB and connect it back on. Repeat it 1-2 times so the PC can recognize the phone.

Leave the phone connected for about 10-15 minutes. If it disconnects by itself most probably you have to repeat the procedure from 1st step.

It is advised to reboot your PC also.

[*]Make sure that have backup all your important stuff (contacts, pictures etc).

[*]Switch OFF the phone by holding the Power button for ~5 seconds.

[*]Run the updater. (Works the same way for Original or Cooked ROMs)

[*]Switch ON the phone again by holding the Power button.

[*]Press START and happy flashing. Do not move your phone or the USB wire as it might fail during flashing.

[*]Wait until the updater shows JOB DONE! DO NOT DISCONNECT BEFORE.

[*]Disconnect your phone.

[*]Leave the phone to reboot 2 times, calibrate screen and finish the start-up procedure.

[*]Enjoy the new firmware.

Hello Sector! hey everybody! help me please! my i900 omnia possibly turn to be brick now as Im trying flash it refer to the instruction above, and it stuck @13% progress until now( almost 1 hours @13% progress flashing.) and I was have a chance to take some snapshot for it before start flash it and while it in progress till it stuck since then.....please!! I beg you all, i know its too late to night now to post this, but please have a chance to reply it since you read this post . ok here they are some snapshot from my flashing process and hopefully you can help me to troubleshoot the problem and determine which part I've made the mistake. thanks Sector! thanks everybody! o'ya! I enclosed my snapshot on attachment file along with this post.

post-589454-1253508762_thumb.jpg

post-589454-1253508898_thumb.jpg

post-589454-1253508916_thumb.jpg

post-589454-1253508933_thumb.jpg

0

Share this post


Link to post
Share on other sites

Posted

Hi Sector,

I was wondering if you could help me with what I'm trying to do. I have an Omnia, but my company gave me a Blackberry. I miss my Omnia and I have done tons of research to see if I could use BBConnect. Everywhere they say it would not work, but I found this thread on XDA that I would like to give it a try. http://forum.xda-developers.com/showthread.php?t=294218. What I would like to try is to change the ROM version of my Omnia to 5.1.195 in order to try BBConnect version 2.1 and give it a shot. If you or someone could help me with the HEX Code to change and where to change it. For example in the XDA forum:

4F 3F A0 E3 02 30 83 E3 45 2F A0 E3 05 10 A0 E3 02 (Rom Version 5.2.318) to

C3 30 A0 E3 02 30 83 E3 45 2F A0 E3 05 10 A0 E3 01to (Rom Version 5.1.195)

Thanks in advance!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.