• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Windows Mobile 6.5 Kitchen

481 posts in this topic

Posted

Please if someone can answer my doubts... (various newbie)

1º. To cook a rom with the releases of Da'G I need to port only XIP? Or I need port the SYS too?

2º. What is the tutorial easier for me to use to port the XIP? I using this tutorial http://forum.ppcgeeks.com/showthread.php?t=76555 to port, but I don't know if I really use it for the i900 because it is for i910.

1. i use the SYS as is and it works fine (just remove other resolution folder)

2. that tutorial works for i900, i use the XIPKitchen beta6. i just dont understand all the step (like why remove Lsomaclient.dll...) my fone works but seems slower :) maybe because of XIP porting or recmod and slot0 (actually i dont understand about them :|)

0

Share this post


Link to post
Share on other sites

Posted

1. i use the SYS as is and it works fine (just remove other resolution folder)

2. that tutorial works for i900, i use the XIPKitchen beta6. i just dont understand all the step (like why remove Lsomaclient.dll...) my fone works but seems slower :) maybe because of XIP porting or recmod and slot0 (actually i dont understand about them :|)

You cook the rom in English or in your language? I try cook in my language but I dont sucess.

0

Share this post


Link to post
Share on other sites

Posted

I'm cooking a german rom, which means i've got BHIC2 xip.bin

which xip.bin do you need? DXID1? If so, I'll port one for you.

Greetings

Thanks DominikZ, but as I edited my post, I have found 23052 xip.

BTW, I use english sys&xip and translation is settled over croatian 041a.mui (manually adapted as there isnt official croatian mui for wm6.5 yet) files installed from CSC. Now I use hybrid sys23049 and xip23052 and everthing works very well.

"Only" problem I found trying to build full (sys&xip) 23052 or 53 system was - it wont use my 041a.mui files, it wont install any cab,..., but, it`s Windows, isnt it? So I am still trying to correct this, and, if anyone has some usefull advice I shall be very thankfull.

0

Share this post


Link to post
Share on other sites

Posted

Hi, anyone known if the last sys/xip like 23412 will be released for i900??

Thanks

0

Share this post


Link to post
Share on other sites

Posted

@ rtomakov: did you change the values in boot.rgu to your mui files? otherwise it will always try to find 409 lang files.

Seconldy: Cabs CAN be installed in my roms. So it's not Windows :)

0

Share this post


Link to post
Share on other sites

Posted (edited)

@ rtomakov: did you change the values in boot.rgu to your mui files? otherwise it will always try to find 409 lang files.

Seconldy: Cabs CAN be installed in my roms. So it's not Windows :)

DominikZ, thanks for xip.bin. I have tried it and it works. BUT, it does not solves my problem - I still cant install anything, and my mui-s arent accepted.

I never changed boot.rgu to set mui to 041a, I have done this (allways successfully) by adding [HKEY_CURRENT_USER\MUI] "CurLang"=dword:041A lines in CSCConfig.rgu. Besides, most of my mui-s are modded, and because, signed with sdkcerts. So I had to add these certs in rom by adding them in CSCConfig.xml (and that allways worked too). Yes, I have both 0409 and 041a files in rom.

I used DXID1 base: OEM, .ROM, .VM, Medadata, also dxid1 eboot and your xip.bin. I tried several times with 23052 & 23053 builds and result is allways the same - cant install anything. I must say that I done this on the same way (exactly) as I made 23049 build (and many others before), but, they worked and 23052-53 wont. I dont know what else I could try.

I downloaded 23052 build form xda-dev site and omniarom. Do you use some other source (and where could I find it)?

EDITED: SOLVED FINALY!

I have tried building from scratch, zero, nothing - and it worked. I used DominikZs xip.bin posted above and new 23052 source. Everything works, including my 041a mui files installed as described.

DominikZ, again, thanks for your xip.

Edited by rtomakov
0

Share this post


Link to post
Share on other sites

Posted

hi all, i'd like to know if our omnia has WM 6.5 Native Kernel? i mean the nk.exe in xip that is compatible with SLOT 60/61.

0

Share this post


Link to post
Share on other sites

Posted

For anyone interested:

Issuses with SMPlayer (Touch Player) and ContentsManager (Media Album) that I described in posts above was caused by missing/invalid lsomaclient.dll file.

Issue is solved by putting new (in fact - old) lsomaclient.dll in \Windows dir.

0

Share this post


Link to post
Share on other sites

Posted

I try to build my first ROM.

First one based on wm6.1 is working well. Then I try to build a wm6.5 ROM based on DXID1 orginal ROM. Everything goes well. I flashed the new ROM, the screen stopped on second screen( yellow one with windows logo)......

What have I done wrong? Please help!!!

0

Share this post


Link to post
Share on other sites

Posted

problem is xip.bin...change xip.bin or do a new porting...

0

Share this post


Link to post
Share on other sites

Posted

problem is xip.bin...change xip.bin or do a new porting...

xip problem? port again, same result.

I use auto-porting tool.

??? :D

0

Share this post


Link to post
Share on other sites

Posted

does anyone have the files needed from build 23614?? of course ported to omnia i'm just not bright enough to do it :D

0

Share this post


Link to post
Share on other sites

Posted

guys I don't get it....why if I drop the os.nb.new on BuildOS I always get an error that some kind of file is already existing?? I mean it doesn't make sense....I removed it from OEM and left the newest files in the SYS...but now it is like comparing with the files inside the OS.nb.NEW.........is there a fix for this?????

thanks a bunch!

0

Share this post


Link to post
Share on other sites

Posted (edited)

guys I don't get it....why if I drop the os.nb.new on BuildOS I always get an error that some kind of file is already existing?? I mean it doesn't make sense....I removed it from OEM and left the newest files in the SYS...but now it is like comparing with the files inside the OS.nb.NEW.........is there a fix for this?????

thanks a bunch!

Use the search, the file must excist somwhere.. What file have you got double of??

EDIT: Have a look HERE, it's yet another i900 Kitchen thread, but it use Wozzer's kitchen. You might get on beter with that ;) . It's what i use and it also overwrites files so you should get no error messages

Edited by Nicklashidegard
0

Share this post


Link to post
Share on other sites

Posted

Use the search, the file must excist somwhere.. What file have you got double of??

EDIT: Have a look HERE, it's yet another i900 Kitchen thread, but it use Wozzer's kitchen. You might get on beter with that ;) . It's what i use and it also overwrites files so you should get no error messages

NIcklas thanks for your quick answer as a pro! :D I hope this one will work now! let me try and I get back with you with an answer! :(....by the way do you have any idea why the Visual Vistang kitchen screws up with following error:

ERROR: Not enough space in Slot 0!

ERROR! platformrebuilder (errorlevel: 1)

Press any key to continue . . .

???

Thanks a bunch!

0

Share this post


Link to post
Share on other sites

Posted

make sure u recmod sys, needs to be done in any kitchen due to 6.1 kernel. in wozzers kitchen there is recmodsys.cmd, make sure u do that and also clear file attributes (wozzer kitchen only).

0

Share this post


Link to post
Share on other sites

Posted

make sure u recmod sys, needs to be done in any kitchen due to 6.1 kernel. in wozzers kitchen there is recmodsys.cmd, make sure u do that and also clear file attributes (wozzer kitchen only).

Nicklas, ok thanks a bunch for the tip! ;) am trying now everything out you told me! :(.....by the way if use the SztupY's syakr tool to remove parts from OEM.....can I check there remove the .NET 2.0 and then check in the updates tab, update to .NET 3.5? Or do I have to check only in the updates tab .NET3.5 and then it removes the old and puts in the new one? Oh and if I add as OEM package the NET 3.7, would it mess up the sys? :D

0

Share this post


Link to post
Share on other sites

Posted

Nicklas, ok thanks a bunch for the tip! ;) am trying now everything out you told me! :(.....by the way if use the SztupY's syakr tool to remove parts from OEM.....can I check there remove the .NET 2.0 and then check in the updates tab, update to .NET 3.5? Or do I have to check only in the updates tab .NET3.5 and then it removes the old and puts in the new one? Oh and if I add as OEM package the NET 3.7, would it mess up the sys? :D

I always manually delete .net + flash and upgrade it manually (just add to sys).. .net3.7 isn't always compatible so i use 3.5. (attached, just add to sys). And you need to delete a couple of flash files from OEM (flashlite.dll, flashsnddec.dll and si_inpl.dll)..

flash_net.rar

0

Share this post


Link to post
Share on other sites

Posted (edited)

I always manually delete .net + flash and upgrade it manually (just add to sys).. .net3.7 isn't always compatible so i use 3.5. (attached, just add to sys). And you need to delete a couple of flash files from OEM (flashlite.dll, flashsnddec.dll and si_inpl.dll)..

thanks a bunch!!

so considering the visual kitchen....I did run recmod sys and I also cleaned the file attributes....BUT it just doesn't work :( .....maybe it is my Windows 7 x64...I still get error:

Problem Event Name: BEX

Application Name: platformrebuilder.exe

Application Version: 2.1.0.0

Application Timestamp: 49988ef1

Fault Module Name: platformrebuilder.exe

Fault Module Version: 2.1.0.0

Fault Module Timestamp: 49988ef1

Exception Offset: 0000cb65

Exception Code: c0000417

Exception Data: 00000000

OS Version: 6.1.7600.2.0.0.256.1

Locale ID: 1033

Additional Information 1: eec1

Additional Information 2: eec1979a9a0119b8354e58878c5c4389

Additional Information 3: bae8

Additional Information 4: bae8688f3f462403dbd4ed63c6b9b1f1

and ma log.txt looks like this:

---------------------------------------------

PLATFORMREBUILDER Copyright © 2008-2009 bepe Feb 15 2009 22:53:49

Building for old kernel!

Build: Premium

Locale: 0409

Preparing release structure...

... done!

Collecting standard packages and initializing hives...

XIP: 6 packages

IMG: 137 packages

... done!

Processing standard packages...

MSXIPKernelLTK

MSXIPKernel

WinCENLS_WWE

LangDB

OEMXIPKERNEL

MSXIPKernelLTK

SMIME

RemoteDesktopMobile

AlarmSounds

Bth_A2DP

SqlCeMobile

WindowsLive

Warning: Overwriting 'rec.txt'

AdobeFlashCodecs

Warning: Overwriting 'rec.txt'

DRM

CHome

MediaOS

Warning: Overwriting 'rec.txt'

RUNTIMES

FWUPDATE

GPSID

WMMoneyWidget

WWAN

LockscreenNonEA

MODEMLINK

SMS_Providers

ppgprov

VoIPOS

OneNote

SampleMusic

ConfettiCore

IPSECVPN

Warning: Overwriting 'rec.txt'

SQM

ADC

WindowsLiveIM

Warning: Overwriting 'rec.txt'

BTDUN

BaseAppsFiles

MediaOSFiles

Bth_HID

Warning: Overwriting 'rec.txt'

Livesearch

Riched20

Enterprise

NetCF

Skybox

Themes

BronzeNonEA

VoIP

Entertainment

Lockscreen

SQLCE

WMWeatherWidget

OSFiles

SYSTEM_DEFAULT_FONTS

bronze

WMWidgets

Warning: Overwriting 'rec.txt'

BROWSINGCORE

Warning: Overwriting 'rec.txt'

RingsAndAlerts

VoiceCommand

AdobeFlash

Warning: Overwriting 'rec.txt'

Metadata

OneNote_lang_0409

WMWidgets_LANG_0409

Fwupdate_Lang_0409

MediaOS_Lang_0409

IPSECVPN_Lang_0409

WindowsLive_Lang_0409

Bth_HID_Lang_0409

ADC_Lang_0409

OS

Warning: Overwriting 'rec.txt'

VoiceCommand_Lang_0409

Bth_A2DP_Lang_0409

Entertainment_Lang_0409

Skybox_Lang_0409

BROWSING

Warning: Overwriting 'rec.txt'

SqlCeMobile_Lang_0409

RemoteDesktopMobile_Lang_0409

AdobeFlash_LANG_0409

CHome_Lang_0409

Enterprise_Lang_0409

WelcomeCenter

Browsing_Lang_0409

BaseApps

Warning: Overwriting 'rec.txt'

WelcomeCenter_Lang_0409

Webview

Office

Office_Lang_0409

browsingie

Warning: Overwriting 'rec.txt'

browsingie_LANG_0409

Shell

Warning: Overwriting 'rec.txt'

Base_Lang_0409

PhoneRedist

Warning: Overwriting 'rec.txt'

INTERNETSHARING

Redist

Warning: Overwriting 'rec.txt'

Phone

Warning: Overwriting 'rec.txt'

Redist_Lang_0409

Phone_Lang_0409

PhoneRedist_Lang_0409

CommonNonEA

Base_DPI_96

base_dpi_96_resh_240_resv_400

Base_Lang_0409_DPI_96

Base_Lang_0409_DPI_96_RESH_240_RESV_400

Bluetooth

Warning: Overwriting 'rec.txt'

Bluetooth_Lang_0409

Bronze_DPI_96

Browsing_DPI_96

Bth_Watch

Bth_Watch_Lang_0409

CHome_DPI_96

Enterprise_DPI_96

Enterprise_Lang_0409_DPI_96

Entertainment_DPI_96

Entertainment_Lang_0409_DPI_96

IPSECVPN_DPI_96

Lockscreen_DPI_96

MediaOS_dpi_96_resh_240_resv_400

MSIMAR

MSIMAR_DPI_96

MSTag

Warning: Overwriting 'rec.txt'

MSTag_Lang_0409

Office_DPI_96

Office_Lang_0409_DPI_96

PhoneRedist_DPI_96

PhoneRedist_Lang_0409_DPI_96

Phone_DPI_96

Phone_dpi_96_resh_240_resv_400

Phone_Lang_0409_DPI_96

Redist_DPI_96

Redist_dpi_96_resh_240_resv_400

Redist_Lang_0409_DPI_96

RIL710MUX

RMGR

Themes_DPI_96

Themes_Lang_0409_DPI_96_RESH_240_RESV_400

Transcriber

Transcriber_Lang_0409

Warning: Overwriting 'rec.txt'

Transcriber_Lang_0409_DPI_96

WidgetApps

WindowsLive_DPI_96

OEMApps

Warning: Overwriting 'calendar.exe'

OEMDrivers

OEMMISC

OEM_DPI_96

OEM_Lang_0409

WozXipFix

Warning: Overwriting 'smsTrigger.exe'

... done!

Processing extended packages...

Showcase.exe

ShowcaseSuite.exe

FavHack.exe

GpsModDriver.dll

GpsModSetup.exe

SynchroTime.exe

Labyrinth.exe

Labyrinth.exe.0409.mui

pdraw.dll

zlib1.dll

Explorer.0407.mui

Explorer.040a.mui

Explorer.040c.mui

Explorer.0410.mui

Explorer.0413.mui

Explorer.exe

RCrypting.dll

RFileShell.0407.mui

RFileShell.040a.mui

RFileShell.040c.mui

RFileShell.0410.mui

RFileShell.0413.mui

RFileShell.dll

RFtpShell.0407.mui

RFtpShell.040a.mui

RFtpShell.040c.mui

RFtpShell.0410.mui

RFtpShell.0413.mui

RFtpShell.dll

RRegShell.0407.mui

RRegShell.040a.mui

RRegShell.040c.mui

RRegShell.0410.mui

RRegShell.0413.mui

RRegShell.dll

RTasks.0407.mui

RTasks.040a.mui

RTasks.040c.mui

RTasks.0410.mui

RTasks.0413.mui

RTasks.exe

RToday.0407.mui

RToday.040a.mui

RToday.040c.mui

RToday.0410.mui

RToday.0413.mui

RToday.dl

ERROR! platformrebuilder (errorlevel: -1073740777)

Press any key to continue . . .

:D ---------------------------------------

rec.txt in the SYS folder

Error! Cannot map umarshaller.exe\imageinfo.bin

Error! Cannot map tkitapp.exe\imageinfo.bin

Error! Cannot map siclnt.exe\imageinfo.bin

Error! Cannot map syscsps.dll\imageinfo.bin

Error! Cannot map tskscheduleu.exe\imageinfo.bin

Error! Cannot map voicedll.dll\imageinfo.bin

Error! Cannot map Avrcp_MPplugin.dll\imageinfo.bin

Error! Cannot map kbdhid.dll\imageinfo.bin

Error! Cannot map wininet.dll\imageinfo.bin

Error! Cannot map wmlview.dll\imageinfo.bin

Error! Cannot map btd.dll\imageinfo.bin

Error! Cannot map flashviddec_sorenson_win32.dll\imageinfo.bin

Error! Cannot map si_impl.dll\imageinfo.bin

Error! Cannot map wmwidgetinstallerres.dll\imageinfo.bin

Error! Cannot map WLMMessengerPlugin.dll\imageinfo.bin

Error! Cannot map WLMTodayScreen.dll\imageinfo.bin

Error! Cannot map TraRecoEnu.dll\imageinfo.bin

Error! Cannot map TagReader.exe\imageinfo.bin

Error! Cannot map wmpocx.dll\imageinfo.bin

Error! Cannot map ipsecvpn.dll\imageinfo.bin

Error! Cannot map wmlview7.dll\imageinfo.bin

HELP! ;)

Edited by downjones
0

Share this post


Link to post
Share on other sites

Posted

thanks a bunch!!

so considering the visual kitchen....I did run recmod sys and I also cleaned the file attributes....BUT it just doesn't work :D .....maybe it is my Windows 7 x64...I still get error:

:D ---------------------------------------

HELP! ;)

Try removing ALL EXT packages and remove MStag from sys, then try again. :(

0

Share this post


Link to post
Share on other sites

Posted

Try removing ALL EXT packages and remove MStag from sys, then try again. ;)

it works!!! THAAAAANKS!!!! dump created successfully! )))) YOU THE MAN! :D

0

Share this post


Link to post
Share on other sites

Posted

it works!!! THAAAAANKS!!!! dump created successfully! )))) YOU THE MAN! ;)

Then add EXT packages gradually. If you add a load and get errors you'll never know what caused it. and never include MSTag , normally creates errors :D

0

Share this post


Link to post
Share on other sites

Posted

Then add EXT packages gradually. If you add a load and get errors you'll never know what caused it. and never include MSTag , normally creates errors ;)

perfect!! :D I already know what was the erro...it was in the ext package of resco explorer ))))) now pda.bin is created....how am I going to make the i900xxx.exe for the update? don't I need csc.bin and eboot.bin?

0

Share this post


Link to post
Share on other sites

Posted

perfect!! :D I already know what was the erro...it was in the ext package of resco explorer ))))) now pda.bin is created....how am I going to make the i900xxx.exe for the update? don't I need csc.bin and eboot.bin?

You do. It should have been created when you dumped the rom. Do you use DXID1 ?? Just use pako's exe (pinned) to create the exe. I've attached DXID1 csc.bin and eboot ;) . Will ONLY work on DXID1 though...

eboot_and_customer_csc.rar

0

Share this post


Link to post
Share on other sites

Posted (edited)

You do. It should have been created when you dumped the rom. Do you use DXID1 ?? Just use pako's exe (pinned) to create the exe. I've attached DXID1 csc.bin and eboot :D . Will ONLY work on DXID1 though...

perfect thank you my friend! I created the exe now am updating! :( I hope it will start!

......AND it fu*king doES NOT!!!

Now it is the worst.....you can not see what is the error.....it just hangs....doesn't start the windows..... (((((((

My base is DXID1 and SYS/XIP 23529...........everything finished without an error and now it does not work.......what do I do now? ;)

Edited by downjones
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.