kabkab

1% driver for omnia here

191 posts in this topic

Just delete \windows\zylonite_battery.dll and the ROM version will come right back.

0

Share this post


Link to post
Share on other sites
Just delete \windows\zylonite_battery.dll and the ROM version will come right back.

Thanks dwallersv, but, when i delete the file, and reset device, the file auto-restored, is the driver 1%.

;)

Edited by esian
0

Share this post


Link to post
Share on other sites
Hi chivi, i need the original driver too, do you find it? thanks you.

link to orginal driver, see post 6780.But dident work on sector rom... ;)

0

Share this post


Link to post
Share on other sites
link to orginal driver, see post 6780.But dident work on sector rom... ;)

Thanks chivi

0

Share this post


Link to post
Share on other sites
Thanks dwallersv, but, when i delete the file, and reset device, the file auto-restored, is the driver 1%.

;)

Actually, it's zylonite_battdrvr.dll. Make sure that's the file you're deleting.

0

Share this post


Link to post
Share on other sites

Alternative ?

1% battery indicator for SGH-i900

post-597967-1236835879_thumb.jpg

Indicator updates every 10 seconds

Tap on battery to show temperature ...

<Yes> - end of the work

No installation needed (just copy file anywhere on omnia and run it)

No Settings.

Use it at your own risk

But i don't believe something bad can happen

pbi.exe

Edited by smilegod
0

Share this post


Link to post
Share on other sites

Thanks a lot for this patch, works great on my i900.

0

Share this post


Link to post
Share on other sites
Alternative ?

1% battery indicator for SGH-i900

post-597967-1236835879_thumb.jpg

Indicator updates every 10 seconds

Tap on battery to show temperature ...

<Yes> - end of the work

No installation needed (just copy file anywhere on omnia and run it)

No Settings.

Use it at your own risk

But i don't believe something bad can happen

pbi.exe

Y is it showing me i hav 48% while my real battery icon showing me having 70%

0

Share this post


Link to post
Share on other sites

Is anybody else having issues using this with the new Verizon CF03 ROMS? After installing I soft reset and my phone and it usually freezes after about a minute. I tired it with bot WinMo 6.1 and 6.5. I had it working fine on CC20..

Edited by Skyline987
0

Share this post


Link to post
Share on other sites

somebody tried this one?????

This is a piece of advice that I wished someone told me when I just bought my phone.

After fully charging the Omnia, e.g. charge 6 hours, do a hard reset, to set the battery meter correctly.

Hard reset is via Settings/System/Hard Reset

If not, you will complain of bad battery life :) i dont know it works for u test it cya good luck ;)

0

Share this post


Link to post
Share on other sites

Works on my Samsung Epix, used the i900 version. Lots of Omnia stuff works, since it has almost the same internals.

EDIT: Its really unstable, and it makes the battery die pretty fast. I had to take it off.

Edited by ~Tito~
0

Share this post


Link to post
Share on other sites
Works on my Samsung Epix, used the i900 version. Lots of Omnia stuff works, since it has almost the same internals.

EDIT: Its really unstable, and it makes the battery die pretty fast. I had to take it off.

Try the 5% version... it's much gentler on the battery (in fact, seems no different to me than the stock driver). Also, haven't had any stability issues with it at all.
0

Share this post


Link to post
Share on other sites
Try the 5% version... it's much gentler on the battery (in fact, seems no different to me than the stock driver). Also, haven't had any stability issues with it at all.

I dl'ed the i900 version but there is only one version in side the folder. The i910 version just keeps the battery status a 100%. I'll give it another test.

0

Share this post


Link to post
Share on other sites

My i910 is producing a notification that can't be dismissed, as follows:

BATTERY


NON SUPPORTED BATTERY!

SEE USER MANUAL

Sorry for the caps the message is written like that :D

Start > Settings > System > Version gives me:

ROM version S:i910.10 B.CC30.20276

H/W version H:i910.10 B.Q

Just FYI in case it helps someone with something.

0

Share this post


Link to post
Share on other sites

Just a curious question:

On the VZW i910 with the standard CF03 firmware the battery icon on the taskbar and the battery application you open by pressing the icon show the battery levels in increments of 20% however, if you open "Easy Settings" the battery icon there on the first screen shows it in increments of 5%.

So the questions is are they getting the value from 2 different drivers? and yes or no to that question can we take advantage of that 5% calculation for use on the taskbar?

It just seems to me that if the Samsung application is reporting it in 5% increments pretty accurately can we take advantage of that and just change the taskbar icon and overlay without putting in a new/modded zylonite_battdrv.dll

Also, what are the default values for the BatteryIconIdStart and BatteryIconlevels parms for the overlay bitmap? and can that be changed to reflect the 5%?

I hope these make sense.

0

Share this post


Link to post
Share on other sites

Thank you, works great.

I have another problem though. My omnia I 900 doesn't want to charge via emergency chargers. I've tried several of them - no luck. I've been using the same cable as I used to charge from my laptop. I've heard there is a registry fix to this problem . Can't find it, though. If there is a charger out there that is guaranteed to be working with I-900 I would buy it. I don't want to experiment with this anymore. I've become a frequent flyer in a local BEST BUY purchasing and returning chargers.

Thanks in advance.

0

Share this post


Link to post
Share on other sites

Says access denied when trying to rename the old dll, or copy the new one over the stock. Is there a problem with the new roms. I am using MrCapcom's 23034? There is the newer taskbar in these roms.

0

Share this post


Link to post
Share on other sites
Says access denied when trying to rename the old dll, or copy the new one over the stock. Is there a problem with the new roms. I am using MrCapcom's 23034? There is the newer taskbar in these roms.

The regular file explorer will not work. You need something like the TotalCommander file explorer to be able to copy over files in ROM.

0

Share this post


Link to post
Share on other sites

Doesn't work on my Omnia i900 (Dutch with XKHJ3) tried twice, installed certs en copied the new battery driver to \windows after renaming the org. and softreset

0

Share this post


Link to post
Share on other sites

Total noob question but I have resco explorer (also tried total commander) installed but when I try to rename the .dll it says access denied. Am I missing a setting in resco or something......?

Also, Has anyone tried using the modified dll to replace one that is not 43520 (I have an i910 btw)

Thanks

Edited by prodmage
0

Share this post


Link to post
Share on other sites

I used resco explorer and Verizon Omnia i910. I replaced the file successfully. Except I don't see any %.... still just a bar with no number. i installed the 256 version. hmm.. im gonna give the 64 one a shot now.

Gave 64 a shot too. Not working...

What am i doing wrong?

I installed the certs.cab into my device. then i copied over the zylonite.dll from the i910 zip and replaced the one in the windows dir. soft reset and went to check batt status and there aint no number. Im using WM6.5 the latest by BlueGill or something...

Edited by QuantumZero
0

Share this post


Link to post
Share on other sites
I used resco explorer and Verizon Omnia i910. I replaced the file successfully. Except I don't see any %.... still just a bar with no number. i installed the 256 version. hmm.. im gonna give the 64 one a shot now.

Gave 64 a shot too. Not working...

What am i doing wrong?

I installed the certs.cab into my device. then i copied over the zylonite.dll from the i910 zip and replaced the one in the windows dir. soft reset and went to check batt status and there aint no number. Im using WM6.5 the latest by BlueGill or something...

You have to install a taskbar that has the icons for battery percentages. See:

http://www.modaco.com/content/i9x0-omnia-h...kbars-for-i910/

0

Share this post


Link to post
Share on other sites

I couldn't work it on vie12 rom. How can i activate it ?

Edited by asfalt
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.