MoDaCo is undergoing planned maintenance. Site functionality may be reduced - follow @modaco or @paulobrien on Twitter for updates.

  • Announcements

    • Reminder - MoDaCo position on illegal content

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software
      Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)


      CUSTOM ROMS

      You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not be hosted directly in topic via the MoDaCo attachment system
      ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)
      ROMs must give full credit to the original author
      This decision has been taken in light of the huge amount of interest in this area of device customisation within the community, and member feedback! Please note that custom ROM discussion should be kept in specific device sub-areas, (e.g. Kaiser.MoDaCo.com for Kaiser based devices). ISSUES If you have any issues with this policy, please contact me directly via PM. P
    • Support MoDaCo by signing up to a MoDaCo Silver or Gold membership

      To sign up to an annual MoDaCo Silver subscription which will eliminate all ads from the site (as well as giving you access to the MoDaCo Online Kitchens for Android) for only £9.99 using PayPal, Credit or Debit Card, ensure you are logged in to the site, and then click the link below, which will take you directly to the subscription store! You can also sign up to an annual MoDaCo Gold subscription for £29.99, which adds the benefits listed below! PURCHASE A MODACO SUBSCRIPTION - FREE Titanium Backup Mobile for Android worth $5.99! - FREE 1 year PrivateInternetAccess.com worth $39.95! - FREE 1 year LastPass Premium worth $12! - FREE CalcConvert for Pocket PC from Binaryfish worth $17.95! - FREE Calendar Bar for Pocket PC from OmegaOne worth $9.99! - FREE CamerAware for Pocket PC and Smartphone from MoDaCo worth £19.99 / $30! - FREE Chronos for Pocket PC from ActiveKitten worth $14.95! - FREE CodeWallet Pro for Smartphone and Pocket PC from DeveloperOne worth up to $24.95! - FREE Concentrix for Pocket PC from eSoft Interactive worth $9.95! - FREE FlexMail for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE FTouchSL for Pocket PC from Vekoff s.r.o. worth 10 euro / $12.50! - FREE Jewel Challenge for Pocket PC from eSoft Interactive worth $9.95! - FREE John Cody's Alerts Pro for Smartphone from Omnisoft worth $14.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Dutch for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> French for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> German for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Italian for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Spanish for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Dutch for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> French for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> German for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Russian for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Turkish for Smartphone from Lingvosoft worth $49.95! - FREE Note2Self for Pocket PC and Smartphone from WebIS worth up to $19.90! - FREE Opera 8.60 for Pocket PC and Smartphone from Opera Software worth up to $48! - FREE Pocket Informant for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE Pocket Launcher for Pocket PC and Smartphone from Conduits worth $9.95! - FREE PTab for Pocket PC and Smartphone from z4soft worth up to $60! - FREE Resco Explorer for Pocket PC and Smartphone from Resco worth up to $49.90! - FREE Safemode for Pocket PC from monocube worth $12.95 - FREE SplashPhoto for Pocket PC and Smartphone from SplashData worth up to $59.90! - FREE Sprite Backup for Pocket PC and Smartphone from Sprite Software worth $29.95! - FREE Teksoft Glyphs UI for Pocket PC and Smartphone from Teksoft €9.95! - FREE Teksoft HeadsetRemote for Pocket PC and Smartphone from Teksoft €4.95! - FREE Traffic Jam for Pocket PC from eSoft Interactive worth $9.95! - FREE unlock (1 per year) from imei-check.co.uk - DISCOUNT of 10% at MoDaCo FairDeal - DISCOUNT of 10% at Semsons.com - FORUM - AD FREE SITE - FORUM - custom rank / title - FORUM - double competition entries - FORUM - double post attachment space - FORUM - no search flood control - FORUM - priority event registration - FORUM - triple PM space
    • Reminder: Selling items on the forum directly is not allowed

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspensions / ban.

Nav'n'Go iGo on TG01

76 posts in this topic

Posted · Report post

Hello,

Did anybody try to install iGo 8 on TG01? I spent 2 hours today, but I can't get working GPS module in Igo... Software can't find GPS receiver... Any ideas?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hello,

Did anybody try to install iGo 8 on TG01? I spent 2 hours today, but I can't get working GPS module in Igo... Software can't find GPS receiver... Any ideas?

you need franson gps gate!

this is answered in other threads. Here

People talk about tomtom but its the same problem.

0

Share this post


Link to post
Share on other sites

Posted · Report post

you need franson gps gate!

this is answered in other threads. Here

People talk about tomtom but its the same problem.

Garmin XT Mobile works just perfect, and it works with the built in GPS without any need of GPS Gate. It also can render maps in high details, which is probably usable only on TG01 at the mo, as it has the power to render such a complex map layout. Do play with the PPC version of Garmin XT and especially if you have a data plan on your phone contract you'll find this to be far superior to TomTom (even the x40 PNA Live series).

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hello,

Did anybody try to install iGo 8 on TG01? I spent 2 hours today, but I can't get working GPS module in Igo... Software can't find GPS receiver... Any ideas?

I'm using IGO8 (with GPSGATE, of course) and IMHO is awesome, much better than TOMTOM. I used it a lot last week on holidays driving in Lanzarote (Canary Islands, Spain) and it works perfect! No problems at all. With a WVGA skin yo have all the information available, and 3D graphics are incredible (you can see the sky, the mountains...)

Best Regards

Edited by xdalover
0

Share this post


Link to post
Share on other sites

Posted · Report post

I have iGO8 R3 as well (a reviewers evaluation copy) though due to NNG's licensing model and the need to remove the TG's battery to change cards, I also used an 'alternative channel' version :D

Both have worked fine 'out of the box'; for some reason, unlike other's experiences I haven't needed to use GPSGate. I don't know why there seem to be sample differences- mine is a stock UK Orange phone.

I'm currently using CPL8 which also loaded and runs without any problems.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Ok, after installation of GPSGate iGo started.. But it's not cool that you need to buy additional software...

0

Share this post


Link to post
Share on other sites

Posted · Report post

Ok, after installation of GPSGate iGo started.. But it's not cool that you need to buy additional software...

try Garmin Mobile XT, no gpsgate needed!! :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

try Garmin Mobile XT, no gpsgate needed!! :D

Sure. But I don't want to buy another software. I have also Polish navigation- Automapa, and it really does not want to work. Even with GPSGate...

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Both have worked fine 'out of the box'; for some reason, unlike other's experiences I haven't needed to use GPSGate. I don't know why there seem to be sample differences- mine is a stock UK Orange phone.

Strange... Can you check your GPS settings and tell us what the settings are ?

I'll also have some registry keys for you to check (I have to check the exact name of keys before).

EDIT : Here are the registry keys to check :

- HKEY_LOCAL_MACHINE\ControlPanel\GPS Settings

- HKEY_LOCAL_MACHINE\Services\InternalGPS

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver

- HKEY_LOCAL_MACHINE\Drivers\Active\74

- HKEY_LOCAL_MACHINE\Drivers\Active\75

- HKEY_LOCAL_MACHINE\Drivers\Active\76

- HKEY_LOCAL_MACHINE\Drivers\BuiltIn\gpsdriver

- HKEY_LOCAL_MACHINE\Drivers\BuiltIn\GPSID

- HKEY_LOCAL_MACHINE\Drivers\BuiltIn\RilGps

Edited by The Real Mc Coy
0

Share this post


Link to post
Share on other sites

Posted · Report post

Strange... Can you check your GPS settings and tell us what the settings are ?

I'll also have some registry keys for you to check (I have to check the exact name of keys before).

EDIT : Here are the registry keys to check :

- HKEY_LOCAL_MACHINE\ControlPanel\GPS Settings

- HKEY_LOCAL_MACHINE\Services\InternalGPS

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver

- HKEY_LOCAL_MACHINE\Drivers\Active\74

- HKEY_LOCAL_MACHINE\Drivers\Active\75

- HKEY_LOCAL_MACHINE\Drivers\Active\76

- HKEY_LOCAL_MACHINE\Drivers\BuiltIn\gpsdriver

- HKEY_LOCAL_MACHINE\Drivers\BuiltIn\GPSID

- HKEY_LOCAL_MACHINE\Drivers\BuiltIn\RilGps

Hi- sorry for not replying to this- completely missed it :D

Anyway, in the interests of community spirit, I reinstalled a version of iGO8 R3 that works on a big SD card (I do have a legitimate version locked to its supplied card) as I've been using CoPilot8 since its release due to its better support for traffic and speed cameras in UK.

As before, I have made no changes to the config settings of the TG01. External GPS is set at: Program Port: GPD9; Hardware: None; Baud: 4800. 'Allow Windows to

manage' is ticked.

Also as before, iGO8 loaded just fine (I run it direct from its exe file on the storage card- renamed 'application.dat' to 'igo8.exe'; I needed to soft reset after the initial loading as it ran out of memory but 2nd time it ran OK and after the EULA screens, iGO8 loaded. I went to the GPS screen and the GPS was already turned on and loading data. The status screen shows it on COM0 and 57600 Baud.

My version is iGO8 V 8.3.2.93112 dated June 8 2009

Registry Keys:

- HKEY_LOCAL_MACHINE\ControlPanel\GPS Settings:

I Have HKLM\Control Panel\Internal GPS which has 2 keys: 'Default'- value not set and 'Group' 0x1 (1)

- HKEY_LOCAL_MACHINE\Services\InternalGPS:

(default): Value not set

Description: no entry

DisplayName: no entry

Dll: InternalGPSService.dll

Index: 0x0 (0)

Keep: 0x1 (1)

Order: 0x10 (16)

Prefix: IGP

UnsignedService: 0x0 (0)

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver]

"OldLogFile"="\\windows\\GPSLogFileBack.txt"

"CurrentLogFile"="\\windows\\GPSLogFile.txt"

"IsEnabled"=dword:00000001

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer]

"DriverInterface"="GPD9:"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer\ActiveDevice]

"Index"=dword:00000009

"Prefix"="GPD"

"Context"=dword:12344160

"Flags"=dword:00000002

"Keep"=dword:00000001

"Dll"="GPSID.dll"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers]

"SleepOnNoData"=dword:000003E8

"RetryWaitOnError"=dword:00000003

"OutputBufferSize"=dword:00001000

"InputBufferSize"=dword:00001000

"CurrentDriver"="GPSOneDevice"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\GPSOneDevice]

"UMTSServerURL"="agpss.orange.co.uk:7275"

"ProcessOtherClientReports"=dword:00000000

"OpenStandalone"=dword:00000001

"FixInterval"=dword:00000001

"FixMode"=dword:00000002

"QOSAccuracy"=dword:00000032

"QOSPerformance"=dword:0000006E

"Version"=dword:00000002

"PollInterval"=dword:000001F4

"CommPort"="GPS0:"

"DriverName"="GPS Device Driver"

"FriendlyName"="QualComm GpsOne Card, version 0.0"

"InterfaceType"="POLL"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\GPSOneEmulate]

"Filex"="\\windows\\GPSOneFileSimulation.txt"

"FriendlyName"="QualComm GpsOne File, version 0.0"

"InterfaceType"="File"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\GPSOnePort]

"CommPort"="GPD10:"

"FriendlyName"="QualComm GpsOne Card, version 0.0"

"InterfaceType"="COMM"

- HKEY_LOCAL_MACHINE\Drivers\Active\74

[HKEY_LOCAL_MACHINE\Drivers\Active\74]

"Hnd"=dword:0031B430

"Name"="GPS0:"

"Key"="Drivers\\BuiltIn\\gpsdriver"

"BusParent"=dword:000AFD00

"InterfaceType"=dword:00000000

"BusName"="BuiltIn_0_21_0"

- HKEY_LOCAL_MACHINE\Drivers\Active\75

[HKEY_LOCAL_MACHINE\Drivers\Active\75]

"Hnd"=dword:0031AD50

"Name"="GPD0:"

"Key"="Drivers\\BuiltIn\\GPSID"

"BusParent"=dword:000AFD00

"InterfaceType"=dword:00000000

"BusName"="BuiltIn_0_22_0"

- HKEY_LOCAL_MACHINE\Drivers\Active\76

I don't have this key

- HKEY_LOCAL_MACHINE\Drivers\BuiltIn\gpsdriver

[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\gpsdriver]

"IClass"=hex(7):7B,00,41,00,33,00,32,00,39,00,34,00,32,00,42,00,37,00,2D,00,39,00,3

,\

00,30,00,43,00,2D,00,34,00,38,00,36,00,62,00,2D,00,42,00,30,00,45,00,36,00,\

2D,00,39,00,32,00,41,00,37,00,30,00,32,00,41,00,39,00,39,00,42,00,33,00,35,\

00,7D,00,00,00,00,00

"Flags"=dword:00000002

"Index"=dword:00000000

"Prefix"="GPS"

"Keep"=dword:00000001

"Order"=dword:00000099

"Dll"="gpsdriver.dll"

- HKEY_LOCAL_MACHINE\Drivers\BuiltIn\GPSID

[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\GPSID]

"Flags"=dword:00000002

"Context"=dword:00000000

"Index"=dword:00000000

"Prefix"="GPD"

"Keep"=dword:00000001

"Order"=dword:00000100

"Dll"="GPSID.dll"

- HKEY_LOCAL_MACHINE\Drivers\BuiltIn\RilGps

[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\RilGps]

"RilGpsPriority256"=dword:00000091

Hope this helps :angry: Most of my Reg Keys are in the attached ZIP file, but usual warnings apply- if you want to try them, make sure you take a backup first ;)

GPS_Reg_Keys.zip

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

GREAT !!!

I'm gonna try this and try to find out the bug ;)

Hi- sorry for not replying to this- completely missed it ;)

Don't worry :D There is no problem... you cannot have an eye on every topic you answer to ;)

That's very kind of you to give your settings :D

I can add to your recommendation : DO NOT TEST THIS UNLESS YOU EXACTLY KNOW WHAT YOU ARE DOING !!!

For example :

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\GPSOneDevice]

"UMTSServerURL"="agpss.orange.co.uk:7275"

should not work unless you are an Orange UK suscriber B)

For me it's not a problem as I know what I am doing and, furthermore, one more hard reset is not a problem for me :angry:

Edited by The Real Mc Coy
0

Share this post


Link to post
Share on other sites

Posted · Report post

Good luck :D

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Good luck :angry:

I imported all your reg keys but GPS still not detected... :D

By the way : can you share your SYS.TXT (if you have one) ?

Next step : downgrade to 8.3.2.93112 (I have 8.3.4.102680 dated 13 August 2009).

And maybe checking drivers versions...

Edited by The Real Mc Coy
0

Share this post


Link to post
Share on other sites

Posted · Report post

I imported all your reg keys but GPS still not detected... :D

By the way : can you share your SYS.TXT (if you have one) ?

Next step : downgrade to 8.3.2.93112 (I have 8.3.4.102680 dated 13 August 2009).

And maybe checking drivers versions...

I'm using the sys.txt supplied by whoever uploaded the files :angry:

[project]

name="igo8_pda"

[device]

type="SGH-i900"

sdcard_dsk_num=3

[folders]

app="%SDCARD%/iGO8"

[interface]

maxzoom2d=6000000

show_exit=1

skin="ui_igo8"

[rawdisplay]

highres=0

autoconfig=1

driver="GDI"

[map]

2dheadup=1

3d_max_tiltlevel=7800

3d_scale_carmodel=1

3dcarsizemin=3000

3dcarsizemax=4500

3dcarsizemul=10000

[debug]

reserve_memory=4088

cache=358444

0

Share this post


Link to post
Share on other sites

Posted · Report post

That's strange...

I made a hard reset yesterday evening because I had a lot of problems (but I test a lot of things so I already did at least 20 hard resets).

Using your sys.txt WITHOUT any registry modification and iGO8 tells me GPS Connected !!!

I am in a skyscrapper right now and furthermore it's raining like cats and dogs so I cannot get a fix... I'm gonna go out to test during my lunch (it's nearly 1pm here in France).

My best bet would be that the following parameter indicates to iGO to use the kind of GPS the TG01 is equiped with :

[device]

type="SGH-i900"

sdcard_dsk_num=3

If someone else could test and let us know...

0

Share this post


Link to post
Share on other sites

Posted · Report post

Well- at least thats some progress :D

Let us know how you get on!

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hello! I'm a TG01 owner from Romania and I use iGO8.3.2.93112 (8 jun 2009) with GpsGate 2.6

Firstly, I inserted in sys.txt only this items:

[device]

type="SGH-i900"

sdcard_dsk_num=3

I started iGO 8.3 and the gps receptor did not detect it... but when I copied all string in sys.txt... it worked without any help or additional settings !!!

Igo GPS is to COM2 with 57600 and Win6.1 settings remaind to GPD9 with automatic win managed port.

Special thanks for Neil5459 !!!

Marian

Edited by marianb
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

IT WORKS !!!!!! Without modifying any other parameter (COM port and so on...) !!!!

Tested with iGO 8.3.2.93112 and 8.3.4.102680 (dated 13 August 2009) !

Thanks alot Neil !

So now we can say iGO 8 works WITHOUT GPSGate :D

capture003.png

By trmc at 2009-09-01

To marianb : try without GPSGate and the sys.txt provided because we know that iGO works flawlessly WITH GPSGate on COM 2.

BTW : I just left the Automatic detection checked as you can see in the screenshot below (in French).

screen24.png

Edited by The Real Mc Coy
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Of course I started iGO without GpsGate, this is ideea in this topic!

I confirmed: WORK perfect without any modification in iGO settings, with all items in sys.txt

Marian

Edited by marianb
0

Share this post


Link to post
Share on other sites

Posted · Report post

Well I'm glad it's working, but I can't see which entry in sys.txt might be doing it :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

Neil5459 : I will try and report :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

Ok : if you remove the [device] section from your sys.txt it fails to detect GPS (plus there is a graphical issue) :angry:

screen25.png

By trmc at 2009-09-01

So my guess was good :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

Well I'm glad it's working, but I can't see which entry in sys.txt might be doing it :D

Hi there, I just copied this two line:

[device]

type="SGH-i900"

sdcard_dsk_num=3

and igo recognized the GPS.

My igo is "13 August version" and my SYS.txt is:

[folders]

app="%SDCARD%/iGO8"

[project]

name="igo8_pda"

[device]

type="SGH-i900"

sdcard_dsk_num=3

[debug]

skip_eula=1

disable_outlookpoi=0

sound_q_length=200

queue_length=200

[interface]

maxzoom2d=6000000

show_exit=1

mapfontscale=160

popup_info=1

vga=1

[rawdisplay]

driver="GX"

highres=1

[map]

2dheadup=1

3d_max_tiltlevel=8600

3d_max_zoomlevel=3000

3d_min_zoomlevel=20

3d_max_zfar=2000

3dcarsizemin=3500

3dcarsizemax=5000

3d_carsizeemul=6000

3d_zfar_horizon_ratio=200

max_poly_segments_shown_1=400 ;makes map drawing a lot faster

min_poly_segments_shown_1=200 ;makes map drawing a lot faster

[3d]

fade_distance_for_car=5

fade_distance_for_guidance_arrow=50

fade_overlap_tolerance=80

[3d_config]

rotated_roadsigns=0 ;názov ulice na ceste horizontalne(0) - otoceny(1)

disable_roadsign_navigation_mode=0 ; nazov v baloniku (0) - nazov na ceste(1)

[roundaboutcam]

enabled=0

centery=50

[sound]

ding=0

sound_q_length=200

queue_length=200

[sound.announcer]

gps_disconnected=0

gps_signal_lost=0

Recalc_voice=0

[power]

powermgm_state=0

backlight_day=100

Backlight_night=100

[tmc]

;port="COM,9"

;source="royaltek"

saved_config_available="1"

[warning]

warn_distances=110:500,80:350,60:300,40:250

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

At the end, only the entry

[device]

type="SGH-i900"

must be added. By the way , no one has commented that SGH-i900 is the Samsung OMNIA!! Any hidden relationship Samsung-Toshiba ?? :D

Warning, I've had crashes if I forget to turn off GPSGate!!

Confirmed , it works, but only on Igo8, we need GPS gate for other apps with GPS use. But for people only using Igo8, congratulations!

Edited by xdalover
0

Share this post


Link to post
Share on other sites

Posted · Report post

no one has commented that SGH-i900 is the Samsung OMNIA!! Any hidden relationship Samsung-Toshiba ?? :D

I or Neil said that I think...

I don't think that there is any "hidden relationship"... Just that the Omnia had the same problem and iGO devs solved it :angry:

In the next version I would not be surprised if there is a "TG-01" parameter added ;)

BTW I tried to post this on your spanish forum but I never succeded in posting ;)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.