MoDaCo is undergoing planned maintenance. Site functionality may be reduced - follow @modaco or @paulobrien on Twitter for updates.

  • Announcements

    • Reminder - MoDaCo position on illegal content

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software
      Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)


      CUSTOM ROMS

      You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not be hosted directly in topic via the MoDaCo attachment system
      ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)
      ROMs must give full credit to the original author
      This decision has been taken in light of the huge amount of interest in this area of device customisation within the community, and member feedback! Please note that custom ROM discussion should be kept in specific device sub-areas, (e.g. Kaiser.MoDaCo.com for Kaiser based devices). ISSUES If you have any issues with this policy, please contact me directly via PM. P
    • Support MoDaCo by signing up to a MoDaCo Silver or Gold membership

      To sign up to an annual MoDaCo Silver subscription which will eliminate all ads from the site (as well as giving you access to the MoDaCo Online Kitchens for Android) for only £9.99 using PayPal, Credit or Debit Card, ensure you are logged in to the site, and then click the link below, which will take you directly to the subscription store! You can also sign up to an annual MoDaCo Gold subscription for £29.99, which adds the benefits listed below! PURCHASE A MODACO SUBSCRIPTION - FREE Titanium Backup Mobile for Android worth $5.99! - FREE 1 year PrivateInternetAccess.com worth $39.95! - FREE 1 year LastPass Premium worth $12! - FREE CalcConvert for Pocket PC from Binaryfish worth $17.95! - FREE Calendar Bar for Pocket PC from OmegaOne worth $9.99! - FREE CamerAware for Pocket PC and Smartphone from MoDaCo worth £19.99 / $30! - FREE Chronos for Pocket PC from ActiveKitten worth $14.95! - FREE CodeWallet Pro for Smartphone and Pocket PC from DeveloperOne worth up to $24.95! - FREE Concentrix for Pocket PC from eSoft Interactive worth $9.95! - FREE FlexMail for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE FTouchSL for Pocket PC from Vekoff s.r.o. worth 10 euro / $12.50! - FREE Jewel Challenge for Pocket PC from eSoft Interactive worth $9.95! - FREE John Cody's Alerts Pro for Smartphone from Omnisoft worth $14.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Dutch for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> French for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> German for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Italian for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Spanish for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Dutch for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> French for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> German for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Russian for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Turkish for Smartphone from Lingvosoft worth $49.95! - FREE Note2Self for Pocket PC and Smartphone from WebIS worth up to $19.90! - FREE Opera 8.60 for Pocket PC and Smartphone from Opera Software worth up to $48! - FREE Pocket Informant for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE Pocket Launcher for Pocket PC and Smartphone from Conduits worth $9.95! - FREE PTab for Pocket PC and Smartphone from z4soft worth up to $60! - FREE Resco Explorer for Pocket PC and Smartphone from Resco worth up to $49.90! - FREE Safemode for Pocket PC from monocube worth $12.95 - FREE SplashPhoto for Pocket PC and Smartphone from SplashData worth up to $59.90! - FREE Sprite Backup for Pocket PC and Smartphone from Sprite Software worth $29.95! - FREE Teksoft Glyphs UI for Pocket PC and Smartphone from Teksoft €9.95! - FREE Teksoft HeadsetRemote for Pocket PC and Smartphone from Teksoft €4.95! - FREE Traffic Jam for Pocket PC from eSoft Interactive worth $9.95! - FREE unlock (1 per year) from imei-check.co.uk - DISCOUNT of 10% at MoDaCo FairDeal - DISCOUNT of 10% at Semsons.com - FORUM - AD FREE SITE - FORUM - custom rank / title - FORUM - double competition entries - FORUM - double post attachment space - FORUM - no search flood control - FORUM - priority event registration - FORUM - triple PM space
    • Reminder: Selling items on the forum directly is not allowed

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspensions / ban.

10/Mar 3.2 - MoDaCo Custom ROM for GSM Hero (now with online kitchen)

5697 posts in this topic

Posted · Report post

No, does not work.

Still the same.

br

phlo

OK, working on it now!

P

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Paul, the update went OK but I seem now to be having an issue with the memory card. I've discovered this as Facebook pictures are not downloading into linked contacts. Looking in settings reveals the phone sees the card, but after removing the card it does not see it when re-inserted until after a reboot.

Any thoughts?

EDIT

As a further update, booting into the recovery image and trying to load anything from SD card results in a failure to mount SD card.

EDIT 2

Phone is now stuck in reboot loop. HERO displayed on screen, i get the one android in the 'O', second android does not appear, this repeats.

ONE MORE EDIT

Removing the SD and doing a handset clear boot allows the handset to boot fully. Not sure what to do now.

Edited by munkimatt
0

Share this post


Link to post
Share on other sites

Posted · Report post

Version 1.1 uploaded - i've flashed this and downloaded paid apps from the market.

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Version 1.1 uploaded - i've flashed this and downloaded paid apps from the market.

P

after the push of build.prop, you need a wipe to get it running :-)

br

phlo

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Paul,

Have installed and flashed to v1.1 with the latest Radio as well and all appears to be fine on mine, excellent achievement!!! Really learnt a lot yesterday and today on how to do things on the phone!

Rich

0

Share this post


Link to post
Share on other sites

Posted · Report post

More things noticed, Superuser permissions will not load and the People application force closes. Facebook pictures still will not load although link is active (statuses are updated).

Just noticed that the memory card seems to have lost the partitions, and has reverted to one single partion...would I be right in thinking this is the problem?

0

Share this post


Link to post
Share on other sites

Posted · Report post

More things noticed, Superuser permissions will not load and the People application force closes. Facebook pictures still will not load although link is active (statuses are updated).

Just noticed that the memory card seems to have lost the partitions, and has reverted to one single partion...would I be right in thinking this is the problem?

Did you select to initialise the memory card at any point?

Sounds like something is screwy!

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Paul, the update went OK but I seem now to be having an issue with the memory card. I've discovered this as Facebook pictures are not downloading into linked contacts. Looking in settings reveals the phone sees the card, but after removing the card it does not see it when re-inserted until after a reboot.

Any thoughts?

EDIT

As a further update, booting into the recovery image and trying to load anything from SD card results in a failure to mount SD card.

EDIT 2

Phone is now stuck in reboot loop. HERO displayed on screen, i get the one android in the 'O', second android does not appear, this repeats.

ONE MORE EDIT

Removing the SD and doing a handset clear boot allows the handset to boot fully. Not sure what to do now.

Sounds like your SD is not partitioned correctly and/or has errors... try formatting / partitioning would be my advice - I have had this before on other ROMs.

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

I seem to be stuck in a reboot loop aswell. I suspect it might be linked to a2sd but I'm not sure.

http://pastebin.com/f51b96bae - dump from logcat just before the phone reboots again

/ # parted /dev/block/mmcblk0

 parted /dev/block/mmcblk0

 GNU Parted 1.8.8.1.179-aef3

 Using /dev/block/mmcblk0

 Welcome to GNU Parted! Type 'help' to view a list of commands.

 (parted) print

 print

 print

 Model: SD SU08G (sd/mmc)

 Disk /dev/block/mmcblk0: 7948MB

 Sector size (logical/physical): 512B/512B

 Partition Table: msdos


 Number  Start   End	 Size	Type	 File system	 Flags

  1	  32.3kB  7181MB  7181MB  primary  fat32		   lba

  2	  7181MB  7245MB  64.3MB  primary  linux-swap(v1)

  3	  7245MB  7948MB  703MB   primary  ext2

This is how my partitions look.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Sounds like your SD is not partitioned correctly and/or has errors... try formatting / partitioning would be my advice - I have had this before on other ROMs.

P

Cheers Paul, I'll re-partition when I get home, would you suggest re-install the updated ROM afterwards too?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I seem to be stuck in a reboot loop aswell. I suspect it might be linked to a2sd but I'm not sure.

http://pastebin.com/f51b96bae - dump from logcat just before the phone reboots again

/ # parted /dev/block/mmcblk0
parted /dev/block/mmcblk0
GNU Parted 1.8.8.1.179-aef3
Using /dev/block/mmcblk0
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print
print
print
Model: SD SU08G (sd/mmc)
Disk /dev/block/mmcblk0: 7948MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 32.3kB 7181MB 7181MB primary fat32 lba
2 7181MB 7245MB 64.3MB primary linux-swap(v1)
3 7245MB 7948MB 703MB primary ext2[/code]

This is how my partitions look.

Strange - you have FAT32/SWAP/EXT2? I run FAT32/EXT3/SWAP... I think the A2SD partition is expected to be the second partition.

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Paul you are a genius!

Just followed all the instructions - custom recovery image installed, nandroid backup, radio update and finally custom rom installed!!! :D

Done within 45mins, all working fine. Didn't need to do a wipe, contacts, emails, sms etc all intact.

Now need to look into apps to sd.... is it worth it? how much difference does it make?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Strange - you have FAT32/SWAP/EXT2? I run FAT32/EXT3/SWAP... I think the A2SD partition is expected to be the second partition.

P

Yep, but the ext2 is actually ext3 just that the partition type for that is the same as ext2 so parted prints ext2.

Gonna try and remake the order in a bit and try again and report back.

Did the logcat dump give you any clues?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yeah - I think swap being the second partition is your problem.

P

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Before I updated my phone this afternoon to the custom build, I read this article http://forum.xda-developers.com/showthread.php?t=534479 - read the first post for partition size info

So if the article is correct it would seem that there is a maximum size to the swap partition of 32MB. There is also a bit about changing the ext2 partition to ext3 - interesting - Hope this helps

Edited by Stevie B
0

Share this post


Link to post
Share on other sites

Posted · Report post

My setup on a 8GB card is a 32MB swap partition is partition 3, 512MB EXT3 as partition 2, then the main partition 1 as the rest - setup using gparted from ubuntu (via the live CD works fine!)

P

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

More things noticed, Superuser permissions will not load and the People application force closes. Facebook pictures still will not load although link is active (statuses are updated).

Just noticed that the memory card seems to have lost the partitions, and has reverted to one single partion...would I be right in thinking this is the problem?

I am having the same issues listed here. Both with 1.0 and 1.1.

I installed the custom restore jobby, then 1.0 then reset to factory. Booted fine but just these probs.

Then i installed 1.1 rebooted, installed newer radio, rebooted, factory reset, then re-formatted memory card. Still same problems.

I am using exchange activesync for my contacts and things.

(edit: one weird thing, after doing all this, i go into some of my contacts, and it is listing a status update on facebook, without me having to re-attach their profile. It is not a profile that would auto link as the name in the phone is quite different. The picture is not coming across though. I wonder if there is some detail stored in the contact info to link it to the facebook profile and this is being re-synced across with the exchange stuff. Maybe this is causing a problem.)

(edit 2: right, i have now noticed that there is a bit in the notes part of the contact detail that tells it about the facebook linking, if i remove this though in outlook, re sync contacts, re link the profile, i just get the force close thing. hmmmm)

Edited by rjefferis
0

Share this post


Link to post
Share on other sites

Posted · Report post

Investigating!

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yeah - I think swap being the second partition is your problem.

P

Yup, that was it. Shuffled the ext3 to partition 2 and stuff worked like a charm, incl. Swapper. Radio update worked awesome aswell.

On another note, thanks alot for all the work you do for the community Paul, it is much appreciated.

0

Share this post


Link to post
Share on other sites

Posted · Report post

No problem! :D

For those saying Facebook pictures aren't downloading properly, all fine here!

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

I am having the same issues listed here. Both with 1.0 and 1.1.

I installed the custom restore jobby, then 1.0 then reset to factory. Booted fine but just these probs.

Then i installed 1.1 rebooted, installed newer radio, rebooted, factory reset, then re-formatted memory card. Still same problems.

I am using exchange activesync for my contacts and things.

(edit: one weird thing, after doing all this, i go into some of my contacts, and it is listing a status update on facebook, without me having to re-attach their profile. It is not a profile that would auto link as the name in the phone is quite different. The picture is not coming across though. I wonder if there is some detail stored in the contact info to link it to the facebook profile and this is being re-synced across with the exchange stuff. Maybe this is causing a problem.)

(edit 2: right, i have now noticed that there is a bit in the notes part of the contact detail that tells it about the facebook linking, if i remove this though in outlook, re sync contacts, re link the profile, i just get the force close thing. hmmmm)

I'm in exactly the same boat as above (except I'm not using exchange, everything with me is via Google contacts) and also having the force close issue with attempting to link Facebook contacts.

Just to let you know Paul, I've tried 1.1 now as well, and re-partitioned the card and still no joy. card is set as follows.

Number Start End Size Type Files System Flags

1 512B 7200mb 7200mb primary fat32 lba

2 7200mb 7700mb 500mb primary ext3

3 7700mb 7732mb 32.0mb primary linux-swap(v1)

if you need anything else, just let me know

0

Share this post


Link to post
Share on other sites

Posted · Report post

No problem! :D

For those saying Facebook pictures aren't downloading properly, all fine here!

P

Out of interest, where are your contacts stored? (Just trying to find any clues as to why they aren't downloading here!)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

i have just tried hard resetting the phone, before setting it up again i went through in outlook and removed all the notes sections that link to the facebook profiles for every contact.

I then re setup the phone and tried linking the profiles again from scratch. I have about 250 contacts and it auto linked about 30, as soon as it got to the end of the little bar it crashed again.

The error (The process android.process.acore has stopped unexpectedly. Please try again) Seemed to be quite common on the G1 didnt it? Probably unrelated though.

EDIT!! (Couple more point to note 1. It seems to crash on mine, even if i only have the link birthday thing ticked and no photo. 2. If you are doing people 1 at a time it crashes, but it does seem to actually do it. ie. The picture does change to their fb pic when you next load it.

Edited by rjefferis
0

Share this post


Link to post
Share on other sites

Posted · Report post

Paul. Just tried it. Installed perfectly. Works a treat. Thanks man! btw first time here in years. Since qtek 8310 and previous SPV's. Good to be back hehehe

0

Share this post


Link to post
Share on other sites

Posted · Report post

The one thing I miss having an iPhone - fiddling!

Same :D

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.