• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

TomTom and internal GPS on WM65

42 posts in this topic

Posted (edited)

You can just edit the register to make this work. Here is the registry tweak you need:

http://www.mediafire.com/?wekzxhz1x0d

Make sure to take a backup of your registry first :)

Edited by Chivas610
0

Share this post


Link to post
Share on other sites

Posted

You can just edit the register to make this work. Here is the registry tweak you need:

http://www.mediafire.com/?wekzxhz1x0d

Make sure to take a backup of your registry first :)

Not working on my Omnia with JC1(by Kies). But GPS stops working on other Navigation progs... Restored my backup.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Not working on my Omnia with JC1(by Kies). But GPS stops working on other Navigation progs... Restored my backup.

What gps settings did you use in Tomtom? You must use other nmea / 4800 baud rate / com7

It should work with internal too, but then you need to change the gps port (can't remember to what, but can look it up if needed). Anyway, it works fine on my O2 (tried several roms, and works on everyone).

EDIT: use com port 4 (and 9 for hardware) for internal gps...might be optional tho...

Edited by Chivas610
0

Share this post


Link to post
Share on other sites

Posted

Okay, I have checked this out with my own device now.

Procedure to make TomTom work with internal GPS:

1: Backup your registry

2: Install the gpsfix cab from post #26

3: Restart your device

4: In GPS setting; set program com port to 4

5: Start Tomtom, go to gps settings and set it to use the internal gps

6: Allow Tomtom some minutes to get gps fix for the first time. After that it should go much faster.

7: Enjoy! :)

PS: You can skip #4 and use "other nmea gps" / baud 4800 / com7 in tomtom gps settings - this works too

Reports from other sites tells this is working, and it's working splendid on my device too ;)

0

Share this post


Link to post
Share on other sites

Posted

Has anybody tried typing in *#1472365# into their Omnia2?

It brings up some extra gps settings, some of which are similar to settings that can be reached in registry but some are unique.

The main one that was of interest to me was the start up mode of GPS.

Mine was set to cold start which meant that every time i started my tomtom it did so by deleting all previous data.

This meant i was on a cold start each and every time i used it which was why it took forever to lock sometimes.

I have now changed this setting to "hotstart" and my locks are instant.

There are various other settings that can be played with and tried out but this setting alone got rid of the only flaw i could find in the Omnia2.

0

Share this post


Link to post
Share on other sites

Posted

I compared the registry of my brothers htc (which has tomtom working)and my omnia i8000 and saw that among other htc specific settings one of the differences was that the intermediate driver had no buffer settings in registry.

I decided to back up my registry and delete both incoming and outgoing buffers and now i have an immediate signal and once locked it does not jump from one satellite to another, they are consistent blue bars.

i have it set to com4 with 4800 baud rate. and it is set to built in gps in tomtom.

i recommend that everybody try this but please back up your registry first.

Please provide some feedback and let others know if it works for you

0

Share this post


Link to post
Share on other sites

Posted

I compared the registry of my brothers htc (which has tomtom working)and my omnia i8000 and saw that among other htc specific settings one of the differences was that the intermediate driver had no buffer settings in registry.

I decided to back up my registry and delete both incoming and outgoing buffers and now i have an immediate signal and once locked it does not jump from one satellite to another, they are consistent blue bars.

i have it set to com4 with 4800 baud rate. and it is set to built in gps in tomtom.

i recommend that everybody try this but please back up your registry first.

Please provide some feedback and let others know if it works for you

What are the registry entries?

0

Share this post


Link to post
Share on other sites

Posted (edited)

I tried to use GPSMod Driver. My TT works, but lag was very big. On another GPS programs everything was ok.

I made some register changes (credits to user JaCoL_JcL from peb.pl forum) and now TT works OK, without GPSMod Driver, with XTRA, without lag.

Modifications:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\InputBufferSize: change from 4096 to 512

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\OutputBufferSize: change from 4096 to 512

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\SleepOnNoData: change from 100 to 0

HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer\MaxBufferSize: change from 16384 to 1024

My TT is 7.917 (9186)

Edit:

The same solution I found today in this post:

http://www.modaco.com/index.php?showtopic=...t&p=1205366

Edited by KMPB
0

Share this post


Link to post
Share on other sites

Posted

What are the registry entries?

like i said i deleted all buffers under intermediate driver in registry.

I have received positive feedback on this method, in other threads i have posted on (although some people have experienced poor accuracy but that is a seperate issue which i have also tweaked to pinpoint accuracy).

I will be taking screen shots of the relevant registry pages just as soon as i get a chance.

0

Share this post


Link to post
Share on other sites

Posted

What are the registry entries?

Please see post 95 in the following thread for my registry settings which give me a very fast fix with excellent accuracy.

http://www.modaco.com/content-page/275659/...0/#entry1238381

0

Share this post


Link to post
Share on other sites

Posted

Tomtom and I8000:

The problem is that TT does not start the GPS, so you can start it with another program o samething like that (you can use gpsfix, gpsmoddriver...) but i don't know what some roms (o some i8000's) starts correctly the GPS, so you do not need to use another program, it's problem of tt and smasung that they are not 100% compatibles

0

Share this post


Link to post
Share on other sites

Posted

i can't get run GPSproxy.

he don' give me the coordinate and if i look in tomtom 7 it say no GPS signal what should i do??

0

Share this post


Link to post
Share on other sites

Posted

Okay, I have checked this out with my own device now.

Procedure to make TomTom work with internal GPS:

1: Backup your registry

2: Install the gpsfix cab from post #26

3: Restart your device

4: In GPS setting; set program com port to 4

5: Start Tomtom, go to gps settings and set it to use the internal gps

6: Allow Tomtom some minutes to get gps fix for the first time. After that it should go much faster.

7: Enjoy! ;)

PS: You can skip #4 and use "other nmea gps" / baud 4800 / com7 in tomtom gps settings - this works too

Reports from other sites tells this is working, and it's working splendid on my device too :P

Before I actually did this, my problem was it isn't working with Tomtom but my GPS is working with BeelineGPS but after using this procedure -- everything isn't working anymore. The fix actually ruined my GPS. Is there a way to undo this?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Please see post 95 in the following thread for my registry settings which give me a very fast fix with excellent accuracy.

http://www.modaco.com/content-page/275659/...0/#entry1238381

This worked for me!

Now IGO8, Navigon and Tomtom are working quiet well! Fast Satfix. Never before managed to get all these Programs together to work.

I´m using JJ1 phone and Eboot and JI1 MS-Team Light rom.

I have built an cab-file for this. It changes reg-keys and you will find in Programs\jo GPS-Fix I8000... folder another cab file with my original Registry settings. So if you want to restore use this cab.

Before you install my cab, please make Registrybackup!!!!

It would be nice, if anyone gave me some Feedback.

Keys, I have changed:

HKLM\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware:

		 InputBufferSize			512							  original: 4096

		 OutputBufferSize		   512							  original: 4096

		 SleepOnNoData			   0							   original: 100


HKLM\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer:

		 MaxBufferSize			  1024							 original: 16384


HKLM\Software\samsung\RIL\GPS:

		 Accuracy					1								original: 19

		 MaxLocationAge			  0								original: 0(?)

		 QOPDelay					0								original: 12

		 ResponseTime				0								original: 2

		 Vaccuracy				   1								original: 0

I´m using it with GPS Port 9, ProgramPort 7, Baud 9600 on all three navigation programs

I hope this will help anybody.

Regards

jo_GPS_FixI8000_IgoNavigonTomtom.cab

Edited by y17dt
0

Share this post


Link to post
Share on other sites

Posted

This worked for me!

Now IGO8, Navigon and Tomtom are working quiet well! Fast Satfix. Never before managed to get all these Programs together to work.

I´m using JJ1 phone and Eboot and JI1 MS-Team Light rom.

I have built an cab-file for this. It changes reg-keys and you will find in Programs\jo GPS-Fix I8000... folder another cab file with my original Registry settings. So if you want to restore use this cab.

Before you install my cab, please make Registrybackup!!!!

It would be nice, if anyone gave me some Feedback.

Keys, I have changed:

HKLM\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware:

		 InputBufferSize			512							  original: 4096

		 OutputBufferSize		   512							  original: 4096

		 SleepOnNoData			   0							   original: 100


HKLM\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer:

		 MaxBufferSize			  1024							 original: 16384


HKLM\Software\samsung\RIL\GPS:

		 Accuracy					1								original: 19

		 MaxLocationAge			  0								original: 0(?)

		 QOPDelay					0								original: 12

		 ResponseTime				0								original: 2

		 Vaccuracy				   1								original: 0

I´m using it with GPS Port 9, ProgramPort 7, Baud 9600 on all three navigation programs

I hope this will help anybody.

Regards

y17dt! It works like a charm for me! No additional drivers and applications needed!

TT v.7 is working in a few seconds after it is started.

Great work. Thank you very very much!

0

Share this post


Link to post
Share on other sites

Posted

thanx mate! it worked for me. i8000 with Rapids latest JI1 ROM

This worked for me!

Now IGO8, Navigon and Tomtom are working quiet well! Fast Satfix. Never before managed to get all these Programs together to work.

I´m using JJ1 phone and Eboot and JI1 MS-Team Light rom.

I have built an cab-file for this. It changes reg-keys and you will find in Programs\jo GPS-Fix I8000... folder another cab file with my original Registry settings. So if you want to restore use this cab.

Before you install my cab, please make Registrybackup!!!!

It would be nice, if anyone gave me some Feedback.

Keys, I have changed:

HKLM\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware:

	     InputBufferSize			512						  	original: 4096

	     OutputBufferSize	       512						  	original: 4096

	     SleepOnNoData		       0						       original: 100


HKLM\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer:

	     MaxBufferSize		  	1024						     original: 16384


HKLM\Software\samsung\RIL\GPS:

	     Accuracy					1								original: 19

	     MaxLocationAge		  	0								original: 0(?)

	     QOPDelay					0								original: 12

	     ResponseTime				0								original: 2

	     Vaccuracy			       1								original: 0

I´m using it with GPS Port 9, ProgramPort 7, Baud 9600 on all three navigation programs

I hope this will help anybody.

Regards

0

Share this post


Link to post
Share on other sites

Posted (edited)

This worked for me!

Now IGO8, Navigon and Tomtom are working quiet well! Fast Satfix. Never before managed to get all these Programs together to work.

I´m using JJ1 phone and Eboot and JI1 MS-Team Light rom.

I have built an cab-file for this. It changes reg-keys and you will find in Programs\jo GPS-Fix I8000... folder another cab file with my original Registry settings. So if you want to restore use this cab.

Before you install my cab, please make Registrybackup!!!!

It would be nice, if anyone gave me some Feedback.

Keys, I have changed:

HKLM\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware:

         InputBufferSize			512					  		original: 4096

         OutputBufferSize           512					  		original: 4096

         SleepOnNoData	           0					           original: 100


HKLM\System\CurrentControlSet\GPS Intermediate Driver\Multiplexer:

         MaxBufferSize	  		1024					         original: 16384


HKLM\Software\samsung\RIL\GPS:

         Accuracy					1								original: 19

         MaxLocationAge	  		0								original: 0(?)

         QOPDelay					0								original: 12

         ResponseTime				0								original: 2

         Vaccuracy		           1								original: 0

I´m using it with GPS Port 9, ProgramPort 7, Baud 9600 on all three navigation programs

I hope this will help anybody.

Regards

you da man !!

worked perfect for me, after a week of messing around to get this to work

thanks for posting the info !

edit: ooops spoke to soon. locked the gps perfectly when i first installed the fix, but next day back to the same problem, tomtom cant lock onto satelites

Edited by nitrozen
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.