• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

O2Compass and O2Flash

501 posts in this topic

Posted

amaizing job rapid. congrats!

0

Share this post


Link to post
Share on other sites

Posted

Great program, great job

0

Share this post


Link to post
Share on other sites

Posted

works great on my Omnia 2 running 6.5.3 JE3. Actually, now I got calibrate the compass (for the first time) :(

I was using the 2.0 version, and never could calibrate it...

0

Share this post


Link to post
Share on other sites

Posted

Rapid,

Your work on this project is amazing. I just got my Omnia II a couple weeks ago, and I have read every message of this thread because I have been enthralled with the process that has led to the latest release. A beer on me is headed your way.

Everything in the 3.31 build is working great on my i920 except a couple minor issues:

1. The spirit level is always off by 10-11 degrees on the positive side of the horizontal axis. I have calibrated the phones motion settings, and they show spot on. Still, when I go into the spirit level it is always off. Maybe adding some kind of trim controls to manually adjust the level would be useful.

2. When I press the "save current location" button the program crashes. Details of the error state: "DirectoryNotFoundException" Is there a folder or something that needs to be created to store saved locations. I am able to save locations manually by typing in the coordinates.

Again. Great work, and have a cold one on me. :(

0

Share this post


Link to post
Share on other sites

Posted

Rapid,

Your work on this project is amazing. I just got my Omnia II a couple weeks ago, and I have read every message of this thread because I have been enthralled with the process that has led to the latest release. A beer on me is headed your way.

Everything in the 3.31 build is working great on my i920 except a couple minor issues:

1. The spirit level is always off by 10-11 degrees on the positive side of the horizontal axis. I have calibrated the phones motion settings, and they show spot on. Still, when I go into the spirit level it is always off. Maybe adding some kind of trim controls to manually adjust the level would be useful.

2. When I press the "save current location" button the program crashes. Details of the error state: "DirectoryNotFoundException" Is there a folder or something that needs to be created to store saved locations. I am able to save locations manually by typing in the coordinates.

Again. Great work, and have a cold one on me. :)

1. I don't know what might that is.

2. That's my fault. I missed 1 line in the code. I udated the cab. Download it again and try. It should work now. :)

0

Share this post


Link to post
Share on other sites

Posted

1. I don't know what might that is.

2. That's my fault. I missed 1 line in the code. I udated the cab. Download it again and try. It should work now. :)

Yep, the update fixed the error. Thanks.

As for the Spirit Level being off, I found a work around. I prop up my phone to read 0 by 0; then I go to the phones motion settings and calibrate. The Spirit Level will then read 0 by 0 on a flat surface.

Nevertheless, I think it would be useful to have a "tare" button similar to one on a scale. Then if it is not possible to find a flat surface the user could "zero out" the spirit level for a baseline.

0

Share this post


Link to post
Share on other sites

Posted

I got the same result with you lightsensor test program on my B7610. Did you share the code of the test program with the Samsung developers?

I'll send them an email about the problem and hope they can solve it. Thanks for you the great effort you took to help the b7610 users.

0

Share this post


Link to post
Share on other sites

Posted

Yep, the update fixed the error. Thanks.

As for the Spirit Level being off, I found a work around. I prop up my phone to read 0 by 0; then I go to the phones motion settings and calibrate. The Spirit Level will then read 0 by 0 on a flat surface.

Nevertheless, I think it would be useful to have a "tare" button similar to one on a scale. Then if it is not possible to find a flat surface the user could "zero out" the spirit level for a baseline.

I'll try to put an option to open the Samsung's motion sensor calibration app. I looked into it last night, but the setting_b.exe need some kind of parameter to open the calibration screen. I'll try to figure it out.

I got the same result with you lightsensor test program on my B7610. Did you share the code of the test program with the Samsung developers?

I'll send them an email about the problem and hope they can solve it. Thanks for you the great effort you took to help the b7610 users.

I attached the source code. It's written in VB.NET with VS2008. The program just PInvokes the 2 functions of the SamsungMobilesdk_2.dll, the SmiLightSensorGetCapabilities and SmiLightSensorGetIlluminance.

I modified it to see the results clearly.

B7610LightSensorTest.zip

0

Share this post


Link to post
Share on other sites

Posted

Hi.. I´ve bought an Omnia Pro... I've installed it but I can't run, I always receive a message "Message text unavailable. Resource file 'Microsoft.Visualbasic. resources' not found...

Could you please give some help.

I have cf 3.5 installed...

0

Share this post


Link to post
Share on other sites

Posted

Hi.. I´ve bought an Omnia Pro... I've installed it but I can't run, I always receive a message "Message text unavailable. Resource file 'Microsoft.Visualbasic. resources' not found...

Could you please give some help.

I have cf 3.5 installed...

CF 3.5 enabled too?

What says when you tap on the details button?

0

Share this post


Link to post
Share on other sites

Posted

works great for me, thanks very much! love the hd2 theme too...!

0

Share this post


Link to post
Share on other sites

Posted

Hello Rapid

I want to suggest a thing about the skinning feature: is it possible to avoid installing the skins and instead read them directly from the .cab file (cab is a simple container) placed in a subfolder of the application?

So the multimedia browser does not find over 400 images of the compass themes :)

Cheers, continue the good work you are doing!

0

Share this post


Link to post
Share on other sites

Posted

Great app, but metal detector and light sensor does not work on my Omnia Pro - anyone else with Omnia Pro have seen this running? Any suggestions?

Thank you!

0

Share this post


Link to post
Share on other sites

Posted

I am having problems with the flashlight working on my Omnia 2 (i920). Its not just these programs though. It also won't work on other "flashlight" programs like SSbubbleLevel. It used to work when I originally installed the apps many months ago. Not sure if I have a setting turned off or what or if an update caused the problem.

Anyone have any ideas where to start trouble shooting this issue? The flash still works with the camera so its not the LED Flash being out/broke.

Only update was the Samsung DC 23 update.

Thanks in advance,

0

Share this post


Link to post
Share on other sites

Posted

Only update was the Samsung DC 23 update.

Thanks in advance,

And what is that?

0

Share this post


Link to post
Share on other sites

Posted (edited)

And what is that?

samsung's software update for the i920. it can be found on the samsung website.

Update: Flashed my Rom with Ninja4hire's NinjaToday Rom and now it works again.

Edited by jcarter32
0

Share this post


Link to post
Share on other sites

Posted (edited)

And what is that?

dc23 is an official update for the full system from verizon/samsung.

it bumps the windows version up to 6.5. it also comes with .net framework version of 3.5.9198.0

UPDATE: The flashlight is working fine for me, on a relatively un-molested DC23 firmware on my verizon i920.

Edited by rxkaffee
0

Share this post


Link to post
Share on other sites

Posted (edited)

I tried the new version 3.31 but I can't install my favorite HTC theme... It can't see the theme except if is a new way to change it and not anymore the sliding... I had to go back to 3.3 :(

I read the update in first post BUT : When I installed the HTC theme the CAB DIDN'T put itself in the "Theme" directory but installed ALL the dirs in the main directory and when I tried to slide for the change did nothing...

Can I do it manually? And I need to create a new dir called "HTC" or something else? Or to replace the "Original Theme"?

ANY comment?

Edited by Terry666
0

Share this post


Link to post
Share on other sites

Posted

Hi, your application is very impressive.

I am giving it a try right now on my Omnia Pro (B7610).

While I was playing around with it I had some ideas.

First about the metal detector.

As I understand it detects the change of the "lines" of the magnetic field (I hope I use the right words, my english aren' t so strong) by using the "magnetometer" that the phone has (the same that the compass uses). I guess that is the reason that we must be careful not to move the device while we are using it. Because of this restriction the feature is more of a play than of a really useful tool.

I do not know if it is possible to use the motion and position sensors that I think the phone includes and use their input to counteract any phone movements. That way the application would display on the screen only the affect of the metal object.

The second idea that i had is that it would be nice and fit with the application's "character" to have an extra screen / feature with a ruler. The user could select the units (cm, in) and the scale that he wants to use (like in the maps "1:1000" or others).

It would also be nice not to use static images for various ruler settings (unit, scale) but to have the application compute and draw the right ruler taking into account the dimensions and resolution of each device's screen (that information could be provided by the user).

I just wanted to share this ideas with you. I hope I wasn't to tedious and anyway even without these extra features the application seems very good.

Keep up the good work.

0

Share this post


Link to post
Share on other sites

Posted

if you notes that is two power of light in omnia 2

and your flash program is but the flash in the first power

capture a pic in dark without auto focusing fast click and see the light

and capture a pic in dark with auto focusing and see the power of the light

see .

can you make as a O2 flash with the powerfull light ??

THANK you .. and sorry my english is weak . :D

0

Share this post


Link to post
Share on other sites

Posted

if you notes that is two power of light in omnia 2

and your flash program is but the flash in the first power

capture a pic in dark without auto focusing fast click and see the light

and capture a pic in dark with auto focusing and see the power of the light

see .

can you make as a O2 flash with the powerfull light ??

THANK you .. and sorry my english is weak . :D

The Samsung SDK only supports the first light.

0

Share this post


Link to post
Share on other sites

Posted

useful apps :huh:

0

Share this post


Link to post
Share on other sites

Posted

useful apps ;)

Hey, rapid. Great app. Everything I have tried seems to work like a charm. The only question I have is this: It seems to need the original calibration after ever soft reset - I get the screen to rotate it in 3- axes after every soft reset. If I do the calibration, I can shut it down and restart it and go straight to the compass - no recal needed.

I scanned the whole thread, but didn't see anywhere this is mentioned. Is this normal? Regardless, it's a great app, and spinning it a few times isn't any kind of hardship! :huh:

0

Share this post


Link to post
Share on other sites

Posted

thanks..

0

Share this post


Link to post
Share on other sites

Posted

Thank you rapid it was a great info i did not know

and can you give us that SDK i really love to try it

some day !!!

THANKS AGAIN >>>SEE YA

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.