• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

i8000 TMC driver development

178 posts in this topic

Posted · Report post

Any idea if enabling this in Copilot 8 is possible? They have a traffic update option, but it's subscription based. Which is kind of ridiculous if it's free OTA.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Any idea if enabling this in Copilot 8 is possible? They have a traffic update option, but it's subscription based. Which is kind of ridiculous if it's free OTA.

This will work on iGO and on Navigon, not on Copilot.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hmmmm.... can't get it to show TMC data in iGO. What baudrate do you use?

0

Share this post


Link to post
Share on other sites

Posted · Report post

dear phj I get 404 error from your site...

0

Share this post


Link to post
Share on other sites

Posted · Report post

dear phj I get 404 error from your site...

Correct url

0

Share this post


Link to post
Share on other sites

Posted · Report post

Will this work in the USA on the i920?

In the case the regional setting I implemented well, and the i920 has the same hardware as the I8000, must be.

0

Share this post


Link to post
Share on other sites

Posted · Report post

In the case the regional setting I implemented well, and the i920 has the same hardware as the I8000, must be.

cool. I'll have to give it a go.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you, I edited the post also

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hmmmm.... can't get it to show TMC data in iGO. What baudrate do you use?

I think the baudrate count nothing in this case, because the COM port is virtual... Otherwise I used 57600.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thank You PHJ! It's a great job. :)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Here You are, how works the program together iGO8 at Budapest. :)

hypera_www.kepfeltoltes.hu_.jpgtmc1_www.kepfeltoltes.hu_.jpg

igotmc_www.kepfeltoltes.hu_.jpgigotmc2_www.kepfeltoltes.hu_.jpg

Screenshot_45_www.kepfeltoltes.hu_.jpgScreenshot_50_www.kepfeltoltes.hu_.jpg

Thx Patience for screenshots!

Edited by frici001
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Nice work! The static TMC setting works.

How is it with dynamik search? No green stripe and "no TMC" Or must I wait a very long time?

Greetings _joker_

post-591067-1263933190_thumb.jpg

Edited by _joker_
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Nice work! The static TMC setting works.

How is it with dynamik search? No green stripe and "no TMC" Or must I wait a very long time?

Greetings _joker_

Just examining the problem. Because of a mystic reason, the seek operation took 10-20 seconds, therefore the iGO never find a valid channel. Until solved please use in static mode..

Edited by phj
0

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you, I edited the post also

thank you both

i think it works for me too but we dont have a tmc information in our town, i travel a lot gonna try it thanks again

0

Share this post


Link to post
Share on other sites

Posted · Report post

awesome app , just a shame i wont be able to use it as tomtom on the omnia2 does not have tmc functions.

actually all tomtom versions on a pda / phone dont have tmc functions.

and i didnt / dont like igo so tobad for me :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

brilliant driver :)

It works good with Royaltek and I receive loads of TMCs, but I receive only cryptic data in GNS mode.

Is there any chance that you decode/implement the GNS protocol as well as some of us are using Navigon 7 that only takes GNS?

Cheers

Marc

0

Share this post


Link to post
Share on other sites

Posted · Report post

awesome app , just a shame i wont be able to use it as tomtom on the omnia2 does not have tmc functions.

actually all tomtom versions on a pda / phone dont have tmc functions.

and i didnt / dont like igo so tobad for me :)

You could also try Sygic or Navigon, as TomTom for PDA is ancient in comparison to iGO, Sygic or Navigon imo

0

Share this post


Link to post
Share on other sites

Posted · Report post

brilliant driver :)

It works good with Royaltek and I receive loads of TMCs, but I receive only cryptic data in GNS mode.

Is there any chance that you decode/implement the GNS protocol as well as some of us are using Navigon 7 that only takes GNS?

Cheers

Marc

Unfortunately I'm not responsible for the TMC protocols - it is done by hypergps.dll , so please contact BeemerTPPC at xda.

0

Share this post


Link to post
Share on other sites

Posted · Report post

You could also try Sygic or Navigon, as TomTom for PDA is ancient in comparison to iGO, Sygic or Navigon imo

Yea i was looking at sygic but im not sure if it can work with this TMC app ?

Navigon is way off on the routes i do all the time when i last tested it a year ago maybe it has become better now ?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yea i was looking at sygic but im not sure if it can work with this TMC app ?

Navigon is way off on the routes i do all the time when i last tested it a year ago maybe it has become better now ?

There is no any special in the implementation - any GPS sw. must work with it which can read Royaltek or GNS formatted TMC data on a serial port, so I think yes.

Issued a new version 1.3. The debug code removed and there are two settings in registry which can be modify: HKLM\Software\gfmapi\ms, which is the cycle time in msec - in this frequency will be queried the chip for valid RDS data; slower (bigger number) reduces the power consumption, quicker yield more TMC messages in a given time. The rssi is the minimum seek RSSI threshold, the automatic scan stops when this value is reached. But until I will find the reason why the auto scan take such a ling time, I removed this and implement a single channel step instead, which is quick but it takes long time for iGO to scan the full band...

0

Share this post


Link to post
Share on other sites

Posted · Report post

Unfortunately I'm not responsible for the TMC protocols - it is done by hypergps.dll , so please contact BeemerTPPC at xda.

To enable GNS TMC you need to set TMC mode in HyperGPS to TMC+GPS, then it should work fine.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Could someone explain to a noob like me what this actually does?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Could someone explain to a noob like me what this actually does?

it allows you to get traffic updates over the FM radio for your GPS nav software.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hey guys, first: Great job!!

Second: Do i have to plug the earpice for enhance the radio signal? Or it should work without the earpice?

My problem is: i went to phj page, downloaded and installed all the stuff.

Then i opened the HyperGPS, enabled TMC at COM4.

Opened iGO, and told it to look for TMC hardware. Then i receive a MSG that TMC is not available... Is this due a lack of radio signal or my city does not have TMC?

Edited by Qualquer coisa
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.