• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

13/Jan 1.2 - Superboot - rooting the Tattoo

73 posts in this topic

Posted

The final fastboot reboot is erroneous, and not required for the Tattoo fastboot.

When it boots and hangs, do you get the splash screen? Is the device visible to adb?

P

0

Share this post


Link to post
Share on other sites

Posted

Thanks mainfram3, I am trying to mount the right partition then. Hmmm...

P

0

Share this post


Link to post
Share on other sites

Posted

1.2 hangs in the same spot.

It never reaches the fastboot reboot command.

C:\1.2-tattoo-superboot>fastboot-windows boot tattoo.superboot.img

< waiting for device >

downloading 'boot.img'... OKAY

booting...

I'll post the output of those adb commands shortly.

I have the same problem....some solution? thanks for all

0

Share this post


Link to post
Share on other sites

Posted

I have the same problem....some solution? thanks for all

Same here.

If I pull the USB cable I get a spalscreen with 3 android chaps.

0

Share this post


Link to post
Share on other sites

Posted

That link is not wget frendly :)

Either way, same result as the others, hangs on "booting...".

No change in the phone screen, still display htc logo, on black background.

Disconnecting USB shows the 3 skating androids, with RUU on top.

0

Share this post


Link to post
Share on other sites

Posted

Gah, very strange!

Not sure what more I can do until I get a Tattoo...

P

0

Share this post


Link to post
Share on other sites

Posted

Same problem :)

0

Share this post


Link to post
Share on other sites

Posted

Could someone confirm they have also tried my alternate boot image from here?

Attempted to use both standard and alt boot img files. Hangs in the same place. Modified the install-superboot-mac.sh file to this (chmod the two other files prior to running this script):

./adb-mac shell reboot oem-78
echo Waiting 10 seconds for reboot...
sleep 10
echo Booting superboot...
./fastboot-mac boot tattoo.superboot.1.1.alternate.img
./fastboot-mac reboot
echo Done!
[/codebox]

0

Share this post


Link to post
Share on other sites

Posted

same results with both images either with script or manually :) (

always hangs in booting !

How long should be this step when it succeed ?

I have tried manually with boot standard and alternate image and I also hangs at booting

(tried on winXP SP2)

downloading 'boot.img'... OKAY

booting...

0

Share this post


Link to post
Share on other sites

Posted

I fear it's doing some sort of signature checking, hence not booting...

P

0

Share this post


Link to post
Share on other sites

Posted

Does this method work on other phones (adb shell reboot oem-78 and fastboot boot) ?

To me, it seems that the tattoo is silently ignoring the boot command, while in RUU mode.

I've tried other combinations, like fastboot oem boot tatto.superboot.img, but I never got any satisfying result.

Is there some debug console(?) or method to check what the Tattoo is answering to the fastboot boot command ?

0

Share this post


Link to post
Share on other sites

Posted

Great job Paul though it does not work

0

Share this post


Link to post
Share on other sites

Posted

Paul please continues trying it!!

0

Share this post


Link to post
Share on other sites

Posted

Any chance that this could be used via Goldcard method to flash the rom?

0

Share this post


Link to post
Share on other sites

Posted

I have the same problem, hangs on booting... :)

0

Share this post


Link to post
Share on other sites

Posted

I am watching this with my fingers crossed, I have been waiting for root access to the Tattoo for 4 months now!! Plz let this work!

0

Share this post


Link to post
Share on other sites

Posted

Any chance that this could be used via Goldcard method to flash the rom?

Not work :)

0

Share this post


Link to post
Share on other sites

Posted

This device is more like the HTC Droid Eris than the hero, we are stuck in the same situation, Paul it may be of help to review what we have tried on the eris at http://forum.xda-developers.com/forumdisplay.php?f=554 The "Locked" thread and the new root thread have all the information on what we have tried. It appears to do a check on the rom before booting it in oem-78 mode.

0

Share this post


Link to post
Share on other sites

Posted (edited)

I modified the install-superboot-windows.bat and added oem to the fastboot command and the phone rebooted. But when I type su through terminal emulator I get permission denied.

Edited by yash08
0

Share this post


Link to post
Share on other sites

Posted

I modified the install-superboot-windows.bat and added oem to the fastboot command and the phone rebooted. But when I type su through terminal emulator I get permission denied.

Check if you can access the root folder, SU may not be installed yet.

0

Share this post


Link to post
Share on other sites

Posted

Doesnt superboot install su? Well tried to reach root folder with a file manager but says 'directory is empty'.

0

Share this post


Link to post
Share on other sites

Posted

Doesnt superboot install su? Well tried to reach root folder with a file manager but says 'directory is empty'.

Hi

I have an unbranded HTC Tattoo and I tried Paul's Superboot v 1.2 and the same thing happened to me: just hangs on during booting process and then when i made a reset I cannot do any operation thta normally requires superuser priviliges, so basically nothing changed in my phone.

0

Share this post


Link to post
Share on other sites

Posted

Trying to get hold of a Tattoo so I can dig further...

P

0

Share this post


Link to post
Share on other sites

Posted

Thanks for your interest man

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.