...angel...

Tips for a Successful ROM Flashing - i900/i908 Omnia ^^,

47 posts in this topic

can you help me pls... i have a i900 that recently cant detect a network connection... tried to change sims but to no avail... someone from the service center told me that its a motherboard problem and it should be changed... but i no longer have a warranty... i can use all the features except the signal for my globe network... is there a fix for this? havent tried to flash it because im a newbie... and the technician told me it will just be a waste of time... but i cant really believe him because its just the signal right? its not like the phone is brick or something.... sometimes when i open it theres a signal but just for a couple of seconds... tried the soft and hard reset already... but to no avail...

Edited by computerich
0

Share this post


Link to post
Share on other sites

need help badly.....pls ;) :D :( java script:add_smilie(":D","smid_16")

Edited by computerich
0

Share this post


Link to post
Share on other sites
can you help me pls... i have a i900 that recently cant detect a network connection... tried to change sims but to no avail... someone from the service center told me that its a motherboard problem and it should be changed... but i no longer have a warranty... i can use all the features except the signal for my globe network... is there a fix for this? havent tried to flash it because im a newbie... and the technician told me it will just be a waste of time... but i cant really believe him because its just the signal right? its not like the phone is brick or something.... sometimes when i open it theres a signal but just for a couple of seconds... tried the soft and hard reset already... but to no avail...

I'm so sorry for the late reply...can you give to me the version of your omnia?settings>>system>>version? Please post your PDA and PHONE Version...

0

Share this post


Link to post
Share on other sites
How did you brick your phone?

As far as I know, elco and others who know jtag programming can repair a bricked phone part(cannot activate phone in wireless manager)

It doesn't matter. I sent my phone to repair shop here in Nunawading. It cost me $400 ;)

I've flashed another ROM; leaving the phone part blank, and it is working fine until now.

Cheers

0

Share this post


Link to post
Share on other sites
It doesn't matter. I sent my phone to repair shop here in Nunawading. It cost me $400 :(

I've flashed another ROM; leaving the phone part blank, and it is working fine until now.

Cheers

400$ ;) It's really costly.... But at least it's okay now... :D

0

Share this post


Link to post
Share on other sites
Dont u guys think it should be pinned?

Indeed.

Gratz for the topic angel.

If i should have looked something like this before flash a while ago, i'd probally keep my omnia alive since the beginning ;)

0

Share this post


Link to post
Share on other sites

Hi and thank you for your tips but please do not forget master (qbus) he was one of best chef that I have ever seen.and also thank you again

0

Share this post


Link to post
Share on other sites

Can I flash the phone part and only the phone part under vista/ win7 or I need WMware ?

0

Share this post


Link to post
Share on other sites

I'm so sorry for the late reply.. I'd been so busy for exams these past few days...

Indeed.

Gratz for the topic angel.

If i should have looked something like this before flash a while ago, i'd probally keep my omnia alive since the beginning :lol:

That's a good idea... so that it will be kept on top and others(specially first time flashers) can read this before doing anything... then there'll be less chance of bricking...Thanks Mr. Bruno... :D Thanks Mr. Carlos.. :D

Hi and thank you for your tips but please do not forget master (qbus) he was one of best chef that I have ever seen.and also thank you again

Okay :D thanks for reminding me..

i wanna flash but i am using vista.. wanna give some tutorials about it?

There are many tutorials here... just search :lol: I don't have a pc running vista to test the process so I think others can help you more than I can B)

Can I flash the phone part and only the phone part under vista/ win7 or I need WMware ?

Yes.. you can use grandprix... you just need the phone.bin... flash it only to the phone part and NOT to the pda part. leave other parts blank :(

This also might help you>>>

http://www.modaco.com/content/i900-general...00-omnia-phone/

Edited by ...angel...
0

Share this post


Link to post
Share on other sites

hey angel... hw did u manage to unbrick urs omnia??? :-((

0

Share this post


Link to post
Share on other sites

Hey all. Sorry for a very late reply to this thread lol. I made a video when i flashed my first ROM.

Part 1:

Part 2:

Sorry for the bad quality.

I dont think it has been mentioned yet, but i go over it in the video. Use Windows Device manager to check the drivers have all installed correctly.

Right click 'My computer' and hit manage. Then choose device manager. Plug your phone in by the USB and give a minute to settle. Then turn it off. When you turn it back on, watch the device manager window for 'Samsung Mits USB'. If it appears, the samsung drivers are installed correctly. If it doesnt, you may need to reinstall them.

It may sound a little complicated but the video explains it a little better :lol: See Part 1 @ 2:00 minutes and you can see what i mean :lol:

If its your first time flashing a phone you should probably watch it all the way through. Has worked perfect for me and have flashed the phone 100+ times (testing of cooking :D )

Furthering this, more advanced users, you can flash from a ROM with the same eboot to another without flashing the eboot part. Just use Pakos executor to remove the eboot part and you then have very little risk :D For example. You can go from my DXID1 base ROMs to Nicks DXID1 or Ock's latest DXID1 base rom by literally just flashing the PDA part. The eboot and the rom base HAVE to match.

The eboot remains untouched, so this reduces the chances of bricking.

DO THIS AT YOUR OWN RISK. I dont want to hear of people new to flashing doing this wrong and bricking their phones. But, if you know what you are doing, its a handy little tip :D

0

Share this post


Link to post
Share on other sites
Hey all. Sorry for a very late reply to this thread lol. I made a video when i flashed my first ROM.

Part 1:

Part 2:

Sorry for the bad quality.

I dont think it has been mentioned yet, but i go over it in the video. Use Windows Device manager to check the drivers have all installed correctly.

Right click 'My computer' and hit manage. Then choose device manager. Plug your phone in by the USB and give a minute to settle. Then turn it off. When you turn it back on, watch the device manager window for 'Samsung Mits USB'. If it appears, the samsung drivers are installed correctly. If it doesnt, you may need to reinstall them.

It may sound a little complicated but the video explains it a little better :lol: See Part 1 @ 2:00 minutes and you can see what i mean :lol:

If its your first time flashing a phone you should probably watch it all the way through. Has worked perfect for me and have flashed the phone 100+ times (testing of cooking :D )

Furthering this, more advanced users, you can flash from a ROM with the same eboot to another without flashing the eboot part. Just use Pakos executor to remove the eboot part and you then have very little risk :D For example. You can go from my DXID1 base ROMs to Nicks DXID1 or Ock's latest DXID1 base rom by literally just flashing the PDA part. The eboot and the rom base HAVE to match.

The eboot remains untouched, so this reduces the chances of bricking.

DO THIS AT YOUR OWN RISK. I dont want to hear of people new to flashing doing this wrong and bricking their phones. But, if you know what you are doing, its a handy little tip :D

and if it is of the same rom base JC, the CSC is also not needed? just flash w/ the PDA part?

0

Share this post


Link to post
Share on other sites

Hi

I think this is my first post here :D

Anyway afetr nearly 1 yr with the omnia, I have finally decided to flash it!(Also I was getting bored & was thinking of upgrading)

I have PDA:i900MBHJ3/MBHJ3

PHONE:I900XXHJ1

Now, I dlded Ryrzy's M2D custome rom Build 28205. I have windows 7 & also dld'ed EXEcutor & Grandprix 1.64 vista.

I've followed all instructions to flash it but when I switch on the mobile, the i get the error "usdl4 has stopped working".

Nothing else happens & the mobile starts on normally.

What do you think is the problem?Do i run it in Vista/XP compatibility mode or am i flashing the wrong f/w?

0

Share this post


Link to post
Share on other sites
and if it is of the same rom base JC, the CSC is also not needed? just flash w/ the PDA part?

Id reccomend you do use the csc too but you dont have to :D Its pretty safe to flash it. The only dangerous part is the eboot section. Things like the rom version name are held in the csc. Sometimes people put other stuff in too tho. I put my touch improvements into it :D

0

Share this post


Link to post
Share on other sites
Id reccomend you do use the csc too but you dont have to :D Its pretty safe to flash it. The only dangerous part is the eboot section. Things like the rom version name are held in the csc. Sometimes people put other stuff in too tho. I put my touch improvements into it :D

Thanks JC. :lol:

0

Share this post


Link to post
Share on other sites
Thanks sir.... I hope that our fellow omniacs :D ( specially those who are new to flashing) can read this topic before doing it. It can save their time and minimize the possibility of bricking their omnia...

This is my first post here....

In addition to safe flashing and worry free of bricking thier i900..

I buy a new hard disk to my existing desktop and installed XP OS...

Install the Active Sync, Samsung XP modem driver and correct ROM...

Note: Don't install any anti virus and off the firewall.

0

Share this post


Link to post
Share on other sites

Angel my Omnia i900 is bricked, only the light up red to on and off appears, nothing on the screen, what to do? The following happened: I was installing the rom Dhee I discovered that the notebook was not have the driver of samsung omnia installed and dont reboot, I dont now what to do. Technical assistance were told that the motherboard was burned and that the price would be almost a new omnia. Can you help me?

Thanks

kani

Edited by kanikamus
0

Share this post


Link to post
Share on other sites

hi dear. very pleased to c ur topic. i have some problem while flashing my omnia rom. after doing some com port ......0 it showd download error on the updater and phone stops updating. panicaly i removed the cable. but it doesnt turn off only i have to pul out the bettry and then at inserting it again it turn on autamiticaly and becomes hangs at samsung omnia logo. now kindly please u can help me.. my email id is [email protected].

0

Share this post


Link to post
Share on other sites
I just saw another person who had failed to flash his omnia because he did not install the samsung modem driver... X_X Please guys... take time to read the tips on the first post... so that we can avoid such situation...

Hello Angel, great guide, i'm sure you have saved alot of people with this guide. I want some help from you, i downloaded ock_GTX_23118 and ock_Premium_23118 by ock. My omnia version is:

PDA : JCIC1

PHONE : JCIC2

I live in South Africa and i want to flash my omnia.

I went through a lot of posts just to get the idea of what i'm getting my self into.

Can you please let me know these roms will work on my phone?

I also don't see to find where to download most of the tools you are talking about (.exe updater, Granprix), can you maybe show me links that are working so that i can download them.

I have been using SBP 3.5, i like it, but i really want to try these roms. the reason i installed it is because i hated the winmo 6.1! i still don't like the look!

Thanx in advance.

0

Share this post


Link to post
Share on other sites

Guys I'm so sorry. I can't update this topic nowadays because I'm busy reviewing for my board exam(5 months to go ;)). Anyway, I hope our friendly ROM chefs and enthusiasts can reply to the queries of our fellow omniacs here. Anyway, you can PM me on my FB account if you really need help.

BTW, thanks sir JC and others for your replies here. :(

Edited by ...angel...
0

Share this post


Link to post
Share on other sites

Hi Angel i followed Sectors instructions to the letter.

1.turned off phone by holding button for 5 secs

2.start updater

3.turn on phone!

but phone wouldnt turn on i pressed the soft reset button and got the omnia logo and updater discovered the phone. i then pressed start and got this

PDA Device Found!

-------------------------------------------------------------------------------------

PDA Device ready to download!

Please Press Start Button if You want to download image now...

-------------------------------------------------------------------------------------

PDA 1 starts downloading...

Don't plug it out until the label becomes blue!!!

-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------

Step 1. Eboot image Downloading

Downloading EBOOT...

EBOOT image downloaded.

PDA Reboot to download Eboot twice!!!

but it has now hanged! any ideas? seems like i know have a brick for a phone!

suggestions for sorting would be appreciated

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.