Site Notice - We are currently investigating an issue with missing download links. Apologies for any inconvenience caused. PaulOBrien

  • Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[VIDEOTORIAL] How To Flash Omnia i900 & i910 on Windows 7, Vista & XP (Noob Friendly)

146 posts in this topic

Posted (edited) · Report post

Bedankt voor de tip, mijn bron had het verkeerd en ik daarom dus ook. Ik heb nu de bron verandert naar het topic op XDA-developers, waar dit goed staat. Hoe gaat het tot nu toe? ;)

zit nu nog even vast zonder csc bestand, uit die ock rom. klopt dit ? zie nu je opmerking in de video voorbij flitsen ..

krijg nu berichtje

OpenSCManager failed (5)

Calculating file parameters(DISKIMAGE)....

Calculating file parameters(DISKIMAGE) Done!!

als ik de rom laad in grandprix ???

opgelost grandprix nu "run as administrator"

Edited by Jopjes
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

zit nu nog even vast zonder csc bestand, uit die ock rom. klopt dit ? zie nu je opmerking in de video voorbij flitsen ..

krijg nu berichtje

OpenSCManager failed (5)

Calculating file parameters(DISKIMAGE)....

Calculating file parameters(DISKIMAGE) Done!!

als ik de rom laad in grandprix ???

opgelost grandprix nu "run as administrator"

Bedankt voor de tip, ik zal dat toevoegen! zelf zet ik UAC (die overbodige, irritante meldingkjes van vista en 7 als je iets opent -__-) uit (waardoor alles als administrator word uitgevoerd) dus ik wist hier niks van.

NL: En er hoeft geen csc bij nee, ook geen eboot trouwens, maar als deze inbegrepen is zou ik hem wel meeflashen.

EN: And there's no need for a csc file indeed, you don't need a eboot file either, but I'd flash it if you have one, just to be sure.. ;)

Edited by mikevhl
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Bedankt voor de tip, ik zal dat toevoegen! zelf zet ik UAC (die overbodige, irritante meldingkjes van vista en 7 als je iets opent -__-) uit (waardoor alles als administrator word uitgevoerd) dus ik wist hier niks van.

NL: En er hoeft geen csc bij nee, ook geen eboot trouwens, maar als deze inbegrepen is zou ik hem wel meeflashen.

EN: And there's no need for a csc file indeed, you don't need a eboot file either, but I'd flash it if you have one, just to be sure.. ;)

ok, here is the result, the phone was proably the oldest one out there t-mobile branded...............and it worked !!

a few tips, connect the phone to laptop and wait for drivers to load. shut down phone start it up again and wait for drivers to load again ? yes and again ....

the third time win7 finally knew that it was the same phone all the time and that the drivers where loaded so all was well.

In grandprix I unchecked the start download immedialty and tryied checking for phone it was found (took 3 go's) when all was fine the button start download came up and I started.

1 min later it said stopped because off bla bla (can't remember) So I pressed the start download again and then all went smooth.

great work guys and a big thanks

Edited by Jopjes
0

Share this post


Link to post
Share on other sites

Posted · Report post

I like chocolate cookies ;)

Cooooooooooooooooookieeeeeeeeeeeeeeee

Cookie, cookie, cookie, cookie...

xD

0

Share this post


Link to post
Share on other sites

Posted · Report post

I appreciate the work you did on this ;)

I think it should get stickied (or the first post anyway).

One thing i would say.......amd i know your not writing about this bit

On Windows 7 64-bit i havent got the "phone" part to work yet, but this tutorial you gave to flash the pda rom does work.

Same on Win 7 32-bit. However, if you were going to flash your phone part on Win7 32-bit it does work.

The way i got it to work was:

Follow all your steps to flash the ROM (but include the phone part).

When it has finished flashing the rom , it will switch the device to phone/modem mode.

It then gave me a lot of failed to find open com etc message in grand prix and windows said "The driver then failed to install successfully" (or similar)

I went back and followed all the instructions again (with a phone part).

And the 2nd time around it worked and flashed the phone part also.

I repeat i have not been able to get this 2nd part to work in Win7 64bit though (i suspect its to do with not loading unsigned drivers - which can be got around before Windows loads with i think F8 and one of those options.)

Again good tutorial tho :D i also use OCK rom's currently.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I appreciate the work you did on this ;)

I think it should get stickied (or the first post anyway).

One thing i would say.......amd i know your not writing about this bit

On Windows 7 64-bit i havent got the "phone" part to work yet, but this tutorial you gave to flash the pda rom does work.

Same on Win 7 32-bit. However, if you were going to flash your phone part on Win7 32-bit it does work.

The way i got it to work was:

Follow all your steps to flash the ROM (but include the phone part).

When it has finished flashing the rom , it will switch the device to phone/modem mode.

It then gave me a lot of failed to find open com etc message in grand prix and windows said "The driver then failed to install successfully" (or similar)

I went back and followed all the instructions again (with a phone part).

And the 2nd time around it worked and flashed the phone part also.

I repeat i have not been able to get this 2nd part to work in Win7 64bit though (i suspect its to do with not loading unsigned drivers - which can be got around before Windows loads with i think F8 and one of those options.)

Again good tutorial tho :D i also use OCK rom's currently.

I have said in the video that you shouldn't flash the phone part, it's unnecessary anyways :( didn't know it worked on win 7 though, but I won't include this, since this increases the chance of bricking your phone. Thanks for telling though :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

nice tutorial, wish i've seen it earlier. i flashed the phone part and i can't get it to work again. i've tried flashing it several times but the phone part never gets done

0

Share this post


Link to post
Share on other sites

Posted · Report post

nice tutorial, wish i've seen it earlier. i flashed the phone part and i can't get it to work again. i've tried flashing it several times but the phone part never gets done

You're welcome! :(

Try flashing without selecting a phone part, that sould fix it. If it doesn't, you'll need acces to a XP machine, or use the VM-ware method, of which I don't know how to use it :D. It's stickied I believe.. good luck! ;)

0

Share this post


Link to post
Share on other sites

Posted · Report post

You're welcome! :(

Try flashing without selecting a phone part, that sould fix it. If it doesn't, you'll need acces to a XP machine, or use the VM-ware method, of which I don't know how to use it :D. It's stickied I believe.. good luck! ;)

thanks man, i'll try that

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm not responsible for your actions and bla bla bla :D

The omnia is freaking hard to brick if you follow this tutorial though, and if something goes wrong, follow it again and your phone should work again. If it doesn't, try on another computer.

Before you start, you must have at least once synced your phone!!

I made this video. Sorry that it's sped up. Just pause to read the annotations and ask if any questions come to your mind. Because a picture says a thousand words. And a video has a thousand pictures B) ;)

I start off with a rom file, they can be found on this forum. The one I'm currently using is made by Ock, Build 25001, M2D version. Found here.

****THIS IS FOR THE i900 OMNIA, NOT i910 !!!!****

Video:Flashing i900 Omnia on Windows 7&Vista

Sim-Locked i900! (not i910) owners, read this first:

[A sim locked i900 is a i900 which is not able to work with a sim-card of another provider]

1: Open up your phone, "call" to  *7465625*638*#

2: Type de NCK code in which you can find here: http://en.wikipedia.org/wiki/Mobile_Network_Code

												  shorter link   : http://bit.ly/nYg0B

												  shorter link 2: http://tinyurl.com/nckcodes

										   ( Copy & Paste into url bar of your browser )

3. Type in the new NCK (12345678), and press OK

4. "call" *#7465625# to check the simlock status

5. "call" #7465625*638*# and type your NCK in (12345678)


Once that's done, you can proceed :D

Source: http://forum.xda-developers.com/showthread.php?p=3101945
i910 owners, read this first:

If your phone has a rom named CF03, continue the tutorial, if you don't know, here's how you can find out!

Start-Settings-System-Version. Look at ROM Version, if it says "S:i910.10 V.CF03 then you have the CF03 Rom and are able to continue with my tutorial. If it says something else, you'll first have to flash the CF03 rom. Don't worry, I'll explain how;)

1: Plug your Omnia in with it's turned on. Windows will automatically download and install the drivers for you.

2: When this is done, unlpug your phone.

3: Download the VZW update software here: http://sharebee.com/bd345218 (just choose a link and download)

4: Run the file and follow it step by step.

*: Only plug in your phone when prompted to in the update process!


My support for i910 devices is limited, since I own a i900 omnia, but I'll do my best;)


source: http://www.modaco.com/content/i910-specific-omnia-rom-discussion/287708/start-here-before-flashing-a-cooked-rom-verizon-i910/

Read this after watching:

All right, the first tool is omnia EXEcutor, by pako777 Download it from: EXEcutor 2.7

The second tool is GrandPrix

Vista and 7 users, download the and open the attachtment. [Open as administrator!]

"USDL_GrandPrix_v1.6.4_VISTA.exe"

XP Users, use the XP version instead. It looks kinda different, but the buttons are the same, you should get it :(

"UMDL_GrandPrix_v1.8.10_XP.exe"

This is my first topic on modaco ever, if I'm violating the rules, please tell me, I didn't mean to :D

Big thanks to pako777, the creators of GrandPrix, all cooks, people that wrote my sources, people that suggested things to add, and people who corrected my mistake!

Without your help it wouldn't have been possible.

I like to cook myself too, but only in real life :D I kinda messed up on my attempt and I'm not wanting to bother anyone with my problem, I'm just a noob at cooking :D but if I ever will find out how to, I'll surely post another video! :D

Update 02/02/10:

-Replaced included zipped grand prix for unzipped one, same version (1.6.4).

-Added section for sim-locked device users.

-Quick video clean up, corrected pauses. You shouldn't have to click the pause button anymore.

-Added i910 support. i910 owners, please confirm wether this works or not.

Update 03/02/10:

-Added XP section. I beleive that my thread is now universal, it supports every windows OS (from XP on) and both i900 and i910 models.

-I'll film a big video tomorrow, showing the flashing progress step by step from a Windows XP laptop and Windows 7 netbook. I'll first reflash Ock's rom, then the dutch rom by Bruno Adler. Both differ a little bit.

[X] Get 10 views

[X] Get 500 views

[ ] Get 1000 views

[X] Get 10 reply's

[ ] Get 50 reply's

[ ] Get 100 reply's

You said that the GRANDPRIX runs on Win7.. why it doesn't on my win7 OS.. help here please!!! thanks in advance!

0

Share this post


Link to post
Share on other sites

Posted · Report post

You said that the GRANDPRIX runs on Win7.. why it doesn't on my win7 OS.. help here please!!! thanks in advance!

Which version of windows 7 are you using?

Have you vlited it? If you don't know what it is, you didn't ;) vliting is basically removing components before installing, if you have did this you might have removed a component required for GrandPrix.

What happens when you try to open GrandPrix? Does a error message show up or just nothing? Have you ran it as administrator?

1 Version of win7?

2 Vlited or not?

3 Any errors?

4 Run as admin or not?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi. So far the instructions have been great but I'm stuck on the part where you turn the phone on once connected to GrandPrix. Instead of flashing the rom it says:

OnDeviceChange: DBT_DEVICEARRIVAL

PDA Device not found

I've gone through all the instructions to the letter and not had any problems up to that point. I've even done it 4 times (with a reboot of phone AND pc in between) but no joy. Do you think it could be the rom?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi. So far the instructions have been great but I'm stuck on the part where you turn the phone on once connected to GrandPrix. Instead of flashing the rom it says:

OnDeviceChange: DBT_DEVICEARRIVAL

PDA Device not found

I've gone through all the instructions to the letter and not had any problems up to that point. I've even done it 4 times (with a reboot of phone AND pc in between) but no joy. Do you think it could be the rom?

I have this issue on one laptop as well, but that was because I removed a component that was required.. anyways, do you use vista? since I haven't tested on vista..

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I have this issue on one laptop as well, but that was because I removed a component that was required.. anyways, do you use vista? since I haven't tested on vista..

Nope, Windows 7 (64bit, just a week out of the box). What was the component?

I've also tried this on my other Windows 7 (32 bit) machine and it tries to connect, states that the USDL has stopped working then bombs out. I must be really unlucky. ;)

Edited by ChromeNewt
0

Share this post


Link to post
Share on other sites

Posted · Report post

Nope, Windows 7 (64bit, just a week out of the box). What was the component?

I've also tried this on my other Windows 7 (32 bit) machine and it tries to connect, states that the USDL has stopped working then bombs out. I must be really unlucky. ;)

Have you vlited your windows build? If you don't know what that means you haven't. Because if you did that might be the issue.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Have you vlited your windows build? If you don't know what that means you haven't. Because if you did that might be the issue.

The program still says it's waiting for rebooting...

Service stopped successfully

Calculating file parameters(DISKIMAGE)....

Calculating file parameters(DISKIMAGE) Done!!

OnDeviceChange: DBT_DEVICEARRIVAL

-------------------------------------------------------------------------------------

PDA Device 1 ready to download!

-------------------------------------------------------------------------------------

PDA 1 starts downloading...

Don't plug it out until the label becomes blue!!!

-------------------------------------------------------------------------------------

EBOOT will be written.

Total 1 PDA region(s) will be written .

-------------------------------------------------------------------------------------

Downloading EBOOT...

PDA Reboot to download Eboot twice!!!

-------------------------------------------------------------------------------------

Service stopped successfully

OnDeviceChange: DBT_DEVICEARRIVAL

PDA Device not found.

0

Share this post


Link to post
Share on other sites

Posted · Report post

excellent stuff, worked the first time ;)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Have you vlited your windows build? If you don't know what that means you haven't. Because if you did that might be the issue.

Nope, not vlited at all. It's a mystery. ;)

0

Share this post


Link to post
Share on other sites

Posted · Report post

The program still says it's waiting for rebooting...

Service stopped successfully

Calculating file parameters(DISKIMAGE)....

Calculating file parameters(DISKIMAGE) Done!!

OnDeviceChange: DBT_DEVICEARRIVAL

-------------------------------------------------------------------------------------

PDA Device 1 ready to download!

-------------------------------------------------------------------------------------

PDA 1 starts downloading...

Don't plug it out until the label becomes blue!!!

-------------------------------------------------------------------------------------

EBOOT will be written.

Total 1 PDA region(s) will be written .

-------------------------------------------------------------------------------------

Downloading EBOOT...

PDA Reboot to download Eboot twice!!!

-------------------------------------------------------------------------------------

Service stopped successfully

OnDeviceChange: DBT_DEVICEARRIVAL

PDA Device not found.

that probally means that it didn't find the drivers for the omnia in flashing-mode. What happens when you try flashing your omnia without selecting a eboot file? and are you using vista or 7?

0

Share this post


Link to post
Share on other sites

Posted · Report post

flash rom complete ..thanks... but how i can flash radio with this ?

0

Share this post


Link to post
Share on other sites

Posted · Report post

flash rom complete ..thanks... but how i can flash radio with this ?

Install the vista modem driver if you can find the right one (works on 7 32-bit also). If your on 64-bit...it may work if you do an F8 and stop the driver signing on boot.

Once done, plug in omnia, let windows mobile device center find it.

Then follow the normal steps to untick the device so windows mobile device center does not launch.

Use the grandprix tool to flash a rom as described in this thread but also include the phone part you want to flash.

It will fail when it switches to radio usually and will then act like it is installing a driver, it may even say it fails....let it.

Then remove the omnia, plug it back in.

Try the grand prix again (i think i may have rebooted after the failed driver install) with the phone part.

It worked the next time around.

There is probably a cleaner way, but this seems to work for me on multiple pc's.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Install the vista modem driver if you can find the right one (works on 7 32-bit also). If your on 64-bit...it may work if you do an F8 and stop the driver signing on boot.

Once done, plug in omnia, let windows mobile device center find it.

Then follow the normal steps to untick the device so windows mobile device center does not launch.

Use the grandprix tool to flash a rom as described in this thread but also include the phone part you want to flash.

It will fail when it switches to radio usually and will then act like it is installing a driver, it may even say it fails....let it.

Then remove the omnia, plug it back in.

Try the grand prix again (i think i may have rebooted after the failed driver install) with the phone part.

It worked the next time around.

There is probably a cleaner way, but this seems to work for me on multiple pc's.

This might work, but I think it's innescesarry to flash phone parts, this process isn't really noob-friendly and isn't required for getting WM6.5 on your omnia, so I won't include it. Thanks for the advice though, I would've answered that it's impossible to flash on 7/vista

0

Share this post


Link to post
Share on other sites

Posted · Report post

This might work, but I think it's innescesarry to flash phone parts, this process isn't really noob-friendly and isn't required for getting WM6.5 on your omnia, so I won't include it. Thanks for the advice though, I would've answered that it's impossible to flash on 7/vista

Sorry didnt want to spam your very helpful thread just was answering the question of leap.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Sorry didnt want to spam your very helpful thread just was answering the question of leap.

haha thanks and no problem:P

Edited by mikevhl
0

Share this post


Link to post
Share on other sites

Posted · Report post

@leap_ahead

how did you flash it? because i cant flash mine here... it always say PDA Device not found.. can you help me?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.