• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

APN for Internet & MMS .apk for Softbank users in JAPAN

85 posts in this topic

Posted

I am using the black sim card from Softbank and the internet settings are not working at all.

Does anyone know why? is it because the black sim card might have different settings?

Any help would be greatly appreciated.

:rolleyes: I am starting this topic for those of you who are like I was, using Softbank in Japan and have no clue how to setup Internet (pakehoudai) and MMS for Softbank.

will start with the easier part - setting up APN for Internet Connection:

1. Go to Settings > Wireless Controls > Mobile Networks > Access Point Names

2. Long press empty space or press menu and select Add New APN

3. For internet input:

  • Name:Open Softbank
  • APN: open.softbank.ne.jp
  • Proxy: <not set>
  • Port: 8080
  • Username:opensoftbank
  • Password:ebMNuX1FIHg9d3DA
  • Server: <not set>
  • MMSC: <not set>
  • MMS proxy: <not set>
  • MMS port: <not set>
  • MCC: 440
  • MNC: 20
  • APN type: default


    4. For MMS set a new APN just like you did for Internet, but with settings below:

    • Name:Open Softbank
    • APN: mailwebservice.softbank.ne.jp
    • Proxy: <not set>
    • Port: <not set>
    • Username:softbank
    • Password:qceffknarlurqgbl
    • Server: <not set>
    • MMSC: http://mms/
    • MMS proxy: sbmmsproxy.softbank.ne.jp
    • MMS port: 8080
    • MCC: 440
    • MNC: 20
    • APN type: mms

    That alone will not magically make your MMS work, because Softbank checks for UserAgent when sending / receiving MMS. So you will need to install a custom Mms.apk attached to this post.

    5. Install Android SDK on your PC

    6. Root your device (AT YOUR OWN RISK! please search for instructions for your specific device on this forum.)

    7. open command prompts (Start > Run > cmd) connect your device with USB cable and execute following commands:

    That's it. Custom Mms.apk combined with correct APN should do the trick and you are able to send/receive MMS with Softbank.

    MMS.zip is for Donut - tested and working on Acer Liquid / Android 1.6 and HTC Hero / Android 1.5

    MmsEclair.zip is for Liquid Android 2.1 (tested on LCR, Vache all versions) Do not forget to ODEX after pushing if needed otherwise you fill have a Force Close error.

    Mms8.zip is for Liquid and Desire on Android 2.1 (tested on Liquid only LCR, Vache all versions) THIS IS THE LATEST most feature rich and error-free version. Do not forget to ODEX after pushing if needed otherwise you fill have a Force Close error. (Credit to Jake for empty messages fix))

    :huh:

    Note: for MMSEclair and Mms8.zip, you have yo go to Messages>Settings>UserAgent and select a user agent. I am using 708SC and it works fine.

0

Share this post


Link to post
Share on other sites

Posted

I am using the black sim card from Softbank and the internet settings are not working at all.

Does anyone know why? is it because the black sim card might have different settings?

Any help would be greatly appreciated.

The APN in this thread is for silver(non-iPhone) SIMs, or so I read.

The correct APN for the black SIM is supposed to be:

  • Name: smilemms
  • APN: smile.world
  • User: dna1trop
  • Password: so2t3k3m2a
  • MMSC: http://mms/
  • MMS Proxy: smilemms.softbank.ne.jp
  • MMS Port: 8080
  • MCC: 440
  • MNC: 20
  • APN Type: default,supl,mms (none seems also OK)

It didn't work for me, but after lots of digging it seems that the problem in my case was not the APN settings.

0

Share this post


Link to post
Share on other sites

Posted

The APN in this thread is for silver(non-iPhone) SIMs, or so I read.

The correct APN for the black SIM is supposed to be:

  • Name: smilemms
  • APN: smile.world
  • User: dna1trop
  • Password: so2t3k3m2a
  • MMSC: http://mms/
  • MMS Proxy: smilemms.softbank.ne.jp
  • MMS Port: 8080
  • MCC: 440
  • MNC: 20
  • APN Type: default,supl,mms (none seems also OK)

It didn't work for me, but after lots of digging it seems that the problem in my case was not the APN settings.

That is right. APNs for balck SIM are different - just as posted above. Thank you, i will quote this APN in the 1st post!

0

Share this post


Link to post
Share on other sites

Posted

Sorry for double-posting, but didn't want to combine a question and an answer ...

I recently bought an lock-free Huawei Ideos u8150-B. I read somewhere it is compatible with Softbank, and indeed it does have the 2100MHz UMTS band, although not the 1500MHz, the other band used by Softbank. Also, connecting to Softbank network was no problem, so calls and SMS come through fine. Docomo and Emobile networks were also detected.

However, with my black iPhone sim, although I tried with many APN settings, I could not connect to the data network. After LOTS of digging, I found a long thread on 2ch, with many people reporting that they can connect only to the (Emobile)APN using Emobile SIMs ... However, some tried doing data roaming with foreign SIM cards on the Docomo network, and it was a go. Nobody tried the Softbank network that way, but I believe the results would be the same as for Docomo.

I am clueless about what could be a problem here. It doesn't seem to be hardware ... Do you have any idea? Without knowing what's wrong, I cannot even start looking for a cure.

0

Share this post


Link to post
Share on other sites

Posted

Hello all, a few questions for all you great Android minds out there living in japan.

First of all, umka, thank you for the APN. I tried it on my desire HD unlocked form hongkong and internet works perferctly. Loving it.

now to my first question. so the MMS.apk works on Eclair, but does the MMS.apk thing work on froyo? has anyone tried this with certainty?

I do not want to urge you to use Internet, however my bill is over 400.000 every month. In the end of the month however, the discount is applied and I only pay 5000yen flat rate fee.

I even use my phone for tethering with my laptop when i need it, and it is still covered by the flat rate. just wait till next billing date and look how much they actually charged you.

As always - everything you do - is your responsibility ;)

2nd question. 2 part tho. the first one is just out of sheer curiousity, but why does softbank take away the mobile hotspot feature for their phones? that's really lame. my Desire HD has the mobile hot spot feature, but when i went and looked at one of the samples from sb, it wasn't there. Ok, for the more important question, umka, what plan are you with? the packet hodai with the wifi plan? or just straight up packet hodai? when i first bought my phone, they told me that i would get charged for tethering and it wasn't covered in the packet shi hodai. the reason why i'm asking is obvious. i would love to use the mobile hot spot on my desire hd. maybe i can experiment next month.

THank you in advance!

0

Share this post


Link to post
Share on other sites

Posted

That is right. APNs for balck SIM are different - just as posted above. Thank you, i will quote this APN in the 1st post!

Hi Have Desire/X06HT (rooted through unrevoked3, S-ON).

The above is confusing to me, as I have only one APN set up (Which is locked and I can't edit).

I have official mms app from softbank. Both internet and MMS are working fine with one APN set up.

From the post above, it looks like you need two separate APNs for internet and MMS. Not sure how I can access both through one APN. Has anything changed recently?

0

Share this post


Link to post
Share on other sites

Posted

Hi Have Desire/X06HT (rooted through unrevoked3, S-ON).

The above is confusing to me, as I have only one APN set up (Which is locked and I can't edit).

I have official mms app from softbank. Both internet and MMS are working fine with one APN set up.

From the post above, it looks like you need two separate APNs for internet and MMS. Not sure how I can access both through one APN. Has anything changed recently?

I also have a Desire HD and I want to get mms working on my device, but I'm a little new to this stuff and don't know what version of file to use and correct steps.

Some info first.

UK version Desire HD using in Japan. Fully permarooted with s-off. Revolution HD rom flashed.

Can someone please help me figure out how to get mms working on this phone. I used the APN setting in this post and I can get connected to the 3G network fine. :huh:

I'm very happy about that, but my phone has no options for mms or anything in the system settings. Please help me set it up as I would like to be able to mail my friends.

Thanks.

0

Share this post


Link to post
Share on other sites

Posted

Hi, Im not sure if this is posted yet, but if anyone has the Grey / White / Green Smart Phone

Sim card and is looking to upgrade their phone to a new non Softbank HTC or other phone

requiring an APN, here it is for that SIM.

Getting MMS to work is still another beast I have yet to fully conquer.

apn carrier="SoftBank Internet"

mcc="440"

mnc="20"

apn="andglobal.softbank.ne.jp"

user="andg001softbank"

password="pumbbghkpgyybsxa"

mmsc="http://mms/"

mmsproxy="andmms.softbank.ne.jp"

mmsport="8080"

type="default,mms"

preferred="true"

0

Share this post


Link to post
Share on other sites

Posted

Hi, Im not sure if this is posted yet, but if anyone has the Grey / White / Green Smart Phone

Sim card and is looking to upgrade their phone to a new non Softbank HTC or other phone

requiring an APN, here it is for that SIM.

Getting MMS to work is still another beast I have yet to fully conquer.

apn carrier="SoftBank Internet"

mcc="440"

mnc="20"

apn="andglobal.softbank.ne.jp"

user="andg001softbank"

password="pumbbghkpgyybsxa"

mmsc="http://mms/"

mmsproxy="andmms.softbank.ne.jp"

mmsport="8080"

type="default,mms"

preferred="true"

I just got a Nexus S, will these settings work in my phone? I think I have a grey sim card.

0

Share this post


Link to post
Share on other sites

Posted

:) I am starting this topic for those of you who are like I was, using Softbank in Japan and have no clue how to setup Internet (pakehoudai) and MMS for Softbank.

will start with the easier part - setting up APN for Internet Connection:

1. Go to Settings > Wireless Controls > Mobile Networks > Access Point Names

2. Long press empty space or press menu and select Add New APN

3. For internet input:

  • Name:Open Softbank
  • APN: open.softbank.ne.jp
  • Proxy: <not set>
  • Port: 8080
  • Username:opensoftbank
  • Password:ebMNuX1FIHg9d3DA
  • Server: <not set>
  • MMSC: <not set>
  • MMS proxy: <not set>
  • MMS port: <not set>
  • MCC: 440
  • MNC: 20
  • APN type: default


    4. For MMS set a new APN just like you did for Internet, but with settings below:
    • Name:Open Softbank
    • APN: mailwebservice.softbank.ne.jp
    • Proxy: <not set>
    • Port: <not set>
    • Username:softbank
    • Password:qceffknarlurqgbl
    • Server: <not set>
    • MMSC: http://mms/
    • MMS proxy: sbmmsproxy.softbank.ne.jp
    • MMS port: 8080
    • MCC: 440
    • MNC: 20
    • APN type: mms

    That alone will not magically make your MMS work, because Softbank checks for UserAgent when sending / receiving MMS. So you will need to install a custom Mms.apk attached to this post.

    5. Install Android SDK on your PC

    6. Root your device (AT YOUR OWN RISK! please search for instructions for your specific device on this forum.)

    7. open command prompts (Start > Run > cmd) connect your device with USB cable and execute following commands:

    That's it. Custom Mms.apk combined with correct APN should do the trick and you are able to send/receive MMS with Softbank.

    MMS.zip is for Donut - tested and working on Acer Liquid / Android 1.6 and HTC Hero / Android 1.5

    MmsEclair.zip is for Liquid Android 2.1 (tested on LCR, Vache all versions) Do not forget to ODEX after pushing if needed otherwise you fill have a Force Close error.

    Mms8.zip is for Liquid and Desire on Android 2.1 (tested on Liquid only LCR, Vache all versions) THIS IS THE LATEST most feature rich and error-free version. Do not forget to ODEX after pushing if needed otherwise you fill have a Force Close error. (Credit to Jake for empty messages fix))

    :)

    Note: for MMSEclair and Mms8.zip, you have yo go to Messages>Settings>UserAgent and select a user agent. I am using 708SC and it works fine.

    Note2: Fot those of you who have black SIMs - the correct APN is below:

    [*]Name: smilemms

    [*]APN: smile.world

    [*]User: dna1trop

    [*]Password: so2t3k3m2a

    [*]MMSC: http://mms/

    [*]MMS Proxy: smilemms.softbank.ne.jp

    [*]MMS Port: 8080

    [*]MCC: 440

    [*]MNC: 20

    [*]APN Type: default,supl,mms (none seems also OK)

    Thanks to merkhant!

    Can anybody please respond ?

    http://android.modaco.com/content/absolute...t-wont-show-up/

0

Share this post


Link to post
Share on other sites

Posted

As far as I know, yes. The APN settings are for the cell network so they are SIM / Carrier specific.

If you have that sim, and is uses those settings, it should work for any phone to my knowledge.

I just got a Nexus S, will these settings work in my phone? I think I have a grey sim card.
0

Share this post


Link to post
Share on other sites

Posted

Until now I couldn't get the MMS to work, is there any solution for that?

Hi, Im not sure if this is posted yet, but if anyone has the Grey / White / Green Smart Phone

Sim card and is looking to upgrade their phone to a new non Softbank HTC or other phone

requiring an APN, here it is for that SIM.

Getting MMS to work is still another beast I have yet to fully conquer.

apn carrier="SoftBank Internet"

mcc="440"

mnc="20"

apn="andglobal.softbank.ne.jp"

user="andg001softbank"

password="pumbbghkpgyybsxa"

mmsc="http://mms/"

mmsproxy="andmms.softbank.ne.jp"

mmsport="8080"

type="default,mms"

preferred="true"

0

Share this post


Link to post
Share on other sites

Posted

Even if you have setup your APNs correctly, You also need to fake your UA (UserAgent) to one that is recognised by Softbank. If you do not have an option to change your UA in MMS>Settings then you need to install one of the MMS.apk provided in the first post.

hope this helps

Until now I couldn't get the MMS to work, is there any solution for that?
0

Share this post


Link to post
Share on other sites

Posted

Even if you have setup your APNs correctly, You also need to fake your UA (UserAgent) to one that is recognised by Softbank. If you do not have an option to change your UA in MMS>Settings then you need to install one of the MMS.apk provided in the first post.

hope this helps

I know how to fake it

But what settings should I enter for an HTC Desire HD, CyanogenMOD 7.0.3 OS using a Grey Simcard?

0

Share this post


Link to post
Share on other sites

Posted

I have Softbank 003SH but I don't like the phone and I would like to use my Motorola Milestone instead.

After filling in APN informations from this thread 3G internet is working. However, I can't get MMS working. When I send a message to my softbank email address all I get is arriving message notification with information about subject and message filesize and "Download" button next to it. However, when I hit the Download, it ends up with error saying unable to download the message.

When I try to send message to my gmail address shows "sending..." but the message is never sent.

I'm running CyanogenMOD 7 RC8 (android 2.3.4) with this custom MMS.apk http://blog.takuo.jp/2010/10/mmsapk-final.html

I tried to change User Agent to "SoftBank X01T" which is included in mms.apk and than my random guess custom "Softbank 003SH" but neither one work. :-(

Any idea what am I doing wrong and how to get MMS working on Milestone with simcard from Sharp 003SH?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Yay! I finally got it working! :D

1) My APN Setting:

Name: Softbank(open)

APN: open.softbank.ne.jp

Proxy: <not set>

Port: <not set>

Username: opensoftbank

Password: ebMNuX1FIHg9d3DA

Server: <not set>

MMSC: http://mms/

MMS proxy: mmsopen.softbank.ne.jp

MMS port: 8080

MCC: 440

MNC: 20

Authentication type: <not set>

APN type: default,dun,mms

APN protocol: IPv4

2) Installed this MMS.apk (CM6 version in my case) http://blog.takuo.jp/2010/10/mmsapk-final.html

3) In MMS application settings change User Agent to iPhone (3.0)

Don't know why, but only with iphone setting MMS work...

I hope this help other people with same problem as I had...

BTW I wonder what the "APN protocol" setting affects.

Edited by Eso Rimmer
0

Share this post


Link to post
Share on other sites

Posted

I know this subject has been pounded and pounded over and over again, but ... as usual i can't get it to work.

i've used so many different types of settings i'm going crazy. Anyone know a super nerd in Japan that can help me?

0

Share this post


Link to post
Share on other sites

Posted

Is there an updated MMS.zip file for Gingerbread?

0

Share this post


Link to post
Share on other sites

Posted

I think I use one of there http://takuo.jp/junk/Mms.apk/non-cm-froyo/ and it works normally on my rooted Motorola Atrix with android 2.3.4.

I'm not sure whether is it standard application from google or from motorola, but on atrix, there is no mms.apk in system. Instead there is another "Messages" app. Which is actually not problem. I just use mms.apk instead. Side effect is that all messages received by mms.apk appear in the default messaging app too, but you can't use it because there's no user agent settings like in mms.apk.

0

Share this post


Link to post
Share on other sites

Posted

I think I use one of there http://takuo.jp/junk...k/non-cm-froyo/ and it works normally on my rooted Motorola Atrix with android 2.3.4.

I'm not sure whether is it standard application from google or from motorola, but on atrix, there is no mms.apk in system. Instead there is another "Messages" app. Which is actually not problem. I just use mms.apk instead. Side effect is that all messages received by mms.apk appear in the default messaging app too, but you can't use it because there's no user agent settings like in mms.apk.

Thanks for the reply.

The files in the link you gave, say they are for Froyo?.. are you using on your Atrix with Gingerbread 2.3.4???

My HTC Sensation is running 2.3.3 still (no OTA update to 2.3.4 yet).. so I guess it should work also.

Are you able to use MMS (ie download emails from Softabank?)

0

Share this post


Link to post
Share on other sites

Posted

Yes I can receive/send softbank's emails.

I've used the same mms.apk on Motorola Milestone with cyanogen mod 7, which is also running android 2.3.4 and the app worked.

The only problem on Atrix is that when MMS comes, notification is done by default Atrix's message app. But it can't download/send the message so I have to open mms.apk to download the message.

Maybe if I remove default messaging app the mms.apk would become default MMS app. But I didn't try it yet.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Okay, I've gotten as far as installing Mms.apk in the /system/app directory. When I try to open up my messages on my phone I get the Force Close error. But when I try to remove the Mms.odex file (rm /system/app/Mms.odex) I get:

rm failed for /system/app/Mms.odex, No such file or directory

Help would be appreciated!

Edited by kiera
0

Share this post


Link to post
Share on other sites

Posted (edited)

Hello everybody,

I'm new to the Android world (will probably buy a Galaxy S2 soon) and I have a few question about making Softbank work with an unlocked Android device.

As for the mms.apk, does that mean the Softbank mms application will be installed?

If it is the case, is the Softbank mms app have an iPhone-like display where SMS and MMS appear like chatting?

I'm thinking about importing a Galaxy S2 from Hong Kong and use it with my black sim card, and I would like to use the stock mms app for SMS and MMS as the stock app has this "chatting display"...

Thanks in advance.

Edited by Kachi69
0

Share this post


Link to post
Share on other sites

Posted

Hi

I followed trough your steps and got stuck in a boot loop shotrly after I pushed the Mms.apk, and rebooted.

HTC Desire with S-OFF/Leedroid

Any ideas on how to adb push the old files again and exit the boot loop? (I saved them with pull before)

0

Share this post


Link to post
Share on other sites

Posted (edited)

ive got the latest mms replacement app installed and using the iphone custom agent (as user above used) and created the apn but I cannot get my data connection going. It also doesnt want to receive/send when i'm on wifi.

ive got a zte blade 2.2 swedish spring and a prepaid silver softbank sim. I can make calls and receive sms but not send :( any advice

edit: ok,ive got data working (3g pops up or H and blinks) but still cannot send anything nor access web

edit2: I can send myself sms so some progress

Edited by DJ-Elo
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.