• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Dusk taskbar for CDMA (wm 6.5.x)

19 posts in this topic

Posted

I tried to make a complete taskbar for CDMA. (original post here http://www.modaco.com/content/i8000-verizo...ion-w-vga-only/ )

I need someone to test it for me on a wm 6.5.x ROM and let me know if every icon is working.

If you edited the registry as I mentioned in the other thread, please remove it before installing the new cabs.

Install the 3 cabs attached (I think all Samsung phones need the BlueTooth fix application)

___tacchan23_Dusk_Taskbar_VGA_wm6.5.5.cab

___tacchan23_CDMAfix_Dusk_Taskbar_VGA_wm6.5.5.cab

___BtIconNotifierDusk.cab

0

Share this post


Link to post
Share on other sites

Posted (edited)

Testing right now, ill let you know momentarily

---------------------------------------------------------------

My Results:

All icons are now themed to your style.

Few issues tho, illtry to get a screenshot but ill explain best i can

Bluetooth icon shows on/off status in green/red icons respictively. But does NOT show any other status, i.e. headset, headphones. Instead the icon changes to the "multiple announcement icon" and shows the stock headset icon when you tap it.

3G icon shows 3G for EVDO like it should, but it is always red, it doesnt show connected status. 1X icon always shows green, whether connected or not.

Signal icon works appropriately, shows signal but no data arrows (i cant rem if its supposed to or not so maybe disregard that)

Audio icon works perfectly as does the battery.

Hope this helps, let me know if i can do any more tests for you! Keep up the great work, i love what you do!

Edited by Radioman96p71
0

Share this post


Link to post
Share on other sites

Posted

Signal icon works. Nice. My EV/1x/3G icon is still stock.. Thanks for the follow up to get this fixed.

0

Share this post


Link to post
Share on other sites

Posted

Signal icon works. Nice. My EV/1x/3G icon is still stock.. Thanks for the follow up to get this fixed.

The only thing we may have different is this:

[HKEY_LOCAL_MACHINE\Security\ResOver\Bitmaps]

"FuncDll"="CDMA_RSSI_PPC.dll"

From another thread.

It LOOKs like maybe the icons just need re-ordered or soemthing to show up properly. Stupid CDMA got to be so difficult xD

0

Share this post


Link to post
Share on other sites

Posted

Hello tacchan,

I've just switched over from Omnia i900. I was wondering if you might be able to convert the attached taskbar cab to be compatible with O2, Win 6.5 build 218xx.

Let me know if my request is even possible, and if so, if I can make it worth your time. There may be others that would be interested in it. By the way, the taskbar is originally from Grigoris and is a 6.1 taskbar for Omnia.

I'm still running a stock ROM because I've literally unpacked the phone yesterday. Anyway I've got some catching up to do on all the current tweaks and hackings for O2.

Thanks a million!

grigoris_a_TaskbarV2.cab

0

Share this post


Link to post
Share on other sites

Posted

The only thing we may have different is this:

[HKEY_LOCAL_MACHINE\Security\ResOver\Bitmaps]

"FuncDll"="CDMA_RSSI_PPC.dll"

From another thread.

It LOOKs like maybe the icons just need re-ordered or soemthing to show up properly. Stupid CDMA got to be so difficult xD

I added the above registry to the new CDMAfix cab, so it should be the same...

@Snow2: did you install the new cab from this thread? if so, I guess I made a mistake with the cab

0

Share this post


Link to post
Share on other sites

Posted (edited)

I added the above registry to the new CDMAfix cab, so it should be the same...

@Snow2: did you install the new cab from this thread? if so, I guess I made a mistake with the cab

Ah, no. I installed the CDMA fix only. I'll try it and post back.

Yep. That fixed it. Good Job. I'll use it for awhile and then report back later. Thanks again.

Edited by Snow02
0

Share this post


Link to post
Share on other sites

Posted

Bluetooth icon shows on/off status in green/red icons respictively. But does NOT show any other status, i.e. headset, headphones. Instead the icon changes to the "multiple announcement icon" and shows the stock headset icon when you tap it.

3G icon shows 3G for EVDO like it should, but it is always red, it doesnt show connected status. 1X icon always shows green, whether connected or not.

Signal icon works appropriately, shows signal but no data arrows (i cant rem if its supposed to or not so maybe disregard that)

Audio icon works perfectly as does the battery.

Hope this helps, let me know if i can do any more tests for you! Keep up the great work, i love what you do!

- Bluetooth: using the stock icons, doesn't it show anyway a "multiple announcement icon" instead of headset/headphones/etc?

- what is 1X actually?^^ anyway I could find just one 1X icon... so really no idea how to make it connceted/disconnected. How does it look with stock icons?

- same as above for EV (I could find 2 icons for EV, but they are exactly the same so don't know how to change them... How do they look with custom icons if connected/disconnected?)

0

Share this post


Link to post
Share on other sites

Posted (edited)

- Bluetooth: using the stock icons, doesn't it show anyway a "multiple announcement icon" instead of headset/headphones/etc?

- what is 1X actually?^^ anyway I could find just one 1X icon... so really no idea how to make it connceted/disconnected. How does it look with stock icons?

- same as above for EV (I could find 2 icons for EV, but they are exactly the same so don't know how to change them... How do they look with custom icons if connected/disconnected?)

I'm not sure about the bluetooth since I don't use A2DP/headset.

As far as 1x/3G, the only difference for the stock icons is connected is white background and disconnected is dark background. So not a big deal in my opinion since the signal icon denotes whether or not data is connected.

Edited by Snow02
0

Share this post


Link to post
Share on other sites

Posted (edited)

Bluetooth: stock rom will change the bluetooth "B" icon to a little "B" icon with headsets or music notes around it for a headset/headphones. Your ROM keeps the bluetooth logo the same, and the stock headset/headphone shows up in a second dropdown when you tap on the icon. I will have to get a screenshot i cant explain it very well haha. How do i do that?

1X would be the equivalent to 2G data. It means 1xRTT, which is more like a dial-up modem. It only shows up in rural areas or weak signal areas. Also will switch to 1X mode for voice calls and sending/receiving SMS.

The 1X/EV logo will not change for a connected/disconnected state. The only diff i see is after a data connection is made. During idle times, the icon will be light grey, active data is white. The signal icon follows the same behaviour.

edit: after doing some poking, the signal icon is changing state correctly for a phone call, and data appears to make a little globe show up. But it does not show active data, just that it is in data mode. i.e. the equivalent of the arrows next to the signal bar but they dont 'light up'

Would it help to screenshot all the different 'states' of the stock icons to see the differences?

Edited by Radioman96p71
0

Share this post


Link to post
Share on other sites

Posted

Bluetooth: stock rom will change the bluetooth "B" icon to a little "B" icon with headsets or music notes around it for a headset/headphones. Your ROM keeps the bluetooth logo the same, and the stock headset/headphone shows up in a second dropdown when you tap on the icon. I will have to get a screenshot i cant explain it very well haha. How do i do that?

1X would be the equivalent to 2G data. It means 1xRTT, which is more like a dial-up modem. It only shows up in rural areas or weak signal areas. Also will switch to 1X mode for voice calls and sending/receiving SMS.

The 1X/EV logo will not change for a connected/disconnected state. The only diff i see is after a data connection is made. During idle times, the icon will be light grey, active data is white. The signal icon follows the same behaviour.

Would it help to screenshot all the different 'states' of the stock icons to see the differences?

Bluetooth it could help some screenshots, but there always have been problem with it couse most of the custom taskbars are based on a .dll file first used by HTC and the bluetooth works correctly only when the HTC dialer is enabled.

Not having such an option, we can just the BTfix I posted above... but I'm not really sure if it prevents the headsets icons to show (also it doens't work for the PopUp icons...)

About 1X/EV I don't think screenshots would help, as I could find just one 1X icon (so I can make it green or red, but not both^^) and the two EV icons I could find are exactly the same (I can try to make one red and one green and see what happens)

But it does not show active data, just that it is in data mode. i.e. the equivalent of the arrows next to the signal bar but they dont 'light up'

About this some screenshot could be nice

0

Share this post


Link to post
Share on other sites

Posted

Your call there, im not sure how the phone makes them flash from white to grey, so maybe they dont change the icons just the state of them or something? Minor details for sure, it shows all the majors so im happy

The bluetooth thing is a little off, i would like to see that better but i understand where you are coming from. Ill get some screens of the various states and see if you can maybe track them down. Thanks again for all the hard work!

0

Share this post


Link to post
Share on other sites

Posted

About 1X and EV, I checked other taskbars with CDMA fix and all of them have just one icon for each of them... so I guess the problem of not having any difference between conncted/disconnect cant be fixed.

About bluetooth and But it does not show active data, just that it is in data mode. i.e. the equivalent of the arrows next to the signal bar but they dont 'light up', some screenshots may help but checking other taskbars I couldn't find any differences with mine so not easy to fix too I guess :)

0

Share this post


Link to post
Share on other sites

Posted

About 1X and EV, I checked other taskbars with CDMA fix and all of them have just one icon for each of them... so I guess the problem of not having any difference between conncted/disconnect cant be fixed.

About bluetooth and But it does not show active data, just that it is in data mode. i.e. the equivalent of the arrows next to the signal bar but they dont 'light up', some screenshots may help but checking other taskbars I couldn't find any differences with mine so not easy to fix too I guess :)

With regards to the arrows, they are the equivalent signal icon switching to the globe. So no issue there. I think it's all good personally.

0

Share this post


Link to post
Share on other sites

Posted

With regards to the arrows, they are the equivalent signal icon switching to the globe. So no issue there. I think it's all good personally.

yes i understand now, checking some other cdma taskbars I could see they used some "arrow" icons in place of the "globe" icons I used.

guess I'll leave the globe as it was made in the original Dusk taskbar (unless someone make and send me some nicer icons to replace them)

about bluetooth, I tried some more fix I read about on ppcgeeks but it's not working... guess I give it up too sorry

I'm going to replace the PopUp taskbar icons (a friend is helping me to make them better) and then I'll post a final version cab

0

Share this post


Link to post
Share on other sites

Posted

Thank you thank you thank you!!! The icons have grown on me and I really dont mind that the icons light up for data, the icon actually 'blinks' a little (if you want to call it that) during an active data call so there really isnt anything wrong! Im wondering if the only reason the arrows went from grey to white is because some part of the OS makes all pixels with a grey color of 0x___ change to white during active data. Which when the icon is now black and green, wont be able to do. Dont know!

All-in-all, very happy with the new look of the taskbar, it was a lot of hard work and we appreciate it!

0

Share this post


Link to post
Share on other sites

Posted (edited)

yes i understand now, checking some other cdma taskbars I could see they used some "arrow" icons in place of the "globe" icons I used.

guess I'll leave the globe as it was made in the original Dusk taskbar (unless someone make and send me some nicer icons to replace them)

about bluetooth, I tried some more fix I read about on ppcgeeks but it's not working... guess I give it up too sorry

I'm going to replace the PopUp taskbar icons (a friend is helping me to make them better) and then I'll post a final version cab

Found a bug. note the discrepancy between the taskbar power and the actual. Soft reset restores it.. No idea what may have caused it.

Edit: Nevermind. Not the taskbar. It's the ROM. I uninstalled the taskbar for a while on a hunch, and the stock battery icon got stuck randomly as well. So no worries. I'll let Shemmy know.

post-618685-1264984611_thumb.png

Edited by Snow02
0

Share this post


Link to post
Share on other sites

Posted

I tried to make a complete taskbar for CDMA. (original post here http://www.modaco.com/content/i8000-verizo...ion-w-vga-only/ )

I need someone to test it for me on a wm 6.5.x ROM and let me know if every icon is working.

If you edited the registry as I mentioned in the other thread, please remove it before installing the new cabs.

Install the 3 cabs attached (I think all Samsung phones need the BlueTooth fix application)

Just an FYI ....... the second file down (55.75k) works for any 6.5.5 taskbar cab. I have a completly differant taskbar installed but kept getting that sutpid white box with the x in it until i installed that file. Now no matter what taskbar i install the proper icon pops up

0

Share this post


Link to post
Share on other sites

Posted (edited)

Works nice on Omnia i920 and ninja4hire rom

Thank You

<_< :mellow:

I spoke to early...

its most likely the rom but battery on task bar is not there and clock is off center ( not in blue box)

post-499047-1268824340_thumb.png

Edited by kdkinc
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.