• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Manila 3D on omnia

65 posts in this topic

Posted (edited) · Report post

hello every body here

I've just edited 3d driver and it works on omnia but it needs some hacking

now I've found manila 3d for qvga ( edited it and put the 3d drivers for omnia )

here's the cab ( working but all white square screens ( 3d is working ) )

TF3D.cab

need support and team working to get it working perfectly on omnia

Edited by magawa
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

reserved ....................

1- pictures are square and white

2- 3/4 screen because it for qvga

Edited by magawa
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Wow. ;)

Would like to see that working on omnia :)

Edited by darkside80
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

hello every body here

I've just edited 3d driver and it works on omnia but it needs some hacking

now I've found manila 3d for qvga ( edited it and put the 3d drivers for omnia )

here's the cab ( working but all white screens ( 3d is working ) )

TF3D.cab

need support and team working to get it working perfectly on omnia

Seems some of the "hackers" here have moved on to new devices ;)

Have gave TF3D a few tries some time back, but furthest I got was some faint outlines of text. Animated text seems ok, but not images, which displayed white squares. I suppose it's a driver issue with regards to support for some textures stuff.

Very interested to know how you've edited the driver. :)

Edited by ock
0

Share this post


Link to post
Share on other sites

Posted · Report post

Wow. ;)

Would like to see that working on omnia :)

but the pictures are white ( i dont know why )

and 3d is working

in settings tab

Touch Flo 3D 1.2.34591.1 . 1813.5

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Seems some of the "hackers" here have moved on to new devices ;)

Have gave TF3D a few tries some time back, but furthest I got was some faint outlines of text. Animated text seems ok, but not images, which displayed white squares. I suppose it's a driver issue with regards to support for some textures stuff.

basically Iam not a hacker :)

see here the driver I've putted

libgles_cm.zip

about the screen reselotion you can see this driver ( for qvga )

libgles_mn.zip

cheers

edit : now I'm trying to change the theme ( hope it solving the pictures issue )

edit 2 : even the theme same think

Edited by magawa
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Well actually it's not working at all. Hangs the omnia nicely. I can't even go to the menu to turn it off. All I can see is a big white square in the middle and No missed calls etc, underneath. As for the developing, I can't see any chance to get it to work as most of the files have no extension (I guess they're all graphics) and they're unopenable. Also, Omnia has no graphics chip to support that.

Edited by Toldo
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Well actually it's not working at all. Hangs the omnia nicely. I can't even go to the menu to turn it off. All I can see is a big white square in the middle and No missed calls etc, underneath. As for the developing, I can't see any chance to get it to work as most of the files have no extension (I guess they're all graphics) and they're unopenable. Also, Omnia has no graphics chip to support that.

how ???

it working on my omnia but pictures and reselution are stop my way to get it working

about the speed its normal

Edited by magawa
0

Share this post


Link to post
Share on other sites

Posted · Report post

i dont believe :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

i dont believe :)

if you want dont believe but working

0

Share this post


Link to post
Share on other sites

Posted · Report post

Well maybe it's because of the build. I'm running Ryrzy's 23547 (start on the bottom). Anyways, I think The Omnia is to slow to run that. I noticed that the housing on the back gets hot when running TF3D, so the processor is running full power and that leads to a huge battery drain. So either it won't work at all or somehow someone will optimize it to run fully.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Well maybe it's because of the build. I'm running Ryrzy's 23547 (start on the bottom). Anyways, I think The Omnia is to slow to run that. I noticed that the housing on the back gets hot when running TF3D, so the processor is running full power and that leads to a huge battery drain. So either it won't work at all or somehow someone will optimize it to run fully.

right bro you now understanding me

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

managed to get it working on my personal 23541 base build, but i experience the same problems outlined in the first post. I'm very eager to see this working completely!

if you are having problems with it hanging, try flashing to a faster ROM without much cooked in. i recommend trying it immediately after flashing a Base/Lite ROM.

since this works, does that mean sense 2.5 is possible on i9x0 ?!?

Edited by thekevster
0

Share this post


Link to post
Share on other sites

Posted · Report post

I won't change my rom just to see the 3D working, a little senseless;) I just tried that, looked into the files thinking maybe I could be of some help but the structure seems to complicated to me. 'Bout the Sense UI, I think It's impossible since Sense needs a native hardware graphics support. Also Sense is in WVGA as for now.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

sense 2.5 is later

now we are working on the 3d thing

when we get pictures working then we will try sense

got it :)

Edited by magawa
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Well, its not working yet.

Installed the first cab and it just shows me the white squares.

Then it hangs the device..( thanks for testing ;)

The Omnia has 3d capabilities, is surly fast enough, so it must be an driver thing or does it need to much memory?

Right. Now, how to get rid if it :)

edit;

forgot to add that some flipping is going on in the back. Supposedly the clock..

But that happens only when the clock part is more up worth instead of in the middle.

it also doesn't lock the device, it just takes over the full screen. Locking the screen(long press red) give you access to the start button.

Edited by ebsbow
0

Share this post


Link to post
Share on other sites

Posted · Report post

i hope it can working on omnia ... :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

3d should work very well but is there any body found a reason for white squares instead of pitures

I've tried TF3D 2.1 same thing white square icons

Ive test 3d and it works perfectly

d3d drives are in the omnia

nothing more than a fix

0

Share this post


Link to post
Share on other sites

Posted · Report post

maybe the way it actually draws bitmaps? so that images are drawn through GPU directly?

0

Share this post


Link to post
Share on other sites

Posted · Report post

The white squares should be graphics-anims, so I guess the problem is with displaying the animations.

0

Share this post


Link to post
Share on other sites

Posted · Report post

It will not work fully. Because we has test it.. like your said any body found a reason for white squares instead of pitures. o any body want to fix it. because everybody know that Omnia has no graphics chip to support 3d manila... for this reason didnt want to fix....

Try it... maybe you can fix

0

Share this post


Link to post
Share on other sites

Posted · Report post

I found why white squares are show

its about libgles driver

0

Share this post


Link to post
Share on other sites

Posted · Report post

I found why white squares are show

its about libgles driver

what are you thinking?

0

Share this post


Link to post
Share on other sites

Posted · Report post

what are you thinking?

Good luck....i would love all the chefs and developers try to make this real.....Touchflo 3d in omnia...

It would be amazing...

Last year i promised 100 euros in xda deve.....ers....to the person who could make this working ...ant i found nobody :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Good luck....i would love all the chefs and developers try to make this real.....Touchflo 3d in omnia...

It would be amazing...

Last year i promised 100 euros in xda deve.....ers....to the person who could make this working ...ant i found nobody :)

$$ ;) hahaha not bad,

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.