PaulOBrien

24/May r4 - HTC Legend rooting guide - Now with 1.31.x

664 posts in this topic

After reading tons of posts it should work if i do the downgrade first (she's running 2.2 now with the latest Hboot). I only have one question regarding the goldcard. My wife's Legend is completely unbranded and original HTC. If i read ok, there is no need for me to create a goldcard for the Legend because this is only necessary if you do have a network branded phone.

So, the short question is: Do i need to create a goldcard when i am going to root this phone and run custom firmware, if my Legend is unbranded and original HTC?

Sorry that I'm 1) Resurrecting this thread, 2) Don't have an answer to this question but I 3) Would really like to know this too. Anyone?

0

Share this post


Link to post
Share on other sites

Thanks for the guide!

Unfortunately I got stuck at the second step, as I have seen others have experienced as well: with the device not found error.

So situation is:

  1. successfully downgraded to 1.31 (with goldcard)
  2. rootedupdate.zip on sdcard (I got "device not found errors" while in recovery mode (red warning sign), so I just copied the zip on the sdcard)

I'm on linux, so step 2 should not be a USB driver issue. (adb finds the legend in normal mode, but not in recovery mode)

When I try to flash rootedupdate.zip (actually I renamed it to update.zip, since that is the only choice I get in the recovery menu), I get the following error:

E:signature verification failed

I have searched the net, seen others with the same issue but no solutions.

Any ideas? TIA

0

Share this post


Link to post
Share on other sites

Hi guys,

spent 3-4 hrs last night trying to root the legend, i have had no problems rooting loading roms with my desire or wifeys wildfire.

I have followed the procedures on how to downgrade and root the legend as displyed in previos pages to no avail?

after 3 hours was able to downgrade to build 131.405

hboot 43

the root process from here however is where i was getting nowhere, the steps where you connect to fastboot and use winbat step1 just quicly flashes through the terminal and closes, no confirmation if this has flashed anything?

can anyone show the code that i am supposed to be seeing here?

tried proceding to step 2 and same issue

evo and and 1 click root will not work onthis phone

any suggestions?

Tx in advance

Col

0

Share this post


Link to post
Share on other sites

I want to root my HTC Legend.

Looked through most of this rather large thread :D and tried searching, but cannot find a clear answer to my situation ...

I have HBOOT-0.43.0003 and Firmware: 2.1-update1, Software number: 2.06.708.2

(1) Do I definitely need to "downgrade to 1.31" before the root procedure in the above thread will work?

(2) I don't have Windows - Is there any way to do this using a Linux (Ubuntu) PC?

TIA

0

Share this post


Link to post
Share on other sites

I'm currently trying root my phone. Having some troubles though. First I got through step 1, and tried to do step 2. Got some error message saying the device could not be found, so I tried again. Same thing. So I reset my Legend to the factory defaults, and recreated the gold card. Doing step 1 now though, it just stays on "writing 'zip'..." just after the "About to start flash...".

Anyone know how to fix this? Have I royally screwed my phone?

0

Share this post


Link to post
Share on other sites

hi im having super trouble with this, ive got a legend but the digitizer is not letting me touch Enable USB debugging in the settings menu , but when i connect with htc syn it enables usb degugging so i go ahead and restart my phone , its hboot 43-00001 and i run step1-windows.bat and it completes

then i run step2-windows.bat after selecting recovery and it errors in every cirumstance

C:\root>step2-windows.bat

Legend Root Step 2

Pushing required files to device...

* daemon not running. starting it now on port 5037 *

* daemon started successfully *

error: device not found

error: device not found

Pushing update file to device sdcard - this may take a few minutes...

error: device not found

error: device not found

Now wipe and apply rootedupdate.zip from the recovery image menu.

error: device not found

i have a valid goldcard inserted and i taske it out on step2

im running win7 32bit

I dont know what else i can try

any help would be grateful, thanks

EDIT: GOT IT WORKING , Had to downgrade to stock 2.1 from 2.1 update-1 :-)

Edited by zerodi
0

Share this post


Link to post
Share on other sites

Soo... I'm now on android 2.1 with root access, how do I load a custom rom ?

Can I just use ROM Manager from the market and use flash recovery, then use the download ROM thingy ?

0

Share this post


Link to post
Share on other sites

I have HBOOT-1.01.0000

When I run the step 1 script I get the error:

FAILED (remote: 43 main version check fail)

Any idea what my problem may be?

0

Share this post


Link to post
Share on other sites

First of all, hello folks!

I've been trying for the past couple of days, all kind of ways to root my legend in order to upgrade to android 2.3 (which as far as I heard won't be published on the Legend at all)

I followed all the steps from post No1, yet I get the same error as many others:

When in recovery mode issueing 'step2-windows.bat', I get something like

Pushing required files to device...

* daemon not running. starting it now on port 5037 *

* daemon started successfully *

error: device not found

error: device not found

Pushing update file to device sdcard - this may take a few minutes...

error: device not found

error: device not found

Now wipe and apply rootedupdate.zip from the recovery image menu.

error: device not found

Any ideas, please?! I'm running android 2.2. I get that the first post is >one year old, so it was back in the days of android 2.1?! did it change in any way since then?

Any help is greatly appreciated!!!!

0

Share this post


Link to post
Share on other sites
All is going well until step 1.

After that I seems I cannot select recovery mode. Vol up - down seems not to work in that menu. Its going after a few seconds to HBoot.

Any help?

I have exactly the same problem.

Did you resolve this yet?

Thanks,

JU

0

Share this post


Link to post
Share on other sites

This guide will allow you to root your HTC Legend, provided it has a bootloader version of 0.43.xxxx or below and a ROM version of 1.31.xxx.x or below. To check this, turn off your device, then turn it back on with the 'back' key held. On the second line in green text you will see HBOOT- and then a number. Provided this is 0.43 or below, this guide should work for you.

I get nothing but power on when I press it with "back", "vol up", "vol down" or any other key. Unlocked legend from Virgin Canada. Any other suggestions? thanks

0

Share this post


Link to post
Share on other sites

Hi

I'm trying to root - but the zip file does not seem to be available on MediaFire - is it available anywhere else??? All links seem to point to the same place.

Thanks

CUK

Disregard - it is back now!

Edited by copteruk
0

Share this post


Link to post
Share on other sites

My HBOOT is 1.00.0000. I am not sure what the ROM number is, but it's Froyo. Can someone please tell me where I can download the relevant file(s).

Edited by tanner9
0

Share this post


Link to post
Share on other sites

the required files - DOWNLOAD (MediaFire Pro) - MD5: rm6154a24e21df9fb6f542834f76e0d8f9

Hey guys!

I'm trying to root a friends phone, but I can't get the link upstated. Can you put it back up? Or can I get it elsewhere?

Kind regards!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.