• Announcements

    • PaulOBrien

      Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance) CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission) ROMs must give full credit to the original author ISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • PaulOBrien

      Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
PaulOBrien

24/May r4 - HTC Legend rooting guide - Now with 1.31.x

664 posts in this topic

Thanks for your answer, by the way, once I try to start the second step, terminal says "device not found" like all the others, and i can't select anything. Should i see any another screens in the meanwhile?

Sorry for my noobish questions but it's my first android device :P so i need to make a little traning (no problem at all (at least) while creating the goldcard :huh: )

Normally your device shows the triangle, then you start step2. A little while after that your phone should show a progress bar and boot into recovery menu. And here you follow the instructions of paul's guide again.

Perhaps you should try it with an ruu and start again from the beginning.. But remember !! The Legend had to be powered on for step2 !!

Hope that helps you.

0

Share this post


Link to post
Share on other sites

Darn.... i tried to downgrade the rom to 1.23 but i got error bootloader mismatch.... gonna wait for the root update....

0

Share this post


Link to post
Share on other sites
Normally your device shows the triangle, then you start step2. A little while after that your phone should show a progress bar and boot into recovery menu. And here you follow the instructions of paul's guide again.

Perhaps you should try it with an ruu and start again from the beginning.. But remember !! The Legend had to be powered on for step2 !!

Hope that helps you.

Thanks for your help, btw, after the screen with the triangle, as soon as i start the step 2, nothing appears, i see on the console that the daemon has been started but just few seconds later it says "device not found". (i tried the kill the daemon and restart executing "./adb devices" but it shows nothing connected).

I tried both with the CD and on the Virtual Machine (WMWare) and the only difference i noticed is a slower transfer speed in VMWare but anything else. I even tried to unplug every other USB devices to avoid conflicts but nothing seems to change :P

(during transfer i always receive the warning "remote: 43 main version check fail")

Finally i tried to follow your steps to downgrade but i received the "Error 140: bootloader version error" (with the goldcard inserted).

I followed the guide to make the goldcard and trying it just after the replace of the headers, it seems to work, cause it is recognized by system.

As far as i know, i should have a 1.31 Rom with HBOOT 0.43.0001 and RADIO 7.05.35.26L

About any other informations, as motherboard i have an Asus P5K-SE, and I don't know if it's normal but in VMWare as soon i move from "fastboot" to "bootloader" the device is recognized as a storage device (while in first time was recognized as "High Android Device 1.0").

One last thing: on Hboot menu, the system checks for images on the SD and it says that nothing can be found. Is that normal?

Thanks for your precious time :huh:

0

Share this post


Link to post
Share on other sites
Darn.... i tried to downgrade the rom to 1.23 but i got error bootloader mismatch.... gonna wait for the root update....

yes is still impossible i hope the Update comes today...

0

Share this post


Link to post
Share on other sites
Thanks for your help, btw, after the screen with the triangle, as soon as i start the step 2, nothing appears, i see on the console that the daemon has been started but just few seconds later it says "device not found". (i tried the kill the daemon and restart executing "./adb devices" but it shows nothing connected).

I tried both with the CD and on the Virtual Machine (WMWare) and the only difference i noticed is a slower transfer speed in VMWare but anything else. I even tried to unplug every other USB devices to avoid conflicts but nothing seems to change :P

(during transfer i always receive the warning "remote: 43 main version check fail")

Finally i tried to follow your steps to downgrade but i received the "Error 140: bootloader version error" (with the goldcard inserted).

I followed the guide to make the goldcard and trying it just after the replace of the headers, it seems to work, cause it is recognized by system.

As far as i know, i should have a 1.31 Rom with HBOOT 0.43.0001 and RADIO 7.05.35.26L

About any other informations, as motherboard i have an Asus P5K-SE, and I don't know if it's normal but in VMWare as soon i move from "fastboot" to "bootloader" the device is recognized as a storage device (while in first time was recognized as "High Android Device 1.0").

One last thing: on Hboot menu, the system checks for images on the SD and it says that nothing can be found. Is that normal?

Thanks for your precious time :huh:

Normally I would say you had to enable USB-Debugging - But then step1 wouldn't run correctly.. But try it..

Howto: Boot your phone -> Settings -> Applications -> Development -> USB Debugging

I would do the rooting on a physical maschine..

I don't know exactly, but I think the image will be copied in step 2 - So it's normal that nothing can be found.

One little tip: Don't unplug your phone while you are in the recovery menu, because it runs the menu from your pc and hangs up if you unplug before you restart.

Regards..

Edited by Peganos
0

Share this post


Link to post
Share on other sites

I'm getting the same error

All go fine until step1, but in step2 show me that device not found...

I'll try to downgrade but i'm really tired, i have been testing and getting errors during all weekend

I'm still waiting for you guys cause you're the pros haha

Thanks a lot

Regards

0

Share this post


Link to post
Share on other sites

"HTC Legend Kernel source now available on http://developer.htc.com/ "

This can help Paul to make it work on 1.31 ??? maby Custom Roms ???

Edited by rodriguezstyle
0

Share this post


Link to post
Share on other sites
I'm getting the same error

All go fine until step1, but in step2 show me that device not found...

I'll try to downgrade but i'm really tired, i have been testing and getting errors during all weekend

I'm still waiting for you guys cause you're the pros haha

Thanks a lot

Regards

Could do the progress again from the beginning and write everything down.. Perhabs I can help you then.. Need more input ;D

0

Share this post


Link to post
Share on other sites

Ok, i'll try again and i'll write here all i do :huh:

regards!

0

Share this post


Link to post
Share on other sites
Could do the progress again from the beginning and write everything down.. Perhabs I can help you then.. Need more input ;D

I'll check too :P (to learn :huh: )

0

Share this post


Link to post
Share on other sites

still no news for the root of 1.31 Mr. Paul ???

:huh: :P :blink:

0

Share this post


Link to post
Share on other sites

Paul, any news about the root for 1.31 yet, today's Monday :huh:

0

Share this post


Link to post
Share on other sites
Paul, any news about the root for 1.31 yet, today's Monday :huh:

Give the guy some peace. It might not be an easy case. As a matter of fact I think not. I have been trying since friday here.

Next thing. Goldgard creation online at Revskills have been pulled.

I am trying another method that might or might not work, using QMAT. But i really cant confirm that at this moment. I will need to either have a working root image, or a non- rooted image with a ROM Version higher than 1.31 with a CID different from my DK Rom.

GOOD LUCK PAUL love yiur work even if I was stupid enough to update OTA.

0

Share this post


Link to post
Share on other sites

Paul is Completely Offline and Root for 1.31 will not Work for sure...

Edited by rodriguezstyle
0

Share this post


Link to post
Share on other sites
Give the guy some peace. It might not be an easy case. As a matter of fact I think not. I have been trying since friday here.

Next thing. Goldgard creation online at Revskills have been pulled.

I am trying another method that might or might not work, using QMAT. But i really cant confirm that at this moment. I will need to either have a working root image, or a non- rooted image with a ROM Version higher than 1.31 with a CID different from my DK Rom.

GOOD LUCK PAUL love yiur work even if I was stupid enough to update OTA.

Just to inform. Goldcard creation is online at http://psas.revskills.de/?q=goldcard

And, no, Paul was online today. Be patient boys. I'm sure he wont let us down.

0

Share this post


Link to post
Share on other sites

At least!

I start again, and created the goldcard again, and then i downgrade to 1.31 ROM that linked on page 2, installed from fastboot usb and then repeat the process and it's done!

Thanks everybody :huh:

Regards

0

Share this post


Link to post
Share on other sites
At least!

I start again, and created the goldcard again, and then i downgrade to 1.31 ROM that linked on page 2, installed from fastboot usb and then repeat the process and it's done!

Thanks everybody :huh:

Regards

You mean you downgraded to 1.23? Did you made the ota to 1.31 after the rooting?

0

Share this post


Link to post
Share on other sites

Can some mod just ban him already ... geez ...

0

Share this post


Link to post
Share on other sites

淡定。。。。。。。。。

0

Share this post


Link to post
Share on other sites

Oh yeah, the guy is so good - he found the real name of our phones. Look under "devices": Lengend ;D

0

Share this post


Link to post
Share on other sites
At least!

I start again, and created the goldcard again, and then i downgrade to 1.31 ROM that linked on page 2, installed from fastboot usb and then repeat the process and it's done!

Thanks everybody :huh:

Regards

When you did the goldcard, did you use the guide posted in this forum because there is no mmc1 in my Legend only a mmc0 when I search for the CID ?

Is that the right ID to use ? I have done a goldcard from that (mmc0) cid-path but I'm not 100% sure that it's correct and it would be great to know :P

0

Share this post


Link to post
Share on other sites
When you did the goldcard, did you use the guide posted in this forum because there is no mmc1 in my Legend only a mmc0 when I search for the CID ?

Is that the right ID to use ? I have done a goldcard from that (mmc0) cid-path but I'm not 100% sure that it's correct and it would be great to know :P

Yeah, i used mmc0 instead mmc1 :huh:

Regards

0

Share this post


Link to post
Share on other sites

.31 root tested and uploading...

P

0

Share this post


Link to post
Share on other sites
.31 root tested and uploading...

P

:huh: Thank u Paul

0

Share this post


Link to post
Share on other sites
.31 root tested and uploading...

P

Thanks a lot :huh:

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.