azuwis

Increase touch screen sensitivity, only tested on LiquidE 1.100.05 based roms

86 posts in this topic

Thanks guys! I got it to work.. Apparently i need to disable su for the script ( i got no idea what su means too).. Cool stuffs.. Will read up about LCR.. Cheers! =)

0

Share this post


Link to post
Share on other sites
What does noise mean here?

It's basically the same like with audio noise - it's an unwanted phenomenon (caused by errors/inaccuracy in your sensors/gains or e.g. capacity changes in your environment). Practically it limits the detection of small signals.

So the filter-value here seems to be a filter that removes signals smaller than a given strength (so only your fingers get detected :)).

Btw: Great work azuwis :)

0

Share this post


Link to post
Share on other sites
It's basically the same like with audio noise - it's an unwanted phenomenon (caused by errors/inaccuracy in your sensors/gains or e.g. capacity changes in your environment). Practically it limits the detection of small signals.

So the filter-value here seems to be a filter that removes signals smaller than a given strength (so only your fingers get detected :)).

Btw: Great work azuwis :)

Does it mean that I should turn the value of "noise" to be smaller if i want the screen being more sensitive?

0

Share this post


Link to post
Share on other sites
Does it mean that I should turn the value of "noise" to be smaller if i want the screen being more sensitive?

The noise as well as the sensitivity (afaik). Don't go too far though or you'll get random "touches". I believe 20 is as low as you can go.

0

Share this post


Link to post
Share on other sites
The noise as well as the sensitivity (afaik). Don't go too far though or you'll get random "touches". I believe 20 is as low as you can go.

I have tried the new version one that is 20/50

It is really better and have a big different against the old one

0

Share this post


Link to post
Share on other sites

try this 30 sensitivity 75 noise ^^

you will have high sensitivity and high precision :)

0

Share this post


Link to post
Share on other sites

This is awesome, mine is like iphone sensitivity now, but did anyone experience that from time to time, the whole screen is just going crazy and pressing everything?

0

Share this post


Link to post
Share on other sites

Just ran the script with my Liquid E on baseband version A1-04.04.02!

Works great, and I must say this is a thumbs up!!!

@Morris, it does, same problem as mine, that's why I used this script. I changed sensitivity to 75/75.

Does the noise actually control the background particle movements? I mean, I want to use 25/75 if that's possible

Edited by Koki1337
0

Share this post


Link to post
Share on other sites
Just ran the script with my Liquid E on baseband version A1-04.04.02!

Works great, and I must say this is a thumbs up!!!

@Morris, it does, same problem as mine, that's why I used this script. I changed sensitivity to 75/75.

Does the noise actually control the background particle movements? I mean, I want to use 25/75 if that's possible

25/75 still does not help, heck, 25/100 still goes crazy!, 50/75 does too. I still can't pin down what is actually causing the interferences to the random touches. I tried to see if it is the internal components by judging the amount of time I have the phone on, if the palm in the back of the phone affects it more, still, no actual direct differences at the moment.

Morris Lee

0

Share this post


Link to post
Share on other sites
25/75 still does not help, heck, 25/100 still goes crazy!, 50/75 does too. I still can't pin down what is actually causing the interferences to the random touches. I tried to see if it is the internal components by judging the amount of time I have the phone on, if the palm in the back of the phone affects it more, still, no actual direct differences at the moment.

Morris Lee

Shouldn't it tolerate with noise better with high sensitivity at 25/75

No idea at all, but this scrip indeed helps a lot after modifying it back to 75/75

0

Share this post


Link to post
Share on other sites
Shouldn't it tolerate with noise better with high sensitivity at 25/75

No idea at all, but this scrip indeed helps a lot after modifying it back to 75/75

but it doesn't make much difference for any extreme values for the noise, it seems to be rather useless.

Actually, I am getting pretty good results with a cleaned screen... but that is hardly the case when I am on the go.

0

Share this post


Link to post
Share on other sites

I'm on Liquid Galaxy ROM @ XDA and it works fine.

10/75 lol.

It's awesome that even my fingertip hair can trigger movements

0

Share this post


Link to post
Share on other sites
I'm on Liquid Galaxy ROM @ XDA and it works fine.

10/75 lol.

It's awesome that even my fingertip hair can trigger movements

Are you using a screen protector?

0

Share this post


Link to post
Share on other sites
Are you using a screen protector?

Yeah, but still not much like.

It jumps when I reboot and reapplied.

Fought with the screen for a while ;D

0

Share this post


Link to post
Share on other sites
Thank you for this tips.

If you want to keep it permanent under LCR :

adb shell ins_run sensitive.sh 'echo 25 > /sys/devices/platform/i2c-adapter/i2c-0/0-005c/sensitivity ; echo 25 > /sys/devices/platform/i2c-adapter/i2c-0/0-005c/noise'

adb reboot

If you want to change value, use exactly the same commandline using different values.

If you want to disable it :

adb shell rm_run sensitive.sh

Can u give an step by step as how to do this .. I dunno what this adb shell etc. means ..

would really like increased sensativity but not sure what to do =D

thanks in advance

.... I am using LCR froyo

0

Share this post


Link to post
Share on other sites
Can u give an step by step as how to do this .. I dunno what this adb shell etc. means ..

would really like increased sensativity but not sure what to do =D

thanks in advance

.... I am using LCR froyo

In LCR-f you can change the sensitivity in LCR-Settings. Just open LCR-settings and scroll down to the button and choose "Sensitivity". And then "Custom Sensitivty" and enter 25 in sens and 25 in noise to get the same result as that adb thingy he used.

0

Share this post


Link to post
Share on other sites

I did an escamotage to make the script definitive on stock/leak version... Tested it works on Eclair and Froyo...

ROOT NEEDED!

Install GScript Lite and Autostart (Root)

Then save into the sdcard/gscript two files

file: crea.sh

#!/system/bin/sh

mkdir /data/opt

cat /sdcard/gscript/autostart.sh > /data/opt/autostart.sh
file: autostart.sh
#!/system/bin/sh

sensitivity=25

noise=75

echo $sensitivity > /sys/devices/platform/i2c-adapter/i2c-0/0-005c/sensitivity

echo $noise > /sys/devices/platform/i2c-adapter/i2c-0/0-005c/noise

Obviuosly sensivity and noise can be changed as you like...

Now add in gscript 'crea.sh' and run it, it will create a folder in /data/opt and it will copy autostart.sh into this new folder

At first boot Autostart (root) will require root privileges, confirm it...

from now on, at every start up the sensivity will be updated :)

I hope it's useful for someone :)

0

Share this post


Link to post
Share on other sites
I did an escamotage to make the script definitive on stock/leak version... Tested it works on Eclair and Froyo...

ROOT NEEDED!

Install GScript Lite and Autostart (Root)

Then save into the sdcard/gscript two files

file: crea.sh

#!/system/bin/sh

mkdir /data/opt

cat /sdcard/gscript/autostart.sh > /data/opt/autostart.sh
file: autostart.sh
#!/system/bin/sh

sensitivity=25

noise=75

echo $sensitivity > /sys/devices/platform/i2c-adapter/i2c-0/0-005c/sensitivity

echo $noise > /sys/devices/platform/i2c-adapter/i2c-0/0-005c/noise
Obviuosly sensivity and noise can be changed as you like... Now add in gscript 'crea.sh' and run it, it will create a folder in /data/opt and it will copy autostart.sh into this new folder At first boot Autostart (root) will require root privileges, confirm it... from now on, at every start up the sensivity will be updated :) I hope it's useful for someone :)
That autostart could be very useful, i imagine. I have persistent sensitivity on my rom In my case I saved the values on a files in sdcard. So everytime it boots it grabs the values from them:
sleep 30

if busybox test ! -e /sdcard/JSRT/Persistent/sensitivity; then busybox echo 75 > /sdcard/JSRT/Persistent/sensitivity; fi

cat /sdcard/JSRT/Persistent/sensitivity > /sys/devices/platform/i2c-adapter/i2c-0/0-005c/sensitivity

if busybox test ! -e /sdcard/JSRT/Persistent/noise; then busybox echo 75 > /sdcard/JSRT/Persistent/noise; fi

cat /sdcard/JSRT/Persistent/noise > /sys/devices/platform/i2c-adapter/i2c-0/0-005c/noise

sync
I have also used gscript for users to set their own values by just changing it in gscript:
sensitivity=75

noise=75

echo $sensitivity > /sdcard/JSRT/Persistent/sensitivity

echo $sensitivity > /sys/devices/platform/i2c-adapter/i2c-0/0-005c/sensitivity

echo $noise > /sdcard/JSRT/Persistent/noise

echo $noise > /sys/devices/platform/i2c-adapter/i2c-0/0-005c/noise

sync

Actually that gscript is dynamic as the saved values are changed gscript values are also changed. Now that's more complicated long story.

0

Share this post


Link to post
Share on other sites
25/75 still does not help, heck, 25/100 still goes crazy!, 50/75 does too. I still can't pin down what is actually causing the interferences to the random touches. I tried to see if it is the internal components by judging the amount of time I have the phone on, if the palm in the back of the phone affects it more, still, no actual direct differences at the moment.

Morris Lee

Hello.

I'm italian. Sorry my English translated by google.

I have the same problem, the screen went crazy.

The problem does not always occur.

Occasionally, the patch works well for a long time, but suddenly the touch crazy.

Acer liquid E with 2.2 froyo acer-official.

Is there a solution?

Edited by cicci0
0

Share this post


Link to post
Share on other sites
Hello.

I'm italian. Sorry my English translated by google.

I have the same problem, the screen went crazy.

The problem does not always occur.

Occasionally, the patch works well for a long time, but suddenly the touch crazy.

Acer liquid E with 2.2 froyo acer-official.

Is there a solution?

Must be bad quality touch screen, we have to stick with 75/75 I guess

0

Share this post


Link to post
Share on other sites
Must be bad quality touch screen, we have to stick with 75/75 I guess

Other people have managed to set the touch with this patch or have any problems?

0

Share this post


Link to post
Share on other sites
Other people have managed to set the touch with this patch or have any problems?

Try to download this program from Google:

LS_touchscreen

You should set the sensitivity automatically

0

Share this post


Link to post
Share on other sites

Great job! :( My wife has Samsung Galaxi S 9000. I tested sensitivity on both. When I set 15/20 on Acer it starts working like Samsung!

0

Share this post


Link to post
Share on other sites

Dude i love u, thank you! You should put if it it happens automatically because i was wondering, but then i noticed it! B) :D ;)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.