• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

"Continuing Internet access will lead to traffic. Continue?"

29 posts in this topic

Posted · Report post

As per subject line - every time my phone swaps from WiFi to 3G, I get a prompt saying "Continuing Internet access will lead to traffic. Continue?"

Anyone know how I can turn this off?

I'm running 2.1r7, but have found this on all 2.1 builds I have tried.

Thanks,

Jules

0

Share this post


Link to post
Share on other sites

Posted · Report post

I`ve got same problem, it makes my phone unusable, because I need phone making autoswitching between wifi and edge :( :( :o

0

Share this post


Link to post
Share on other sites

Posted · Report post

I just left it on that screen for about 5 seconds and it dissapeared :(

Dan

0

Share this post


Link to post
Share on other sites

Posted · Report post

I think that when WiFi isn't available 3G auto switces on, thats if you haven't disabled Data Service in Wireless and network settings

0

Share this post


Link to post
Share on other sites

Posted · Report post

I just left it on that screen for about 5 seconds and it dissapeared :(

Dan

data service is enabled :(

0

Share this post


Link to post
Share on other sites

Posted · Report post

Same Problem here

Are there any solutions ??

0

Share this post


Link to post
Share on other sites

Posted · Report post

This is very annoying. Haven't figured out how to turn it off, though...

0

Share this post


Link to post
Share on other sites

Posted · Report post

Bump

Same here and rather annoying!!!

Cheers

Phill

0

Share this post


Link to post
Share on other sites

Posted · Report post

I just left it on that screen for about 5 seconds and it dissapeared :(

Dan

If I leave it on the screen it doesn't disappear. It's a bigger issue when you lock your screen (and Wi-Fi disconnects) and this thing appears, meaning 3G won't work until you unlock and explicitly tell allow it.

Any solutions? :|

0

Share this post


Link to post
Share on other sites

Posted · Report post

As a side note, I think this "feature" is why I'm seeing such drastically improved battery life:

The phone sleeps, WiFi turns off, and 2g/3g never turns on because of this prompt. SO the phone spends most of it's days not connected to the internet hence no push email, etc, etc.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Nope, I had drastically improved battery life on the beta 2.1 without this prompt.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Isn't there a switch in the network settings for 'network always on' or something? Haven't tried it yet but this might be the deal, flipping it on will make this go away?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

EDIT: False alarm. Sorry guys.

Just fixed it.

You need to enable "Data roaming" on "Mobile Networks" inside "Wireless & network settings".

Since this is a Swiss ROM, I'm guessing it "thinks" it's roaming... but not sure. This fixed it for me :-)

Edited by Gonçalo Silva
0

Share this post


Link to post
Share on other sites

Posted · Report post

Just fixed it.

You need to enable "Data roaming" on "Mobile Networks" inside "Wireless & network settings".

Since this is a Swiss ROM, I'm guessing it "thinks" it's roaming... but not sure. This fixed it for me :-)

that does not work :(

0

Share this post


Link to post
Share on other sites

Posted · Report post

that does not work :(

You're right. Somehow I had the impression it was working, but today I'm getting that confirmation screen again. Sorry for that.

I hate this thing :|

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

You're right. Somehow I had the impression it was working, but today I'm getting that confirmation screen again. Sorry for that.

I hate this thing :|

Edit /system/build.prop

This is the switch that causes the prompting

ro.config.hw_new_wifitopdp=0

Change the 1 to a 0

reboot.

You may have to re-enable data services.

Edit : removed the region and locale settings as these are not needed (thanks Jan M)

Edited by jonuwz
0

Share this post


Link to post
Share on other sites

Posted · Report post

if you are in the UK, this works :

Edit /system/build.prop, uncomment these 2 lines and change the region to GB

ro.product.locale.language=en

ro.product.locale.region=GB

This is the switch that causes the prompting (just setting the region is not enough)

ro.config.hw_new_wifitopdp=0

Change the 1 to a 0

reboot.

You may have to re-enable data services.

So I wont get the message as long as those lines of code are as you have shown?

0

Share this post


Link to post
Share on other sites

Posted · Report post

stupid question, how to edit that system file?

P.S. I have not that 2 lines

0

Share this post


Link to post
Share on other sites

Posted · Report post

if you are in the UK, this works :

Edit /system/build.prop, uncomment these 2 lines and change the region to GB

ro.product.locale.language=en

ro.product.locale.region=GB

This is the switch that causes the prompting (just setting the region is not enough)

ro.config.hw_new_wifitopdp=0

Change the 1 to a 0

reboot.

You may have to re-enable data services.

I didn't have those ro.product lines so I just changed the ro.config and it looks like it worked...

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Original post ammended.

You don't need to edit these, so if they don't exist, don't worry.

ro.product.locale.language=en

ro.product.locale.region=GB

They exist on another stock UK android phone, so I added them anyway.

To edit build.prop, if you're not a cli person :

Install estrongs file manager from the market (free), enable the root settings, mount /system rw, browse to /system, click build.prop, open as text, edit the file, save, reboot.

Edited by jonuwz
0

Share this post


Link to post
Share on other sites

Posted · Report post

You are the best

IT WORKS

THANX THANX THANX

0

Share this post


Link to post
Share on other sites

Posted · Report post

Woot, nice find! This should be added to the faq

0

Share this post


Link to post
Share on other sites

Posted · Report post

great man, it works :(

0

Share this post


Link to post
Share on other sites

Posted · Report post

Edit /system/build.prop

This is the switch that causes the prompting

ro.config.hw_new_wifitopdp=0

Nice find mate :(

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks so much man, it works great! Had a bit of a hard time getting it changed since estrongs didn't want to let me use root settings but i finally got it to work through terminal emulator :(

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.